RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Benutzeravatar
jmaus
Beiträge: 5042
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von jmaus » 07.10.2019, 20:51

Gluehwurm hat geschrieben:
07.10.2019, 15:50
Vielleicht könnte mit der Antwort auf diese Frage
Was wurde denn in der CCU2-Version ...20 geändert, daß es da wieder funktioniert ?
schon eine Eingrenzung stattfinden ?
Gut, dann versuche ich mal etwas detaillierter auf die Firmware-Änderungen zwischen x.47.15 => x.47.20 in Bezug auf den HmIP Dienst einzugehen.

Meinen Informationen nach wurde hier im HmIP Teil (HMIPServer) versucht durch Anpassungen/Änderungen von Timeouts Netzwerkkommunikationsproblemen entgegen zu wirken die damit zusammen hängen/hingen, das bei der XMLRPC Kommunikation mit dem HMIPServer es dazu kommen kann/konnte, das dieser die komplette XMLRPC Kommunikation auf Grund von einzelnen, nicht mehr verfügbaren (lauschenden) XMLRPC Clients eingestellt hat. D.h. wenn z.B. ein Client sich für die XMLRPC Kommunikation registriert, dann aber nicht ordentlich abmeldet bzw. z.B. eine Smartphone App einfach nicht mehr verfügbar ist weil das Smartphone eben z.B. ausser Reichweite ist, dann kann es dazu kommen das beim Versenden von Events via XMLRPC der interne XMLRPC Serverdienst im HMIPServer der die Clientkommunikation sequentiell abarbeitet ins Stocken gerät weil er eben versucht die Events an einen nicht mehr lauschenden Client auszuliefern. Und durch die interne Art und Weise der Abarbeitung dieser Eventauslieferungen kann es dann leider dazu kommen, das der HMIPServer bis zum Eintreten eines entsprechenden Timeouts in der Event-Auslieferung komplett blockiert wird und folglich auch z.B. die interne XMLRPC basierte Kommunikation mit der WebUI ins Stocken bzw. zum kompletten Erliegen kommt.

Und nun gab es eben von der x.47.15 zur x.47.18 eine Anpassung bei der die Timeouts von ursprünglich 10-15 Minuten auf ca. 5 Sekunden reduziert wurde um dem HMIPServer zu ermöglichen schneller auf solche nicht mehr verfügbaren XMLRPC Clients zu reagieren um nicht die gesamte XMLRPC basierte Eventauslieferung für einen sehr langen Zeitraum zu blockieren. Als jedoch die x.47.18 dann für die CCU2 herausgegeben wurde zeigte sich leider, das wohl bei gewissen Installationen dieses kurze Timeout auch negative Effekte in ähnlichem Ausmaß hervorbrachte einfach weil die CCU2 selbst nicht performant genug ist/war um diese Timeout-Schwelle bei der normalen Kommunikation einzuhalten. Daraufhin wurde dann recht schnell mit der x.47.20 durch eine erneute Erhöhung der Timeouts im Bereich von wenigen Minuten versucht entgegen zu wirken. Und wie sich bis jetzt zeigte hat dies anscheinend auch zumindest bezogen auf die CCU2 den gewünschten Erfolg gebracht. Bei der CCU3 bzw. RaspberryMatic gab es jedoch bis zum Release der 2.47.20 keinerlei Hinweise das die CCU3/OCCU/RaspberryMatic Version des HMIPServer auch davon substantiell betroffen ist und man hier durch ein 3.47.20 release reagieren müsste.

Wie sich aber in den letzten Tagen wohl zeigte, scheint hier das Problem zumindest in abgeschwächter Form auch zu existieren und so scheint es nun so zu sein, dass es wohl in naher Zukunft eine weitere 3.47.x Version geben wird die die selben Anpassungen in den Netzwerktimeouts bei der XMLRPC Kommunikation mitbringen wird. Und sobald diese dann herausgebracht wurde bzw. eine entsprechende OCCU Version gibt wird natürlich dann auch RaspberryMatic von dieser erneuten Anpassung profitieren. Ich hoffe das bringt etwas Licht ins Dunkel.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

Benutzeravatar
lemonbiter
Beiträge: 158
Registriert: 16.10.2016, 23:14
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von lemonbiter » 07.10.2019, 23:39

Klingt soweit verständlich. Aber wäre dann nicht eine unterschiedliche Version der XMLRPC Kommunikation für Raspi/CCU3 und parallel der CCU2, mit jeweils optimierter Kommunikation für das jeweilige System, ein sinnvoller Ansatz?
okay... ich arbeite dran

Benutzeravatar
jmaus
Beiträge: 5042
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von jmaus » 07.10.2019, 23:47

lemonbiter hat geschrieben:
07.10.2019, 23:39
Klingt soweit verständlich. Aber wäre dann nicht eine unterschiedliche Version der XMLRPC Kommunikation für Raspi/CCU3 und parallel der CCU2, mit jeweils optimierter Kommunikation für das jeweilige System, ein sinnvoller Ansatz?
Nein, das hat nichts damit zu tun und wäre auch nicht zielführend. Vielmehr wird es in Zukunft noch weitere Optimierung an der XMLRPC Schnittstellenkommunikation im HMIPServer geben der eine parallele und unabhängige Kommunikation zu jeden Client zulässt. Bis dahin muss es die Timeout Optimierung eben bringen.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

aba320
Beiträge: 21
Registriert: 19.02.2014, 12:34

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von aba320 » 08.10.2019, 07:48

Hallo an alle,
wie von mir am 20. september gemeldet spinnt bei mit der aussenthermostat HMIP STHO. bin trotz des nicht funktionierenden scripts bei der neuen 18 version geblieben. der wert wird beim neustart in die Variable geschrieben( steht jetzt seit über einer woche auf 22.6°C) und danach nicht mehr aktualisiert. in den diagrammen die die aussentemperatur enthalten werden die werte aktualisiert. was soll ich prüfen?
das serverlog auszugsweise als anlage.
das systemprotokoll ist leer.
Gruß Achim Bethke

Edit 16.10:
scheint mit RC 3.47.22.20191015 gelöst zu sein
Dateianhänge
20191008 hmserver.log.txt
(109.57 KiB) 8-mal heruntergeladen
Zuletzt geändert von aba320 am 16.10.2019, 13:16, insgesamt 1-mal geändert.
HW: Raspi 3B+ ; RPI-RF-MOD; XML API; Cux Daemon;;email addon
57 HM Geräte ; ein HMIP Wassermelder 1 HMIP STHO

Bratmaxe
Beiträge: 1421
Registriert: 28.05.2015, 12:48
Wohnort: Willich
Hat sich bedankt: 1 Mal
Danksagung erhalten: 2 Mal

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von Bratmaxe » 08.10.2019, 08:43

Moin,

als erstes ist mir die Möglichkeit in den Kopf gekommen, das es an der verwendeten Funkmodule Version liegt.
Ich verwende noch das alte Funkmodul 'HM-MOD-RPI-PCB' und habe das Problem mit HmIP.
Gerne teile ich euch die Harware/Software von meinem System mit, vielleicht findet sich ja so eine Gemeinsamkeit:

Hardware:
Raspberry Pi 2B
USB-Stick

Funkmodul:
HM-MOD-RPI-PCB

Software:
RaspberryMatic 3.47.18.20190918

Addons:
XML-API V1.20
CUxD-Highcharts V1.4.5
JP HB Devices V2.12
CUx-Deamon V2.3.4
hm_pdetect V1.5
Programmedrucken V1.2a

Keine weiteren Verbindungen zu Homeserver oder iobroker und Co. vorhanden
Auch keine HUE oder sonstige Adapter
Gruß Carsten

Benutzeravatar
jmaus
Beiträge: 5042
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von jmaus » 08.10.2019, 08:51

Bratmaxe hat geschrieben:
08.10.2019, 08:43
als erstes ist mir die Möglichkeit in den Kopf gekommen, das es an der verwendeten Funkmodule Version liegt.
Dafür gibt es momentan keinerlei Anzeichen und das halte ich auch für höchst unwahrscheinlich.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

krk-elektrotechnik
Beiträge: 80
Registriert: 14.03.2017, 10:45
Wohnort: Borgentreich
Hat sich bedankt: 1 Mal
Kontaktdaten:

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von krk-elektrotechnik » 08.10.2019, 09:07

jmaus hat geschrieben:
08.10.2019, 08:51
Dafür gibt es momentan keinerlei Anzeichen und das halte ich auch für höchst unwahrscheinlich.
Habe einen Kunden bei dem die HmIP Probleme mit dem alten Funkmodul auftraten.
Nun hat er mittlerweile das neue Modul, auch dort treten selbige Fehler auf.
Da ich im Kundensystem nicht testen kann, wird das System über einen täglichen S61rfd restart bei Laune gehalten.
Kann gerne ein Logfile posten, jedoch wird das durch den täglichen restart wohl nichts nützen vermute ich.

In meinem eigenen System mit 13 HmIP Geräten (+60 Hm) läuft alles rund, auch mit der aktuellen Firmware.
VG Benjamin

Benutzeravatar
jmaus
Beiträge: 5042
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von jmaus » 08.10.2019, 09:10

krk-elektrotechnik hat geschrieben:
08.10.2019, 09:07
jmaus hat geschrieben:
08.10.2019, 08:51
Dafür gibt es momentan keinerlei Anzeichen und das halte ich auch für höchst unwahrscheinlich.
Habe einen Kunden bei dem die HmIP Probleme mit dem alten Funkmodul auftraten.
Nun hat er mittlerweile das neue Modul, auch dort treten selbige Fehler auf.
Da ich im Kundensystem nicht testen kann, wird das System über einen täglichen S61rfd restart bei Laune gehalten.
Also S61rfd kann es nicht sein, denn "rfd" ist für die alte BidCos-RF Welt zuständig. Wenn dann muss man schon täglich den HMIPServer via S62HMServer neustarten damit der HmIP Dienst neugestartet wird.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

krk-elektrotechnik
Beiträge: 80
Registriert: 14.03.2017, 10:45
Wohnort: Borgentreich
Hat sich bedankt: 1 Mal
Kontaktdaten:

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von krk-elektrotechnik » 08.10.2019, 10:19

jmaus hat geschrieben:
08.10.2019, 09:10
Also S61rfd kann es nicht sein, denn "rfd" ist für die alte BidCos-RF Welt zuständig. Wenn dann muss man schon täglich den HMIPServer via S62HMServer neustarten damit der HmIP Dienst neugestartet wird.
Das stimmt natürlich.
Gerade nochmal nachgesehen, auf dem Kundensystem wird täglich /sbin/reboot ausgeführt.
S61rfd war ne andere Sache, das habe ich wohl was durcheinander gebracht :?

Benutzeravatar
jmaus
Beiträge: 5042
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: RaspberryMatic 3.47.18.20190918 – Erfahrungsberichte

Beitrag von jmaus » 08.10.2019, 10:46

krk-elektrotechnik hat geschrieben:
08.10.2019, 10:19
jmaus hat geschrieben:
08.10.2019, 09:10
Also S61rfd kann es nicht sein, denn "rfd" ist für die alte BidCos-RF Welt zuständig. Wenn dann muss man schon täglich den HMIPServer via S62HMServer neustarten damit der HmIP Dienst neugestartet wird.
Das stimmt natürlich.
Gerade nochmal nachgesehen, auf dem Kundensystem wird täglich /sbin/reboot ausgeführt.
S61rfd war ne andere Sache, das habe ich wohl was durcheinander gebracht :?
Ein kompletter Reboot ist sicherlich etwas over-the-top. Es sollte reichen einfach "/etc/init.d/S62HMServer restart" auszuführen oder im Falle von RaspberryMatic mit monit einfach "monit restart HMIPServer"
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

Antworten

Zurück zu „RaspberryMatic“