KeyMatic Störung nach Neustart

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Visu
Beiträge: 450
Registriert: 04.12.2016, 23:30

KeyMatic Störung nach Neustart

Beitrag von Visu » 28.09.2019, 09:12

Guten Morgen,
mir ist aufgefallen, dass die KeyMatic HM-Sec-Key immer nach einem Neustart der Zentrale Kommunikationsprobleme meldet und sich nicht mehr ansteuern (über WebUI etc.) lässt. Dann muss ich die KeyMatic immer manuell am Gerät 1x betätigen (egal ob auf oder zu), danach die Servicemeldung quittieren und es läuft ohne Probleme wieder. Batterien sind neue drin.

Keine Ahnung ob es ein Raspberrymatic oder eine generelles Probblem ist.

Asus Tinker Board S
3.47.18.20190918

G.V.

Xel66
Beiträge: 6942
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 32 Mal
Danksagung erhalten: 210 Mal

Re: KeyMatic Störung nach Neustart

Beitrag von Xel66 » 28.09.2019, 09:39

Visu hat geschrieben:
28.09.2019, 09:12
Keine Ahnung ob es ein Raspberrymatic oder eine generelles Probblem ist.
Weder..., noch... Ich betreibe eine Keymatic seit mehreren Jahren und nur ca. ein Jahr weniger RaspberryMatic. Ein solches Problem ist mir noch nicht untergekommen und wurde hier auch noch nicht berichtet (außer, dass bei einigen Usern die KM bei Systemstart öffnet, weil sie es so programmiert haben). Ich vermute mal, die Ursache ist bei Dir ähnlich und bedingt durch Deine Programmierung wird die KM mehrfach angesteuert, so dass sie wegen der vielen Befehle das Handtuch und Kommunikationsfehler wirft. Die Ursache ist also weniger allgemeiner Natur, sondern in Deinem System und dessen Programmierung zu suchen.

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
Testsystem: CCU3 3.49.17
---------------------------------------------------------------------------------

Visu
Beiträge: 450
Registriert: 04.12.2016, 23:30

Re: KeyMatic Störung nach Neustart

Beitrag von Visu » 27.10.2019, 08:39

Morgen,
habe alle Programme die mit dem Teil in Verbindung stehen um die CCU Reboot Funktion ergänzt, somit wird keines der Programme nach einem Systemstart ausgeführt. Heute habe ich das aktuelle RaspberryMatic Update eingespielt. Läuft alles ohne Probleme, bis auf die KeyMatic, die hatte wieder Kommunikationsstörung. Das Teil 1x von hand bedient, alles wieder ok....

G.V.

beckerpa
Beiträge: 54
Registriert: 15.04.2018, 08:34
Wohnort: 56329 St. Goar
Hat sich bedankt: 4 Mal

Re: KeyMatic Störung nach Neustart

Beitrag von beckerpa » 27.10.2019, 08:49

Moin,

kann ich auch so nicht bestätigen.
Habe die Keymatic auch seit langem, bisher keine Probleme.
Eben gerade das Update gemacht. Keine Probleme.

Gruß
beckerpa
Raspi 3B mit RasberryMatic mit 101 Geräten HmIP, 29 Geräten HM, CUxD, 98 Programme
Raspi 4B mit ioBroker
HmIP AP mit 77 Geräten

Xel66
Beiträge: 6942
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 32 Mal
Danksagung erhalten: 210 Mal

Re: KeyMatic Störung nach Neustart

Beitrag von Xel66 » 27.10.2019, 09:14

Visu hat geschrieben:
27.10.2019, 08:39
...somit wird keines der Programme nach einem Systemstart ausgeführt.
Das ist damit abhängig von der Programmierung keinesfalls sichergestellt (SONST). Hast Du das im WebUI nachgeprüft (kein Zeitstempel)? Es gibt keinen Grund, warum die Keymatic sich so verhalten sollte, außer in Deiner persönlichen Umgebung oder Programmierung. Wäre dieses ein grundsätzliches Problem, würde man davon öfter lesen. Das gelegentliche Öffnen der Keymatic bei Systemstarts liegt auch an der Programmierung der Anwender.

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
Testsystem: CCU3 3.49.17
---------------------------------------------------------------------------------

osu
Beiträge: 200
Registriert: 13.06.2016, 19:02
Hat sich bedankt: 10 Mal
Danksagung erhalten: 2 Mal

Re: KeyMatic Störung nach Neustart

Beitrag von osu » 27.10.2019, 09:26

Visu hat geschrieben:
27.10.2019, 08:39
Morgen,
habe alle Programme die mit dem Teil in Verbindung stehen um die CCU Reboot Funktion ergänzt, somit wird keines der Programme nach einem Systemstart ausgeführt. Heute habe ich das aktuelle RaspberryMatic Update eingespielt. Läuft alles ohne Probleme, bis auf die KeyMatic, die hatte wieder Kommunikationsstörung. Das Teil 1x von hand bedient, alles wieder ok....

G.V.
Ich hatte an einer der beiden Keymatics nach dem Update bedingten reboot der raspberrymatic eine gemeldete Störung. Die betroffene hängt am LAN Gateway.

Einmal kurz mit tinymatic aufgeschlossen und wieder zu: Kommunikationsstörung behoben und alles gut. Nichts worüber ich mir Sorgen mache.

Gruß,
Oli

Revi
Beiträge: 19
Registriert: 03.02.2019, 09:37
Hat sich bedankt: 3 Mal

Re: KeyMatic Störung nach Neustart

Beitrag von Revi » 27.10.2019, 11:30

Meine beiden KM laufen mit meinen Pi3 Charly und der 3.47.22.20191024 unverändert.

Visu
Beiträge: 450
Registriert: 04.12.2016, 23:30

Re: KeyMatic Störung nach Neustart

Beitrag von Visu » 27.10.2019, 13:52

Xel66 hat geschrieben:
27.10.2019, 09:14
Das ist damit abhängig von der Programmierung keinesfalls sichergestellt (SONST). Hast Du das im WebUI nachgeprüft (kein Zeitstempel)? Es gibt keinen Grund, warum die Keymatic sich so verhalten sollte, außer in Deiner persönlichen Umgebung oder Programmierung. Wäre dieses ein grundsätzliches Problem, würde man davon öfter lesen. Das gelegentliche Öffnen der Keymatic bei Systemstarts liegt auch an der Programmierung der Anwender.

Gruß Xel66
Das letzte Programm wurde gestartet, als ich die KeyMatic manuel betätigt habe.
keyMatic.JPG

Xel66
Beiträge: 6942
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 32 Mal
Danksagung erhalten: 210 Mal

Re: KeyMatic Störung nach Neustart

Beitrag von Xel66 » 27.10.2019, 22:07

Ich kenne den Inhalt des Programms nicht, aber laut Screenshot wird eine LED vermutlicherweise in Abhängigkeit vom Status der Keymatic gesteuert. Dieses Programm kann dann aber nicht die Ursache für Meldungen der Keymatic sein, da vermutlich nur deren Rückmeldung das Prgramm triggert.

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
Testsystem: CCU3 3.49.17
---------------------------------------------------------------------------------

Visu
Beiträge: 450
Registriert: 04.12.2016, 23:30

Re: KeyMatic Störung nach Neustart

Beitrag von Visu » 28.10.2019, 11:03

du hast doch nach Zeitstempeln gefragt, da habe ich nur den Hinweis zum Screen gegeben, dass ich das letzte Programm ja manuell gestartet habe, da ich ja die KeyMatic manuell betätigt habe...

Antworten

Zurück zu „RaspberryMatic“