RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

hippetu
Beiträge: 19
Registriert: 09.03.2014, 12:58
Hat sich bedankt: 3 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von hippetu » 14.01.2020, 19:12

Jetzt läuft es!
Nachdem ich die Änderungen von Frank durchgeführt habe!
Danke Frank!

Gruß
Bernd

Benutzeravatar
jmaus
Beiträge: 6112
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 34 Mal
Danksagung erhalten: 361 Mal
Kontaktdaten:

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von jmaus » 14.01.2020, 19:18

hippetu hat geschrieben:
14.01.2020, 19:12
Jetzt läuft es!
Nachdem ich die Änderungen von Frank durchgeführt habe!
Danke Frank!
Und wenn du uns jetzt noch verrätst welche Änderungen und welcher Frank?!? Link zu seiner geposteten Lösung reicht übrigens..
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

hippetu
Beiträge: 19
Registriert: 09.03.2014, 12:58
Hat sich bedankt: 3 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von hippetu » 14.01.2020, 19:52

bis zum Ende lesen !

So, hiermit noch mal der Link von Frank, der mein virtuelles rasberryMatic zum Laufen brachte:

viewtopic.php?f=65&t=54055&start=340#p548125

Die Änderungen der Einstellungen des Festplattencontrollers von "VirtIO SCSI-Controller" auf "SATA-Controller" und des
Netzwerkinterfaces von "virtio" auf "e1000" führten zum Erfolg.

......und schon kommt die nächste Herausforderung:
Beim Einspielen meines Backups vom meinem Tinkerboard S kommt folgende Fehlermeldung:

"Backup fehlerhaft/unvollständig /z.B. *.apkx Datei fehlt" (kann das etwas mit meiner individuellen Verschlüsselung zu tun haben)

und der Watchdog meldet sich immer wieder mit "hss_led restarted"

.... 3 Stunden später:
Trotz der Fehlermeldung: "Backup fehlerhaft/unvollständig /z.B. *.apkx Datei fehlt" wurde das Backup zurückgespielt. Inwieweit es vollständig ist, kann ich noch nicht beurteilen...
denn das Funkmodul (RPI-RF-MOD) funktioniert nicht an der Synology DS918+. Das ist schon seltsam: Wenn ich das Funkmodul wieder an mein Tinkerboard S zurückstecke, läuft es einwandfrei. Ergo: Das Funkmodul ist ok, funktioniert aber nicht am USB-Port der 918+.
Hat jemand eine Idee ??
Muss das Funkmodul evtl. doch eine separate Stromversorgung haben. Am meinem bisherigen Tinkerboard S durfte es auf keinen Fall eine gesonderte Stromversorgung haben.
Nach meinem Verständnis müsste der USB-Port der DS 918+ 500mA bereitstellen, die für das Funkmodul RPI-RF-MOD ausreichen müssten.

... 4 Stunden später:
das Funkmodul RPI-RF-MOD (vorher am Tinkerboard S angeschlossen) wird jetzt erkannt. Bei der Synology DS 918+ (bei anderen Modellen einfach mal probieren) müsst Ihr beim Punkt "10." der Installationsanweisung von Jens Maus unbedingt USB 3.0 (und nicht USB2.0) wählen. Sonst bekommt das Modul keinen oder nicht genügend Strom.

So, jetzt scheint alles zu laufen. Es werde es die nächsten Tage testen.

Allerletzte Frage:
Das mein Funkmodul Blau/orange blinkt ist OK? oder was bedeutet das ?

Guten Nacht!
Bernd
Zuletzt geändert von hippetu am 14.01.2020, 22:53, insgesamt 1-mal geändert.

Baxxy
Beiträge: 1520
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 143 Mal
Danksagung erhalten: 226 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von Baxxy » 14.01.2020, 22:24

hippetu hat geschrieben:
14.01.2020, 19:52
Kann jemand helfen ??
Hier hatte Jens mal etwas zu deiner Fehlermeldung
hippetu hat geschrieben:
14.01.2020, 19:52
"Backup fehlerhaft/unvollständig /z.B. *.apkx Datei fehlt"
geschrieben.

Wird dein Funkmodul richtig erkannt?
hippetu hat geschrieben:
14.01.2020, 18:17
externes Funkmodul (neues Modell)
Ist es ein RPI-RF-MOD auf der HB-RF-USB-TK?

Ich vermute da einen Zusammenhang mit
hippetu hat geschrieben:
14.01.2020, 18:17
und mit 5m USB-Verlängerung an die DS918+ angeschlossen. (ich habe sowohl ein aktives als auch ein passives USB-Verlängerungskabel probiert).
Da würde ich zum testen mal ein kurzes USB-Kabel nehmen.

Grüße
Baxxy
Grüße
Baxxy

hippetu
Beiträge: 19
Registriert: 09.03.2014, 12:58
Hat sich bedankt: 3 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von hippetu » 16.01.2020, 09:55

Ja, es ist ein RPI-RF-MOD auf der HB-RF-USB-TK

Und auch die Probleme mit den USB-Verlängerungskabeln an meiner DS918+ sind gelöst:

Es funktioniert sowohl mit einem passiven als auch mit einem aktivem 5m-Verlängerungskabel.n
Der Grund für den sporadische Ausfall waren nicht die Kabel, sondern die Tatsache, dass nach einem Start oder Neustart der virtuellen Maschine im VMM (Virtual Maschine Manager) das USB-Gerät: "Future Technology Devices" immer wieder "getrennt" war.

Einfache Lösung (auch während einer laufenden virtuellen Maschine im VMM) und mit meiner Synology DS918+ getestet:

1. Die virtuelle Maschine "rasberry-Matic" auswählen
2. über "Aktion", "Bearbeiten", Sonstiges" den "Virtuellen USB-Controller" auf USB 3.0
UND das "USB-Gerät" von "Getrennt" wieder auf "Future Technolgy Devices" stellen.


Und schon funktioniert das Funkmodul RPI-RF-MOD auf der HB-RF-USB-TK an der DS918+ (wie vorher an meinem Tinkerboard S).

Herzlichen Dank noch einmal an Jens Maus für dieses geniale Projekt !!
... natürlich an alle anderen für ihre Tipps!

ein begeisterter

Bernd

wiwo
Beiträge: 7
Registriert: 17.01.2020, 17:48
Hat sich bedankt: 3 Mal
Danksagung erhalten: 1 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von wiwo » 17.01.2020, 18:11

Ich möchte mich hier an dieser Stelle für das tolle und professionelle Projekt bei Jens Maus bedanken.

Leider habe ich ein Problem bei der produktiven Umsetzung eines Umzuges von einer CCU2 auf die neue Plattform und benötige Unterstützung.

Ich habe unter Proxmox auf einer x86 Plattform die Raspberry Version 3.49.17.20191225 installiert und mit dem Funkmodul RPI-RF-MOD auf der HB-RF-USB-TK ausgestattet und als Addon die CUxD Version (https://github.com/jens-maus/cuxd/releases/latest) installiert. Ein Testbetrieb mit einigen Homematic und HomematicIP Komponenten läuft sehr stabil.

Produktiv betreibe ich z. Zt. noch eine CCU2 unter der Version 2.47.20 mit der CUxD Version 2.3.3 mit gemischter Infrastruktur aus Homematic und HomematicIP Komponenten sowie einigen CUxD Geräten, die Funktion ist stabil, wenn auch nicht besonders performant.

Den Umzug auf das virtuelle System habe ich wie hier im Forum beschrieben so vorbereitet, dass ich die dort vorhandene Zusatzsoftware „XML-API“ sowie „HQ-WebUI„ auf der CCU2 deinstalliert habe, CUxD installiert gelassen habe und dann ein Backup erstellt habe.

Das erstellt Backup lässt sich in der virtuellen Raspberry Version 3.49.17.20191225 problemlos zurückspielen, die entsprechende x86 CUxD Version darüber installieren. Nach einem durchgeführten Neustart läuft der CUxD als Prozess auf dem System (via Prozessliste geprüft) kann auch aus der CCU Systemsteuerung mit Web Interface aufgerufen werden, zeigt dort aber keine CCU Verbindungsinformationen an und wird nach einiger Zeit von der Raspberrymatic als nicht laufend gemeldet.

Ich habe den Fehler nach diversen Tests vermutlich soweit einkreisen können, dass er von CUxD Geräten vom Typ 90 „State Monitor Device“ herrührt die in dem CCU2 Backup enthalten sind und auf der CCU2 in der oben beschrieben Konfiguration problemlos arbeiten.

Als Gegentest habe ich ein Backup der oben beschrieben virtuellen Testinstallation zurückgespielt die wiederum problemlos läuft und dort mit einem unberührten CUxD ein Gerät vom Type 90 „State Monitor Device“ erstellt und nach einem Neustart in der RasüberryMatic als Gerät aus dem Posteingang aktiviert. Sobald man das Gerät zur Konfiguration aus dem WebUI der Raspberrymatic aufruft und abspeichern möchte, zeigt sich das gleiche Verhalten, wie nach dem Einspielen des Backups der CCU2, der CUxD stellt seine Arbeit ein.

Es sieht für mich momentan so aus, als wenn die x86 Version des CUxD ein Problem mit dem Device Typ 90 „State Monitor Device“ hat. Für die weitere Fehlersuche wäre es für mich sehr hilfreich zu hören ob es vergleichbare Fehlerbilder gibt.

Ich bin für jede Hilfestellung dankbar!

Gruss
Wolfgang
Shuttle DL10J, Proxmox VE mit RaspberryMatic 3.53.30.20200919, HB-RF-USB, HM-LGW + HmIP-HAP als LAN-Gateway, 628 Kanäle, 106 Geräte

Hackertomm
Beiträge: 302
Registriert: 18.04.2018, 12:32
Hat sich bedankt: 8 Mal
Danksagung erhalten: 7 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von Hackertomm » 22.01.2020, 13:06

Gestern war meine Raspberrymatic, die auf einer Qnap NAS TS-453 Pro 8GB läuft nicht erreichbar.
War aber nicht die Raspberrymatic schuld, sondern die NAS, deren Virtueller LAN-Adapter sich aufgehängt hat, was ich dann auch im LOG der NAS sah.
Im Log der VI der Raspberrymatic stand, dass sie die Verbindung verloren hat, was ja auch kein Wunder war.
Nachdem ich nagesehen habe, ob der virtuelle LAN wieder läuft, habe ich die Raspberrymatic einfach Neu gestartet und sehe mir die kommenden Tage sporadisch die Logs an.
Ansonsten habe ich mit der Raspberrymatic als VI keine Probleme, das läuft einwandfrei!
Gruß
Hackertomm

Virtual Image auf einer Qnap TS-453pro, 2GHZ Celeron u. 8GB RAM, aktuell Raspberry X86, Vers. 3.53.30.20200919

Baxxy
Beiträge: 1520
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 143 Mal
Danksagung erhalten: 226 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von Baxxy » 22.01.2020, 17:36

wiwo hat geschrieben:
17.01.2020, 18:11
Es sieht für mich momentan so aus, als wenn die x86 Version des CUxD ein Problem mit dem Device Typ 90 „State Monitor Device“ hat. Für die weitere Fehlersuche wäre es für mich sehr hilfreich zu hören ob es vergleichbare Fehlerbilder gibt.
Hallo Wolfgang,
ich konnte das Problem heute nachstellen. Habe eine frische virtuelle RaspberryMatic aufgesetzt, die passende CUxD-Version installiert und dann ein State-Monitor-Device (Typ 90) angelegt. Sah erstmal gut aus, das Gerät erschien im Posteingang der vRM und ließ sich problemlos übernehmen. Nach einem Neustart der vRM blieb dann die CUxD-Status Seite leer, beziehungsweise nach ca. 30 Sekunden Ladezeit erschien der CUxD-Service im Statusfenster. Bei der CUxD-Geräte Seite verhält es sich ähnlich. Zuerst leer, dann nach ca. 30s so...
CUxD_Fehler.JPG
Da ist also was nicht in Ordnung.
Das State-Monitor-Device lässt sich übrigens auch nicht mehr aus der vRM löschen. Alle Löschvarianten schlugen fehl.

Da müsste Jens dann mal schauen was da nicht passt.

Grüße
Baxxy
Grüße
Baxxy

Benutzeravatar
jmaus
Beiträge: 6112
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 34 Mal
Danksagung erhalten: 361 Mal
Kontaktdaten:

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von jmaus » 22.01.2020, 19:07

Ich würde eher mal vorschlagen an den Autor von CUxD heranzutreten da das Problem ja von CUxD ausgehen wird.
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Baxxy
Beiträge: 1520
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 143 Mal
Danksagung erhalten: 226 Mal

Re: RaspberryMatic Installationsanleitung: vmWare ESXi, VirtualBox, Proxmox, Synology, QNAP, QEmu, HyperV

Beitrag von Baxxy » 22.01.2020, 19:34

jmaus hat geschrieben:
22.01.2020, 19:07
Ich würde eher mal vorschlagen an den Autor von CUxD heranzutreten da das Problem ja von CUxD ausgehen wird.
Ich dachte diese spezielle CUxD-Version (cuxd_2.3.3_ccu_x86_32.tar.gz) für die virtuelle RaspberryMatic kommt von Dir.
Sie ist ja auch nicht im CUxD 2.3.4 - Thread zu finden.
Uwe fragen ist natürlich trotzdem eine Idee wert. :)

Grüße
Baxxy
Grüße
Baxxy

Gesperrt

Zurück zu „RaspberryMatic“