RaspberryPi/Tinkerboard Onboard Bluetooth

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

armin34320
Beiträge: 27
Registriert: 13.07.2016, 20:39
Wohnort: Kassel/Söhrewald

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von armin34320 » 09.01.2020, 12:22

Also alte version 3.45.5 mit HM-Funkmodul zeigt gleiches Verhalten. Kein ttyS0 vorhanden. Kein hci0 device zu sehen.

Soll ich das Funkmodul wirklich mal entfernen. Würde das das Bootverhalten denn ändern?
LG
Armin Schlösser

armin34320
Beiträge: 27
Registriert: 13.07.2016, 20:39
Wohnort: Kassel/Söhrewald

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von armin34320 » 09.01.2020, 13:27

Hab mal im S31bluetooth das Devive auf tty0 gelegt.
Nach dem boot finden sich dann folgende Ausgaben im /var/log/messages

Code: Alles auswählen

Jan  9 13:08:13 localhost user.info usbmount[289]: executing command: run-parts /etc/usbmount/mount.d
Jan  9 13:08:15 localhost user.info kernel: [    9.856596] usbcore: registered new interface driver snd-usb-audio
Jan  9 13:08:27 localhost user.notice rfkill: unblock set for type bluetooth
Jan  9 13:08:39 localhost user.info kernel: [   34.355391] Bluetooth: Core ver 2.22
Jan  9 13:08:39 localhost user.info kernel: [   34.355441] NET: Registered protocol family 31
Jan  9 13:08:39 localhost user.info kernel: [   34.355445] Bluetooth: HCI device and connection manager initialized
Jan  9 13:08:39 localhost user.info kernel: [   34.355456] Bluetooth: HCI socket layer initialized
Jan  9 13:08:39 localhost user.info kernel: [   34.355462] Bluetooth: L2CAP socket layer initialized
Jan  9 13:08:39 localhost user.info kernel: [   34.355485] Bluetooth: SCO socket layer initialized
Jan  9 13:08:39 localhost user.notice rfkill: block set for type bluetooth
Jan  9 13:08:40 localhost user.info kernel: [   34.419711] Generic PHY stmmac-0:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=stmmac-0:00, irq=POLL)
Leider aber immer noch kein hci device in rfkill zu sehen.

Code: Alles auswählen

rfkill unblock bluetooth
hilft auch nicht.
LG
Armin Schlösser

armin34320
Beiträge: 27
Registriert: 13.07.2016, 20:39
Wohnort: Kassel/Söhrewald

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von armin34320 » 09.01.2020, 13:44

Hab das S31bluetooth mal per hand aufgerufen.

Code: Alles auswählen

#
# ./S31bluetooth start
+ PATH=/sbin:/bin:/usr/sbin:/usr/bin
+ DESC=bluetooth
+ DAEMON=/usr/libexec/bluetooth/bluetoothd
+ HCIATTACH=/usr/bin/hciattach
+ HCICONFIG=/usr/bin/hciconfig
+ RFKILL=/usr/sbin/rfkill
+ DEVICE=/dev/tty0
+ SSD_OPTIONS='--oknodo --quiet --exec /usr/libexec/bluetooth/bluetoothd -- --compat'
+ test -f /usr/libexec/bluetooth/bluetoothd
+ echo -n 'Starting bluetooth: '
Starting bluetooth: + '[[' -f /etc/config/enableBluetooth ]]
+ '[[' -c /dev/tty0 ]]
+ '[[' -r /var/hm_mode ]]
+ . /var/hm_mode
+ HM_HMIP_ADDRESS=
+ HM_HMIP_DEV=RPI-RF-MOD
+ HM_HMIP_DEVNODE=/dev/raw-uart
+ HM_HMIP_SERIAL=98A9A585D7
+ HM_HMIP_SGTIN=3014F711A0001F98A9A585D7
+ HM_HMIP_VERSION=4.0.16
+ HM_HMRF_ADDRESS=
+ HM_HMRF_DEV=RPI-RF-MOD
+ HM_HMRF_DEVNODE=/dev/raw-uart
+ HM_HMRF_SERIAL=98A9A585D7
+ HM_HMRF_VERSION=4.0.16
+ HM_HOST=tinkerboard
+ HM_HOST_GPIO_RESET=185
+ HM_HOST_GPIO_UART=/dev/raw-uart
+ HM_LED_GREEN=/sys/class/leds/act-led
+ HM_LED_GREEN_MODE1=mmc0
+ HM_LED_GREEN_MODE2=heartbeat
+ HM_LED_RED=/sys/class/leds/pwr-led
+ HM_LED_RED_MODE1=timer
+ HM_LED_RED_MODE2=mmc0
+ HM_LED_YELLOW=/sys/class/leds/heartbeat-led
+ HM_LED_YELLOW_MODE1=none
+ HM_LED_YELLOW_MODE2=none
+ HM_MODE=NORMAL
+ HM_RTC=rx8130
+ '[[' tinkerboard '==' tinkerboard ]]
+ HCIATTACH=/usr/bin/rtk_hciattach
+ HCIATTACH_OPT='-s 115200 /dev/tty0 rtk_h5'
+ /usr/sbin/rfkill unblock bluetooth
+ /usr/bin/rtk_hciattach -s 115200 /dev/tty0 rtk_h5
+ echo -n .
.+ sleep 2
+ /usr/bin/hciconfig dev
+ '[' 1 -eq 0 ]
+ echo 'WARNING: bluetooth setup failed'
WARNING: bluetooth setup failed
+ /usr/sbin/rfkill block bluetooth
+ exit 0
Hilft das?
LG
Armin Schlösser

Benutzeravatar
jmaus
Beiträge: 5554
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 11 Mal
Danksagung erhalten: 216 Mal
Kontaktdaten:

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von jmaus » 09.01.2020, 14:01

armin34320 hat geschrieben:
09.01.2020, 13:44
Hab das S31bluetooth mal per hand aufgerufen.
[...]
Hilft das?
Nein, das hilft nicht und es liegt auch nicht am S31bluetooth. Auch ist /dev/tty0 definitiv falsch, das ist ein Konsolendevice und kein serielles wie /dev/ttyS0 (man beachte das 'S' im device namen!). Also bitte immer noch einfach mal ein paar Versionen zurückgehen und schauen ab wann es dann ein /dev/ttyS0 device gibt direkt nach dem booten.
RaspberryMatic 3.49.17.20191225 @ ESXi mit ~160 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

armin34320
Beiträge: 27
Registriert: 13.07.2016, 20:39
Wohnort: Kassel/Söhrewald

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von armin34320 » 09.01.2020, 18:45

Wo finde ich eine uralt version (noch vor 3.45.5)?
LG
Armin Schlösser

armin34320
Beiträge: 27
Registriert: 13.07.2016, 20:39
Wohnort: Kassel/Söhrewald

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von armin34320 » 09.01.2020, 18:50

Hat sich schon erledigt. Habe den next Button bei den Releases übersehen.
LG
Armin Schlösser

armin34320
Beiträge: 27
Registriert: 13.07.2016, 20:39
Wohnort: Kassel/Söhrewald

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von armin34320 » 27.01.2020, 11:08

Hallo jmaus.

Habe nun endlich nach deinem Wunsch eine uralt Version installiert.

RaspberryMatic-2.31.25.20180526-tinkerboard.zip

Tinkerboard booted und sit über ssh erreichbar.

Code: Alles auswählen

# uname -a
Linux schl_ccu3 4.4.126 #1 SMP PREEMPT Sat May 26 07:47:28 CEST 2018 armv7l GNU/Linux
# rfkill list
0: bt_default: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
2: phy1: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
3: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
#
# ls /dev/ttyS*
/dev/ttyS0  /dev/ttyS1  /dev/ttyS2  /dev/ttyS3
#
Hier sind also die seriellen tty's noch vorhanden. Und auch Bluetooth ist da.

Leider kann ich mich nun nicht mehr über die WebUI einloggen. Kommt immer 404 zurück.

Hoffe das hilft dir.
LG
Armin Schlösser

Benutzeravatar
jmaus
Beiträge: 5554
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 11 Mal
Danksagung erhalten: 216 Mal
Kontaktdaten:

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von jmaus » 27.01.2020, 11:20

armin34320 hat geschrieben:
27.01.2020, 11:08
Habe nun endlich nach deinem Wunsch eine uralt Version installiert.

RaspberryMatic-2.31.25.20180526-tinkerboard.zip

Tinkerboard booted und sit über ssh erreichbar.
[...]
Hier sind also die seriellen tty's noch vorhanden. Und auch Bluetooth ist da.

Leider kann ich mich nun nicht mehr über die WebUI einloggen. Kommt immer 404 zurück.

Hoffe das hilft dir.
Danke für das testen. Allerdings ist die 2.x.x ja wirklich schon recht alt. Nun müsstest du einfach mal dich schrittweise vorarbeiten bis zu der version wo die tty devices nicht mehr zu sehen sind bzw. bluetooth nicht mehr geht. das würde mir dann den entscheidenden hinweis geben woran das liegen könnte...
RaspberryMatic 3.49.17.20191225 @ ESXi mit ~160 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

armin34320
Beiträge: 27
Registriert: 13.07.2016, 20:39
Wohnort: Kassel/Söhrewald

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von armin34320 » 27.01.2020, 11:24

Hallo jmaus.

Komme jetzt aber nicht mehr über das WebUI auf die Raspberrymatic. Kann also auch nicht mehr installieren.

Nur der Zugriff über ssh geht noch.

Wie kann ich denn über die Konsole einen Update fahren?
LG
Armin Schlösser

Benutzeravatar
jmaus
Beiträge: 5554
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 11 Mal
Danksagung erhalten: 216 Mal
Kontaktdaten:

Re: RaspberryPi/Tinkerboard Onboard Bluetooth

Beitrag von jmaus » 27.01.2020, 11:26

armin34320 hat geschrieben:
27.01.2020, 11:24
Komme jetzt aber nicht mehr über das WebUI auf die Raspberrymatic. Kann also auch nicht mehr installieren.

Nur der Zugriff über ssh geht noch.

Wie kann ich denn über die Konsole einen Update fahren?
Boote doch in den Recovery Modus und spiele das Update von dort ein...
RaspberryMatic 3.49.17.20191225 @ ESXi mit ~160 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

Antworten

Zurück zu „RaspberryMatic“