virtualis. RaspberryMatic unter Synology: Crash bei USB-Disconnect

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
qwertz
Beiträge: 185
Registriert: 15.02.2012, 19:35
Hat sich bedankt: 2 Mal
Danksagung erhalten: 4 Mal

virtualis. RaspberryMatic unter Synology: Crash bei USB-Disconnect

Beitrag von qwertz » 03.02.2020, 14:13

Hallo zusammen !

Ich experimentiere mit virtueller RaspMatic unter Synology Virtual Machine Manager.

Das Funkmodul ist abgesetzt mit HB-RF-USB-TK und soll in Zukunft gfs. mit Verlängerungskabel oder RJ45-USB-Adapter funktechnisch optimal außerhalb des Serverschranks platziert werden. Aktuell klappt das im Normalbetrieb sehr gut und perfomant.

Damit das SmartHome zuverlässig und robust läuft, möchte ich gerne mitbekommen, wenn auf der Strecke USB-Kabel<<RJ45-Adapter<<LAN-Kabel>>RJ45-Adapter<<HB-RF-USB-TK etwas schief geht:

Zum Testen habe ich deshalb im laufenden Betrieb das USB-Kabel vom HB-RF-USB-TK abgezogen.

mit folgendem Ergebnis:

-Logmeldung s.u.
nach wenigen Sekunden:
-WebUI und Cuxd nicht erreichbar
-SSH-Konsole nicht erreichbar
-IP via PING nicht erreichbar
-im Synology VirtualMachineManager wird keine IP mehr angezeigt.
-im Synology VirtualMachineManager steigt die CPU-Auslastung der virt.RaspiMatic auf schwankend um 40-50%
-im Synology VirtualMachineManager lässt sich noch auf die HDMI-Konsole der RaspiMatic verbinden: dort zeigt sich das normale logo mit Firmware-Version und der IP

Konfig
Synology RS1219+
DSM DSM 6.2.2-24922 Update 4
VMM 250-9432
RaspiMatic3.49.17.20200131
Feb 3 13:50:04 ccu2keller user.info kernel: [59742.318046] usb 3-1: USB disconnect, device number 2
Feb 3 13:50:04 ccu2keller user.crit kernel: [59742.321490] gpio gpiochip0: REMOVING GPIOCHIP WITH GPIOS STILL REQUESTED
Feb 3 13:50:04 ccu2keller user.err kernel: [59742.321586] usb 3-1: bitmode request failed for value 0x0070: -19
Feb 3 13:50:06 ccu2keller user.warn kernel: [59745.875920] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59745.876003] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59745.876088] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59745.876158] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59745.876237] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59745.876319] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59745.876365] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59750.881986] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59750.882069] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59750.882154] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Feb 3 13:50:06 ccu2keller user.warn kernel: [59750.882223] gpio gpiochip0: gpiod_set_raw_value: backing chip is gone
Bildschirmfoto 2020-02-03 um 14.01.36.png
Bildschirmfoto 2020-02-03 um 13.53.03.png
Kann das Verhalten jemand reproduzieren mit seiner Synology, Proxmox oder intelNuc?
Ich fände es besser, wenn die RaspiMatic nicht komplett crashen würde, sondern noch in der Lage wäre z.B. über DutyCycle "-1" zu melden, dass etwas passiert ist.

Aktuell würde ich so einen Total-Crash wegen verlorenem Funkmodul nur durch den ausbleibenden LifeBeat (uptimerobot.com) mitkriegen.

Besten Dank und Gruß,
Sebastian

deimos
Beiträge: 3414
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 15 Mal
Danksagung erhalten: 134 Mal
Kontaktdaten:

Re: virtualis. RaspberryMatic unter Synology: Crash bei USB-Disconnect

Beitrag von deimos » 03.02.2020, 14:31

Hi,

das Problem kann ich dir bestätigen ohne es zu reproduzieren: Ich habe die Treiber für den Raw-Uart nicht auf Hotplug ausgelegt, weil der multimacd von einem fest verbauten GPIO Header ausgeht und dementsprechend kein Hotplug unterstützt. Und da letzerer Closed Source ist, kann nur eQ-3 daran was anpassen und da glaube ich nicht wirklich, dass sie das machen. Daher habe ich im Treiber die "Abkürzung" genommen.

Viele Grüße
Alex

qwertz
Beiträge: 185
Registriert: 15.02.2012, 19:35
Hat sich bedankt: 2 Mal
Danksagung erhalten: 4 Mal

Re: virtualis. RaspberryMatic unter Synology: Crash bei USB-Disconnect

Beitrag von qwertz » 04.02.2020, 10:51

Hi Alex !
Danke für die Rückmeldung. Das Verhalten ist damit verständlich.

Wird das gleiche auch dann bei der in Entwicklung befindlichen LAN-Version des HB-RF-USB passieren: also LAN-Disconnect = Crash ?

Auf jeden Fall Besten Dank für die tolleN Entwicklungen zum Thema abgesetzte Funkmodule !
Sebastian

deimos
Beiträge: 3414
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 15 Mal
Danksagung erhalten: 134 Mal
Kontaktdaten:

Re: virtualis. RaspberryMatic unter Synology: Crash bei USB-Disconnect

Beitrag von deimos » 04.02.2020, 11:01

Hi,

jein. Da hat der Disconnect keinen Stromausfall zur Folge. Problematisch wird es da dann nur, wenn der Disconnect wirklich lange anhält, wobei das dann nicht zu einem Crash auf Kernel Ebene führt.

Viele Grüße
Alex

roe1974
Beiträge: 518
Registriert: 17.10.2017, 16:15
Wohnort: Wien
Hat sich bedankt: 8 Mal
Danksagung erhalten: 2 Mal

Re: virtualis. RaspberryMatic unter Synology: Crash bei USB-Disconnect

Beitrag von roe1974 » 05.02.2020, 17:46

klingt sehr spannend !!!
wann ist die LAN Version geplant ?
lg Richard

scorpionking
Beiträge: 270
Registriert: 14.02.2016, 12:32
Hat sich bedankt: 10 Mal
Danksagung erhalten: 18 Mal

Re: virtualis. RaspberryMatic unter Synology: Crash bei USB-Disconnect

Beitrag von scorpionking » 05.02.2020, 21:03

roe1974 hat geschrieben:
05.02.2020, 17:46
wann ist die LAN Version geplant ?
Ich vermute die Antwort wird sein "Wenn sie fertig ist." :D

Antworten

Zurück zu „RaspberryMatic“