[GELÖST] Hilfe, mein usb0 ist weg

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Benutzeravatar
jmaus
Beiträge: 6382
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 46 Mal
Danksagung erhalten: 440 Mal
Kontaktdaten:

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von jmaus » 02.04.2020, 16:08

Andronid hat geschrieben:
02.04.2020, 13:35
Ok danke, habe ich gemacht. Ich gehe mal davon aus, dass nicht sofort ein Backup gemacht wird, sondern über Nacht. Dann werde ich mal etwas Geduld haben.
Nein, wenn du den Befehl "/sbin/cronBackup.sh" in einer SSH Sitzung manuell ausführst sollte natürlich sofort und unmittelbar ein Backup angelegt werden. Aber nur natürlich wenn der Pfad "/media/usb0" auch existiert.
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Benutzeravatar
Andronid
Beiträge: 258
Registriert: 06.03.2012, 17:52
Wohnort: Beelitz

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von Andronid » 02.04.2020, 16:19

jmaus hat geschrieben:
02.04.2020, 16:08
Nein, wenn du den Befehl "/sbin/cronBackup.sh" in einer SSH Sitzung manuell ausführst sollte natürlich sofort und unmittelbar ein Backup angelegt werden. Aber nur natürlich wenn der Pfad "/media/usb0" auch existiert.
Also mit diesem Befehl schreibt er: -sh: /sbin/cronBackup.sh: not found

Mit: sh /bin/cronBackup.sh führt er anscheinend etwas aus, da keine Fehlermeldung erscheint, aber ein Backup wird nicht erzeugt, obwohl usb0 vorhanden und alles unter usb1 abgelegt ist.
Beste Grüße
Andronid


--------------------------------------------------------------------------------------------------------
RaspiMatic, Fw: 3.51.6, 132 Kanäle in 66 Geräten und 48 CUxD-Kanäle in 3 CUxD-Geräten:

---------------------------------------------------------------------------------------------------------

Benutzeravatar
jmaus
Beiträge: 6382
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 46 Mal
Danksagung erhalten: 440 Mal
Kontaktdaten:

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von jmaus » 02.04.2020, 16:40

Andronid hat geschrieben:
02.04.2020, 16:19
jmaus hat geschrieben:
02.04.2020, 16:08
Nein, wenn du den Befehl "/sbin/cronBackup.sh" in einer SSH Sitzung manuell ausführst sollte natürlich sofort und unmittelbar ein Backup angelegt werden. Aber nur natürlich wenn der Pfad "/media/usb0" auch existiert.
Also mit diesem Befehl schreibt er: -sh: /sbin/cronBackup.sh: not found

Mit: sh /bin/cronBackup.sh führt er anscheinend etwas aus, da keine Fehlermeldung erscheint, aber ein Backup wird nicht erzeugt, obwohl usb0 vorhanden und alles unter usb1 abgelegt ist.
Ja, /bin/cronBackup.sh ist natürlich richtig. Hatte mich vertippt.

Und es gibt natürlich bedingungen die gegeben sein müssen damit das cronBackup auch wirklich losläuft. Zeig doch mal bitte die Ausgabe der folgenden Kommandos:

Code: Alles auswählen

df -h

Code: Alles auswählen

ls -la /media/

Code: Alles auswählen

cat /etc/config/CronBackupPath

Code: Alles auswählen

ls -la /etc/config/NoCronBackup
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Benutzeravatar
Andronid
Beiträge: 258
Registriert: 06.03.2012, 17:52
Wohnort: Beelitz

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von Andronid » 02.04.2020, 17:09

jmaus hat geschrieben:
02.04.2020, 16:40

Code: Alles auswählen

df -h

Code: Alles auswählen

ls -la /media/

Code: Alles auswählen

cat /etc/config/CronBackupPath

Code: Alles auswählen

ls -la /etc/config/NoCronBackup

Code: Alles auswählen

df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root               975.9M    504.4M    404.3M  56% /
devtmpfs                479.9M         0    479.9M   0% /dev
tmpfs                   484.4M         0    484.4M   0% /dev/shm
tmpfs                   484.4M    112.0K    484.3M   0% /tmp
tmpfs                   484.4M    124.0K    484.2M   0% /run
tmpfs                   484.4M     13.6M    470.8M   3% /var
tmpfs                   484.4M      5.0M    479.3M   1% /media
/dev/mmcblk0p3           27.9G     75.6M     26.4G   0% /usr/local
/dev/mmcblk0p1          255.7M     46.3M    209.4M  18% /boot


[email protected]:~# ls -la /media/
total 4
drwxrwxrwt   10 root     root           220 Mar 22 11:50 .
drwxr-xr-x   23 root     root          4096 Mar 22 10:53 ..
lrwxrwxrwx    1 root     root            11 Mar 22 11:50 usb0 -> /media/usb1
drwxrwxrwx    7 root     root           160 Mar 23 16:57 usb1
drwxr-xr-x    2 root     root            40 Mar 22 10:51 usb2
drwxr-xr-x    2 root     root            40 Mar 22 10:51 usb3
drwxr-xr-x    2 root     root            40 Mar 22 10:51 usb4
drwxr-xr-x    2 root     root            40 Mar 22 10:51 usb5
drwxr-xr-x    2 root     root            40 Mar 22 10:51 usb6
drwxr-xr-x    2 root     root            40 Mar 22 10:51 usb7
drwxr-xr-x    2 root     root            40 Mar 22 10:51 usb8


[email protected]:~# cat /etc/config/CronBackupPath
cat: can't open '/etc/config/CronBackupPath': No such file or directory
Beste Grüße
Andronid


--------------------------------------------------------------------------------------------------------
RaspiMatic, Fw: 3.51.6, 132 Kanäle in 66 Geräten und 48 CUxD-Kanäle in 3 CUxD-Geräten:

---------------------------------------------------------------------------------------------------------

Benutzeravatar
jmaus
Beiträge: 6382
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 46 Mal
Danksagung erhalten: 440 Mal
Kontaktdaten:

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von jmaus » 02.04.2020, 17:37

Andronid hat geschrieben:
02.04.2020, 17:09

Code: Alles auswählen

df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root               975.9M    504.4M    404.3M  56% /
devtmpfs                479.9M         0    479.9M   0% /dev
tmpfs                   484.4M         0    484.4M   0% /dev/shm
tmpfs                   484.4M    112.0K    484.3M   0% /tmp
tmpfs                   484.4M    124.0K    484.2M   0% /run
tmpfs                   484.4M     13.6M    470.8M   3% /var
tmpfs                   484.4M      5.0M    479.3M   1% /media
/dev/mmcblk0p3           27.9G     75.6M     26.4G   0% /usr/local
/dev/mmcblk0p1          255.7M     46.3M    209.4M  18% /boot
Ähmm. Ich seh da aber auch keinen USB Stick gemountet?!? Bist du sicher das du da einen korrekten USB Stick dranstecken hast der auch entsprechend mit einem unterstütztes Dateisystem (FAT, NTFS, ext4, f2fs, etc.) vorformatiert wurde? Wenn ja, dann sollte der Stick auch hier unter "df -h" auftauchen und die Diagrammfunktion sollte dann z.B. auch unter Einstellungen -> Diagramme keine Fehlermeldung bringen das kein USB Speicher angesteckt ist?!?
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Benutzeravatar
Andronid
Beiträge: 258
Registriert: 06.03.2012, 17:52
Wohnort: Beelitz

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von Andronid » 02.04.2020, 18:22

Der USB Stick (SD Karte) uwrde mit FAT 32 vorformatiert. Wenn er nicht richtig funktionieren würde, hätte ich sicher auch keine täglichen log Einträge. Mehr kann ich dazu allerdings nicht sagen. Ob er richtig gemountet ist ?????
Beste Grüße
Andronid


--------------------------------------------------------------------------------------------------------
RaspiMatic, Fw: 3.51.6, 132 Kanäle in 66 Geräten und 48 CUxD-Kanäle in 3 CUxD-Geräten:

---------------------------------------------------------------------------------------------------------

Benutzeravatar
jmaus
Beiträge: 6382
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 46 Mal
Danksagung erhalten: 440 Mal
Kontaktdaten:

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von jmaus » 02.04.2020, 18:49

Andronid hat geschrieben:
02.04.2020, 18:22
Der USB Stick (SD Karte) uwrde mit FAT 32 vorformatiert. Wenn er nicht richtig funktionieren würde, hätte ich sicher auch keine täglichen log Einträge. Mehr kann ich dazu allerdings nicht sagen. Ob er richtig gemountet ist ?????
Wo siehst du denn bitte „tägliche Logeinträge“ auf dem USB Stick? Das einzige was ich aus deinen ausgaben erkennen kann ist, das es ein /media/usb1 verzechnis gibt das anscheinend schreibbar ist und in dem daten liegen. Das liegt aber komischerweise nicht auf dem USB Stick sondern rein im RAM. D.h. Nach eine neustart dürfte das verzeichnis leer sein. Die frage wäre also, wer macht das /media/usb1 schreibbar ist und usb0 auf usb1 verlinkt?!? Ein usb stock erkenne ich definitiv nicht aus deiner „df -h“ anzeige. Du musst also irgendwas gemacht haben das /media/usb1 schreibbar gemacht hat...
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Benutzeravatar
Andronid
Beiträge: 258
Registriert: 06.03.2012, 17:52
Wohnort: Beelitz

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von Andronid » 02.04.2020, 19:15

jmaus hat geschrieben:
02.04.2020, 18:49
Wo siehst du denn bitte „tägliche Logeinträge“ auf dem USB Stick?
Mein homeputerprogramm schreibt tägliche log Einträge und diese werden auf dem USB unter usb1 gesspeichert. Der Pfad : /media/usb1/log

usb1 ist auf usb0 verlinkt ich habe dazu einen Befehl aus einem früheren Post genommen, weil eben usb0 gefehlt hatte nachdem letzten Update. Vorher war eben alles funktionstüchtig.

Mehr kann ich leider nicht dazu sagen. Wenn du eine andere Anleitung hast würde ich mich freuen.
Beste Grüße
Andronid


--------------------------------------------------------------------------------------------------------
RaspiMatic, Fw: 3.51.6, 132 Kanäle in 66 Geräten und 48 CUxD-Kanäle in 3 CUxD-Geräten:

---------------------------------------------------------------------------------------------------------

Benutzeravatar
jmaus
Beiträge: 6382
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 46 Mal
Danksagung erhalten: 440 Mal
Kontaktdaten:

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von jmaus » 02.04.2020, 19:28

Andronid hat geschrieben:
02.04.2020, 19:15
jmaus hat geschrieben:
02.04.2020, 18:49
Wo siehst du denn bitte „tägliche Logeinträge“ auf dem USB Stick?
Mein homeputerprogramm schreibt tägliche log Einträge und diese werden auf dem USB unter usb1 gesspeichert. Der Pfad : /media/usb1/log

usb1 ist auf usb0 verlinkt ich habe dazu einen Befehl aus einem früheren Post genommen, weil eben usb0 gefehlt hatte nachdem letzten Update. Vorher war eben alles funktionstüchtig.

Mehr kann ich leider nicht dazu sagen. Wenn du eine andere Anleitung hast würde ich mich freuen.
Genau da liegt der Fehler! Du hast manuell in etwas eingegriffen das vollautomatisch beim anstecken des USB Sticks passiert (das verlinken von usb0 auf usb1)! Und ich vermute deshalb kann dein USB Stick nicht korrekt angebunden werden. Mein Vorschlag wäre dahee, bau erstmal alles wieder bzgl manuell Link anlegen usw zurück und dann schau erstmal das der USB Stick mit „df -h“ auch korrekt angebunden wird!
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Benutzeravatar
Andronid
Beiträge: 258
Registriert: 06.03.2012, 17:52
Wohnort: Beelitz

Re: "gelöst" Hilfe, mein usb0 ist weg

Beitrag von Andronid » 03.04.2020, 13:34

Ich habe jetzt die RaspiMatic ausgeschaltet, den Stick neu formatiert, ihn wieder hineingesteckt und die RaspiMatic gestartet. Mit Filezilla konnte ich feststellen, dass usb0 angelegt und in usb1 2 Dateien angelegt. Mit dem Befehl "sh /bin/cronBackup.sh" wurde auch der Backup Ordner mit dem ersten Backup angelegt. Auch die grüne LED blinkt nicht mehr. Ich gehe somit davon aus, dass nun alles richtig funktioniert.
Mit df -h erscheint
[email protected]:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 975.9M 504.4M 404.3M 56% /
devtmpfs 479.9M 0 479.9M 0% /dev
tmpfs 484.4M 0 484.4M 0% /dev/shm
tmpfs 484.4M 108.0K 484.3M 0% /tmp
tmpfs 484.4M 128.0K 484.2M 0% /run
tmpfs 484.4M 3.4M 481.0M 1% /var
tmpfs 484.4M 0 484.4M 0% /media
/dev/mmcblk0p3 27.9G 75.6M 26.4G 0% /usr/local
/dev/mmcblk0p1 255.7M 46.3M 209.4M 18% /boot
/dev/sda1 29.7G 12.3M 29.7G 0% /media/usb1

Die letzte Zeile war vorher nicht vorhanden (siehe vorheriger Post).
Danke an alle, die mitgeholfen haben.
Beste Grüße
Andronid


--------------------------------------------------------------------------------------------------------
RaspiMatic, Fw: 3.51.6, 132 Kanäle in 66 Geräten und 48 CUxD-Kanäle in 3 CUxD-Geräten:

---------------------------------------------------------------------------------------------------------

Antworten

Zurück zu „RaspberryMatic“