RaspberryMatic 3.51.6.20200420 – Neue Version

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

CoolmanHB
Beiträge: 64
Registriert: 14.02.2010, 20:33
Hat sich bedankt: 5 Mal
Danksagung erhalten: 2 Mal

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von CoolmanHB » 30.04.2020, 18:40

.....geht usb mit Tinkerboard?.....

Ja geht ohne Probleme! :D

Filesystem: /media/usb1 vfat (rw) Total 60637696k Used 2727168k ( 4.5%) Free 57910528k (95.5%)
@TinkerS
:wink:

Benutzeravatar
jmaus
Beiträge: 5793
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 14 Mal
Danksagung erhalten: 285 Mal
Kontaktdaten:

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von jmaus » 30.04.2020, 19:04

CoolmanHB hat geschrieben:
30.04.2020, 18:40
.....geht usb mit Tinkerboard?.....

Ja geht ohne Probleme! :D

Filesystem: /media/usb1 vfat (rw) Total 60637696k Used 2727168k ( 4.5%) Free 57910528k (95.5%)
Gut! Dann bitte mal den anderen Leute die anscheinend Probleme mot USB Sticks und Tinkerboard haben etwas unter die Arme greifen und zusammen das Problem debuggen. Es muss ja da irgendeinen Grund geben warum es bei denen anscheinend nicht funktioniert.
RaspberryMatic 3.51.6.20200420 @ ESXi mit ~170 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

Benutzeravatar
jmaus
Beiträge: 5793
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 14 Mal
Danksagung erhalten: 285 Mal
Kontaktdaten:

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von jmaus » 30.04.2020, 19:19

jmaus hat geschrieben:
30.04.2020, 19:04
CoolmanHB hat geschrieben:
30.04.2020, 18:40
.....geht usb mit Tinkerboard?.....

Ja geht ohne Probleme! :D

Filesystem: /media/usb1 vfat (rw) Total 60637696k Used 2727168k ( 4.5%) Free 57910528k (95.5%)
Gut! Dann bitte mal den anderen Leute die anscheinend Probleme mot USB Sticks und Tinkerboard haben etwas unter die Arme greifen und zusammen das Problem debuggen. Es muss ja da irgendeinen Grund geben warum es bei denen anscheinend nicht funktioniert.
So, nun hab ich einfach mal kurz es selber getestet. Es scheint in der Tat wohl so zu sein das mit der aktuellen 3.51.6.20200420 Version mit dem Tinkerboard das Hotplug von USB Sticks nicht zu funktionieren scheint. D.h. wenn man den USB Stick bereits beim Starten/Reboot des Tinkerboard angeschlossen hat wird er wohl korrekt erkannt. Aber sobald man ihn einmal unmountet oder rauszieht und wieder verbindet wird er nicht mehr erkannt. Hier scheint es irgendein Kernelproblem zu geben das ich mir genauer anschauen muss. Wer will kann dazu gerne mal im RaspberryMatic GitHub ein entsprechendes Ticket aufmachen.
RaspberryMatic 3.51.6.20200420 @ ESXi mit ~170 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

hammeran
Beiträge: 6
Registriert: 23.12.2018, 04:56
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von hammeran » 30.04.2020, 19:23

jmaus hat geschrieben:
30.04.2020, 18:22
Gerade aber heute hat jemand berichtet bei uhm geht usb mit Tinkerboard?!? Siehe viewtopic.php?f=65&t=58251&start=90#p578668

Nun bin ich aber verwirrt. Geht, geht nicht, Geht?!? Was denn nun?
Bei mir ebenfalls kein Problem mit USB und Tinkerboard ...

Benutzeravatar
kopy
Beiträge: 53
Registriert: 28.12.2015, 14:35
Danksagung erhalten: 3 Mal

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von kopy » 30.04.2020, 21:58

Also, ich habe auf meinem Pi4 vor kurzem die Vorgängerversion der Raspberrymatic ohne Probleme installieren können, und das update läuft auch einwandfrei. Das einzige Problem das ich seit der Umstellung von der CCu2 auf Raspi habe, das mein Wemos, den ich als IR-Fernbedienung nutze, manchmal fast 20 sekunden überlegt ob er nun senden soll oder nicht. Sehr eigenartig. Werden 2 Befehle hintereinander geschickt, dann ist der zweite flux da. Als wenn der CuxD mit dem ich den HTTP Befehl sende einfach eingeschlafen wäre.

Sieht bei mir so aus:

Code: Alles auswählen

string url = "http://192.168.2.136/dvd";
dom.GetObject("CUxD.CUX2801002:10.CMD_EXEC").State("wget -q -O /dev/null  "#url);
Vieleicht hat ja noch jemand eine Idee

Benutzeravatar
jmaus
Beiträge: 5793
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 14 Mal
Danksagung erhalten: 285 Mal
Kontaktdaten:

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von jmaus » 30.04.2020, 22:52

kopy hat geschrieben:
30.04.2020, 21:58
Sieht bei mir so aus:

Code: Alles auswählen

string url = "http://192.168.2.136/dvd";
dom.GetObject("CUxD.CUX2801002:10.CMD_EXEC").State("wget -q -O /dev/null  "#url);
Vieleicht hat ja noch jemand eine Idee
Auch hier nochmal der Hinweis, das das nutzen von CUxD für solch simple „wget“ aufrufe wirklich doch ein Relikt aus alten Tagen ist. Dafür kann man schon seit geraumer Zeit völlig problemlos und wesentlich schonender den folgenden system.Exec() Aufruf nutzen:

Code: Alles auswählen

string url = "http://192.168.2.136/dvd";
system.Exec("wget -q -O /dev/null '"# url # "' &");
Vielleicht löst ja auch das bereits dein Problem. Würde mich nicht wundern.
RaspberryMatic 3.51.6.20200420 @ ESXi mit ~170 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

Benutzeravatar
jmaus
Beiträge: 5793
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 14 Mal
Danksagung erhalten: 285 Mal
Kontaktdaten:

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von jmaus » 01.05.2020, 09:09

jmaus hat geschrieben:
30.04.2020, 19:19
So, nun hab ich einfach mal kurz es selber getestet. Es scheint in der Tat wohl so zu sein das mit der aktuellen 3.51.6.20200420 Version mit dem Tinkerboard das Hotplug von USB Sticks nicht zu funktionieren scheint. D.h. wenn man den USB Stick bereits beim Starten/Reboot des Tinkerboard angeschlossen hat wird er wohl korrekt erkannt. Aber sobald man ihn einmal unmountet oder rauszieht und wieder verbindet wird er nicht mehr erkannt. Hier scheint es irgendein Kernelproblem zu geben das ich mir genauer anschauen muss. Wer will kann dazu gerne mal im RaspberryMatic GitHub ein entsprechendes Ticket aufmachen.
Gestern hab ich mich dem Problem mit dem USB Stick mounten unter einem Tinkerboard noch einmal angenommen und den Linux Kernel auf die aktuellste 4.19.119 geupdatet. Dies scheint zumindest hier das Problem gelöst zu haben. Wer also das Problem hat oder gerne testen will ob mit der aktuellen 20200501 Testversion das Problem wirklich verschwunden ist, kann gerne diese von folgender Stelle runterladen und testen:

https://github.com/jens-maus/RaspberryM ... /snapshots
RaspberryMatic 3.51.6.20200420 @ ESXi mit ~170 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

Joetra
Beiträge: 55
Registriert: 10.09.2015, 13:06

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von Joetra » 01.05.2020, 10:16

jmaus hat geschrieben:
30.04.2020, 19:19
jmaus hat geschrieben:
30.04.2020, 19:04
CoolmanHB hat geschrieben:
30.04.2020, 18:40
.....geht usb mit Tinkerboard?.....

Ja geht ohne Probleme! :D

Filesystem: /media/usb1 vfat (rw) Total 60637696k Used 2727168k ( 4.5%) Free 57910528k (95.5%)
Gut! Dann bitte mal den anderen Leute die anscheinend Probleme mot USB Sticks und Tinkerboard haben etwas unter die Arme greifen und zusammen das Problem debuggen. Es muss ja da irgendeinen Grund geben warum es bei denen anscheinend nicht funktioniert.
So, nun hab ich einfach mal kurz es selber getestet. Es scheint in der Tat wohl so zu sein das mit der aktuellen 3.51.6.20200420 Version mit dem Tinkerboard das Hotplug von USB Sticks nicht zu funktionieren scheint. D.h. wenn man den USB Stick bereits beim Starten/Reboot des Tinkerboard angeschlossen hat wird er wohl korrekt erkannt. Aber sobald man ihn einmal unmountet oder rauszieht und wieder verbindet wird er nicht mehr erkannt. Hier scheint es irgendein Kernelproblem zu geben das ich mir genauer anschauen muss. Wer will kann dazu gerne mal im RaspberryMatic GitHub ein entsprechendes Ticket aufmachen.
Hallo Jens,

vielen Dank für Deine Mühe und Deine Rückmeldung. Ich verzweifelte so langsam an mir selbst ("bei jedem funktioniert's - nur bei mir nicht? :roll: ).
Als Linux-Dummie bin ich immer wieder baff, was Du so alles entdeckst, obwohl meine Beschreibungen extrem laienhaft sind.
Es geht wieder mal eine Kleinigkeit raus.

Viele Grüße

Jörg

Benutzeravatar
jmaus
Beiträge: 5793
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 14 Mal
Danksagung erhalten: 285 Mal
Kontaktdaten:

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von jmaus » 01.05.2020, 11:05

Joetra hat geschrieben:
01.05.2020, 10:16
jmaus hat geschrieben:
30.04.2020, 19:19

So, nun hab ich einfach mal kurz es selber getestet. Es scheint in der Tat wohl so zu sein das mit der aktuellen 3.51.6.20200420 Version mit dem Tinkerboard das Hotplug von USB Sticks nicht zu funktionieren scheint. D.h. wenn man den USB Stick bereits beim Starten/Reboot des Tinkerboard angeschlossen hat wird er wohl korrekt erkannt. Aber sobald man ihn einmal unmountet oder rauszieht und wieder verbindet wird er nicht mehr erkannt. Hier scheint es irgendein Kernelproblem zu geben das ich mir genauer anschauen muss. Wer will kann dazu gerne mal im RaspberryMatic GitHub ein entsprechendes Ticket aufmachen.
vielen Dank für Deine Mühe und Deine Rückmeldung. Ich verzweifelte so langsam an mir selbst ("bei jedem funktioniert's - nur bei mir nicht? :roll: ).
Als Linux-Dummie bin ich immer wieder baff, was Du so alles entdeckst, obwohl meine Beschreibungen extrem laienhaft sind.
Heisst das jetzt das du die 20200501 Testversion installiert hast und das Problem damit jetzt bei dir behoben ist? Das würde mir nämlich helfen diese Information zurück zu erhalten damit es für die nächste offizielle Version dann so vermerkt ist.
RaspberryMatic 3.51.6.20200420 @ ESXi mit ~170 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

Benutzeravatar
kopy
Beiträge: 53
Registriert: 28.12.2015, 14:35
Danksagung erhalten: 3 Mal

Re: RaspberryMatic 3.51.6.20200420 – Neue Version

Beitrag von kopy » 01.05.2020, 11:58

Danke, ich werde es ausprobieren.

Gruß, Gerd

Antworten

Zurück zu „RaspberryMatic“