Backup erstellen - nur Betriebssystem wir gespeichert, keine Betriebsdaten

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
ASchni
Beiträge: 1
Registriert: 20.12.2019, 07:41

Backup erstellen - nur Betriebssystem wir gespeichert, keine Betriebsdaten

Beitrag von ASchni » 26.04.2020, 11:19

Hallo,
ich nutze seit einigen Monaten Homematic (Raspberry Pi 3 Modell B, Bausatz von ELV in Verbindung mit AP-wired System),
bin also noch ein Anfänger.
Es ist mit Sicherheit ein Anfängerfehler, bin aber zu blöd ihn zu finden.

Seit dem update auf 3.51.6.20200420 kann ich kein bzw. nur ein abgespecktes backup erstellen.

Mein Vorgehen wie immer:
+ Einstellungen - Systemsteuerung - Sicherheit - Backup-Verwaltung - Backup erstellen
+ "Das System-Backup wird jetzt erstellt. Dieser Vorgang kann einige Minuten dauern."
+ Jetzt erscheint sofort das Auswahlfenster (ich speicher meine .skb lokal auf einem Notebook) "Datei speichern"
+ Die .skb Datei wird auch gespeichert

Die .skb Datei ist aber nur 1,4 MB groß und enthält nur das Betriebssystem.
Es sind keinerlei Betriebs-/ Nutzerdaten vorhanden.
Meine richtigen backups mit Betriebs- und Nutzerdaten sind im Schnitt 23 MB groß.

Ich habe das 1,4 MB backup auch schon einmal eingespielt, es befindet sich dann ausschließend das
Betriebssystem auf der CCU (wie bei der Erstinbetriebnahme).

Schon gemacht:
- Neustart
- Ältes backup mit Betriebs-/ und Nutzerdaten eingspielt (backup läuft einwandfrei)

Noch nicht gemacht:
- auf die Version "RaspberryMatic 3.51.6.20200229" zurück gewechselt,
da ich sehr viele Änderungen gemacht habe und diese dann alle weg wären

mfG

Hütte
Beiträge: 393
Registriert: 08.02.2017, 11:08
Hat sich bedankt: 8 Mal
Danksagung erhalten: 28 Mal

Re: Backup erstellen - nur Betriebssystem wir gespeichert, keine Betriebsdaten

Beitrag von Hütte » 04.05.2020, 20:06

Also bei meiner Installation (Tinker S) kann ich das nicht bestätigen - gerade eben noch einmal getestet. Da wird mir auch schon bei der Anzeige "Speichern unter" die Größe von 31.9 MB angezeigt und auch so komplett abgespeichert.

Das Backup enthält aber nicht das Betriebssystem sondern nur alle installierten AddOns sowie die von dir angelegten Objekte, wie Geräte, Systemvariablen, Programme, Favoriten, Netzwerk- und Firewalleinstellungen, ... Wenn das Betriebssystem mit enthalten wäre, dann wäre dein Backup über 230 MB groß, denn so groß ist alleine schon die gepackte Image-Datei für einen RasbBerry Pi 3.

Hast du eventuell das Mediola Addon deinstalliert? Das schlägt schon allein mit knapp 21 MB zu Buche, auch wenn es deaktiviert ist. Wenn du es deinstalliert hast, dann würde es schon einmal so ziemlich genau die Differenz zu deiner früheren Backup-Größe von 23 MB erklären.

Du wirst ja sicherlich einen USB-Stick an deinem System haben. Dort wird seit einiger Zeit täglich um 00:07 vom System automatisch ein Backup angelegt.

Falls du das CUxD-AddOn installiert hast, dann kannst du nach Aufruf der CUxD-Seite bei Info in das Verzeichnis "/media/usb1/backup/" mal schauen, wie groß dort die täglich gespeicherten Backups sind.

Falls du kein CUxD installiert hast und auch nicht das Mediola-AddOn deinstalliert hast, dann fahre am Besten die Zentrale konrolliert über "Einstellungen - Systemsteuerung - Zentralen Wartung - Herunterfahren" herunter. Dabei wird auch noch gleichzeitig der Systemzustand komplett festgeschrieben. Erst wenn am Pi alle LED's aus sind kannst du Pi stromlos machen und den USB-Stick abziehen, an deinem Notebook anstecken und dann im Verzeichnis "Backup" nachschauen. Dort liegen die automatisch generierten Backups der letzten 30 Tage (falls nicht anderes eingestellt). Sollten die ebenfalls nur so klein sein, dann hätte ich nur noch die Vermutung, dass du in einigen Verzeichnissen eine Datei mit dem Namen ".nobackup" angelegt hast (Punkt am Anfang ist wichtig). Denn dann werden diese Verzeichnisse vom Backup ausgeschlossen. Diese Backup-Dateien kannst du dir dann gleich auf deinen Rechner sichern, wenn du möchtest. Danach den USB-Stick wieder am Pi anstecken und und den Pi mit Strom versorgen, so das er wieder startet.

Und zu deinem letzen Satz. Bei einem Wechel auf eine frühere Version wären deine Änderungen nicht weg, da, wie gesagt, im Backup nicht das System, sondern deine Nutz-Daten enthalten sind. Das kannst du ganz einfach testen. Du erstellst ein Backup wie du es bisher gemacht hast. Auch beim Erstellen eines Backups wird zuerst der Systemzustand festgeschrieben, was sonst nur aller paar Stunden erfolgt oder bei einem aktiven Abmelden in der WebUI. Dann flashst du eine neue SD-Karte mit dem Image vom 29. Februar, fährst wie oben angegeben den Pi runter, tauschst die SD-Karten, dadurch hast du immer den alten Zustand in Reserve. Dann Pi starten, Backup einspielen, einmal neu starten und dann sollte der gleiche Zustand mit all deinen Geräten, Programmen, ... wieder vorhanden sein.

Antworten

Zurück zu „RaspberryMatic“