RaspberryMatic verliert Verbindung zum Funklangateway

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

virgin
Beiträge: 521
Registriert: 09.01.2013, 18:36
Wohnort: Leichlingen
Hat sich bedankt: 4 Mal
Kontaktdaten:

RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von virgin » 15.05.2020, 08:44

In unregelmäßigen Abständen verliert meine RaspberryMatic die Verbindung zum FLGW. Das FLGW lässt sich weiterhin anpingen. Abhilfe schafft dann nur ein Neustart des RaspberryMatic.

Ich benutze die Version 3.51.6.20200229. Ich bilde mir ein, kann es aber nicht sicher sagen, dass das Problem bei der 3.49.17.20200131 nicht auftrat.

Gibt es eine Möglichkeit, nur den Dienst, der für die Verbindung zuständig ist, neu zu starten? Was könnte die Ursache fur den Verlust der Verbindung sein?

Danke für Hilfe.
Bernd

manfredh
Beiträge: 3045
Registriert: 09.09.2012, 10:41
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 26 Mal
Danksagung erhalten: 119 Mal

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von manfredh » 15.05.2020, 09:22

Mit welcher Physik verbindest du? LAN-Kabel/WLAN/Powerlan...
Es gibt 10 Arten von Menschen: solche die Binärcode verstehen und solche, die ihn nicht verstehen.

virgin
Beiträge: 521
Registriert: 09.01.2013, 18:36
Wohnort: Leichlingen
Hat sich bedankt: 4 Mal
Kontaktdaten:

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von virgin » 15.05.2020, 09:34

Es geht leider nur wlan, d.h. ich habe an das FLGW wlan to lan Adapter angeschlossen. Das ist übrigens auch bei meinem 2. FLGW der Fall. Nur da tritt das Problem nicht auf.
Bernd

manfredh
Beiträge: 3045
Registriert: 09.09.2012, 10:41
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 26 Mal
Danksagung erhalten: 119 Mal

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von manfredh » 15.05.2020, 14:17

Lan Gateway nicht per Kabel anschließen ist halt leider eine Lösung, die Fehleranfällig ist. Das LGW ist da eine Mimose. Es kann funktionieren, muss aber nicht - kurze Störungen / Unterbrechungen der Verbindung können dazu führen, dass es dauerhaft bis zu einem Reboot fehlt.

Ich würde mal nach Störern suchen und / oder mit den Funkkanälen experimentieren.
Es gibt 10 Arten von Menschen: solche die Binärcode verstehen und solche, die ihn nicht verstehen.

virgin
Beiträge: 521
Registriert: 09.01.2013, 18:36
Wohnort: Leichlingen
Hat sich bedankt: 4 Mal
Kontaktdaten:

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von virgin » 15.05.2020, 14:22

Vielen Dank für den Hinweis. Ist das LGW oder die Zentrale die Mimose?

Ich werde sicherheitshalber sich noch einmal testen, ob die Version der RaspberryMatic einen Einfluss hat.

Kann man nicht einfach nur den Dienst neu starten?
Bernd

manfredh
Beiträge: 3045
Registriert: 09.09.2012, 10:41
System: Alternative CCU (RaspberryMatic etc.)
Hat sich bedankt: 26 Mal
Danksagung erhalten: 119 Mal

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von manfredh » 15.05.2020, 14:29

virgin hat geschrieben:
15.05.2020, 14:22
Ist das LGW oder die Zentrale die Mimose?
Keine Ahnung.
virgin hat geschrieben:
15.05.2020, 14:22
Kann man nicht einfach nur den Dienst neu starten?
Auch das weiß ich nicht.

Meine Versuche mit dem LGW habe ich recht schnell eingestellt. Mit einer Aurel Groudplane decke ich jetzt jeden Winkel meines EFH inkl. 800qm Grundstück ab.
Es gibt 10 Arten von Menschen: solche die Binärcode verstehen und solche, die ihn nicht verstehen.

virgin
Beiträge: 521
Registriert: 09.01.2013, 18:36
Wohnort: Leichlingen
Hat sich bedankt: 4 Mal
Kontaktdaten:

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von virgin » 16.05.2020, 09:26

Wie ich sehe, haben auch andere das Problem. Aber, welche Lösung gibt es? Ich meine softwareseitig? Neustart des Systems kann ja keine dauerhafte Lösung sein. Es müsste doch vlt. via watchdog und Neustart nur des Dienstes funktionieren?
Bernd

jp112sdl
Beiträge: 5105
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 189 Mal
Danksagung erhalten: 402 Mal
Kontaktdaten:

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von jp112sdl » 16.05.2020, 09:36

manfredh hat geschrieben:
15.05.2020, 14:17
Das LGW ist da eine Mimose.
Eher der RFD seitens der CCU/RM.
virgin hat geschrieben:
15.05.2020, 14:22
Kann man nicht einfach nur den Dienst neu starten?
Beim Start des Dienstes "RFD" wird das LGW verbunden.
Und eigentlich nach einem Disconnected auch wieder neu verbunden.
Das klappt - manchmal - manchmal auch nicht.

Ein Restart des RFD sollte reichen.

VG,
Jérôme ☕️

virgin
Beiträge: 521
Registriert: 09.01.2013, 18:36
Wohnort: Leichlingen
Hat sich bedankt: 4 Mal
Kontaktdaten:

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von virgin » 16.05.2020, 09:44

Dankeschön. Ich teste das mal.
Bernd

virgin
Beiträge: 521
Registriert: 09.01.2013, 18:36
Wohnort: Leichlingen
Hat sich bedankt: 4 Mal
Kontaktdaten:

Re: RaspberryMatic verliert Verbindung zum Funklangateway

Beitrag von virgin » 16.05.2020, 09:58

Wie starte ich den rfd Dienst neu?
Bernd

Antworten

Zurück zu „RaspberryMatic“