offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
ESPe71
Beiträge: 4
Registriert: 25.06.2020, 15:41
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 3 Mal

offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von ESPe71 » 25.06.2020, 15:56

Hallo,

langsam bin ich mit meinem Latein am Ende. Ich habe den offiziellen POE-Hat auf meinem RPi4-2GB. Strom bekommt er auch vom Switch. Leider scheint der Lüfter nicht mit Raspberrymatic zu funktionieren. An einem anderen RPi mit Raspian funktioniert der Lüfter und schaltet sich auch bei etwa 50°C ein um sich dann bei ca. 46-48°C einzupegeln.
Die I2C-Schnittstelle ist bei Raspberrymatic auch aktiviert. Mehr muss man normalerweise auch nicht machen; oder doch?
Hat jemand auch schon einmal dieses Problem gehabt und es gelöst?

Vielen Dank schon mal im Voraus...
Zuletzt geändert von Roland M. am 25.06.2020, 16:16, insgesamt 1-mal geändert.
Grund: Thema verschoben

Benutzeravatar
jmaus
Beiträge: 6287
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 41 Mal
Danksagung erhalten: 415 Mal
Kontaktdaten:

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von jmaus » 26.06.2020, 09:57

ESPe71 hat geschrieben:
25.06.2020, 15:56
langsam bin ich mit meinem Latein am Ende. Ich habe den offiziellen POE-Hat auf meinem RPi4-2GB. Strom bekommt er auch vom Switch. Leider scheint der Lüfter nicht mit Raspberrymatic zu funktionieren. An einem anderen RPi mit Raspian funktioniert der Lüfter und schaltet sich auch bei etwa 50°C ein um sich dann bei ca. 46-48°C einzupegeln.
Die I2C-Schnittstelle ist bei Raspberrymatic auch aktiviert. Mehr muss man normalerweise auch nicht machen; oder doch?
Hat jemand auch schon einmal dieses Problem gehabt und es gelöst?
Nun, RaspberryMatic ist eben kein RaspberryPiOS/Raspbian. Und für das POE-Hat benötigt es ein sogenanntes device tree overlay das es wohl bei Raspbian/PiOS standardmäßig dabei gibt, bei RaspberryMatic aber eben nicht. Und das aus dem einfachen Grund da ich selbst keins dieser POE-Hat hier habe um mir das anzuschauen und ggf. das so zu integrieren das es auch keine negativen auswirkungen auf nicht-POE-Hat Nutzer hat.

Darüberhinaus bezweifle ich aber auch, das der nutzen dieses POE-Hat gerade im Hinblick auf RaspberryMatic bzw. einer HomeMatic CCU wirklich immens ist. Gerade bezogen auf das Funkmodul, das man da ja noch oben draufmachen müsste würde es mich nicht wundern wenn das POE-Hat soviel RF interferenzen in der unmittelbaren nähe des funkmodules macht das damit dann die Funkqualität eine oben aufgesetzten Funkmodules nicht unweigerlich in die Knie geht.

Auch gibt es doch nicht unwesentlich viele externe POE Splitter die wirklich sehr gut sind (diesen kann ich uneingeschränkt empfehlen: https://www.amazon.de/gp/product/B00MOIDXZ0/), sodass ich immer dazu raten würde doch besser einen externen POE Splitter zu nutzen um den RaspberryPi bzw. das Funkmodul mit Strom zu versorgen statt jetzt auf dieses POE-Hat zu setzen das IMHO keinerlei wirkliche Vorteile gegenüber den externen POE Splittern bringt (ausser das es natürlich "nice-to-have" wäre).
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

ESPe71
Beiträge: 4
Registriert: 25.06.2020, 15:41
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 3 Mal

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von ESPe71 » 26.06.2020, 14:06

Sowas in die Richtung habe ich mir schon gedacht. :(
Ich möchte keinen zusätzlichen POE-Splitter; wo soll ich denn damit noch im Schrank hin... Wobei du natürlich Recht hast, dass man auf die Interferenzen achten soll. Ich betreibe das Funkmodul jedoch an einem USB-Extender, so dass Interferenzen ausgeschlossen sind. Und wenn Alex seinen LAN-Extender fertig bekommt, kann ich mir auch noch den aktiven USB-Hub sparen (sofern er denn dann auch POE beherrscht).
Zurück zum POE-Hat. Meine Überlegung ging ja dahin, da der Hat ja offiziell von der Rasperry-Foundation herausgebracht wird, dass gerade dieser unterstützt wird. Ist es im Bereich des Möglichen das sich da in nächster Zeit etwas dran ändert? Falls du keinen POE-Hat hast, könnte ich dir sicherlich einen zukommen lassen.
Im Moment werde ich das dann wohl mit einem HM-Programm und einer Transistorschaltung realisieren. Ist leider nur die zweite Wahl....

Nichtsdestotrotz möchte ich mich für deine Rückmeldung und deine großartige Arbeit bedanken,

viele Grüße
Enrico

deimos
Beiträge: 3883
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 48 Mal
Danksagung erhalten: 341 Mal
Kontaktdaten:

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von deimos » 26.06.2020, 15:12

Hi,

oder du nimmst halt piVCCU oder debmatic, die setzen auf Raspbian auf und da funktioniert das dann out-of-the-box.
Bei der HB-RF-ETH habe ich ja auch (optional) PoE auf dem Board, da konnte ich bisher keine Probleme mit Interferenzen feststellen. Allerdings auch mit einem deutlich geringeren Stromverbrauch als bei Pi, was natürlich direkt auch Auswirkungen auf den Schaltregler vom PoE und dessen Frequenz hat.

Viele Grüße
Alex

ESPe71
Beiträge: 4
Registriert: 25.06.2020, 15:41
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 3 Mal

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von ESPe71 » 26.06.2020, 17:28

Hallo,

piVCCU hatte ich vorher. Ist auch sehr gut gelaufen, da piVCCU aber auf die Originale CCU aufsetzt und bei Raspberrymatic wirklich feine Verbesserungen gegenüberstehen mag ich es gefühlt mehr. Einen wirklichen Grund dazu gibt es allerdings nicht.
Ich umgehe jetzt einfach die Hat-Steuerung und regel den Lüfter selber.
Super, dass du bei deinem HB-RF-ETH auch PoE unterstützt. Wann denkst du denn über einen Rollout nach? In einem Beitrag habe ich etwas von Juli gelesen. Bleibt es dabei?

Ich bin Informatiker und kann mir vorstellen wie viel Zeit und Engagement in deinem und auch Jens Projekten stecken. Das Ringt mir großen Respekt ab.

Viele Grüße
Enrico

Benutzeravatar
jmaus
Beiträge: 6287
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 41 Mal
Danksagung erhalten: 415 Mal
Kontaktdaten:

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von jmaus » 26.06.2020, 19:10

ESPe71 hat geschrieben:
26.06.2020, 14:06
Ich möchte keinen zusätzlichen POE-Splitter; wo soll ich denn damit noch im Schrank hin... Wobei du natürlich Recht hast, dass man auf die Interferenzen achten soll. Ich betreibe das Funkmodul jedoch an einem USB-Extender, so dass Interferenzen ausgeschlossen sind.
Da hast du natürlich recht. Wenn du jetzt schon ein HB-RF-USB einsetzt dann sollte es in dem Falle weniger zu interferenzen kommen.
ESPe71 hat geschrieben:
26.06.2020, 14:06
Zurück zum POE-Hat. Meine Überlegung ging ja dahin, da der Hat ja offiziell von der Rasperry-Foundation herausgebracht wird, dass gerade dieser unterstützt wird. Ist es im Bereich des Möglichen das sich da in nächster Zeit etwas dran ändert? Falls du keinen POE-Hat hast, könnte ich dir sicherlich einen zukommen lassen.
Ja, so einfach ist das im Grunde. Ich habe bisher solch ein POE-Hat nicht und konnte es einfach deshalb nicht testen und auch entsprechend nicht integrieren. Wenn du mir also in der Tat freundlicherweise einen zukommen lassen möchtest freue ich mich natürlich nicht nur darüber sondern werde mir das in der Tat dann etwas näher anschauen und dann auch schauen ob ich das mit wenig Reibungsverlusten hinbekomme. Versprechen kann ich allerdings natürlich nichts.
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Benutzeravatar
jmaus
Beiträge: 6287
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 41 Mal
Danksagung erhalten: 415 Mal
Kontaktdaten:

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von jmaus » 30.06.2020, 08:29

jmaus hat geschrieben:
26.06.2020, 19:10
ESPe71 hat geschrieben:
26.06.2020, 14:06
Zurück zum POE-Hat. Meine Überlegung ging ja dahin, da der Hat ja offiziell von der Rasperry-Foundation herausgebracht wird, dass gerade dieser unterstützt wird. Ist es im Bereich des Möglichen das sich da in nächster Zeit etwas dran ändert? Falls du keinen POE-Hat hast, könnte ich dir sicherlich einen zukommen lassen.
Ja, so einfach ist das im Grunde. Ich habe bisher solch ein POE-Hat nicht und konnte es einfach deshalb nicht testen und auch entsprechend nicht integrieren. Wenn du mir also in der Tat freundlicherweise einen zukommen lassen möchtest freue ich mich natürlich nicht nur darüber sondern werde mir das in der Tat dann etwas näher anschauen und dann auch schauen ob ich das mit wenig Reibungsverlusten hinbekomme. Versprechen kann ich allerdings natürlich nichts.
So, das ging schneller als erwartet. Nachdem Enrico mir freundlicher ein solches POE HAT zukommen lassen hatte habe ich gestern abend mal geschaut was da so in RaspberryMatic abgeändert gehört damit dieses unterstützt werden kann (auch wenn ich den nutzen davon unterm Strich immer noch zweifelhaft finde). Und ich konnte die notwendigen Anpassungen nun vornehmen und die nächste Version von RaspberryMatic wird daher das POE Hat voll unterstützen und automatisch den Lüfter angehen lassen sobald man es bootet. Vorab können gerne interessierte/mutige Tester / Nutzer sich den aktuellen experimental nightly build schnappen (https://github.com/jens-maus/RaspberryM ... /snapshots) und testen. Dort sollte das POE Hat bereits problemlos funktionieren. Danke auf jeden Fall noch einmal an Enrico für das POE HAT.
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

ESPe71
Beiträge: 4
Registriert: 25.06.2020, 15:41
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 3 Mal

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von ESPe71 » 30.06.2020, 18:01

Das ist ja super, dass es geklappt hat. Und dann auch noch so schnell. :D :D :D

Vielen, vielen Dank
Enrico

Chilled
Beiträge: 1
Registriert: 09.10.2020, 11:09
System: Alternative CCU (auf Basis OCCU)

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von Chilled » 09.10.2020, 11:59

Vielen Dank für deine Implementierung. Ich nutze das ganze jetzt auch seit einer Woche. Allerdings habe ich ein etwas seltsames Verhalten des Lüfters festgestellt und bin mir nicht sicher ob das so sein soll.
Der Lüfter geht immer für ziemlich genau 20 Sekunden an. Danach ist er ziemlich genau 15 Sekunden aus. In diesem Takt pendelt er dann zwischen an / aus. Ist dieses Verhalten gewünscht oder liegt hier irgendwo ein Fehler vor?

Benutzeravatar
jmaus
Beiträge: 6287
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 41 Mal
Danksagung erhalten: 415 Mal
Kontaktdaten:

Re: offizieller POE-Hat; Lüfter funktioniert nicht mit Raspberrymatic

Beitrag von jmaus » 09.10.2020, 12:04

Chilled hat geschrieben:
09.10.2020, 11:59
Vielen Dank für deine Implementierung. Ich nutze das ganze jetzt auch seit einer Woche. Allerdings habe ich ein etwas seltsames Verhalten des Lüfters festgestellt und bin mir nicht sicher ob das so sein soll.
Der Lüfter geht immer für ziemlich genau 20 Sekunden an. Danach ist er ziemlich genau 15 Sekunden aus. In diesem Takt pendelt er dann zwischen an / aus. Ist dieses Verhalten gewünscht oder liegt hier irgendwo ein Fehler vor?
Tja, die Lüftersteuerung des POE-Hat ist eben sehr rudimentär und kennt nur an/aus und versucht halt so die temperatur zu halten. Entweder mit Leben oder ne andere Lösung suchen. Ich persönlich halte ohnehin nicht viel von diesem POE-Hat. Da erscheint mir die Lösung über einen externen POE-Splitter viel zielführender als dieses POE-HAT das sicherlich auch noch negative Zusatzeffekte auf die Sende/Empfangsqualität hat wenn man auf dem GPIO auch noch ein Funkmodul drausteckt...
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Antworten

Zurück zu „RaspberryMatic“