Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen werden

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
digi100
Beiträge: 14
Registriert: 08.02.2018, 21:34
Danksagung erhalten: 1 Mal

Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen werden

Beitrag von digi100 » 08.07.2020, 21:19

Ich bekomme seit neustem die Fehlermeldung "Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen werden. Um die Diagrammdaten zu speichern, ist externer USB-Speicher erforderlich. "

Die Fehlermeldung erscheint bei Aufruf der Diagrammdaten via "Status & Bedienung" als auch via "Einstellungen. Ich habe die neueste Version 3.51.6.20200621 auf einem RasperryMatic installiert.

Unter der "Allgemeinen Einstellungen" wird korrekt "externeren USB Speicher vorhanden" angezeigt. Ebenso funktioniert Daten sichern auf USB. Auch CCU-Historian funktioniert perferkt.

Woher kann meine Problem kommen? Wie behebe ich dies ?

Danke im Voraus
Stefan

MuellerT
Beiträge: 2
Registriert: 01.12.2019, 13:18

Re: Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen we

Beitrag von MuellerT » 13.07.2020, 18:02

Hallo,
ich habe genau das gleiche Problem, Stick wird erkannt, aber beim Aufruf der Diagramme ist angeblich kein USB Speicher vorhanden.
Habe auch schon einiges versucht, anderer Steckplatz, Neustart usw., bin aber auch zu keinen Erfolg gekommen.
Vielleicht hat noch jemand eine Idee ?

Gruß
Torsten

PaulM
Beiträge: 143
Registriert: 16.02.2015, 17:05
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 30 Mal
Danksagung erhalten: 3 Mal

Re: Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen we

Beitrag von PaulM » 18.07.2020, 13:29

Das Problem habe ich auf meinem Remote System mit Firmware 3.51.6.20200420 auch. USB0 wird nicht angezeigt, bisherige CCU-Historian Daten (de facto auf USB1 gespeichert) werden nach Neustart gelöscht.

Die Daten werden auch gelöscht, wenn in der CCU-Historian Konfiguration USB1 (statt USB0) gesetzt ist.

Im laufenden Betrieb scheint der USB-Speicher normal zu funktionieren.
Mit Mut und Entschlossenheit gegen Intoleranz

DJDieter
Beiträge: 209
Registriert: 11.01.2008, 14:41
Hat sich bedankt: 6 Mal
Danksagung erhalten: 7 Mal

Re: Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen we

Beitrag von DJDieter » 11.09.2020, 00:10

Es liegt wahrscheinlich daran, dass usb0 - warum auch immer - nicht mehr existiert. usb0 hat einen Softlink auf usb1. Dieses Problem hatte ich auch mal und die Lösung dafür gibt's hier: viewtopic.php?f=65&t=57552#p572821
CCU3 mit RaspberryMatic und 4 LAN-Gateways mit 959 Kanälen auf 187 Geräten
CUxD mit 180 Kanälen auf 43 Geräten
Zusatzsoftware: HVL, XML-API, CUxD-Highcharts, NEO-Server, CL-Studio, Programmedrucken, CUxD, E-Mail, Philips Hue, Messenger
Anbindungen: Wolf eBus; NodeMCU-Ultraschall-Füllstandsmessung mit Temperatureinfluß; Fußbodenheizung mit Rücklauftemperaturbegrenzer (RTL)

mkninc
Beiträge: 3
Registriert: 12.09.2020, 21:27
System: Alternative CCU (auf Basis OCCU)

Re: Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen we

Beitrag von mkninc » 19.09.2020, 23:30

@digi100: Konntest du das Problem lösen?

Ich habe auch grade das Problem, dass der USB Stick für die Diagramme nicht erkannt wird.

Der USB Stick wird normal gemountet und ist schreib/lesbar. CCU-Historian und Nodered Logdateien werden ohne Probleme darauf geschrieben.

Code: Alles auswählen

[email protected]:~# mount
/dev/root on / type ext4 (ro,relatime)
devtmpfs on /dev type devtmpfs (rw,relatime,size=462620k,nr_inodes=115655,mode=755)
proc on /proc type proc (rw,relatime)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,relatime,mode=777)
tmpfs on /tmp type tmpfs (rw,noatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,noatime,mode=755)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /var type tmpfs (rw,noatime)
tmpfs on /media type tmpfs (rw,noatime)
/dev/mmcblk0p3 on /usr/local type ext4 (rw,noatime,nodiratime,nodelalloc,data=journal)
/dev/mmcblk0p1 on /boot type vfat (ro,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/sda1 on /media/usb1 type f2fs (rw,lazytime,nodev,noexec,noatime,nodiratime,background_gc=on,discard,no_heap,user_xattr,inline_xattr,acl,inline_data,inline_dentry,flush_merge,extent_cache,mode=adaptive,active_logs=6,alloc_mode=reuse,fsync_mode=posix)
/media/usb0 ist auch vorhanden.

Code: Alles auswählen

[email protected]:~# ls -la /media/
total 8
drwxrwxrwt   10 root     root           220 Sep 19 22:55 .
drwxr-xr-x   23 root     root          4096 Sep 19 12:16 ..
lrwxrwxrwx    1 root     root            11 Sep 19 22:55 usb0 -> /media/usb1
drwxr-xr-x    6 root     root          4096 Sep 19 23:16 usb1
drwxr-xr-x    2 root     root            40 Sep 19 22:55 usb2
drwxr-xr-x    2 root     root            40 Sep 19 22:55 usb3
drwxr-xr-x    2 root     root            40 Sep 19 22:55 usb4
drwxr-xr-x    2 root     root            40 Sep 19 22:55 usb5
drwxr-xr-x    2 root     root            40 Sep 19 22:55 usb6
drwxr-xr-x    2 root     root            40 Sep 19 22:55 usb7
drwxr-xr-x    2 root     root            40 Sep 19 22:55 usb8
in der "Systemsteuerung -> Allgemeine Einstellungen -> Externer USB-Speicher" steht auch "Status: externer USB-Speicher vorhanden."

In den Diagrammeinstellungen kommt dann aber nur die Fehlermeldung
"Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen werden. Um die Diagrammdaten zu speichern, ist externer USB-Speicher erforderlich."

Hütte
Beiträge: 499
Registriert: 08.02.2017, 11:08
Hat sich bedankt: 10 Mal
Danksagung erhalten: 45 Mal

Re: Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen we

Beitrag von Hütte » 20.09.2020, 17:21

Wieviele Diagramme zeichnest du schon auf?

Ich meine, mich zu erinnern, dass es da innerhalb der CCU (somit auch in RaspberryMatic) eine Begrenzung in der Anzahl der Diagramme, die angelegt werden können, gibt.

mkninc
Beiträge: 3
Registriert: 12.09.2020, 21:27
System: Alternative CCU (auf Basis OCCU)

Re: Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen we

Beitrag von mkninc » 20.09.2020, 18:12

Hütte hat geschrieben:
20.09.2020, 17:21
Wieviele Diagramme zeichnest du schon auf?
Sind aktuell nur 13 Diagramme.
Wenn ich das richtig in DiagrammSettingsListPage.ftl https://github.com/eq-3/occu/blob/maste ... ge.ftl#L20 sehe, ist das Limit bei 50 und hat eine andere Fehlermeldung.

mkninc
Beiträge: 3
Registriert: 12.09.2020, 21:27
System: Alternative CCU (auf Basis OCCU)

Re: Es ist kein USB-Speicher für die Speicherung der Diagrammdaten vorhanden oder auf diesen konnte nicht zugegriffen we

Beitrag von mkninc » 20.09.2020, 18:57

Das Problem war eine defekte RRD Datei.
Auszug aus "/var/log/hmserver.log"

Code: Alles auswählen

Sep 20 12:11:28 de.eq3.lib.datalogging.rrd.RrdDatalogging ERROR [Timer-0] Could not initialize rrd database
java.io.IOException: Invalid file header. File [/tmp/measurement/5.rrd] is not a RRD4J RRD file

Antworten

Zurück zu „RaspberryMatic“