Crash bei Backup

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
gunterc
Beiträge: 14
Registriert: 05.04.2020, 12:09

Crash bei Backup

Beitrag von gunterc » 26.08.2020, 18:11

Ich mache hin und wieder, nachdem ich Einstellungen angepasst habe, ein Backup der Einstellungen. Wird ja auch allgemein empfohlen...
Leider ist es mir nun zum wiederholten Mal passiert, dass das System danach eher unbrauchbar wird, ohne dass ich dabei zu einem Backup komme.
Wenn alles funktioniert, bekomme ich das Download-Fenster und kann das Backup auf den Host laden.
In meinem Fall allerdings meldet das System nach ca. 20min einen Fehler bei der Ausführung der Aktion:

An internal error was detected in the service software. The diagnostics are being emailed to the service system administrator (root).

Wenn ich die Seite erneut starte, bekomme ich das:
Bildschirmfoto vom 2020-08-26 16-38-26.png

Nach einem Neustart des RPi scheint alles zu funktionieren. Allerdings ist es nicht möglich, ein Backup durchzuführen. (Hatte gehofft, dass vieleicht irgendwelche temp-Dateien gelöscht wurden...)

Als ich das das letzte mal hatte, hatte ich das System auf einer anderen SD-Karte neu installiert und mein letztes Backup eingespielt. Das war zwar nicht ganz taufrisch, aber besser als nichts. Eine Zeitlang funktionierten hier auch die Backups. - Bis heute.

Im Verzeichnis /usr/local/backup sind einige Dateien, die so aussehen, als wären sie 'Backups'.
Ist das SO?
Die meisten sind leer, einige haben Inhalt. Mit SCP lassen sich die kopieren.

Wäre für einen Tipp dankbar. Habe übrigens jetzt die Version homematic-raspi-3.51.6.20200229.

MichaelN
Beiträge: 1014
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 77 Mal
Danksagung erhalten: 94 Mal

Re: Crash bei Backup

Beitrag von MichaelN » 26.08.2020, 18:25

Ist das so?
Schwer zu sagen, wenn man nicht vor dem Rechner sitzt. Schau doch einfach mal rein.

Btw: wie groß sind deine Backups, das der Rechner 20 Minuten dafür benötigt?

gunterc
Beiträge: 14
Registriert: 05.04.2020, 12:09

Re: Crash bei Backup

Beitrag von gunterc » 26.08.2020, 18:41

Also nach den 20minuten habe ich gar nichts. Von daher ist auch schwer zu sagen, wie groß das ist...
Ältere Backups haben so um die 100MB.
Die Dateien in /usr/local/backup sind entweder leer, oder haben 2,8GB. Es scheint sich da also um was anderes zu handeln :D

Kann mir übrigens nicht vorstellen, dass ich der erste bin, der sowas hat. Hab aber im Forum nichts gefunden. Vermutlich falsch 'gesucht'.

Baxxy
Beiträge: 1544
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 144 Mal
Danksagung erhalten: 230 Mal

Re: Crash bei Backup

Beitrag von Baxxy » 26.08.2020, 19:38

gunterc hat geschrieben:
26.08.2020, 18:41
Dateien in /usr/local/backup sind entweder leer, oder haben 2,8GB
Normalerweise sollte es in /usr/local gar kein Verzeichnis "backup" geben. Wenn nichts händisch angepasst wurde speichert RaspberryMatic eigentlich die Backups direkt auf dem USB-Stick der hoffentlich angeschlossen ist. 2,8GB Dateigröße ist schon ne Nummer, wenn dazu nur eine 8GB SD-Karte im Raspi sitzt wird das wohl ziemlich eng. Wenn du ein funktionierendes Backup hast lösche mal alle Dateien in /usr/local/backup und starte neu. Danach dann mal probieren ob es nun klappt.
Grüße
Baxxy

gunterc
Beiträge: 14
Registriert: 05.04.2020, 12:09

Re: Crash bei Backup

Beitrag von gunterc » 27.08.2020, 15:40

OK. Nachdem ich die Dateien, die eigentlich gar nicht da sein sollten, gelöscht habe, wurde ein Backup über das WebUI in weniger als einer Minute erzeugt. Größe ca. 30MB und das System läuft weiter. Fazit: Problem gelöst. - DANKE.

Hab aber doch noch eine Frage zum USB-Stick, der 'hoffentlich angeschlossen ist': Wo steht das und wofür sollte das gut sein?

Baxxy
Beiträge: 1544
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 144 Mal
Danksagung erhalten: 230 Mal

Re: Crash bei Backup

Beitrag von Baxxy » 27.08.2020, 20:09

gunterc hat geschrieben:
27.08.2020, 15:40
Wo steht das
Es steht bei Einstellungen --> Systemsteuerung --> Allgemeine Einstellungen und sollte so aussehen.
RM_USB_Stick erkannt.JPG
gunterc hat geschrieben:
27.08.2020, 15:40
wofür sollte das gut sein?
Hatte ich ja schon geschrieben...
gunterc hat geschrieben:
26.08.2020, 18:41
speichert RaspberryMatic eigentlich die Backups direkt auf dem USB-Stick
... und das jede Nacht. Außerdem werden die Diagrammdaten (falls benutzt) dort abgespeichert, sowie mögliche Nutzdaten von diversen Add-Ons.
gunterc hat geschrieben:
27.08.2020, 15:40
Fazit: Problem gelöst. - DANKE.
Keine Ursache. Da aber nicht vollkommen geklärt ist wie es zu deinem Problem kam würde ich ab und an mal schauen ob sich wieder Dateileichen angesammelt haben und ob noch genug Platz auf deiner SD-Karte ist.
Grüße
Baxxy

Antworten

Zurück zu „RaspberryMatic“