HMIPServer restarted und weitere

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Patt
Beiträge: 121
Registriert: 25.05.2017, 01:24
Hat sich bedankt: 4 Mal

HMIPServer restarted und weitere

Beitrag von Patt » 30.09.2020, 18:44

Hallo,

ich habe jeden Tag Alarmmeldung mit HMIPServer restarted. Macht er 1000 mal.
Hatte mal gelesen, dass dies ein bekanntes Problem war und jensmaus das dann wohl in einem Release gefixt hat.
Bei mir ist das aber nach wie vor obwohl ich auf der aktuellen Version bin.

Ich habe keinen Plan was das genau verursacht.

In der Systemsteuerung kann ich auch das Menü Allgemein nicht öffnen. Das stürzt es immer ab.??

Bin ratlos und freue mich auf Hilfe.

Grüße
Dateianhänge
3.PNG
2.png
2.png (15.5 KiB) 496 mal betrachtet
1.png
0.PNG
0.PNG (19.78 KiB) 496 mal betrachtet

Benutzeravatar
jmaus
Beiträge: 6412
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 48 Mal
Danksagung erhalten: 446 Mal
Kontaktdaten:

Re: HMIPServer restarted und weitere

Beitrag von jmaus » 06.10.2020, 09:02

Patt hat geschrieben:
30.09.2020, 18:44
ich habe jeden Tag Alarmmeldung mit HMIPServer restarted. Macht er 1000 mal.
[...]
Ich habe keinen Plan was das genau verursacht.

In der Systemsteuerung kann ich auch das Menü Allgemein nicht öffnen. Das stürzt es immer ab.??

Bin ratlos und freue mich auf Hilfe.
Dazu müsstest du erst einmal zu deiner aktuell verwendeten Pi-Hardware, Funkmodul, etc. etc. etwas mehr verraten. Und dann auch einmal einen Blick in die /var/log/hmserver.log und /var/log/messages Datei werfen. Da drin findest du vielleicht den Grund wieso der HMIPServer sich hier/da mal verabschiedet.
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Patt
Beiträge: 121
Registriert: 25.05.2017, 01:24
Hat sich bedankt: 4 Mal

Re: HMIPServer restarted und weitere

Beitrag von Patt » 06.10.2020, 13:54

Hallo,

ok jetzt weiß ich was gebraucht wird:

Hardware: Tinker board S, Charly mit ext. Antenne,
dann habe ich noch einen Raspi und eine CCU2 als LAN-Gateway im Unter- bzw. Obergeschoss.

bezüglich der Log Dateien.

kann ich den Inhalt problemlos posten ohne SIcherheitsrisiko???

Grüße

Patt
Beiträge: 121
Registriert: 25.05.2017, 01:24
Hat sich bedankt: 4 Mal

Re: HMIPServer restarted und weitere

Beitrag von Patt » 06.10.2020, 14:12

ich hoffe mal das passt so :?:
Dateianhänge
messages.log
(2.66 MiB) 5-mal heruntergeladen
hmserver.log
(1.93 MiB) 5-mal heruntergeladen

Benutzeravatar
jmaus
Beiträge: 6412
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 48 Mal
Danksagung erhalten: 446 Mal
Kontaktdaten:

Re: HMIPServer restarted und weitere

Beitrag von jmaus » 06.10.2020, 15:43

Patt hat geschrieben:
06.10.2020, 14:12
ich hoffe mal das passt so :?:
Ja, aber daraus kann ich leider keinen Fehler herauslesen ausser das dein HMIPServer anscheinend dauernd neustartet. Der Grund wieso das passiert ist mir jedoch noch unklar. Mach mal folgendes in einer SSH Sitzung:

Code: Alles auswählen

monit stop hmipserver

Code: Alles auswählen

/etc/init.d/S62HMServer stop

Code: Alles auswählen

/etc/init.d/S62HMServer start
Und dann beobachte mal was da so als letztes in der hmserver.log datei landet und was das start kommando da so ausgibt.
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Patt
Beiträge: 121
Registriert: 25.05.2017, 01:24
Hat sich bedankt: 4 Mal

Re: HMIPServer restarted und weitere

Beitrag von Patt » 06.10.2020, 16:14

hab ich gemacht. allerdings kam bei S61HMServer ein not found.

habe mal kurz in den Ordner geschaut. es gibt dort nur S62HMServer , habe daher mit 62 ausgeführt.

Aktuell heisst es "Starting HMIPServer:"......... und es läuft der Cursor, immer ein Punkt weiter...........

dauert das immer etwas länger?

Patt
Beiträge: 121
Registriert: 25.05.2017, 01:24
Hat sich bedankt: 4 Mal

Re: HMIPServer restarted und weitere

Beitrag von Patt » 06.10.2020, 16:20

jetzt kam ERROR

Code: Alles auswählen

[email protected]:~# /etc/init.d/S62HMServer start
Starting HMIPServer: .......................................................................................................................................................ERROR
[email protected]:~#
Dateianhänge
hmserver.log
(1003.37 KiB) 6-mal heruntergeladen

Benutzeravatar
jmaus
Beiträge: 6412
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 48 Mal
Danksagung erhalten: 446 Mal
Kontaktdaten:

Re: HMIPServer restarted und weitere

Beitrag von jmaus » 06.10.2020, 16:44

S62HMServer ist natürlich richtig, hatte ich falsch angegeben.

Aber ich werde aus der Ausgabe immer noch nicht schlau...

Kannst du mal bitte dein CloudMatic Interface abschalten und dann nochmal probieren. Nichtd as das irgendetwas komisches erzeugt.

Zusätzlich geb mal bitte aus was das folgende Kommando so ausgibt:

Code: Alles auswählen

cat /var/hm_mode
RaspberryMatic 3.53.30.20201024 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Patt
Beiträge: 121
Registriert: 25.05.2017, 01:24
Hat sich bedankt: 4 Mal

Re: HMIPServer restarted und weitere

Beitrag von Patt » 06.10.2020, 21:18

Dienste von cloudmatic habe ich beendet, das meinst du mit Interface abschalten oder?

achso und muss ich mal noch neu starten?
der Befehl /etc/init.d/S62HMServer start ging ja nicht durch, folglich ist ja was nicht gestartet :-) ??

Code: Alles auswählen

[email protected]:~# cat /var/hm_mode
HM_HMIP_ADDRESS='0xBC3805'
HM_HMIP_ADDRESS_ACTIVE='0xBC3805'
HM_HMIP_DEV='RPI-RF-MOD'
HM_HMIP_DEVNODE='/dev/raw-uart'
HM_HMIP_SERIAL='58A992FA5B'
HM_HMIP_SGTIN='3014F711A0001F58A992FA5B'
HM_HMIP_VERSION='4.2.6'
HM_HMRF_ADDRESS='0xFFFA5B'
HM_HMRF_ADDRESS_ACTIVE='4207456'
HM_HMRF_DEV='RPI-RF-MOD'
HM_HMRF_DEVNODE='/dev/raw-uart'
HM_HMRF_SERIAL='PEQ0627291'
HM_HMRF_VERSION='4.2.6'
HM_HOST='tinkerboard'
HM_HOST_GPIO_RESET='185'
HM_HOST_GPIO_UART='/dev/raw-uart'
HM_LED_GREEN='/sys/class/leds/act-led'
HM_LED_GREEN_MODE1='mmc2'
HM_LED_GREEN_MODE2='heartbeat'
HM_LED_RED='/sys/class/leds/pwr-led'
HM_LED_RED_MODE1='timer'
HM_LED_RED_MODE2='mmc2'
HM_LED_YELLOW='/sys/class/leds/heartbeat-led'
HM_LED_YELLOW_MODE1='none'
HM_LED_YELLOW_MODE2='none'
HM_MODE='NORMAL'
HM_RTC='rx8130'
[email protected]:~#


Patt
Beiträge: 121
Registriert: 25.05.2017, 01:24
Hat sich bedankt: 4 Mal

Re: HMIPServer restarted und weitere

Beitrag von Patt » 08.10.2020, 07:04

hab jetzt mal neu gestartet, die Alarmmeldung kommt immer noch. 😢

Antworten

Zurück zu „RaspberryMatic“