[GELÖST] RaspberryMatic mit VMXNET konfigurieren?

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
Tattoofreak
Beiträge: 4
Registriert: 17.10.2020, 08:04
System: in Planung

[GELÖST] RaspberryMatic mit VMXNET konfigurieren?

Beitrag von Tattoofreak » 17.10.2020, 08:11

Ich bin gerade dabei, RaspberryMatic das erste mal auszuprobieren. Das Ganze mache ich gleich auf einem ESXi-Server.
Nun meine Frage: Ist es möglich, anstatt die standardmässig konfigurierte "E1000" vNIC eine "VMXNET" zu wählen?
Beim Versuch mit "VMXNET" habe ich keine IP-Adresse vom DHCP-Server zugewiesen bekommen, mit "E1000" klappt alles.
Gibt es einen Workaround? Wenn möglich, würde ich lieber auf "VMXNET" setzen.
Zuletzt geändert von Tattoofreak am 18.10.2020, 11:38, insgesamt 2-mal geändert.

Benutzeravatar
jmaus
Beiträge: 6283
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 41 Mal
Danksagung erhalten: 405 Mal
Kontaktdaten:

Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von jmaus » 17.10.2020, 09:34

Das sollte natürlich so funktionieren, ja. Müsstest du mal zeigen wie du das umgestellt hast und was da dann beim hochfahren bei dir beim hochfahren des Netzwerkes angezeigt wird.
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Tattoofreak
Beiträge: 4
Registriert: 17.10.2020, 08:04
System: in Planung

Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von Tattoofreak » 17.10.2020, 20:48

Ich habe jetzt lange rumprobiert und komme einfach nicht darauf, was das Problem ist.
Was mir jedoch aufgefallen ist (beide Varianten erfolgen unmittelbar nach erfolgreichem Import der .ova auf den ESXi Host, die VM wurde noch nicht gestartet):

Variane 1, vCenter: Wenn ich die VM via vCenter Webinterface konfiguriere, kann ich den bestehenden "Adapter Type" der vNIC nicht ändern, weil er ausgegraut ist. Es bleibt also keine andere Möglichkeit, als den "Adapter Type" auf "E1000" zu belassen.
Die einzige Möglichkeit, die bleibt, ist, die vNIC ganz zu löschen und eine neue vNIC anzulegen und als "Adapter Type" den Typ "VMXNET" zu wählen (es bestünden noch zwei weitere Möglichkeiten "E1000" und "Flexible"). Dann aber, wenn ich "VMXNET" wähle, erhalte ich nach dem Start der VM keine IP Adresse vom DHCP Server. Auf dem RaspberryMatic Webinterface steht dann nur: "ERROR: No IP address set".

Variante 2, ESXi: Wenn ich die VM via ESXi Webinterface konfiguriere, kann ich den bestehenden "Adapter Type" der vNIC zwar ändern, zur Auswahl habe ich für "Adapter Type" jedoch nur "E1000" und "AMD Lance PCNet 32", leider keine "VMXNET".
Selbst wenn ich die vNIC lösche und neu anlege, bleiben nur die genannten zwei "Adapter Type" zur Verfügung.

Ich verwende die aktuellste vSphere 7U1 Umgebung.

jp112sdl
Beiträge: 6435
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 306 Mal
Danksagung erhalten: 620 Mal
Kontaktdaten:

Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von jp112sdl » 17.10.2020, 21:13

Ich vermute, es liegt am erkannten Guest OS (Other Linux xxx?), welches inkompatibel zum VMXNET3 Adapter-Typ ist.
In der RaspberryMatic OVA laufen wahrscheinlich weder Open-VM-Tools noch die VMware Tools, die die entsprechenden Kerneltreiber mitbringen.

Da es aber bei RaspberryMatic nicht auf Datendurchsatz ankommt (selbst 100MBit wären m.E. völlig ausreichend), spricht eigentlich nichts gegen E1000.
Es sei denn du wolltest auch unbedingt DirectPath IO nutzen.

Ist zwar etwas älter, aber hier ein Beitrag aus den vmware Docs:
VMXNET

...
Da die Betriebssystem-Hersteller keine integrierten Treiber für diese Karte anbieten, müssen Sie VMware Tools installieren, damit ein Treiber für den VMXNET-Netzwerkadapter verfügbar ist.

Tattoofreak hat geschrieben:
17.10.2020, 08:11
Wenn möglich, würde ich lieber auf "VMXNET" setzen.
Vielleicht könntest du kurz erklären, warum du gern VMXNET für die RaspberryMatic nutzen möchtest?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Benutzeravatar
jmaus
Beiträge: 6283
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 41 Mal
Danksagung erhalten: 405 Mal
Kontaktdaten:

Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von jmaus » 17.10.2020, 21:48

jp112sdl hat geschrieben:
17.10.2020, 21:13
Ich vermute, es liegt am erkannten Guest OS (Other Linux xxx?), welches inkompatibel zum VMXNET3 Adapter-Typ ist.
In der RaspberryMatic OVA laufen wahrscheinlich weder Open-VM-Tools noch die VMware Tools, die die entsprechenden Kerneltreiber mitbringen.
Die beiden Vermutungen kann ich leider so nicht bestätigen :) Beim mir läuft RaspberryMatic problemlos mit "VMXNET 3" als Netzwerkadapter. Siehe:
Bildschirmfoto 2020-10-17 um 21.41.00.png
Und innerhalb der RaspberryMatic VM sieht man auch recht schön das der VMXNET Treiber entsprechend initialisiert wird und der Link auch normal hochkommt:

Code: Alles auswählen

[    0.311034] VMware vmxnet3 virtual NIC driver - version 1.4.17.0-k-NAPI
[    0.311045] vmxnet3 0000:03:00.0: # of Tx queues : 2, # of Rx queues : 2
[    0.311911] vmxnet3 0000:03:00.0 eth0: NIC Link is Up 10000 Mbps
Auch die Vermutung mit den nicht verfügbaren vmtools ist nicht richtig wie man an der folgende Ausgabe einer laufenden RaspberryMatic VM unter ESXi sieht:

Code: Alles auswählen

[email protected]:~# ps aux | grep vmtoolsd
  367 root      0:00 /usr/bin/vmtoolsd
Es sollte also alles bzgl. VMXNET Konnektivität recht problemlos funktionieren.
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

jp112sdl
Beiträge: 6435
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 306 Mal
Danksagung erhalten: 620 Mal
Kontaktdaten:

Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von jp112sdl » 17.10.2020, 21:54

jmaus hat geschrieben:
17.10.2020, 21:48
367 root 0:00 /usr/bin/vmtoolsd
Ja, dann sollte es klappen.
Dass die Tools verfügbar sind, wusste ich nicht

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Tattoofreak
Beiträge: 4
Registriert: 17.10.2020, 08:04
System: in Planung

[Gelöst] Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von Tattoofreak » 18.10.2020, 07:43

@jmaus: Danke für's Gegenprüfen. Ich gehe mal davon aus, dass du nicht versucht hast, die .ova komplett neu zu importieren?
Das Problem ist nämlich, dass die Gastbetriebssystemfamilie der VM nach dem Import von ESXi defaultmässig als "Other Linux (32-bit)" eingestuft wird. Das hat zur Folge, dass ESXi havon ausgeht, dass der Kernel älter als 2.4.x eingestuft wird und somit höchstens "VMXNET" (Nicht "VMXNET 3") verwendet werden kann, was wiederum von neueren Kerneln nicht mehr unterstützt wird (https://kb.vmware.com/s/article/2032753).
Nachdem ich das nun manuell auf "Other 3.x or later Linux (32-bit)" geändert habe, funktioniert alles, wie es soll. Dann habe ich auch nicht mehr nur "VMXNET", sondern "VMXNET 3" zu Verfügung.

Ich nehme mal an, dass man das irgendwo in der .vmx definieren, als was die VM beim Imporieren erkannt werden soll? Dann sollte das angepasst werden.

Besten Dank nochmals für die freundliche Unterstützung!

Benutzeravatar
jmaus
Beiträge: 6283
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 41 Mal
Danksagung erhalten: 405 Mal
Kontaktdaten:

Re: [Gelöst] Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von jmaus » 18.10.2020, 12:29

Tattoofreak hat geschrieben:
18.10.2020, 07:43
@jmaus: Danke für's Gegenprüfen. Ich gehe mal davon aus, dass du nicht versucht hast, die .ova komplett neu zu importieren?
Das Problem ist nämlich, dass die Gastbetriebssystemfamilie der VM nach dem Import von ESXi defaultmässig als "Other Linux (32-bit)" eingestuft wird. Das hat zur Folge, dass ESXi havon ausgeht, dass der Kernel älter als 2.4.x eingestuft wird und somit höchstens "VMXNET" (Nicht "VMXNET 3") verwendet werden kann, was wiederum von neueren Kerneln nicht mehr unterstützt wird (https://kb.vmware.com/s/article/2032753).
Nachdem ich das nun manuell auf "Other 3.x or later Linux (32-bit)" geändert habe, funktioniert alles, wie es soll. Dann habe ich auch nicht mehr nur "VMXNET", sondern "VMXNET 3" zu Verfügung.
Das ist ein guter Hinweis. Hab das gerade selbst mal ausprobiert und es ist in der Tat so, das hier VMXNET3 gar nicht erst angeboten wird weil in der .ovf Datei die falsche OperatingSystemSection ovf:id eingestellt war. Hab das nun entsprechend korrigiert:

https://github.com/jens-maus/RaspberryM ... 1541d6077f

D.h. mit der nächsten kommenden RaspberryMatic .ova Datei sollte nun korrekt ein 2.x/3.x/4.x Linux OS angenommen werden und folglich dann auch VMXNET3 als Netzwerkinterface auswählbar sein. Standardmäßig bleibt es allerdings beim E1000 weil das .ova ja bei anderen VM Lösungen wie VirtualBox, Proxmox, etc. funktionsfähig bleiben muss.
RaspberryMatic 3.53.30.20200919 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Tattoofreak
Beiträge: 4
Registriert: 17.10.2020, 08:04
System: in Planung

Re: [Gelöst] Re: RaspberryMatic mit VMXNET konfigurieren?

Beitrag von Tattoofreak » 18.10.2020, 12:38

jmaus hat geschrieben:
18.10.2020, 12:29
Standardmäßig bleibt es allerdings beim E1000 weil das .ova ja bei anderen VM Lösungen wie VirtualBox, Proxmox, etc. funktionsfähig bleiben muss.
Leuchtet ein, danke für's Fixen!

jp112sdl
Beiträge: 6435
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 306 Mal
Danksagung erhalten: 620 Mal
Kontaktdaten:

Re: [GELÖST] RaspberryMatic mit VMXNET konfigurieren?

Beitrag von jp112sdl » 18.10.2020, 13:13

jp112sdl hat geschrieben:
17.10.2020, 21:13
Ich vermute, es liegt am erkannten Guest OS (Other Linux xxx?), welches inkompatibel zum VMXNET3 Adapter-Typ ist.
jmaus hat geschrieben:
18.10.2020, 12:29
es ist in der Tat so, das hier VMXNET3 gar nicht erst angeboten wird weil in der .ovf Datei die falsche OperatingSystemSection ovf:id eingestellt war
Na dann lag ich ja doch gar nicht so verkehrt.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Antworten

Zurück zu „RaspberryMatic“