64bit Support für RaspberryMatic: Tester gesucht!

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

drose28357
Beiträge: 110
Registriert: 14.10.2011, 09:05
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von drose28357 » 28.10.2020, 21:05

Beide versionen (26.10 und die neuen 28.10) heute auf RPI3b (2017) installiert.
Bootet einwandfrei.
Das Systembackup von 26.10. ( zwei kleine Programme, die eine Systemvariable ändern) konnte problemlos nach 28.10. geladen werden. Die zeitgesteuerten Programme sind automatisch wieder angelaufen.
Habe das kleine/alte Funkmodul, dort wurde beim booten von 26.10. ein Firmware-Update durchgeführt.
Die Anlern-Modi für HM und HMIP konnten gestartet werden.
Insgesamt fühlt es sich flüssig und problemlos an.
Hier das Log
homematic-raspi-2020-10-28.log
SystemLog von Ver 28.10
(77.41 KiB) 11-mal heruntergeladen
mit

Code: Alles auswählen

Oct 28 21:01:50 de.eq3.cbcs.lib.backbone.lanrouting.BackboneWorker ERROR [vert.x-worker-thread-3] AP 3014F711A061A7D3C9962965: Could not parse outgoing routing frame 
de.eq3.cbcs.util.core.InvalidParameterLengthException: The parameter key must be 16 byte long
Leider habe ich keine freien Aktoren, um Geräte anzulernen. Daher hier erstmal Ende meines Test(beitrages).

MathiasZ
Beiträge: 2142
Registriert: 29.03.2015, 09:54
Wohnort: München
Hat sich bedankt: 74 Mal
Danksagung erhalten: 49 Mal

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von MathiasZ » 29.10.2020, 00:02

@jmaus
Hardware Raspberry PI4 2GB-RAM, RPI-RF-MOD auf dem HB-RF-USB
Gerade das neue Beta installiert und bootet einwandfrei.
Backup der Test-RaspberryMatic (x.86) eingespielt.---> i.O.
Backup der beta-Version gezogen: ---> i.O.
CuxD, Programme drucken, XML-Api ---> i.O.
Facrory Reset durchgeführt ---> i.O.
Einspielen der gerade erstellten Backups---> i.O.
Downgrade zur 3.53.30.20201024 ---> nach zwei selbständigen Neustarts i.O
Upgrade zur Beta vom 28.10.2020
LED des Funkmoduls blinkt langsam, dann schnell violett, Autoupdate läuft, Neustart ---> i.O.
Man könnte ja bei der nächsten Beta schon die 3.53.34 nehmen? :mrgreen:
Der Raspberry kommt dann wieder als Octopi an den 3D-Drucker.
Gruß,
Mathias
Dann werde ich mich wagen, das 3.53.34 auf das produktive System loszulassen, allerdings auf dem PI 3B+
RaspberryMatic x64 mit der neuesten Firmware und IObroker auf dem Mini-PC als VM und dem HB-RF-USB, als Testlauf. das produktive System noch auf dem Raspberry. Die Anwesenheitskennung läuft zuverlässig über IObroker und Radar2 mit G-Tags. Weiter will ich die Videosprechanlage Doorio oder DoorPI installieren. Als Sprachsteuerung läuft erst mal testweise Rhasspy

Benutzeravatar
jmaus
Beiträge: 6673
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 82 Mal
Danksagung erhalten: 517 Mal
Kontaktdaten:

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von jmaus » 29.10.2020, 22:18

So, nun habe ich gerade erneut eine weitere 64bit Testversion hochgeladen und würde bitten diese erneut zu testen und hier vor allem einen Augenmerk auf die Kompatibilität zu Addons wie CUxD, hm-tools & Co zu setzen und zu schauen ob es noch Addons gibt die ein Problem mit dem 64bit OS haben. Meine eigenen Tests haben zwar keine größeren Probleme mehr gezeigt, aber wissen kann man ja nie wo ggf. noch der Wurm drin ist. Und falls der Eine oder Andere auch noch einen RaspberryPi2 zur Hand hat dann bitte auch die Version entsprechend durchtesten da die separate Platformunterstützung für den Pi2 ja recht neu ist.
RaspberryMatic 3.53.34.20201121 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

MathiasZ
Beiträge: 2142
Registriert: 29.03.2015, 09:54
Wohnort: München
Hat sich bedankt: 74 Mal
Danksagung erhalten: 49 Mal

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von MathiasZ » 29.10.2020, 22:55

@jmaus
pi2 kann ich morgen mit dem kleinen Funkmodul übernehmen. Bin ich richtig in der Annahme, daß auf Github die Testversionen für das x86 und auf Deiner Cloud die x64 liegen?
RaspberryMatic x64 mit der neuesten Firmware und IObroker auf dem Mini-PC als VM und dem HB-RF-USB, als Testlauf. das produktive System noch auf dem Raspberry. Die Anwesenheitskennung läuft zuverlässig über IObroker und Radar2 mit G-Tags. Weiter will ich die Videosprechanlage Doorio oder DoorPI installieren. Als Sprachsteuerung läuft erst mal testweise Rhasspy

Benutzeravatar
jmaus
Beiträge: 6673
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 82 Mal
Danksagung erhalten: 517 Mal
Kontaktdaten:

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von jmaus » 29.10.2020, 23:24

Ja. Nur die in meiner cloud sind die 64bit versionen.
RaspberryMatic 3.53.34.20201121 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Baxxy
Beiträge: 2176
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 187 Mal
Danksagung erhalten: 318 Mal

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von Baxxy » 29.10.2020, 23:56

jmaus hat geschrieben:
29.10.2020, 22:18
ob es noch Addons gibt die ein Problem mit dem 64bit OS haben
Also die hm-tools 0.6.0 lassen sich zwar installieren aber funktionieren nicht.

Code: Alles auswählen

[email protected]:~# htop
/usr/local/addons/hm-tools/bin/htop: line 1: syntax error: unexpected word (expecting ")")

[email protected]:~# nano /boot/config.txt
/usr/local/addons/hm-tools/bin/nano: line 1: syntax error: unexpected word (expecting ")")

[email protected]:~# iostat -x 2
/usr/local/addons/hm-tools/bin/iostat: line 1: syntax error: unexpected word (expecting ")")
jmaus hat geschrieben:
29.10.2020, 22:18
einen Augenmerk auf die Kompatibilität zu Addons
Hier eine Übersicht der Add-Ons die ich auf der 64bit RaspberryMatic-3.53.34.20201029-7bd02f2-ova getestet habe.
RM_x64_getestete Addons.JPG
Meine 3 Testkriterien: Installation / Deinstallation sowie grundsätzliche Funktionalität waren bei allen (außer den HM-Tools) in Ordnung.

Mit diesen installierten Add-Ons habe ich dann ein Backup erstellt und darauf über Systemsteuerung --> Sicherheit --> System Reset die Zentrale zurückgesetzt. Anschließend konnte das Backup ohne Probleme wieder eingespielt werden und alle Add-Ons waren wieder vorhanden und funktionierten (Ausnahme HM-Tools siehe Oben).
Grüße
Baxxy

MathiasZ
Beiträge: 2142
Registriert: 29.03.2015, 09:54
Wohnort: München
Hat sich bedankt: 74 Mal
Danksagung erhalten: 49 Mal

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von MathiasZ » 30.10.2020, 04:06

@Baxxy
Das gleiche Resultat hatte ich auch auf dem PI4 2GB RAM. Das habe ich aber Jens schon gemeldet.
Nun gehts an die Image für den PI2..... dann melde ich mich wieder.
RaspberryMatic x64 mit der neuesten Firmware und IObroker auf dem Mini-PC als VM und dem HB-RF-USB, als Testlauf. das produktive System noch auf dem Raspberry. Die Anwesenheitskennung läuft zuverlässig über IObroker und Radar2 mit G-Tags. Weiter will ich die Videosprechanlage Doorio oder DoorPI installieren. Als Sprachsteuerung läuft erst mal testweise Rhasspy

Benutzeravatar
jmaus
Beiträge: 6673
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 82 Mal
Danksagung erhalten: 517 Mal
Kontaktdaten:

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von jmaus » 30.10.2020, 09:57

Baxxy hat geschrieben:
29.10.2020, 23:56
jmaus hat geschrieben:
29.10.2020, 22:18
ob es noch Addons gibt die ein Problem mit dem 64bit OS haben
Also die hm-tools 0.6.0 lassen sich zwar installieren aber funktionieren nicht.

Code: Alles auswählen

[email protected]:~# htop
/usr/local/addons/hm-tools/bin/htop: line 1: syntax error: unexpected word (expecting ")")

[email protected]:~# nano /boot/config.txt
/usr/local/addons/hm-tools/bin/nano: line 1: syntax error: unexpected word (expecting ")")

[email protected]:~# iostat -x 2
/usr/local/addons/hm-tools/bin/iostat: line 1: syntax error: unexpected word (expecting ")")
Danke für den Test. Allerdings ist dieses Problem auf einen Fehler bzw. Unzulänglichkeit im hm-tools Addon selbst zurückzuführen, denn dort werden fälschlicherweise die ARM binaries auch auf einem x86_64 host installiert. Hab das ganze gerade mal in hm-tools repariert und ein PullRequest dazu generiert (https://github.com/fhetty/hm-tools/pull/15).

Und eine erste Testversion des reparierten hm-tools Addons (0.6.1) findet ihr nun auch in meinem Cloudspeicher wo auch die RaspberryMatic 64bit Testversionen liegen. Würde mich freuen wenn ihr/du das nochmal testen könntet.
Baxxy hat geschrieben:
29.10.2020, 23:56
jmaus hat geschrieben:
29.10.2020, 22:18
einen Augenmerk auf die Kompatibilität zu Addons
Hier eine Übersicht der Add-Ons die ich auf der 64bit RaspberryMatic-3.53.34.20201029-7bd02f2-ova getestet habe.
RM_x64_getestete Addons.JPG
Meine 3 Testkriterien: Installation / Deinstallation sowie grundsätzliche Funktionalität waren bei allen (außer den HM-Tools) in Ordnung.

Mit diesen installierten Add-Ons habe ich dann ein Backup erstellt und darauf über Systemsteuerung --> Sicherheit --> System Reset die Zentrale zurückgesetzt. Anschließend konnte das Backup ohne Probleme wieder eingespielt werden und alle Add-Ons waren wieder vorhanden und funktionierten (Ausnahme HM-Tools siehe Oben).
Danke auch dafür. Am besten wäre es wohl einfach mal die Addon Liste in der offiziellen RaspberryMatic Dokumentation durchzugehen und jedes Addon 1x unter ARM64 (aarch64) und 1x unter x86_64 zu probieren und das dann hier zu melden ob es damit probleme gibt. Die Liste findet man hier:

https://github.com/jens-maus/RaspberryM ... tzsoftware
RaspberryMatic 3.53.34.20201121 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Benutzeravatar
jmaus
Beiträge: 6673
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 82 Mal
Danksagung erhalten: 517 Mal
Kontaktdaten:

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von jmaus » 30.10.2020, 09:59

MathiasZ hat geschrieben:
30.10.2020, 04:06
@Baxxy
Das gleiche Resultat hatte ich auch auf dem PI4 2GB RAM. Das habe ich aber Jens schon gemeldet.
Nun gehts an die Image für den PI2..... dann melde ich mich wieder.
Unter ARM64 (also auf einem Pi4) sollte das hm-tools Addon aber mit den aktuellsten 64bit Testversionen von RM korrekt funktionieren. Bitte also noch einmal testen mit einem Pi4.
RaspberryMatic 3.53.34.20201121 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

MathiasZ
Beiträge: 2142
Registriert: 29.03.2015, 09:54
Wohnort: München
Hat sich bedankt: 74 Mal
Danksagung erhalten: 49 Mal

Re: 64bit Support für RaspberryMatic: Tester gesucht!

Beitrag von MathiasZ » 30.10.2020, 14:56

@jmaus
hm-tools laufen jetzt unter einem pi4.
Das Backup einspielen läuft auch
Backup einspielen ohne Funkmodul auch keine Fehler mehr, nur die SysVar Servicemeldungen ist weg.
mal schauen, ob sie wieder auftaucht, wenn ich das Funkmodul wieder einstecke........
Die SysVar Servicemeldungn ist nach dem Einstecken des FM auch wieder da. :lol:
Mein produktives System heißt RaspberryMatic-3.53.34.20201029 (x64) :mrgreen:
auf einem Raspberry PI3B+
Edit:
Ich benutze die App Home24 für Android.
Der Geschwindigkeitszuwachs der Aktualisierung und der kompletten Aktualisierung sind enorm! 👍
@jmaus Danke für die Testversion!
Anmerkung (wird aktualisiert)
Zeitprogramme laufen auch!
RaspberryMatic x64 mit der neuesten Firmware und IObroker auf dem Mini-PC als VM und dem HB-RF-USB, als Testlauf. das produktive System noch auf dem Raspberry. Die Anwesenheitskennung läuft zuverlässig über IObroker und Radar2 mit G-Tags. Weiter will ich die Videosprechanlage Doorio oder DoorPI installieren. Als Sprachsteuerung läuft erst mal testweise Rhasspy

Gesperrt

Zurück zu „RaspberryMatic“