Watchdog meldet keine Internetverbindung

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

zophyreus
Beiträge: 6
Registriert: 28.10.2020, 16:10
System: Alternative CCU (auf Basis OCCU)

Watchdog meldet keine Internetverbindung

Beitrag von zophyreus » 28.10.2020, 16:27

Hallo,
ich bin neu hier im Forum, verwende Homematic mit OpenHab jetzt seit vier Jahren mit circa 60 Komponenten zur Steuerung der FBH, Licht, Steckdosen und Rollläden. Meine CCU habe ich bald entsorgt und verwende seit längerem einen Raspi 3 mit RaspberryMatic.

Aktuell mit Version 3.53.30.20201024

Seit Version 3.51.6.20200621 habe ich immer wieder die Meldung "No internet connection detected" in der Alarmmeldungen der GUI.
Die Verbindung ist aber da, meine Fritzbox 7590 hat keine Abbrüche in den letzten Wochen gehabt...

In den Logs habe ich die Meldung
"Oct 28 16:04:29 RaspberryMatic user.err monit[1035]: 'internetCheck' status failed (1) -- no output"
alle 18 Sekunden wie bereits in einem anderen Thread (Wieso benötigt RaspberryMatic eine Internetverbindung trotz eigenem NTP Server?) beschrieben worden ist. Die dort erwähnte IP muc11s02-in-f14.1e100.net (172.217.22.238) lässt sich problemlos anpingen...

Ich möchte den Watchdog nicht deaktivieren, mich irritieren nur die Fehlermeldungen...

watchdog.PNG
watchdog.PNG (12.89 KiB) 335 mal betrachtet
log_no_internet.PNG
log_no_internet.PNG (7.27 KiB) 335 mal betrachtet
Viele Grüße,
Simon

zophyreus
Beiträge: 6
Registriert: 28.10.2020, 16:10
System: Alternative CCU (auf Basis OCCU)

Re: Watchdog meldet keine Internetverbindung

Beitrag von zophyreus » 29.10.2020, 11:59

Hmmm, habe ich mich nicht detailliert genug ausgedrückt?
Oder Forenregeln nicht befolgt?

Hat niemand einen Tipp was ich noch auf dem Raspi überprüfen könnte?

Viele Grüße,
Simon.

Benutzeravatar
jmaus
Beiträge: 6614
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 73 Mal
Danksagung erhalten: 504 Mal
Kontaktdaten:

Re: Watchdog meldet keine Internetverbindung

Beitrag von jmaus » 29.10.2020, 12:07

Nun, es wird schon seinen Grund haben das der internetCheck der Meinung ist das es das Internet von RaspberryMatic aus nicht richtig erreichen kann. Konkret findet die Internetprüfung ja wie folgt statt:

https://github.com/jens-maus/RaspberryM ... ckInternet

D.h. er versucht zuerst einen ping in richtung google.com zu senden, wenn das nicht klappt versucht er einen webserver von google.com auf port 80 zu erreichen und wenn das nicht klappt meldet er erst einen entsprechenden ausfall des internets. Wenn also zur besagten Ausführung dieses Checks auch nur für kurze Zeit das internet unterbrochen war oder es verbindungsprobleme in deinem LAN gegeben hat, oder der Switch sich verschluckt oder neugestartet hatte dann wird RaspberryMatic schon recht haben das es hier zu dieser Uhrzeit nicht das Internet erreichen konnte.
RaspberryMatic 3.53.34.20201121 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

zophyreus
Beiträge: 6
Registriert: 28.10.2020, 16:10
System: Alternative CCU (auf Basis OCCU)

Re: Watchdog meldet keine Internetverbindung

Beitrag von zophyreus » 29.10.2020, 12:16

Danke für den Link auf den Quellcode, damit kann ich mal weiterforschen :-)

zophyreus
Beiträge: 6
Registriert: 28.10.2020, 16:10
System: Alternative CCU (auf Basis OCCU)

Re: Watchdog meldet keine Internetverbindung

Beitrag von zophyreus » 29.10.2020, 12:48

Interessant, folgenden output bekomme ich auf der Konsole des Raspi:

[email protected]:/# ping -q -W 3 -c 1 google.com
ping: bad address 'google.com'

[email protected]:/# nc -z -w 3 google.com 80
nc: bad address 'google.com'


Aber nicht immer, manchmal klappt es....

[email protected]:/# ping -q -W 3 -c 1 google.com
PING google.com (2a00:1450:4016:802::200e): 56 data bytes

--- google.com ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 20.749/20.749/20.749 ms


Es liegt wohl an der Namensauflösung. Die macht eigentlich die Fritzbox Bei der habe ich allerdings vor ein paar Wochen DOT/DOH aktiviert...
Das teste ich mal.

Jemand eine bessere Idee?

jp112sdl
Beiträge: 6750
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 339 Mal
Danksagung erhalten: 693 Mal
Kontaktdaten:

Re: Watchdog meldet keine Internetverbindung

Beitrag von jp112sdl » 29.10.2020, 13:04

zophyreus hat geschrieben:
29.10.2020, 12:48
Bei der habe ich allerdings vor ein paar Wochen DOT/DOH aktiviert...
Der nächste mit dem Fritten-Problem und DNS over TLS... :evil:
viewtopic.php?f=65&t=61923&p=612952&hilit=dns#p612952

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Benutzeravatar
jmaus
Beiträge: 6614
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 73 Mal
Danksagung erhalten: 504 Mal
Kontaktdaten:

Re: Watchdog meldet keine Internetverbindung

Beitrag von jmaus » 29.10.2020, 13:12

In der Tat! AVM sollte man ein bisschen konservativer sein mit dem Freischalten solcher Dinge oder ne Möglichkeit schaffen solche experimentellen Features zurückziehen zu können.

Ergo: Schnell mal hingehen und das in der FritzBox deaktivieren, brauch eh kein Mensch! :D
RaspberryMatic 3.53.34.20201121 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

LibertyX
Beiträge: 726
Registriert: 10.11.2012, 19:47
System: Alternative CCU (auf Basis OCCU)
Wohnort: RP
Hat sich bedankt: 1 Mal
Danksagung erhalten: 18 Mal

Re: Watchdog meldet keine Internetverbindung

Beitrag von LibertyX » 29.10.2020, 13:23

Die Fritte macht nur DoT kein DoH.

Bei den DNS Servern sollte man aufpassen, dass man hier keine mit Filtern benutzt.

Aber ja, die Fritte hat da ein Problem, allerdings nicht mit DoT selbst sondern DNSSEC.
RaspberryMatic (3.51.6.20200613) @RPI3 | 56 HM 1 HMIP Gerät(e) und 4 CUxD-Geräte (2.4.3) | iobroker.pro - CCU-Historian (2.4.0)

Benutzeravatar
jmaus
Beiträge: 6614
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 73 Mal
Danksagung erhalten: 504 Mal
Kontaktdaten:

Re: Watchdog meldet keine Internetverbindung

Beitrag von jmaus » 29.10.2020, 14:03

LibertyX hat geschrieben:
29.10.2020, 13:23
Die Fritte macht nur DoT kein DoH.

Bei den DNS Servern sollte man aufpassen, dass man hier keine mit Filtern benutzt.

Aber ja, die Fritte hat da ein Problem, allerdings nicht mit DoT selbst sondern DNSSEC.
Wurscht egal, den ganzen "Rotz" abschalten. :D Das gaugelt nur vermeintliche Sicherheit vor die es nicht wirklich gibt oder leistet und macht auch DNS abfragen tendenziell nur langsamer oder wie man hier sehen kann kaputt...
RaspberryMatic 3.53.34.20201121 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

roe1974
Beiträge: 608
Registriert: 17.10.2017, 16:15
Wohnort: Wien
Hat sich bedankt: 19 Mal
Danksagung erhalten: 4 Mal

Re: Watchdog meldet keine Internetverbindung

Beitrag von roe1974 » 29.10.2020, 14:07

Also hier MikroTik Router mit DoH ..... alles Tutti :mrgreen: :mrgreen: 8) 8) :wink: :wink:
War aber persönlich nie ein Fan von AVM :wink: :wink:

Antworten

Zurück zu „RaspberryMatic“