Raspberrymatic / Homematic IP keine Kopplung

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
TimoBausO
Beiträge: 4
Registriert: 20.11.2020, 15:29
System: Alternative CCU (auf Basis OCCU)

Raspberrymatic / Homematic IP keine Kopplung

Beitrag von TimoBausO » 20.11.2020, 15:46

Hallo,
vermutlich gibt es dieses Thema hier im Forum bereits tausendfach, leider habe ich keine Lösung zu meinem Problem gefunden. Sollte es dennoch so sein, möchte ich euch bitten einen entsprechenden Link zu posten.
Vielen Dank!

Ich bin blutiger Anfänger in Sachen Raspberry und Raspberrymatic. Derzeit betreibe ich eine "Sparversion" von Smarthome (Homematic IP AP mit Bewegungsmelder, Schaltaktor und Wandtaster), die ich aber gerne erweitern möchte. Ich habe auf einen Raspberry Pi 4 das Funkmodul HM-MOD-RPI-PCB gesteckt. Leider schaffe ich es nicht meine Homematic IP-Komponenten mit dem Raspberry zu verbinden. Dazu habe ich folgendes gemacht:
- RaspberryMatic-3.53.30.20201024-rpi4.zip mit SD-Card im Raspberry. Der Zugriff über WebUI funktioniert.
- HMIP-Geräte aus dem AccessPoint gelöscht und auf Werkseinstellungen zurück gesetzt.

Über Geräte anlernen mit der Internetvariante versucht eine Verbindung herzustellen. Leider läuft nur die Minute herunter, ohne dass ein Gerät im Posteingang erscheint.
Besteht die Möglichkeit mein Funkmodul zu testen? So könnte ich einen Hardwarefehler ausschließen. Ich glaube zwar nicht, dass ich falsch gelötet habe, aber der Teufel ist ein Einhörnchen.

Beste Grüße und vielen Dank für die Hilfe
Timo

muellerjm
Beiträge: 70
Registriert: 13.11.2018, 10:21
Hat sich bedankt: 7 Mal

Re: Raspberrymatic / Homematic IP keine Kopplung

Beitrag von muellerjm » 20.11.2020, 17:35

persönlich bin ich kein Freund von HM IP. Ich hatte auch Aktoren, die sich nicht anmelden ließen. Da mir ELV die Gerät als i.O zurück schickte, habe ich mir aus lauter Frust eine orginal CCU gekauft... Da ging es dann tatsächlich... Aber was der Grund dafür ist, würde ich auch zu gerne wissen. Aber der Teufel steckt wie oft im Detail.

Wenn die RGBLed abwechselnd blinkt (grün rot) dann ist alles chic... Versuche mal den RM im abgesicherten Modus (sofern du Zusatzsoftware installiert hast). Und bei HM IP darf man auch mal Wunder erwarten...Kann sein das es morgen funktioniert. Da gab es schon so viele....

Baxxy
Beiträge: 2093
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 182 Mal
Danksagung erhalten: 296 Mal

Re: Raspberrymatic / Homematic IP keine Kopplung

Beitrag von Baxxy » 20.11.2020, 18:10

TimoBausO hat geschrieben:
20.11.2020, 15:46
Ich glaube zwar nicht, dass ich falsch gelötet habe, aber der Teufel ist ein Einhörnchen.
Der Teufel ist hier mit 99%iger Wahrscheinlichkeit der Pi4. Der stört direkt aufgesteckte Funkmodule so stark das keine Kommunikation zu Stande kommt. Dazu gibt es schon einige Berichte hier im Forum.

Lösungsmöglichkeiten.
dem Funkmodul eine bessere (abgesetzte) Antenne verpassen - kann helfen, muss aber nicht
das Funkmodul vom Pi4 absetzen mittels USB-Adapterplatine (HB-RF-USB-2) oder GPIO-Verlängerung

Vorschlag:
Den Pi4 für andere Sachen nutzen. Eine "Zentrale" braucht die Leistung des Pi4 bei weitem nicht (außer du willst viele schwergewichtige Add-Ons nutzen). Einen Pi3B oder Pi3B+ einsetzen, die CCU3 hat auch nur einen Pi3B im Bauch.
Grüße
Baxxy

TimoBausO
Beiträge: 4
Registriert: 20.11.2020, 15:29
System: Alternative CCU (auf Basis OCCU)

Re: Raspberrymatic / Homematic IP keine Kopplung

Beitrag von TimoBausO » 21.11.2020, 19:43

Vielen Dank für die Tips.
Ich werde mich am Montag mal um einen Raspberry Pi3 bemühen und dann mein Glück versuchen. Ich melde mich mit Ergebnissen.

echoDave
Beiträge: 3
Registriert: 20.11.2020, 21:38
System: Alternative CCU (auf Basis OCCU)

Re: Raspberrymatic / Homematic IP keine Kopplung

Beitrag von echoDave » 21.11.2020, 20:08

Hi ich hatte das Problem mit HM-MOD-RPI-PCB und der 3.53.30 Version siehe Thread: viewtopic.php?f=65&t=62782
Probier mal bitte ein Downgrade auf 3.51.6.20200613 ob es dann geht, bei mir ging es dann (geht über die WebUI fix wie ein Update).
Scheint irgendwas mit der 3.53.30 Version in Verbindung mit dem HM-MOD-RPI-PCB Modul zu sein.

Viele Grüße, David

TimoBausO
Beiträge: 4
Registriert: 20.11.2020, 15:29
System: Alternative CCU (auf Basis OCCU)

Re: Raspberrymatic / Homematic IP keine Kopplung

Beitrag von TimoBausO » 23.11.2020, 21:57

Hallihallo,
ich habe mir mal einen Pi3B+ und damit funktioniert die Kopplung einwandfrei.
echoDave hat geschrieben:
21.11.2020, 20:08
Probier mal bitte ein Downgrade auf 3.51.6.20200613 ob es dann geht
Werde ich im Laufe der Woche nochmal ausprobieren. Bin jetzt erstmal froh, dass meine Außenbeleuchtung wieder ihren Dienst tut :-)

TimoBausO
Beiträge: 4
Registriert: 20.11.2020, 15:29
System: Alternative CCU (auf Basis OCCU)

Re: Raspberrymatic / Homematic IP keine Kopplung

Beitrag von TimoBausO » 24.11.2020, 16:21

Ich habe nochmals probiert:
echoDave hat geschrieben:
21.11.2020, 20:08
Hi ich hatte das Problem mit HM-MOD-RPI-PCB und der 3.53.30 Version siehe Thread: viewtopic.php?f=65&t=62782
Probier mal bitte ein Downgrade auf 3.51.6.20200613 ob es dann geht, bei mir ging es dann (geht über die WebUI fix wie ein Update).
Scheint irgendwas mit der 3.53.30 Version in Verbindung mit dem HM-MOD-RPI-PCB Modul zu sein.
Nach dem Downgrade hat die Kopplung funktioniert.
Anschließend habe ich ein Update auf die aktuellste Version 3.53.34.20201121 durchgeführt. Mit dieser Version funktioniert die Kopplung ebenfalls. Es scheint demnach ein Fehler meiner Hardware in Kombination mit der Software zu sein.

Ich habe jetzt eine zufriedenstellende Lösung und bedanke mich für die Unterstützung.

Antworten

Zurück zu „RaspberryMatic“