HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
zer0x2a
Beiträge: 4
Registriert: 30.12.2020, 18:22
System: Alternative CCU (auf Basis OCCU)

HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von zer0x2a » 30.12.2020, 18:40

Hallo zusammen,

ich bin neu hier. Ich habe einige Jahre die MAX! Linie mit einem selbstgebauten CUL Stick eingesetzt. Grundsätzlich war ich ganz zufrieden mit der Lösung. Da meine Kids wieder einmal einen Thermostat zerstört haben musste ich feststellen, dass für MAX geräte keine Ersatzteile mehr gibt.

Also habe ich kurzentschlossen bei ELV das RPI-RF-MOD Board samt Raspberry PI 3, Netzteil ind Speicherkarte besorgt. Dazu noch einen Homematic Themostat und zwei Fenster/Tür Kontakte. Diese funktionieren alle einwandfrei.

Dazu habe ich mir noch das Display HmIP-WRCD aus der Homematic IP Serie besorgt. Ich habe schon lange nach einer einfachen Möglichkeit gesucht meine Familie bei offenen Fenstern zu benachrichtigen. Das ganze habe ich im Oktober in Betrieb genommen und ist bis Vorgestern auch einwandfrei gelaufen. Dann ist mir aufgefallen, dass es zwischen dem HmIP-WRCD ständig zu "Gerätekommunikation gestört" Fehlern kommt. Ich konnte das Display nicht mehr ansprechen. Ich habe es dann versucht über die Weboberfläche zu löschen aber die Kommunikation aht auch nicht geklappt. Gelöscht war es trotzdem also weider anlernen

Was ich seither unternommen habe:

HmIP-WRCD:
  • Neue Batterien
  • Werksreset (gefühlt eine Million mal)
  • Erfolglose Anlernversuche (egal ob lokal mit Daten vom Sticker oder Internet)
Raspberrymatic
  • SD Karte neu geflashed und Backup eingespielt
  • Andere SD Karte
  • Position der Zentrale verändert und alle anderen Netzteile in der Nähe ausgemacht
  • Systemschlüssel eingetragen
Nichts davon hat geholfen. Ich bekomme einfach keine Verbindung mit dem Wandtaster / Display mehr zustande. Habe ich noch was übersehen oder ist das ein Garantiefall?

Viele Grüße
Christian

zer0x2a
Beiträge: 4
Registriert: 30.12.2020, 18:22
System: Alternative CCU (auf Basis OCCU)

Re: HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von zer0x2a » 31.12.2020, 10:14

Update:

Ich habe gestern nochmal eine SD Karte mit RaspberryMatic 3.51.6.20200621 geflashed und das Anlernen hat sofort geklappt. Davor hatte ich 3.53 und 3.55 versucht. Kommunikation kein Problem bisher.

Was soll ich dazu jetzt sagen? Auf die Idee bin ich gekommen weil jemand hier geschrieben hatte, dass anlernen und Kommunikation mit Homematic IP und Version 3.51 besser gehen würde.

Ich werde mal schauen was passiert wenn ich die jetzige SD Karte auf 3.55 Upgrade. Wobei das mit dem eingebauten Updater irgendwie nicht funktioniert. Das Hochladen des Updates dauert ewig und irgendwann bekomme ich die Meldung, dass kein Platz sei. Muss mir die Partitionen mal genau anschauen. Warum dauert denn das Hochladen so extrem lange? Mein Netzwerk ist sehr stabil und die Kommunikation mit dem NAS oder anderen Geräten funktioniert in meinem Gigabit Lan so wie man es erwartet. Braucht der Raspberry Pi so lange um die Daten auf die SD Karte zu schreiben? So langsam dürfte das aber auch nicht sein.
Derzeit flashe ich die Karte einfach neu und spiele das Backup ein. Scheint auch zu gehen.

Viele Grüße

Hütte
Beiträge: 661
Registriert: 08.02.2017, 11:08
Hat sich bedankt: 27 Mal
Danksagung erhalten: 64 Mal

Re: HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von Hütte » 31.12.2020, 11:39

Wie groß ist denn deine SD-Karte und wie groß sind die Backups? Denn knapp 2 GB müssen schon noch frei sein, damit ein Update über die WebUI klappen soll. Einmal der Platz für zip-Datei und dann muss die ja noch entpackt werden. Dafür werden so knapp weitere 1,3 GB benötigt.

zer0x2a
Beiträge: 4
Registriert: 30.12.2020, 18:22
System: Alternative CCU (auf Basis OCCU)

Re: HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von zer0x2a » 02.01.2021, 11:28

Es ist eine 4GB SD Karte. Die Backups der Raspberrymatic? Gerade eines gemacht, das hat ~13MB.

Ich teste es gerade nochmal. Der Upload ist wieder sehr langsam. Was passiert da eigentlich?

Hütte
Beiträge: 661
Registriert: 08.02.2017, 11:08
Hat sich bedankt: 27 Mal
Danksagung erhalten: 64 Mal

Re: HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von Hütte » 02.01.2021, 13:42

zer0x2a hat geschrieben:
02.01.2021, 11:28
Es ist eine 4GB SD Karte. Die Backups der Raspberrymatic? Gerade eines gemacht, das hat ~13MB.

Ich teste es gerade nochmal. Der Upload ist wieder sehr langsam. Was passiert da eigentlich?
Also, ich würde mal sagen, dass deine SD-Karte einfach zu klein ist. Welche AddOns hats du alles installiert? Wenn du CUxD drauf hast, dann kannst du auf der Status-Seite von CUxD ganz leicht sehen, wieviel Speicherplatz auf den einzelnen Partitionen der SD-Karte und auf einem, eventuell angeschlossenenen, USB-Stick noch frei ist. Denn von den 4 GB geht schon erst einmal der Platz für die Boot-Partition und die Recovery-Partition "verloren", stehen also für das System zur Laufzeit nicht zur Verfügung. Dann benötigt das System selbst erst mal Speicherplatz. Da bleibt somit nicht meher genug Platz übrig, das Update hochzuladen und dann auch noch zu entpacken.

Wie ist dein Pi mit dem Netzwerk verbunden? LAN oder WLAN? Aber die Ursache wird wohl eher an der zu kleinen SD-Karte liegen.

Als erstes solltest du eine größere SD-Karte benutzen. Nimm am Besten eine 16 GB "High Endurance" Karte, die halten wesentlich länger. Auf dieser Karte dann über Etcher oder so, die neue FW flashen, danach noch einmal ein ganz aktuelles Backup erstellen und den Pi über "Einstellungen - Systemsteuerung - ZentralenWartung" sauber herunterfahren. Danach die Karten tauschen und, falls noch nicht vorhanden, einen USB-Stick (nimm auch da gleich einen mit wenigstens 16 GB und keinen von den billigsten) anschließen. Anschließend den Pi wieder starten und danach dach Backup zurückspielen. Somit werden die nächtlichen Backups gleich auch auf dem USB-Stick abgelegt, falls du nicht bereits eine andere Lösung implementiert hast.

zer0x2a
Beiträge: 4
Registriert: 30.12.2020, 18:22
System: Alternative CCU (auf Basis OCCU)

Re: HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von zer0x2a » 04.01.2021, 17:31

Danke für dein Hilfe @Hütte

Ich habe mich wohl selbst dumm angestellt wegen des Updates. Ich habe mich einfach mal per ssh auf das System verbunden und mir dann angeschaut wo das Update eigentlich hinwandert was ich da einzuspielen versucht habe. Dabei ist mir aufgefallen, dass der tmp Folder immer weiter anwächst. Schlussendlich ist mir dann noch aufgefallen, dass du von einem Zip File gesprochen hast. Ich habe dagegen ständig versucht das img File hochzuladen.
Eigentlich ist das ja auch üblich weil ich vorher immer noch die sha256 überprüfe. Macht das Backend das auch?
Zumindest einen entsprechenden Datei Filter Choose File Dialog einsetzen oder einen Hinweis in der Webapp einbauen.

Mit dem ZIP File geht es einigermaßen schnell und funktioniert auch mit meiner 4GB Karte.

Mein Problem mit dem HmIP-WRCD habe ich immer noch nicht gelöst. Obwohl die Raspberry Matic jetzt nur 1.5m entfernt steht habe ich immer wieder Probleme mit der Kommunikation.

Hütte
Beiträge: 661
Registriert: 08.02.2017, 11:08
Hat sich bedankt: 27 Mal
Danksagung erhalten: 64 Mal

Re: HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von Hütte » 07.01.2021, 01:05

@zer0x2a

Das mit dem img-File hatte vor Jahren auch funktioniert. Und ich persönlich gehe nicht davon aus, dass Jens hier Funktionalitäten eingebaut hat, so dass dies nicht mehr funktioniert. Ich habe ein Tinker S im Einsatz und hatte da noch nie Probleme mit einem Update.

Aber ausgehend davon, dass auch weiterhin ein Update mit der img-Datei funktioniert, so würde es in diesem Fall schon alleine dadurch auf einee 4 Gb-SD-Karte zu Problemen kommen, da du nicht etwa 250 MB für eine zip-Datei sondern etwa 1.3 GB für die img-Datei auf die SD-Karte hochlädst.Während diese Uploads werden diese 1.3 GB im kleineren "Häppchen" auf der SD-Karte abgelegt. Das sind dann schon eimal 1.3. GB auf der SD-Karte. Danach werden diese "Häppchen" durch das System zur eigentlichen Datei zusammen "gebastelt", die dann während diese Prozesses gleichzeitig weitere 1.3 GB Platz auf der Karte benötigt. Das sind dann schon einmal 2.6 GB an Platz auf der SD-Karte, die benötigt werden, auch wenn der Platz erst einmal eigentlich nur temporär benötigt wirde. Denn wenn die Datei erfolgreich "zusammen gebastelt" wurde, dann werden die "Häppchen" gelöscht. Und alleine dieser Prozess "sprengt" dann einfach den verfügbaren Platz der 4-GB-Karte, zumal ja uch noch der Rest (das eigentliche System, die Boot-Partition und die Recovery-Parition) Platz auf der Karte benötigt.

Ein weiterer Unterschied besteht aber auch darin, dass in der zip-Datei nicht nur die img-Datei liegt, sondern noch weitere 6 Dateien. Eine davon hat die Dateiendung ".sha256" und enthält eine Checksumme, über die dann festgestellt wird, ob die entpackte img-Datei auch wirklich korrekt ist und nicht eventuell entweder manipuliert wurde oder anderweitig korrupt ist. Das gibt eine weitere Sicherheit, dass beim Upload nichts schief gegangen ist.

Ich würde also dringend dazu raten, in Zukunft größere SD-Karten (am Besten "High-Endurance"-Karten) von mindestens 16 GB zu benutzen, und dies auch im Wechsel - also mindestens 2 Karten. Bei einem Update die neue Karte mit Etcher, oder so, flashen, ein Backup erstellen, das System sauber herunter fahren, danach die Karten zu tauschen, System starten und das Backup wieder einzuspielen. Dadurch hast du die vorheriege Version in Form der anderen SD-Karte immer als "Notnagel" zur Verfügung. Es gibt hier so viele Aussagen von Nutzern, dass ihr letztes Backup schon Monate alt oder sogar noch älter ist.

muellerjm
Beiträge: 85
Registriert: 13.11.2018, 10:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 1 Mal

Re: HmIP-WRCD - Keine Kommunikation mehr - Nach Reset nicht anlernbar

Beitrag von muellerjm » 07.01.2021, 13:04

ich darf meine Erfahrung kund tun...

das Problem kenne ich zu gut. Aus heiterem Himmel funktioniert HMIp nicht mehr. Klassische Geräte funktionieren weiterhin. Das Problem hat mich Monate beschäftigt. Nun bin ich den ein oder anderen Umstand auf die Schliche gekommen. und jetzt alles läuft besten. Zum Teil abwägig aber - Tatsache.

Das Wlan - ist doch nicht 868 sollte man meinen. Meine Fritzbox ist auf "autokanal" eingestellt. Und siehe da wenn die Box auf Kanal 9 oder 11 funkte, funktionierten die HMIP Geräte nicht mehr. Auch eine löschen, resetten und neu anlernen ging nicht. Antenne mind. 3m weg vom AP und alles war chic.

Netzteil - Ich betreibe RM mit einer externen Antenne. In der Nähe eines Netzteils gab es auch immer wieder Probleme.

DNS - undbedingt den DNS des Providers nutzen. Sofern der Nameserver auf z.B. 1.1.1.1 oder Google-ns zeigt. war der Keyserver nicht erreichbar (beim Anlernen). Speziell beim mir (Vodafone) greifen hier wohl Schutz oder Failovermechanismen. Warum kann ich nicht sagen, war aber definitv so.

Vor einigen Monaten hat mich ein User auf den Standort der Antenne hingewiesen. Ich wollte das nicht glauben. Aber es ist tatsächlich so, dass der Standort über HMIP Sein oder nicht sein mit entscheidet. Nun funktionieren alle HM IP fehlerfrei auch nach Raspiupdates, Rücksicherungen, etc... Keinerlei Probleme mehr.

Antworten

Zurück zu „RaspberryMatic“