RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Nairolf31
Beiträge: 2
Registriert: 26.01.2021, 20:46
System: Alternative CCU (auf Basis OCCU)
Danksagung erhalten: 1 Mal

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von Nairolf31 » 26.01.2021, 21:19

Hallo,
ich hoffe ich bin hier mit meinem Beitrag richtig. Zuerst wollte ich einen Bug in Github einstellen.
Vielen Dank erstmal für die tolle Umsetzung von RaspberryMatic. Ich bin nun seit ca. drei Jahren mit dem Image sehr zufrieden.

Ich verfolge die Docker-Entwicklung sehr gespannt, da ich gerne mehr Applikationen (Container) auf meinem Raspberry Pi 3 mit Funkmodul (HM-MOD-RPI-PCB) laufen lassen möchte.

Ich habe mein Raspberry am Wochenende mit dem neuesten Pi OS neu aufgesetzt.
Anschließend Docker und Portainer installiert. Docker funktioniert grundsätzlich einwandfrei.

Die Anleitung "Installation Docker OCI" habe ich strikt befolgt. Leider scheint es so zu sein, dass das Funkmodul nicht erkannt wird.
Ich habe den Punkt "https://github.com/jens-maus/RaspberryM ... ost-system" zweimal ohne Fehlermeldung durchgeführt.

Die Webapplikation bzw. der Container läuft grundsätzlich ohne Fehlermledung. Auch konnte ich ein Backup einspielen.
Allerdings kann ich die Aktoren nicht ansprechen bzw. neu anlernen.

Hat mir jemand einen Tipp wie ich dem Fehler auf die Schliche kommen kann ?
Kann ich für eine Hilfestellung von euch mehr Informationen bereitstellen ?

Hierdas LOG nach dem letzten Container-Deployment:

Code: Alles auswählen

Starting watchdog...
Identifying onboard hardware: oci, OK
Initializing RTC Clock: no hardware found
Running sysctl: OK
Checking for Factory Reset: not required
Checking for Backup Restore: not required
Initializing System: OK
Starting logging: OK
Populating /dev using udev: done
Init onboard LEDs: init, OK
Starting irqbalance: OK
Starting network: eth0: link up, fixed, firewall,       inet down, 172.17.0.4, OK
Identifying Homematic RF-Hardware: HmRF: none, HmIP: none, OK
[b]Updating Homematic RF-Hardware: no GPIO/USB connected RF-hardware found
Preparing start of hs485d: no Hm-Wired hardware found[/b]
Starting xinetd: OK
Starting eq3configd: OK
Starting lighttpd: creating new SSL cert... OK
Starting ser2net: no configuration file
Starting ssdpd: OK
Starting NUT services: disabled
Initializing Third-Party Addons: OK
Starting LGWFirmwareUpdate: ...OK
Setting LAN Gateway keys: OK
Starting hs485d: no Hm-Wired hardware found
Starting multimacd: not required
Starting rfd: no BidCos-RF hardware found
Starting HMIPServer: .......OK
Starting ReGaHss: .OK
Starting CloudMatic: OK
Starting NeoServer: OK
Starting Third-Party Addons: OK
Starting crond: OK
Setup onboard LEDs: booted, OK
Vielen Dank im Voraus und nochmal Danke für die tolle Arbeit.
Es ist für mich als Nicht-Entwickler sehr interessant die Entwicklung/Entstehung in GitHub zu verfolgen.


Grüße
Florian

Benutzeravatar
jmaus
Beiträge: 7083
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 161 Mal
Danksagung erhalten: 681 Mal
Kontaktdaten:

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von jmaus » 27.01.2021, 10:25

Nairolf31 hat geschrieben:
26.01.2021, 21:19
Die Anleitung "Installation Docker OCI" habe ich strikt befolgt. Leider scheint es so zu sein, dass das Funkmodul nicht erkannt wird.
Ich habe den Punkt "https://github.com/jens-maus/RaspberryM ... ost-system" zweimal ohne Fehlermeldung durchgeführt.

Die Webapplikation bzw. der Container läuft grundsätzlich ohne Fehlermledung. Auch konnte ich ein Backup einspielen.
Allerdings kann ich die Aktoren nicht ansprechen bzw. neu anlernen.

Hat mir jemand einen Tipp wie ich dem Fehler auf die Schliche kommen kann ?
Kann ich für eine Hilfestellung von euch mehr Informationen bereitstellen ?
Erst einmal danke dir für das Feedback. Das ist schon einmal grundsätzlich sehr hilfreich! Wie du vielleicht schon vermutest ist das ganze momentan noch ziemlich im Alpha-Status (und deshalb auch der Titel dieses Beitrags!). Und ehrlich gesagt habe ich das bisher nur auf einem amd64 system probiert und noch gar nicht auf einem RaspberryPi selbst. Ich denke da wird es vielleicht noch das Eine oder Andere geben das noch angepasst werden kann, damit der Funkmodul (wenn es auf dem GPIO sitzt) erkannt werden kann. Bei einem amd64 system ist das Funkmodul ja immer via HB-RF-USB bzw. HB-RF-ETH in Betrieb, d.h. da kommt dann auch keinerlei GPIO Schnittstelle ins spiel. Meine aktuelle Vermuting ist, das hier ggf. noch das DeviceTreeOverlay für den RaspberryPi fehlt damit er statt der internen seriellen schnittstelle dann /dev/raw-uart für den GPIO Bus nimmt. Bei RaspberryMatic auf einem Pi kommt das ja von Haus aus bereits mit und da ist dann das device tree overlay nicht nur dabei, sondern auch entsprechend in der config.txt vermerkt. Wie gesagt, bis jetzt noch nicht selbst getestet...

Das beste wäre allerdings du machst dazu vielleicht doch ein GitHub Ticket/Issue auf uns beschreibst deine eigesetzte Hardware, welchen snapshot du verwendest, etc. etc. und dann kommt das auch nicht in Vergessenheit bis zum finalen Release...
RaspberryMatic 3.55.10.20210213 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Olli_Odw
Beiträge: 5
Registriert: 22.12.2017, 19:29
Hat sich bedankt: 2 Mal

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von Olli_Odw » 27.01.2021, 15:11

Hallo Jens,

bin mit einem frisch aufgesetztem Raspi4 die Docker-Anleitung durchgegangen.

an folgender Stelle geht es beim deploy.sh nicht weiter:
Pull/Update OCI image ghcr.io/jens-maus/raspberrymatic:latest
Error response from daemon: name unknown

-> ist hier was bekannt?

Hinweis: docker habe ich nicht per apt-get installiert - da dies dann nicht funktioniert hat. (bei Docker kam direkt command not found)
Daher habe ich docker nach dieser Anleitung installiert:
https://linuxhint.com/install_docker_raspberry_pi-2/

Benutzeravatar
jmaus
Beiträge: 7083
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 161 Mal
Danksagung erhalten: 681 Mal
Kontaktdaten:

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von jmaus » 27.01.2021, 15:24

Olli_Odw hat geschrieben:
27.01.2021, 15:11
bin mit einem frisch aufgesetztem Raspi4 die Docker-Anleitung durchgegangen.

an folgender Stelle geht es beim deploy.sh nicht weiter:
Pull/Update OCI image ghcr.io/jens-maus/raspberrymatic:latest
Error response from daemon: name unknown

-> ist hier was bekannt?
Ja, denn das ist bereits die Anleitung für die kommende stable/release version die es noch nicht gibt. :) Wenn du ein aktuelles "snapshot" installieren willst, musst du entweder beim "docker pull" kommando statt "latest" "snapshot" hinten dranstellen. Oder wenn du das deploy.sh nutzt muss du das deploy.sh wie folgt aufrufen:

Code: Alles auswählen

CCU_OCI_TAG=snapshot ./deploy.sh
Olli_Odw hat geschrieben:
27.01.2021, 15:11
Hinweis: docker habe ich nicht per apt-get installiert - da dies dann nicht funktioniert hat. (bei Docker kam direkt command not found)
Daher habe ich docker nach dieser Anleitung installiert:
https://linuxhint.com/install_docker_raspberry_pi-2/
Dann wäre es schön du gehst hin in passt die Anleitung entsprechend diesen Informationen an wenn es wirklich via einfachem "apt install docker" nicht geht - oder fügst nen speziellen Hinweis nur für RaspberryPi hinzu.
RaspberryMatic 3.55.10.20210213 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Olli_Odw
Beiträge: 5
Registriert: 22.12.2017, 19:29
Hat sich bedankt: 2 Mal

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von Olli_Odw » 27.01.2021, 15:58

Hallo Jens,

danke - mit dem Snapshot-Deploy nach deiner Anweisung ist es durch gelaufen.
WebUI läuft - Backup zurück gespielt (War vorher PiVCCU3)

Nun hänge ich hier, es scheint das Funkmodul nicht zu erkennen:
Identifying Homematic RF-Hardware: ...HmRF: none, HmIP: none, OK
Updating Homematic RF-Hardware: no GPIO/USB connected RF-hardware found

Gesteckt ist über GPIO ein: HM-MOD-RPI-PCB welches mit einem testweise eingerichtetem Raspberrymatic ohne Docker läuft

Baxxy
Beiträge: 2835
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 213 Mal
Danksagung erhalten: 453 Mal

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von Baxxy » 27.01.2021, 16:08

Olli_Odw hat geschrieben:
27.01.2021, 15:58
Gesteckt ist über GPIO ein: HM-MOD-RPI-PCB welches mit einem testweise eingerichtetem Raspberrymatic ohne Docker läuft
Du hast Dir den Post von @jmaus etwas weiter oben durchgelesen?
So wie ich das verstehe kann ein Funkmodul auf GPIO noch nicht funktionieren.

Olli_Odw
Beiträge: 5
Registriert: 22.12.2017, 19:29
Hat sich bedankt: 2 Mal

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von Olli_Odw » 27.01.2021, 17:03

Ah, verstehe. Ging noch vom Startpost aus:
BITTE BEACHTEN:
Bitte noch beachten, dass bei Nutzung eines Funkmodules (RPI-RF-MOD, HM-MOD-RPI-PCB) es notwendig wird die von Alexander Reinert im Rahmen des piVCCU Projektes dankenswerterweise entwickelten Kernelmodule im Hostsystem selbst (auf dem der Docker gestartet wird) vor Nutzung der Docker-Variante zu installieren.

Nairolf31
Beiträge: 2
Registriert: 26.01.2021, 20:46
System: Alternative CCU (auf Basis OCCU)
Danksagung erhalten: 1 Mal

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von Nairolf31 » 27.01.2021, 17:25

Vielen Dank Jens.
Ich habe einen Issue erstellt und wie ich sehe bin ich nicht alleine :-)

https://github.com/jens-maus/RaspberryMatic/issues/1106

ptweety
Beiträge: 307
Registriert: 07.01.2017, 16:48
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 12 Mal
Danksagung erhalten: 13 Mal

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von ptweety » 28.01.2021, 21:28

Hallo Jens,

ich habe heute mit dem aktuellen Snapshot vom Docker-Image rumgespielt und ein paar Sachen sind mir dann doch aufgefallen. Das mag aber auch teilweise an meiner Umgebung liegen.
  • Das Volume ccu_data mass man selber anlegen. Das sollte ggfs. in der Doku etwas besser beschrieben werden
  • Für ssh braucht man eine weitere Portfreigabe (etwa 2022:22)
  • Das root-pw war nicht gesetzt. Ich habe es per docker exec -it ccu /bin/sh und passwd nachholen müssen
  • Das root-fs ist read-only. Ist das unter Docker relevant?
  • Ich hatte nur eine grüne Led nach erstem start. Einbinden von /lib/modules als volume hat geholfen.
  • Per https einloggen geht, braucht aber eine weitere Portfreigabe (etwa 8443:443)
Hier auch noch der Ausschnitt aus dem Compose file

Code: Alles auswählen

  raspberrymatic:
    container_name: ccu
    restart: unless-stopped
    image: ghcr.io/jens-maus/raspberrymatic:snapshot
    hostname: homematic-raspi
    privileged: true
    stop_grace_period: 30s
    labels:
      com.centurylinklabs.watchtower.enable: "false"
    volumes:
      - ccu_data:/usr/local
      - /lib/modules:/lib/modules:ro
    ports: [ "2022:22", "8080:80", "8443:443", "2001:2001", "2010:2010", "8181:8181", "9292:9292" ]

volumes:
    ccu_data:
      external:
        name: ccu_data
Docker log:

Code: Alles auswählen

Identifying onboard hardware: oci, OK
Initializing RTC Clock: onboard, OK
Running sysctl: OK
Checking for Factory Reset: not required
Checking for Backup Restore: not required
Initializing System: OK
Starting logging: OK
Populating /dev using udev: done
Init onboard LEDs: init, OK
Starting irqbalance: OK
Starting network: eth0: link up, fixed, firewall, inet up, 172.20.0.9, OK
Identifying Homematic RF-Hardware: .....HmRF: RPI-RF-MOD/[email protected]:00:14.0-3.1, HmIP: RPI-RF-MOD/[email protected]:00:14.0-3.1, OK
Updating Homematic RF-Hardware: RPI-RF-MOD: 4.2.6, OK
Preparing start of hs485d: no Hm-Wired hardware found
Starting xinetd: OK
Starting eq3configd: OK
Starting lighttpd: OK
Starting ser2net: no configuration file
Starting ssdpd: OK
Starting sshd: OK
Starting NUT services: disabled
Initializing Third-Party Addons: OK
Starting LGWFirmwareUpdate: ...OK
Setting LAN Gateway keys: OK
Starting hs485d: no Hm-Wired hardware found
Starting multimacd: .OK
Starting rfd: .OK
Starting HMIPServer: .......OK
Starting ReGaHss: .OK
Starting CloudMatic: OK
Starting NeoServer: disabled
Starting Third-Party Addons: OK
Starting crond: OK
Setup onboard LEDs: booted, OK
Host:

Code: Alles auswählen

$ uname -a
Linux nucleus 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64 GNU/Linux

$ lsmod | grep hb 
hb_rf_usb              16384  0
generic_raw_uart       20480  5 hb_rf_usb
usbcore               294912  12 xhci_hcd,usbhid,cdc_acm,usb_storage,btusb,xhci_pci,uas,hb_rf_usb

$ lsmod | grep eq3
eq3_char_loop          20480  8

$ lsmod | grep led
rpi_rf_mod_led         16384  0

$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 05e3:0612 Genesys Logic, Inc. Hub
Bus 002 Device 002: ID 2109:0716 VIA Labs, Inc. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 024: ID 1cf1:0030 Dresden Elektronik 
Bus 001 Device 005: ID 0403:6f70 Future Technology Devices International, Ltd HB-RF-USB
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 001 Device 004: ID 8087:0026 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Container:

Code: Alles auswählen

[email protected]:~# grep -i error /var/log/hmserver.log 
Jan 28 21:13:49 de.eq3.cbcs.server.core.vertx.KeyServerWorker ERROR [vert.x-worker-thread-1] Missing key server configuration parameter (Network.Key) for  mode: KEYSERVER_LOCAL 

[email protected]:~# cat /var/log/messages 
Jan 28 21:13:34 homematic-raspi syslog.info syslogd started: BusyBox v1.32.0
Jan 28 21:13:37 homematic-raspi user.info firewall: configuration set
Jan 28 21:13:44 homematic-raspi daemon.err xinetd[386]: Unable to read included directory: /etc/config/xinetd.d [file=/etc/xinetd.conf] [line=14]
Jan 28 21:13:44 homematic-raspi daemon.crit xinetd[386]: 386 {init_services} no services. Exiting...
Jan 28 21:13:44 homematic-raspi auth.info sshd[412]: Server listening on 0.0.0.0 port 22.
Jan 28 21:13:44 homematic-raspi auth.info sshd[412]: Server listening on :: port 22.
Jan 28 21:13:44 homematic-raspi user.info root: Updating RF Lan Gateway Coprocessor Firmware
Jan 28 21:13:44 homematic-raspi user.debug update-coprocessor: firmware filename is: coprocessor_update_hm_only.eq3
Jan 28 21:13:44 homematic-raspi user.info root: Updating RF Lan Gateway Firmware
Jan 28 21:13:44 homematic-raspi user.info update-lgw-firmware: No gateway found in config file /etc/config/rfd.conf
Jan 28 21:14:02 homematic-raspi daemon.info : starting pid 699, tty '/dev/null': '/usr/bin/monit -Ic /etc/monitrc'
Jan 28 21:14:02 homematic-raspi user.info monit[699]: Starting Monit 5.27.1 daemon with http interface at /var/run/monit.sock
Jan 28 21:14:02 homematic-raspi user.info monit[699]: 'homematic-raspi' Monit 5.27.1 started
Jan 28 21:14:17 homematic-raspi user.err monit[699]: 'hs485dEnabled' status failed (2) -- grep: /var/etc/hs485d.conf: No such file or directory
Jan 28 21:14:17 homematic-raspi user.err monit[699]: 'hmlangwEnabled' status failed (1) -- no output
Jan 28 21:14:17 homematic-raspi user.warn monit[699]: 'hasUSB' status failed (1) -- no output
Jan 28 21:14:17 homematic-raspi user.err monit[699]: 'hb_rf_eth-CheckEnabled' status failed (1) -- no output
Jan 28 21:14:17 homematic-raspi user.err monit[699]: Lookup for '/media/usb1' filesystem failed  -- not found in /proc/self/mounts
Jan 28 21:14:17 homematic-raspi user.err monit[699]: Filesystem '/media/usb1' not mounted
Jan 28 21:14:17 homematic-raspi user.err monit[699]: 'usb1' unable to read filesystem '/media/usb1' state
Jan 28 21:14:17 homematic-raspi user.info monit[699]: 'usb1' trying to restart
Jan 28 21:14:24 homematic-raspi auth.info sshd[747]: Accepted publickey for root from 192.168.178.35 port 55111 ssh2: RSA SHA256:ngxuulEhr1E/7DHUvFi4ZwrjkzHfKEVkPgenCJfWs0Y
Jan 28 21:14:31 homematic-raspi user.warn monit[699]: 'hasUSB' status failed (1) -- no output
Jan 28 21:14:31 homematic-raspi user.err monit[699]: Filesystem '/media/usb1' not mounted
Jan 28 21:14:31 homematic-raspi user.err monit[699]: 'usb1' unable to read filesystem '/media/usb1' state
Jan 28 21:14:31 homematic-raspi user.info monit[699]: 'usb1' trying to restart
Jan 28 21:14:46 homematic-raspi user.warn monit[699]: 'hasUSB' status failed (1) -- no output
Jan 28 21:14:46 homematic-raspi user.err monit[699]: Filesystem '/media/usb1' not mounted
Jan 28 21:14:46 homematic-raspi user.err monit[699]: 'usb1' unable to read filesystem '/media/usb1' state
Jan 28 21:14:46 homematic-raspi user.info monit[699]: 'usb1' trying to restart
Jan 28 21:15:02 homematic-raspi user.warn monit[699]: 'hasUSB' status failed (1) -- no output
Jan 28 21:15:02 homematic-raspi user.err monit[699]: Filesystem '/media/usb1' not mounted
Jan 28 21:15:02 homematic-raspi user.err monit[699]: 'usb1' unable to read filesystem '/media/usb1' state
Jan 28 21:15:02 homematic-raspi user.info monit[699]: 'usb1' trying to restart
Jan 28 21:15:17 homematic-raspi user.err monit[699]: 'hasUSB' status failed (1) -- no output

Benutzeravatar
jmaus
Beiträge: 7083
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 161 Mal
Danksagung erhalten: 681 Mal
Kontaktdaten:

Re: RaspberryMatic – Neue Docker/Container-Alpha-Testversion

Beitrag von jmaus » 28.01.2021, 23:47

ptweety hat geschrieben:
28.01.2021, 21:28
ich habe heute mit dem aktuellen Snapshot vom Docker-Image rumgespielt und ein paar Sachen sind mir dann doch aufgefallen. Das mag aber auch teilweise an meiner Umgebung liegen.
Danke erst einmal für die Rückmeldung. Schön das sich wohl mehr und mehr Tester bzgl. der Docker/Container Variante einfinden...

Dann versuche ich mal auf die unterschiedlichen Dinge einzugehen auch wenn das keine neuen Dinge sind:
ptweety hat geschrieben:
28.01.2021, 21:28
[*]Das Volume ccu_data mass man selber anlegen. Das sollte ggfs. in der Doku etwas besser beschrieben werden
Das sollte "nur" eine Spezialität von docker compose sein. Dort müsstest du meiner Erinnerung nach in einer extra "volumes:" section ganz am Schluss das "ccu_data" noch definieren damit docker compose das dann automatisch anlegt.
ptweety hat geschrieben:
28.01.2021, 21:28
[*]Für ssh braucht man eine weitere Portfreigabe (etwa 2022:22)
[*]Per https einloggen geht, braucht aber eine weitere Portfreigabe (etwa 8443:443)
Das ist richtig und nichts ungewöhnliches und das muss jeder Nutzer eben an seine Umgebung anpassen weil gerade bei docker es ja einige Dienste geben kann die man parallel laufen lassen kann und da muss dann schon jeder selbst entscheiden ob er den SSH auf dem host exposen will oder nicht. Und für HTTPS gilt im Grunde das selbe.
ptweety hat geschrieben:
28.01.2021, 21:28
[*]Das root-pw war nicht gesetzt. Ich habe es per docker exec -it ccu /bin/sh und passwd nachholen müssen
Auch das ist normal und so gewollt und in der Tat auch nicht anders als das bei einer RaspberrPi-basierten Zentrale der Fall ist. Dort ist das root-pw auch leer und man muss erst einmal via WebUI SSH anschalten und dort das Root-Passwort setzen.
ptweety hat geschrieben:
28.01.2021, 21:28
[*]Das root-fs ist read-only. Ist das unter Docker relevant?
Nicht relevant, aber auch nicht schädlich und somit konsistent mit dem Verhalten/Verfahren wie bei den anderen Platformen. Addons, etc. verlassen sich ja auch darauf das das rootfs read-only ist.
ptweety hat geschrieben:
28.01.2021, 21:28
[*]Ich hatte nur eine grüne Led nach erstem start. Einbinden von /lib/modules als volume hat geholfen.
Das ist in der Tat ein guter hinweis. Werde ich mir dann bei Gelegenheit einmal anschauen. Das müsste wegen dem led kernel modul notwendig sein. Oder gab/gibt es ohne das /lib/modules volume irgendwelche Fehlermeldungen?
RaspberryMatic 3.55.10.20210213 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Gesperrt

Zurück zu „RaspberryMatic“