HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

chrizz-o
Beiträge: 12
Registriert: 11.01.2021, 20:47
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 4 Mal

HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von chrizz-o » 11.01.2021, 21:43

Hallo zusammen,

im Rahmen einer Sanierung haben wir zur Steuerung der Fußbodenheizung sieben Homematic IP Wandthermostat mit Schaltausgang (150628A0) mit der Kurzbezeichnung HmIP-BWTH im April 2020 verbauen lassen und sie bis dato manuell genutzt.

Da mich das Thema Smart Home immer stärker in den Bann gezogen hat und ich per Hue einige tolle Sachen umgesetzt habe, legte ich mir vor kurzem einen Raspberry Pi 4 mit Homematic IP Funkmodul zu. RaspberryMatic habe ich frisch aufgespielt und auf den aktuellen Stand gebracht (FW 3.55.5.20201226).

Leider bringt mich das Anlernen von 6 der 7 Wandthermostate an den Rand des Wahnsinns :twisted:

Beim ersten hat, wie es in der Anleitung beschrieben ist, ein kurzer Druck auf die Systemtaste ausgereicht und es war mit der OCCU gekoppelt. Bei allen anderen war ich nicht erfolgreich und habe folgendes bisher ohne Erfolg ausgeführt:

1. Überprüfung per Skript, ob OCCU mit Internet verbunden ist -> ist sie
2. Werksreset an den Thermostaten und erneute Anlernversuche
3. Neustart der OCCU
4. Herunterfahren der OCCU, vom Strom genommen und Umpositionierung, um Funkprobleme auszuschließen, da der Pi in einer Ecke mit dem Modem steht
5. Anlernen mit QR-CODE und die SGTIN vom Aufkleber -> einen KEY, wie er in OCCU gefordert wird, haben wir nicht

Da der Fehler meist vor dem Monitor sitzt, möchte ich euch um Hilfe bitten. Habt ihr Ideen, was ich noch versuchen könnte?

Kann man an den Wandthermostaten erkennen, wann sie im Anlernmodus sind? Wenn man die Systemtaste lange drückt, erscheint ein Pairing. Dazu steht nichts in der Bedienungsanleitung, daher gehe ich davon aus, dass das zum Verknüpfen mit anderen Homematic IP Aktoren und Sensoren gedacht ist und nicht zum Verknüpfen mit der OCCU.
Kann es sein, dass die OCCU Firmware zu neu ist / die Firmware der BWTHs zu alt?
Die Logs protokollieren aktuell alles mit. Ich konnte aber keine fehlgeschlagenen Anlernversuche identifzieren. Muss ich auf ein bestimmtes Key-Word im Log achten?

Weitere Infos:
Das angelernte BWTH hat 1.2.4 als Firmware und im Haus die größte räumliche Distanz zur OCCU.

Ich danke euch vorab für eure Antworten.

Viele Grüße
chrizz-o
Zuletzt geändert von Roland M. am 11.01.2021, 21:47, insgesamt 1-mal geändert.
Grund: Thema verschoben

Baxxy
Beiträge: 2553
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 206 Mal
Danksagung erhalten: 402 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von Baxxy » 11.01.2021, 23:07

Das Problem könnte mit
chrizz-o hat geschrieben:
11.01.2021, 21:43
einen Raspberry Pi 4 mit Homematic IP Funkmodul
zusammenhängen.
Hier müsstest du mal beschreiben...
  • welches Funkmodul ist es?
  • wie ist es mit dem Pi4B verbunden?
  • hat es eine externe Antenne oder den original Drahtstummel?
(Screenshots gehen auch)
Der Pi4B ist ein ziemlich fieser Funkstörer. Gerade bei IP-Geräten macht sich das bemerkbar.
Da wird Anlernen je nach (PI-Funkmodul-Antennen) - Konstellation zum Glücksspiel.
chrizz-o hat geschrieben:
11.01.2021, 21:43
5. Anlernen mit QR-CODE und die SGTIN vom Aufkleber -> einen KEY, wie er in OCCU gefordert wird, haben wir nicht
Auf dem den Geräten beiliegenden Aufkleber ist doch unten immer Key & SGTIN abgedruckt.

chrizz-o
Beiträge: 12
Registriert: 11.01.2021, 20:47
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 4 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von chrizz-o » 12.01.2021, 07:14

Hallo Baxxy,

vielen Dank für deine schnelle Antwort.

Der Raspberry 4 hat ein Funkmodul namens RPI-RF-MOD verbaut. Der Drahtstummel wurde ersetzt durch eine externe Antenne.

Zum Zusammenbau kann ich nur Vermutungen anstellen, da ich den Raspberry 4 zusammengebaut über eBay erworben habe.

Viele Grüße
chrizz-o

muellerjm
Beiträge: 84
Registriert: 13.11.2018, 10:21
Hat sich bedankt: 7 Mal
Danksagung erhalten: 1 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von muellerjm » 12.01.2021, 07:38

Hallo,

das ist mit ziemlicher Wahrscheinlichkeit ein Problem mit Störsignalen. Raspi 4 ist schon mal suboptimal - stört sehr. Da du eine externe Antenne hast, ist die Sache noch wesentlich empfindlicher. Seltsamerweise betrifft das nur HM IP Geräte. Also mind. 3m geschirmtes USB Kalbel und die Antenne weg von WLAN, Netzeil, Telefon etc. Dann wird es funktionieren.... Die Antenne dann aber auch im Betrieb da lassen wo es funktioniert. Du kannst dir das Funkgeschehen schön mit einem SDR und einem DVB-T Stick ansehen. Wenn deine Antenne zu breitbandig ausgelegt ist, solltest du was anderes nehmen. Eine Groundplane z.B...mit 2mm Draht
https://m0ukd.com/calculators/quarter-w ... alculator/

chrizz-o
Beiträge: 12
Registriert: 11.01.2021, 20:47
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 4 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von chrizz-o » 12.01.2021, 07:44

Hallo muellerjm,

vielen Dank auch für deine Antwort.

Ich werde später mal den Raspberry herunterfahren, auf einer anderen Etage platzieren und mit einem langen Ethernetkabel verbinden.

Die externe Antenne ist am Gehäuse verschraubt. Getrennt vom Raspberry kann ich die leider nicht platzieren.

Viele Grüße
Christian

chrizz-o
Beiträge: 12
Registriert: 11.01.2021, 20:47
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 4 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von chrizz-o » 12.01.2021, 08:05

Hallo zusammen,

ich habe den Raspberry mal in einem Raum ohne W-LAN Signal platziert und nur per Ethernet an das Internet gekoppelt. In dem Raum befindet sich neben dem Raspberry, das einzig funktionierende BWTH und eine ZigBee Lampe. Zwischen BWTH und Raspberry liegen ca. 4 Meter und der Abstand zum ZigBee Lampe beträgt auch ca. 1,5 Meter.

Alternativ würde ich nochmal einen Hardreset des PIs vornehmen. Vielleicht hat der sich beim ersten Anlernen "verschluckt"?

shartelt
Beiträge: 3173
Registriert: 14.01.2015, 14:59
Hat sich bedankt: 44 Mal
Danksagung erhalten: 97 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von shartelt » 12.01.2021, 09:56

die entfernung von PI zu antenne ist zu gering.
Tausch das PI4 gegen ein PI3 und es wird funktionieren ;)

Xel66
Beiträge: 8630
Registriert: 08.05.2013, 23:33
System: Alternative CCU (auf Basis OCCU)
Wohnort: Nordwürttemberg
Hat sich bedankt: 71 Mal
Danksagung erhalten: 453 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von Xel66 » 12.01.2021, 10:08

Und bezüglich der nachträglich geänderten Antenne. Es ist viel Müll auf dem Markt. Viel hängt auch von der Ausführung der Lötarbeiten ab. Eine Antenne mit mehr Gewinn empfängt auch mehr Störungen. Dein Problem ist aber der vom Pi4 verursachte Störnebel. Der Pi4 ist nicht wirklich der geeignete Rechner für eine Anwendung, die per Funk kommuniziert und auf einen möglichst störungsfreien Empfang angewiesen ist.

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 141 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
274 Programme, 265 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.51.6.20200420
Testsystem: CCU3 3.49.17
---------------------------------------------------------------------------------

chrizz-o
Beiträge: 12
Registriert: 11.01.2021, 20:47
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 4 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von chrizz-o » 12.01.2021, 10:16

Ich danke euch, für eure Antworten. Dann habe ich mich wohl von dem Angebot auf eBay blenden lassen, welches das Rasp 4 mit dem Funkmodul als leistungsstärkere CCU beworben hat.

Damit die 200€ nicht für die Tonne waren: Kann ich versuchen, die Distanz zwischen RaspberryPI und Antenne zu vergrößern? Gibt es die Möglichkeit eines "Verlängerungskabels", um dann eine Standantenne anzuschließen? Kann ich technische Störquellen auf dem Raspberry Pi4 deaktivieren?

Was würde auf Fehler bei den Lötarbeiten hindeuten? Kann man das eingrenzen? Dann hätte ich ggfs. Anspruch auf Gewährleistung, da es sich bei dem eBay-Verkäufer um ein kommerziellen Anbieter handelt.

shartelt
Beiträge: 3173
Registriert: 14.01.2015, 14:59
Hat sich bedankt: 44 Mal
Danksagung erhalten: 97 Mal

Re: HmIP-BWTH - Anlernen schlägt in 6 von 7 Fällen fehl

Beitrag von shartelt » 12.01.2021, 10:20

chrizz-o hat geschrieben:
12.01.2021, 10:16
Damit die 200€ nicht für die Tonne waren
what...Du hast dafür 200 Euro gezahlt?
Ich glaub ich muss auch anfangen ein paar Funkmodule zusammenzulöten und ne externe Stummelantenne dran zu machen ;)

Antworten

Zurück zu „RaspberryMatic“