RaspberryMatic 3.55.10.20210213 – Neue Version

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

JoMass
Beiträge: 208
Registriert: 26.11.2016, 12:52
Hat sich bedankt: 4 Mal
Danksagung erhalten: 7 Mal

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von JoMass » 21.02.2021, 16:38

zur info, da der VoltageCheck hier widerholt auffällig beschrieben wird

nachdem meine Raspberrymatic die letzten 10 Tage ohne Auffälligkeiten mit der neuen Version durchgelaufen ist, heute diese Meldungen im ca. 30sec Takt

Code: Alles auswählen

Feb 21 15:11:45 Raspi-ccu2 user.crit kernel: [511519.922786] Under-voltage detected! (0x00050005)
Feb 21 15:11:49 Raspi-ccu2 user.info kernel: [511523.956256] Voltage normalised (0x00000000)
Feb 21 15:12:07 Raspi-ccu2 user.warn monit[1359]: 'voltageCheck' status failed (0) -- no output
Feb 21 15:12:25 Raspi-ccu2 user.warn monit[1359]: 'voltageCheck' status failed (0) -- no output
Feb 21 15:12:43 Raspi-ccu2 user.warn monit[1359]: 'voltageCheck' status failed (0) -- no output
Feb 21 15:13:01 Raspi-ccu2 user.warn monit[1359]: 'voltageCheck' status failed (0) -- no output
.... 
Raspberry nach etwa 10min runtergefahren, Stromlos gemacht und dann wieder gestartet, Seither ist wieder Ruhe und es sind keine weitere Meldung aufgetreten. Original Netzteil, welches mit dem Sende-Modul RPI-RF-MOD von ELV mitgeliefert wird. In den letzten 6 Monaten gab es keine einzige derartige Meldung.

Die Testsequenz von Jens liefert im jetzt wieder funktionierenden System:

Code: Alles auswählen

vcgencmd version; vcgencmd get_throttled; vcgencmd measure_vo
lts; vcgencmd measure_temp;
Jan  8 2021 14:31:16
Copyright (c) 2012 Broadcom
version 194a85abd768c7334bbadc3f1911c10a7d18ed14 (clean) (release) (start)
throttled=0x0
volt=0.8438V
temp=41.3'C
JoMass
~150 Geräte; ~70 Programme FW: 3.53.34.20210213 – RaspberryPi4 als CCU - HISTORIAN V2.5.3 auf QNAP; Mediola AIO Creator NEO - RedMatic latest on RPI4/4GB

JoMass
Beiträge: 208
Registriert: 26.11.2016, 12:52
Hat sich bedankt: 4 Mal
Danksagung erhalten: 7 Mal

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von JoMass » 21.02.2021, 17:17

jmaus hat geschrieben:
16.02.2021, 14:30
...
...

EDIT:
Nun hab ich den under-voltage check eben aber nochmal etwas abgeändert und prüfe nun "nur noch" auf bit 0 (d.h. ob aktuelle eine under-voltage vorliegt) Und nur wenn diese > 20 sekunden anhält wird es dann eine Alarmierung in Zukunft geben. Vielleicht ist das ja der bessere, konservativere Ansatz um nicht bei einer kleinen Unterversorgung beim Start sofort eine Alarmierung in Gang zu setzen.
falls es wieder auftritt, versuche ich mal eine "Nightly Release"
JoMass
~150 Geräte; ~70 Programme FW: 3.53.34.20210213 – RaspberryPi4 als CCU - HISTORIAN V2.5.3 auf QNAP; Mediola AIO Creator NEO - RedMatic latest on RPI4/4GB

Ban
Beiträge: 37
Registriert: 09.04.2019, 08:04
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 2 Mal

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von Ban » 21.02.2021, 22:08

Also die CCU hat Recht. Heute hatte ich wieder einen Alarm und zu diesem Zeitpunkt hatte der HM-Lan scheinbar Aussetzer.
Aktuell hatte ich zum Test noch alles beim Alten gelassen, Kabel, Dose...
Jetzt muss sich rausbekommen, was da los ist. Dieser HM-Lan hatte an einem anderen Standort keine Aussetzer.

Alarm.png
Alarm.png (13.62 KiB) 854 mal betrachtet

Code: Alles auswählen

21.02.2021 13:39:27 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:28 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:29 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:30 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:31 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:32 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:33 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:34 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:35 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:36 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:39:41 - Zeitüberschreitung der Anforderung.
21.02.2021 13:39:46 - Zeitüberschreitung der Anforderung.
21.02.2021 13:39:51 - Zeitüberschreitung der Anforderung.
21.02.2021 13:39:56 - Zeitüberschreitung der Anforderung.
21.02.2021 13:40:01 - Zeitüberschreitung der Anforderung.
21.02.2021 13:40:02 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:03 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:04 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:05 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:06 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:07 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:08 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:09 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:10 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:11 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:12 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:13 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:14 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:15 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:16 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:17 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:18 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:19 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:20 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:21 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:22 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:23 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
21.02.2021 13:40:24 - Antwort von 192.168.10.8: Bytes=32 Zeit<1ms TTL=128
Edit: Heute morgen hatte ich wieder einen Alarm. In dieser Minute hatte der HM-Lan nur 2x langsam geantwortet. 260ms. aber keine Aussetzer.
Gleichzeitig hatte ich einen Ping auf meinen Internetrouter laufen. Der war unauffällig. Läuft alles über denselben Switch. Den kann ich dann wohl schon mal ausschliessen.
Jetzt habe ich die komplette Strecke zum Switch getauscht. Lankabel, Dose und damit anderes Kabel in der Wand.
Mal abwarten.
Charly mit RaspberryMatic, 2 HM-Lan, 2 HmIP-HAP, 1 RF-WLAN Gateway, ca. 190 Geräte

condor07
Beiträge: 30
Registriert: 20.11.2011, 17:50
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dortmund

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von condor07 » 22.02.2021, 08:11

Hallo Ban

Die passive Infrastrukturwürde ich bei mir mal ausschliessen da bei mir die 3 Gateways an unterschiedlichen Switchen mit unterschiedlichen Netzwerkdosen bzw. direkt gepatcht sind.
Ich habe an allen 3 Gateways aussetzer.

Code: Alles auswählen

Feb 21 06:55:49 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 06:58:00 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 09:52:55 homematic info  Info: Event="HEQ0400109"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 11:51:53 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 11:56:37 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 13:45:05 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 15:30:02 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 18:11:45 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 18:13:56 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 18:56:32 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 19:04:51 homematic info  Info: Event="HEQ0400109"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 23:09:41 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 23:45:41 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 21 23:45:59 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 22 02:48:18 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 22 02:48:37 homematic info  Info: Event="HEQ0400062"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 22 05:02:22 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 22 06:10:44 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
Feb 22 06:11:02 homematic info  Info: Event="HEQ0400383"."CONNECTED"=false [execute():iseXmlRpc.cpp:321]
<spekulation>
Mein momentaner Tip/Vermutung ist da eher ein Timingproblem zwischen CCU und Gateways eventuell ist ja auf Eq-3
Seite die Zeit verändert worden bis die Gateways sich nach einer Anfrage zurück melden müssen.
</spekulation>

Michael
-------------------------------------------
RM auf pi4B mit Firmware 3.55.10.xxxx
CUxD 2.5.1 / HPInstCCU3RM 3.84
mit 157 Geräten
-------------------------------------------

timmertechnik
Beiträge: 2
Registriert: 31.01.2020, 09:32

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von timmertechnik » 22.02.2021, 09:04

Moin an alle.

Ich habe sofort nach dem erscheinen das Update über die neue Funktion "Direkt auf CCU laden und installieren durchgeführt (Tinkerboard S).

Leider hat das nicht so richtig funktioniert und viele Geräte waren nicht mehr erreichbar, den Duty-Cycle war sehr hoch. Also: nochmal, aber jetzt das Image runter geladen und dann mit der alte gewohnte Funktion geupdatet. Alles Perfekt! ... dachte ich...

Seitdem steigt mein CCU jede Nacht um 00:13 - 00:15 aus. Mit AskSin Analyzer, CCU-Historian und durchsuchen alle Programme habe ich nichts finden können. Ich vermute das automatische Backup als störquelle da ich einen USB-Stick gesteckt habe (Total 30868364k Used 3731936k (12.1%) Free 27136428k (87.9%)). Da verwunderliche ist aber das ich seit Monaten nichts mehr an der Konfiguration oder Programme geändert habe, wieso passiert das denn? Die Fehlermeldung sagt aus das die CPU Temperatur über 80° war, muss dann jetzt wohl ein Lüfter im Gehäuse einbauen

Ich wäre Dankbar wenn jemanden mir einen konstruktiven Hinweis geben könnte, wie ich das Problem lösen kann.

edsch
Beiträge: 7
Registriert: 06.08.2018, 13:09

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von edsch » 22.02.2021, 16:14

Hallo Zusammen,

Auch bei mir erscheint massenhaft der „WatchDog-Alarm“ „under-voltage detected“ (ca. 7 in 45 Min) seit dem Update vom 3.51.6.20200621 auf dieses Neue.
Da ich nicht so firm bin mit der Programmierung.
Empfehlung von Jens vom 17.2.21:
Die Datei https://github.com/jens-maus/RaspberryM ... tc/monitrc nach /etc/monitrc kopieren.

Wo öffne ich in der WebUI „/etc/monitrc um die Datei hinein zu kopieren“?

Hat dies bisher den gewünschten Erfolg gebracht, oder ist ein stärkeres Netzgerät die bessere Wahl?
Über eine Empfehlung würde ich mich freuen.
Gruß
Edwin

Raspberry PI 3 B+ Charly, cull 433 Mhz, 16 HMIP Geräte, 11 Somfy Rolläden

Donut
Beiträge: 16
Registriert: 21.09.2017, 19:57

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von Donut » 22.02.2021, 18:24

Moin Moin zusammen,

auch von mir ein großer Dank an die Mitwirkenden bei diesem Projekt, Superarbeit.

Leider habe ich jetzt zum ersten Mal nach einem Update ein Problem feststellen müssen. Ich habe das Update am 14.2. durchgeführt und heute festgestellt, dass seit dem Datum keine nächtlichen Backups mehr durchgeführt werden, das letzte war am 14.2. um 00:07, genau wie es sein sollte.

Raspberrymatic läuft bei mir bisher sehr zuverlässig auf einem Pi3 B+, die Sicherung lief bisher auf einem NAS, gemounted mit CUxD.

Was habe ich bisher getestet?
1. ist das NAS gemounted? Ja, unter /mnt/ finde ich die Sicherungen bis zum 14.02.
2. Kann ich auf das NAS schreiben? ja, per Befehl touch testdatei wird ebendiese auf dem NAS erzeugt.
3. Was steht in der Datei CronBackupPath? /mnt/, wie es sein soll.
4. Kann ich ein Backup manuell erzeugen? Befehl /bin/createBackup.sh /mnt erzeugt mir wie gewünscht ein Backup auf dem NAS.

Probiert habe ich noch /bin/createBackup.sh ohne Angabe eines Pfades in der Hoffnung, das dann der aus der Datei CronBackupPath verwendet wird, leider auch erfolglos. Ich habe dann die Datei CronBackupPath geändert das dort ein lokales Verzeichnis angegeben ist, /share/, dies brachte aber auch keinen Erfolg.

Leider bin ich jetzt mit meinem Latein am Ende, vielleicht hat ja hier jemand eine Idee, ich würde dieses absolut sinnvolle Feature gerne weiter verwenden.

vielen dank im Voraus,
Niclas

Ban
Beiträge: 37
Registriert: 09.04.2019, 08:04
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 2 Mal

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von Ban » 22.02.2021, 18:35

Ich hatte eben wieder einen Alarm vom HM-Lan.
Habe jetzt den HM-Lan getauscht, welcher vorher keinen Alarm geworfen hat, habe alle Kabel, inkl. der Netzwerkose getauscht und immer noch den Alarm. Vorher hatte ich nie einen Alarm. Der Dauerping zu dem Zeitpunkt hat keinen Aussetzer, der HM-Lan hatte in dem Moment 126ms für die Antwort bentöigt. Der Ping zum Router hat durchgehen kleiner 1ms. Also ich würde sagen am Hm-Lan, den Kabeln und am Netzwerk liegt es nicht. Irgendetwas ist da zu sensibel geworden.
Charly mit RaspberryMatic, 2 HM-Lan, 2 HmIP-HAP, 1 RF-WLAN Gateway, ca. 190 Geräte

SteveDdorf
Beiträge: 6
Registriert: 16.05.2019, 19:10
Hat sich bedankt: 3 Mal
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von SteveDdorf » 22.02.2021, 19:12

matzefro hat geschrieben:
20.02.2021, 17:19
SteveDdorf hat geschrieben:
15.02.2021, 18:31
plotzkella hat geschrieben:
14.02.2021, 12:35
Das selbe Verhalten bei mir, obwohl ich ein 4A Netzteil dran hatte. Komme übrigens von 3.53.30.20201024. Bin jetzt auf ein alternatives Netzteil mit 3,8A gewechselt und jetzt ist erst mal Ruhe...

Ansonsten scheint alles so zu laufen, wie es soll.
danke für Deine Rückmeldung. Ich habe mittlerweile auch ein leistungsfähigeres Netzteil bestellt und hoffe damit ist das Problem gelöst. Sonst scheint es auch bei mir keine weiteren Probleme mit der aktuellen Version zu geben.
warum das erst mit diesem Update aufgetreten ist bleib wohl ein Rätsel :?: . Das Netzteil wird sich nicht im selben Augenblick entschlossen haben weniger Strom zu Verfügung zu stellen :roll: .
Nun habe ich mir das "offizielles Netzteil für Raspberry Pi 4 Model B, USB-C, 5.1V, 3A" bestellt und angeschlossen.
Fehler ist damit verschwunden.
Moin zusammen,

ich wollte Euch nochmal mein Feedback geben. Ich habe seit ein paar Tagen ein original Raspberry Netzteil für den Pi 2 Model B im Einsatz. Das System funktioniert nun OHNE Probleme. Das Netzteil ist leitungsfähiger und weicht in der Spannung von einem Standard USB Netzteil leicht ab:

Neues Netzteil Output: 5,1V 2,5A (Typ: Original Raspberry Netzteil DSA-13PFC-05)
Altes Netzteil Output: 5,0V 1,5A (Typ: HN Electronic HNP06-MicroUSBL6)

Ich denke die Spannungsüberwachung des Raspberry Pi 2 Model B spricht etwas sensibel an, deshalb ist für den störungsfreien Betrieb ein Netzteil mit leicht erhöhter Ausgangsspannung und genug Leistungsreserven zu empfehlen.

Vielen Dank an alle, die von der Lösung ähnlicher Probleme berichtet haben, das hat mir sehr geholfen.

VG, Stephan

Monsterberti
Beiträge: 38
Registriert: 16.07.2018, 13:08

Re: RaspberryMatic 3.55.10.20210213 – Neue Version

Beitrag von Monsterberti » 22.02.2021, 19:30

Hallo, seit dem Update auf die neueste Version auf meinem RPI3 bekomme ich jeden Tag von diesem CO-PROCESSOR das jetzt neu da ist eine DUTY Cycle Warnung: DutyCycle 99% (58A9A70F12)

Was kann ich tun ?

Lg

Antworten

Zurück zu „RaspberryMatic“