RaspberryMatic 3.57.4.20210320 - Neue Version

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

sissiwup
Beiträge: 271
Registriert: 10.03.2015, 10:54
Wohnort: Süd NDS
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von sissiwup » 30.03.2021, 14:19

Hallo,

hat sich was an lighthttp-Server geändert?

Bisher ging mein Aufruf:

Code: Alles auswählen

http://ip:8181/cuxd.exe?x=dom.GetObject(\"CUxD.CUX2801003:1.SET_STATE\").State(0)
Ohne Probleme. Jetzt kommt ein Bad Request 400
MfG

Sissiwup

--------------------------------------------
CCu3,CCu2Gateway,RaspiGateway,LanGateway
--------------------------------------------

jp112sdl
Beiträge: 8468
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 474 Mal
Danksagung erhalten: 1114 Mal
Kontaktdaten:

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von jp112sdl » 30.03.2021, 14:21

murelli146 hat geschrieben:
30.03.2021, 11:27
Hatte eben selbes Problem und habe das Script angepasst falls es jemand hilft.
Ich hatte auch das Problem und nutze nun das von RM mitgelieferte createBackup.sh, um dessen Funktionsfähigkeit sich Jens selbst kümmert.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

Baxxy
Beiträge: 3035
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 224 Mal
Danksagung erhalten: 502 Mal

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von Baxxy » 30.03.2021, 17:36

sissiwup hat geschrieben:
30.03.2021, 14:19
hat sich was an lighthttp-Server geändert?
Zumindest wurde eine neuere Version implementiert.
sissiwup hat geschrieben:
30.03.2021, 14:19
Jetzt kommt ein Bad Request 400
Hmm... bei mir geht das wie folgt:

Code: Alles auswählen

http://ip:8181/ret.exe?ret=dom.GetObject("HmIP-RF.0001D3C99CA0D2:3.STATE").State(1)

Jockel123
Beiträge: 5
Registriert: 31.03.2021, 17:13
System: CCU

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von Jockel123 » 31.03.2021, 17:22

Ich habe meine Charly CCU von der Version 3.55.10.20210213 auf die aktulle Version 3.57.4.20210320 upgedated. Nach der Installation ist leider fast keine Gerätekommunikation mehr möglich. Es wird nur noch "Gerätekommunikation gestört" angezeigt und die Devices sind nicht mehr erreichbar. Nach Rücksprung auf die letzte 3.55 Version ist alles wieder i.O. Hat jemand eine Idee, woran das bei dem neuen Release liegen kann ?

Vielen Dank vorab!

Baxxy
Beiträge: 3035
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 224 Mal
Danksagung erhalten: 502 Mal

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von Baxxy » 31.03.2021, 18:04

Jockel123 hat geschrieben:
31.03.2021, 17:22
fast keine Gerätekommunikation mehr
Was heißt das?
Jockel123 hat geschrieben:
31.03.2021, 17:22
und die Devices sind nicht mehr erreichbar.
Welche? HM / HmIP / Selbstbau?
Jockel123 hat geschrieben:
31.03.2021, 17:22
Hat jemand eine Idee,
Möglicherweise...
Erweiterungen / Änderungen
[HMCCU-773] RPI-RF-MOD / CCU3 Coprozessor Firmware auf Version 4.2.14 aktualisiert. Die Firmware
Behebt einen Fehler, der unter bestimmten Voraussetzungen zu einer dauerhaften
Kommunikationsstörung führen konnte und korrigiert eine geringfügige RFFrequenzabweichung.

Jockel123
Beiträge: 5
Registriert: 31.03.2021, 17:13
System: CCU

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von Jockel123 » 31.03.2021, 19:57

Vielen herzlichen Dank für die schnelle Antwort.

Was heißt das?
Nach der Installation der 3.57. zeigt die Statusmeldung fast alle Geräte mit der Servicemeldung "Gerätekommunikation gestört" Auch sind die Geräte nicht mehr von der CCU aus steuerbar.

Welche? HM / HmIP / Selbstbau?
Überwiegend HmIP (ca25) und einige HM (8)

Möglicherweise...
Der besagte Fix würde gut zu meiner Installation passen. Allerdings behebt er den Fehler nicht, sondern produziert ihn. Ich bin jetzt wieder zurück auf die 3.55. Aber das ist ja keine Lösung für die Zukunft. Ist auch komisch, dass der Fehler nicht häufiger gemeldet wird. Gibt es noch Ideen, was ich noch machen kann ??

gbrosch
Beiträge: 1
Registriert: 31.03.2021, 21:24
System: sonstige
Hat sich bedankt: 1 Mal

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von gbrosch » 31.03.2021, 21:33

Ich habe genau dasselbe Problem. Hatte ein Upgrade von Raspberrymatic 3.55.10 auf 3.57.4 gemacht. Selbst wenn man im Verzeichnis steht und ./ccu_backup als root macht, kommt der Fehler auf Zeile 25. Wahrscheinlich wurde in Zeile 15 (regexp-Befehl) die Variable nicht richtig gefüllt.

Willy_Elv
Beiträge: 23
Registriert: 08.12.2016, 21:39
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von Willy_Elv » 01.04.2021, 14:53

Hallo zusammen,

bloß der Vollständigkeit halber - ich bin auch wieder auf die Vorgängerversion 3.55.10.20210213 zurückgegangen.

Grund:
Mein Eigenbau - Barometer (AskSinpp Library, HW-Aufbau: HB-UNI-Sensor1, CCU-SW-Addon hb-tm-devices 2.5 vom Juli 2020) war nicht mehr vernünftig ansprechbar.
Normalerweise sollen Luftdruck, Temperatur und Luftfeuchtigkeit alle 10min an die Zentrale Charly (Raspi 3) gemeldet werden.
Mit der neuesten SW habe ichs nur geschafft, daß sich das Barometer 2* innerhalb 24h (!!!), und zwar immer genau einmal nach Einlegen der Batterien gemeldet hat.
Und das Schreiben neuer Geräte-Daten (u.A. "Meldeintervall") zu dem Device ging gar nicht -> Servicemeldung forever.

Das klingt so ähnlich wie die Probleme anderer Nutzer mit anderen Devices, ich wollte es nur als Zusatz-Info zur Fehlersuche hier veröffentlichen.
Mit der Vorgängerversion geht wieder alles einwandfrei.

Grüße, Willy_Elv

p.s.: Drüberhinaus ist mir aufgefallen, daß sich auch an der Schnittstelle zum ioBroker was geändert haben muß - ich mußte die hm_rega, hm_rpc0, hmrpc1 Daten nochmal neu einlesen, ansonsten waren die ioBroker - Objekte zum Teil nicht initialisiert / leer !
Ich kann aber nicht sagen, ob diese Änderung mit der 20210320 oder schon mit der 20210213 reingekommen ist.
Zentrale "Charly" mit Raspberry Pi 3
RaspberryMatic 3.57.4.20210320 - oder neuer
jede Menge Sensoren und Aktoren (Rolladensteuerung, Wetter- / Helligkeitssensoren, Heizungssteuerung, etc..)

MichaelN
Beiträge: 2064
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 167 Mal
Danksagung erhalten: 265 Mal

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von MichaelN » 01.04.2021, 14:58

Willy_Elv hat geschrieben:
01.04.2021, 14:53
Das klingt so ähnlich wie die Probleme anderer Nutzer mit anderen Devices, ich wollte es nur als Zusatz-Info zur Fehlersuche hier veröffentlichen.
Die Fehlersuche muss auf deiner Seite stattfinden. Du musst einen Frequenzabgeich für dein Eigenbaugerät durchführen (Nach dem FW update!)

Bernhard-bsh
Beiträge: 9
Registriert: 15.11.2015, 14:14
System: Alternative CCU (auf Basis OCCU)

Re: RaspberryMatic 3.57.4.20210320 - Neue Version

Beitrag von Bernhard-bsh » 01.04.2021, 15:34

Bernd-Joras hat geschrieben:
26.03.2021, 17:18
Bernhard-bsh hat geschrieben:
26.03.2021, 12:07
Hat noch jemand das Verhalten beobachtet?
scheinbar eher nicht ....

Syslogserver angeschlossen bzw. in Betrieb oder kannst Du einen Monitor anschließen?
(Monitor sollte jedoch vor dem Starten des Raspi angeschlossen sein, sonst bleibt der dunkel))
So ohne weitere Fehlermeldungen und/oder Hinweise Deinerseits wird´s schwierig … BG Bernd

Nachtrag ... Nach dem Ausfall... bzw. nächsten Start gibt es da eine Watchdog Meldung ?
Hi, heute war es wieder so weit. Vodafone hatte Probleme - meine Fritzbox stieg aus und der Provider hat nach eigenen Angaben die Box neu gestartet. Danach ist dann die HomeMatik nicht erreichbar gewesen, bis ich den Netzwerkstecker gezogen und wieder gesteckt habe. Hier auch das syslog vom Syslogserver:

Code: Alles auswählen

2021-04-01,15:24:23,Warning,192.168.0.10,user,rfd,"XmlRpc transport failed (first try), retrying..."
2021-04-01,15:24:21,Information,192.168.0.10,auth,sshd,Accepted password for root from 192.168.0.93 port 53948 ssh2
2021-04-01,15:24:06,Information,192.168.0.10,user,monit,'internetCheck' status succeeded (0) -- no output
2021-04-01,15:24:03,Information,192.168.0.10,user,rfd,RF-3014F711A0001F5A4993D941 support newDevices
2021-04-01,15:24:03,Information,192.168.0.10,user,rfd,RF-3014F711A0001F5A4993D941 support deleteDevices
2021-04-01,15:24:03,Information,192.168.0.10,user,rfd,RF-3014F711A0001F5A4993D941 support event
2021-04-01,15:24:03,Information,192.168.0.10,user,rfd,RF-3014F711A0001F5A4993D941 support system.multicall
2021-04-01,15:24:01,Information,192.168.0.10,user,monit,'klogd' zombie check succeeded
2021-04-01,15:23:48,Error,192.168.0.10,user,monit,'internetCheck' status failed (1) -- no output
2021-04-01,15:23:48,Information,192.168.0.10,daemon,ifplugd(eth0),Program executed successfully.
2021-04-01,15:23:48,Warning,192.168.0.10,daemon,ifplugd(eth0),"client: eth0: link up, static, firewall, inet up, 192.168.0.10, "
2021-04-01,15:23:45,Information,192.168.0.10,user,firewall,configuration set
2021-04-01,15:23:43,Error,192.168.0.10,user,monit,'klogd' process with pid 11462 is a zombie
2021-04-01,15:23:42,Notice,192.168.0.10,user,kernel,klogd started: BusyBox v1.33.0 (2021-03-20 10:35:15 UTC)
2021-04-01,15:23:42,Information,192.168.0.10,daemon,ifplugd(eth0),Executing '/etc/ifplugd/ifplugd.action eth0 up'.
2021-04-01,15:23:41,Information,192.168.0.10,user,kernel,[547200.618290] smsc95xx 1-1.1:1.0 eth0: Link is Up - 100Mbps/Full - flow control off
2021-04-01,15:23:41,Information,192.168.0.10,daemon,ifplugd(eth0),Link beat detected.
*** Ethernet Kabel gezogen und wieder gesteckt ***
2021-04-01,12:03:10,Information,192.168.0.10,user,firewall,configuration set
2021-04-01,12:03:07,Notice,192.168.0.10,user,kernel,klogd started: BusyBox v1.33.0 (2021-03-20 10:35:15 UTC)
2021-04-01,12:03:07,Information,192.168.0.10,daemon,ifplugd(eth0),Executing '/etc/ifplugd/ifplugd.action eth0 up'.
2021-04-01,11:59:10,Information,192.168.0.10,user,firewall,configuration set
2021-04-01,11:59:09,Error,192.168.0.10,user,monit,'internetCheck' status failed (1) -- no output
2021-04-01,11:59:08,Notice,192.168.0.10,user,kernel,klogd started: BusyBox v1.33.0 (2021-03-20 10:35:15 UTC)
2021-04-01,11:59:08,Information,192.168.0.10,daemon,ifplugd(eth0),Executing '/etc/ifplugd/ifplugd.action eth0 up'.
2021-04-01,11:59:07,Information,192.168.0.10,user,kernel,[534925.788814] smsc95xx 1-1.1:1.0 eth0: Link is Up - 100Mbps/Full - flow control off
2021-04-01,11:59:07,Information,192.168.0.10,daemon,ifplugd(eth0),Link beat detected.
2021-04-01,11:25:02,Information,192.168.0.10,user,firewall,configuration set
2021-04-01,10:38:18,Information,192.168.0.10,user,kernel,[530076.951420] smsc95xx 1-1.1:1.0 eth0: Link is Up - 100Mbps/Full - flow control off
2021-04-01,10:38:18,Information,192.168.0.10,daemon,ifplugd(eth0),Link beat detected.
Beobachtet noch jemand dieses Verhalten? Was könnte ich tun, damit die Netzwerkschnittstelle selbständig wieder nutzbar wird.

Gruß

BR
zwei CCU ( 1xRaspberrymatic / 1xCCU1 )

Antworten

Zurück zu „RaspberryMatic“