R-Matic im Docker: kein Zugriff per ssh

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

myx
Beiträge: 9
Registriert: 26.04.2021, 12:45
System: Alternative CCU (auf Basis OCCU)

Re: R-Matic im Docker: kein Zugriff per ssh - Konsolenzugriff geht per SPICE

Beitrag von myx » 02.05.2021, 17:02

Ich habe parallel zum Experimentieren mit debMatic zwischendurch noch weiter herumprobiert und kann jetzt zumindestens per Konsole auf die RaspberryMatic zugreifen.

Notwendige Einstellungsänderung der VM im PROXMOX Web-Interface:

Hardware -> Graphic Card: SPICE

setzen.

Dann kommt mit "Alt F2" ein Terminalfenster in der Konsole.
Zuletzt geändert von myx am 02.05.2021, 19:31, insgesamt 1-mal geändert.

myx
Beiträge: 9
Registriert: 26.04.2021, 12:45
System: Alternative CCU (auf Basis OCCU)

Re: R-Matic im Docker: kein Zugriff per ssh

Beitrag von myx » 02.05.2021, 18:49

Sicherheitshalber habe ich die RaspberryMatic-VM's komplett gelöscht und eine neue VM aus dem letzten Release eingerichtet.

Ich würde vermuten, dass der root cause für das Problem mit dem ssh-Zugriff an der Größe von /dev/sda3 liegt:
Lt. "df" ist /dev/sda3 auf /usr/local gemountet und voll (Größe: 1947 1k blocks, belegt: 1886)

myx
Beiträge: 9
Registriert: 26.04.2021, 12:45
System: Alternative CCU (auf Basis OCCU)

Re: R-Matic im Docker: kein Zugriff per ssh

Beitrag von myx » 03.05.2021, 09:40

Habe in
... /source/RaspberryMatic-master/buildroot-external/board/ova/post-image.sh
die userfs-Größe von 3000 in 3000000 geändert :
mkfs.ext4 -d "${BUILD_DIR}/userfs" -F -L userfs "${BINARIES_DIR}/userfs.ext4" 3000000
und das Image neu gebaut.

Jetzt läuft die virtuelle Maschine inkl. RaspberryMatic, ssh aber weiterhin nicht:
homematic-raspi user.err monit[787]: 'sshdEnabled' status failed (1) -- no output

Benutzeravatar
jmaus
Beiträge: 7213
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 181 Mal
Danksagung erhalten: 729 Mal
Kontaktdaten:

Re: R-Matic im Docker: kein Zugriff per ssh

Beitrag von jmaus » 03.05.2021, 10:24

myx hat geschrieben:
03.05.2021, 09:40
Habe in
... /source/RaspberryMatic-master/buildroot-external/board/ova/post-image.sh
die userfs-Größe von 3000 in 3000000 geändert :
mkfs.ext4 -d "${BUILD_DIR}/userfs" -F -L userfs "${BINARIES_DIR}/userfs.ext4" 3000000
und das Image neu gebaut.

Jetzt läuft die virtuelle Maschine inkl. RaspberryMatic, ssh aber weiterhin nicht:
homematic-raspi user.err monit[787]: 'sshdEnabled' status failed (1) -- no output
Das ist ja auch nicht ziel der übung jetzt hier sich selbst nen image zu bauen! Bist du sicher das du die Anleitung zur Installation der OVA in Proxmox richtig durchgearbeitet hast? Du darfst den Schritt 6 natürlich nicht vergessen (Startvolume/disk) vergrößern. Siehe: https://github.com/jens-maus/RaspberryM ... Proxmox-VE . Achja, und das musst du natürlich machen BEVOR du die virtuelle Maschine das 1. mal startest. Wenn du sie bereits gestartet hast kannst du die Startdisk nicht einfach so vergrößern!
RaspberryMatic 3.57.5.20210424 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Auweia
Beiträge: 58
Registriert: 04.08.2012, 16:57
Wohnort: Regensburg
Danksagung erhalten: 1 Mal

Re: R-Matic im Docker: kein Zugriff per ssh

Beitrag von Auweia » 04.05.2021, 19:00

Soll ich einen Issue im Github für das Problem aufmachen?
mit der glibc 2.35 sollte das Problem behoben sein. Dafür ist aber ein Update des Kernel bzw. der Sandbox notwendig.
Im snapshot von 02.05.2021 wird immer noch die 2.34 verwendet
RaspberryMatic , Rpi4B, SSD, RPI-RF-MOD, 1x LAN-, 1x LAN RF Gateway, 90 HM-Geräte, HPCL (Prod)
RPI4B, 8GB, SSD, Docker: RaspberryMatic RPI-RF-MOD (Test)
RPI4B, 4GB, SSD, Influxdb, Grafana, OWFS, 1-W, KNX, OH2, CometVisu (Prod)

Benutzeravatar
jmaus
Beiträge: 7213
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 181 Mal
Danksagung erhalten: 729 Mal
Kontaktdaten:

Re: R-Matic im Docker: kein Zugriff per ssh

Beitrag von jmaus » 04.05.2021, 20:12

Auweia hat geschrieben:
04.05.2021, 19:00
Soll ich einen Issue im Github für das Problem aufmachen?
mit der glibc 2.35 sollte das Problem behoben sein. Dafür ist aber ein Update des Kernel bzw. der Sandbox notwendig.
Im snapshot von 02.05.2021 wird immer noch die 2.34 verwendet
Du kannst gerne ein Issue aufmachen, ja. Aber dann bitte mit mehr technischen Details und Background Infos und links so den angeblichen fixes die das Problem beheben sollen in der glibc 2.35.

Aber wie schon vorher gesagt sehe ich für die Hauptplatformen (RaspberryPi, OVA, etc.) keinen Impact hier und lediglich Docker ist betroffen und auch dort nur die Host-Platform die du gewählt hast. Und bis jetzt bist du auch der einzige der das bisher irgendwo hervorgebracht hat. Und ein glibc update überlasse ich eigentlich buildroot selbst. Sobald die auf 2.35 springen sollte das ja dann mit behoben sein.
RaspberryMatic 3.57.5.20210424 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Auweia
Beiträge: 58
Registriert: 04.08.2012, 16:57
Wohnort: Regensburg
Danksagung erhalten: 1 Mal

Re: R-Matic im Docker: kein Zugriff per ssh

Beitrag von Auweia » 06.05.2021, 14:57

da hast du recht: wenn das Update automatisch kommt, kann ich das abwarten.
Vielen Dank
RaspberryMatic , Rpi4B, SSD, RPI-RF-MOD, 1x LAN-, 1x LAN RF Gateway, 90 HM-Geräte, HPCL (Prod)
RPI4B, 8GB, SSD, Docker: RaspberryMatic RPI-RF-MOD (Test)
RPI4B, 4GB, SSD, Influxdb, Grafana, OWFS, 1-W, KNX, OH2, CometVisu (Prod)

myx
Beiträge: 9
Registriert: 26.04.2021, 12:45
System: Alternative CCU (auf Basis OCCU)

Re: R-Matic im Docker: kein Zugriff per ssh

Beitrag von myx » 09.05.2021, 09:22

Wochenende ... habe wieder Zeit, um weiterzumachen :-)

Asche auf mein Haupt - beim ersten Mal habe ich Schritt 6 ausgeführt, bei den folgenden Malen nicht.
Jetzt läuft alles, nur auf die Konsole komme ich mit der "default"-Einstellung nicht, sondern nur mit "spice" wie oben schon ausgeführt.

Wg. Image selber bauen - ich finde es immer instruktiv einmal in die Tiefen eines Systems hineinzuschauen. Und mindestens war es ein "Buildungs-Erlebnis" ;-)

jmaus hat geschrieben:
03.05.2021, 10:24
myx hat geschrieben:
03.05.2021, 09:40
Habe in
... /source/RaspberryMatic-master/buildroot-external/board/ova/post-image.sh
die userfs-Größe von 3000 in 3000000 geändert :
mkfs.ext4 -d "${BUILD_DIR}/userfs" -F -L userfs "${BINARIES_DIR}/userfs.ext4" 3000000
und das Image neu gebaut.

Jetzt läuft die virtuelle Maschine inkl. RaspberryMatic, ssh aber weiterhin nicht:
homematic-raspi user.err monit[787]: 'sshdEnabled' status failed (1) -- no output
Das ist ja auch nicht ziel der übung jetzt hier sich selbst nen image zu bauen! Bist du sicher das du die Anleitung zur Installation der OVA in Proxmox richtig durchgearbeitet hast? Du darfst den Schritt 6 natürlich nicht vergessen (Startvolume/disk) vergrößern. Siehe: https://github.com/jens-maus/RaspberryM ... Proxmox-VE . Achja, und das musst du natürlich machen BEVOR du die virtuelle Maschine das 1. mal startest. Wenn du sie bereits gestartet hast kannst du die Startdisk nicht einfach so vergrößern!

Antworten

Zurück zu „RaspberryMatic“