"CCU_im_reboot_var" funktioniert nach Update auf 3.57.4.20210320 nicht mehr, Programme werden nach Neustart ausgeführt

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Jayo73
Beiträge: 59
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 3 Mal

Re: "CCU_im_reboot_var" funktioniert nach Update auf 3.57.4.20210320 nicht mehr, Programme werden nach Neustart ausgefüh

Beitrag von Jayo73 » 02.04.2021, 15:26

Das steht jetzt nach dem Neustart da.
Bildschirmfoto 2021-04-02 um 15.25.47.png
Habe ich das vielleicht ein wenig falsch verstanden und ich muss das Script von Alchy in alle Programme packen wo ich denke das sie nach einem Neustart ausgelöst werden?

MichaelN
Beiträge: 2064
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 167 Mal
Danksagung erhalten: 265 Mal

Re: "CCU_im_reboot_var" funktioniert nach Update auf 3.57.4.20210320 nicht mehr, Programme werden nach Neustart ausgefüh

Beitrag von MichaelN » 02.04.2021, 15:37

Ich habe jetzt nicht im Kopf, was Alchy zur Anwendung geschrieben hat, aaber jja , du musst es in JEDEM Zweig unterbringen, den du analysieren möchtest.

Jayo73
Beiträge: 59
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 3 Mal

Re: "CCU_im_reboot_var" funktioniert nach Update auf 3.57.4.20210320 nicht mehr, Programme werden nach Neustart ausgefüh

Beitrag von Jayo73 » 02.04.2021, 15:39

Okay, dann werde ich das Script jetzt mal in meine ganzen Push Programm packen die seit der RaspberryMatic aus März nach einem Neustart ausgelöst werden.


Jayo73
Beiträge: 59
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 3 Mal

Re: "CCU_im_reboot_var" funktioniert nach Update auf 3.57.4.20210320 nicht mehr, Programme werden nach Neustart ausgefüh

Beitrag von Jayo73 » 02.04.2021, 16:31

Unglaublich, jetzt passiert hier nichts mehr, keine Programme werden ausgeführt. Nur das hier wurde geloggt und eine Push davon kam auch nicht
Bildschirmfoto 2021-04-02 um 16.29.14.png


Ich habe das Gefühl, dass die Programme jetzt nicht mehr ausgelöst werden, weil ich diese bearbeitet und erneut "gespeichert" habe. Ich werde das jetzt testen. Backup einspielen ohne ein Programm anzufassen, dann mal sehen ob Programme nach einem Neustart ausgeführt werden, wenn ja, dann öffne ich mal ein Programm und "speichere" es erneut mit "OK" ab, und dann mal sehen was passiert.

Jayo73
Beiträge: 59
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 3 Mal

Re: "CCU_im_reboot_var" funktioniert nach Update auf 3.57.4.20210320 nicht mehr, Programme werden nach Neustart ausgefüh

Beitrag von Jayo73 » 02.04.2021, 18:28

So, mir ist jetzt etwas ganz komisches aufgefallen.

Sobald es von diesem Screen
Bildschirmfoto 2021-04-02 um 18.24.00.png

Zu diesem Screen geht
Bildschirmfoto 2021-04-02 um 18.24.46.png
Sofort in die WebUI einloggen, erst dann werden die Programme nach Umstellen der Systemvariable "CCU_im_reboot_var" von "ja" auf "nein" ausgeführt. Logge ich mich nicht in die WebUI ein, dann werden die Programme nicht ausgeführt, auch nicht nachdem die Systemvariable "CCU_im_reboot_var" von "ja" auf "nein" gesprungen ist.

Ich habe das jetzt mehrmals wiederholt. Wenn ich mich nicht einlogge, ist alles ok. Logge ich mich ein, dann werden die Programme ausgeführt.

Wenn ich mich nicht einlogge und warte bis die Systemvariable "CCU_im_reboot_var" von "ja" auf "nein" gesprungen ist, und mich erst danach einlogge, ist auch alles ok.

Antworten

Zurück zu „RaspberryMatic“