RaspberryMAtic macht plötzlich keine auto Backups mehr

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Jayo73
Beiträge: 122
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von Jayo73 » 05.05.2021, 17:22

Habe ich schon alles getestet und nicht geholfen. Der selbe Stick an einer anderen CCU mit RM funktioniert dort einwandfrei. Habe jmaus schon angeschrieben, aber ignoriert das wohl.

Benutzeravatar
jmaus
Beiträge: 7735
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 257 Mal
Danksagung erhalten: 917 Mal
Kontaktdaten:

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von jmaus » 05.05.2021, 17:26

Jayo73 hat geschrieben:
05.05.2021, 17:22
Habe jmaus schon angeschrieben, aber ignoriert das wohl.
Ich ignoriere gar nichts. Nur zähle ich eben auf das "Schwarmwissen" hier und kann mich auch leider nicht um jede Kleinigkeit selbst kümmern. Ich bin mir aber sicher die anderen Forummitglieder finden zusammen mit dir den Grund für deine Probleme und wenn die Lösung hier öffentlich und nicht in PNs diskutiert wird haben auch mehr Menschen unterm' Strich was davon als wenn ich das mit dir alleine kläre.
RaspberryMatic 3.59.6.20211009 @ ESXi – ~195 Hm-RF/HmIP-RF/HmIPW Geräte + ioBroker – GitHub / Twitter / Facebook / Sponsors

Benutzeravatar
shartelt
Beiträge: 4536
Registriert: 14.01.2015, 14:59
Hat sich bedankt: 141 Mal
Danksagung erhalten: 284 Mal

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von shartelt » 05.05.2021, 17:27

Jayo73 hat geschrieben:
05.05.2021, 17:22
Habe jmaus schon angeschrieben, aber ignoriert das wohl.
naja...Du brauchst einen github issue...

steht ja nicht umsonst in der Anleitung:
Sollte aus den Diskussionen dort sich dann ein spezieller Feature-Wunsch oder von anderen Personen bestätigter Bug in RaspberryMatic herauskristallieren wird darum gebeten diesen Bug bzw. diesen Feature-Request im Issue Tracker von RaspberryMatic entsprechend einzutragen bzw. zu melden.

Jayo73
Beiträge: 122
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von Jayo73 » 05.05.2021, 17:30

Das sollte auch nicht per PN geklärt werden, sondern ich wollte Dich mit dieser PN auf dieses Problem aufmerksam machen.

Kann es denn sein, dass sich die Schreibrechte geändert haben? Wenn ich per FTP nachsehe welche Rechte der Stick und die Ordner darin haben, das ist das 755. Der Ordner Media hat 777.

Benutzeravatar
jmaus
Beiträge: 7735
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 257 Mal
Danksagung erhalten: 917 Mal
Kontaktdaten:

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von jmaus » 05.05.2021, 17:59

shartelt hat geschrieben:
05.05.2021, 17:27
Jayo73 hat geschrieben:
05.05.2021, 17:22
Habe jmaus schon angeschrieben, aber ignoriert das wohl.
naja...Du brauchst einen github issue...
Neee, in dem Falle sehe ich nicht das hier ein GitHub Issue gerechtfertig sein sollte. Es ist hier nicht davon auszugehen das das ein generelle Problem ist das > 1 Nutzer betrifft und da auf einen Bug schließen lässt. Vielmehr deutet momentan noch alles daraufhin das das ein Problem ist das lediglich bei Jayo73 auftritt. Und ein GitHub Issue sollte erst aufgemacht werden wenn es > 1 Person betrifft und wenn es erkennbare Hinweise auf einen Bug in RaspberryMatic selbst gibt. Das sehe ich hier aber momentan noch nicht in der Diskussion.
RaspberryMatic 3.59.6.20211009 @ ESXi – ~195 Hm-RF/HmIP-RF/HmIPW Geräte + ioBroker – GitHub / Twitter / Facebook / Sponsors

Benutzeravatar
jmaus
Beiträge: 7735
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 257 Mal
Danksagung erhalten: 917 Mal
Kontaktdaten:

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von jmaus » 05.05.2021, 18:05

Jayo73 hat geschrieben:
05.05.2021, 17:30
Das sollte auch nicht per PN geklärt werden, sondern ich wollte Dich mit dieser PN auf dieses Problem aufmerksam machen.

Kann es denn sein, dass sich die Schreibrechte geändert haben? Wenn ich per FTP nachsehe welche Rechte der Stick und die Ordner darin haben, das ist das 755. Der Ordner Media hat 777.
Da im Grunde fast alles innerhalb von RaspberryMatic mit root-Rechten läuft, sehe ich nicht was diese Permission-Änderungen verhindern sollte. Es bleibt dabei: Führe "/bin/cronBackup.sh" manuell in der SSH Konsole aus und beobachten und zeige hier die Fehler. Dann kann man sich daraus vielleicht einen Reim machen was bei dir los ist. Und natürlich formatiere den USB Stick komplett frisch und zieh ihn nicht einfach ohne Auswerfen irgendwo ab weil sonst das dateisystem defekt geht und das wiederum dazu führt das der Stick von Linux als Read-Only gemountet wird.
RaspberryMatic 3.59.6.20211009 @ ESXi – ~195 Hm-RF/HmIP-RF/HmIPW Geräte + ioBroker – GitHub / Twitter / Facebook / Sponsors

Jayo73
Beiträge: 122
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von Jayo73 » 05.05.2021, 18:40

Hallo,

wie gesagt, "/bin/cronBackup.sh" führt zu:
root@raspberrymatic:~# /bin/cronBackup.sh
mktemp: (null): Read-only file system
root@raspberrymatic:~#
Kann ich den Stick auf der RaspberryMatic in der Konsole in ein gutes/passendes Format formatieren?

Wie ist denn der Befehl um den Stick auszuwerfen und/oder geht das auch in der WebUi?

Ein Backup löschen z.B. geht auch nicht:
root@raspberrymatic:/media/usb1/ccu_backups# rm raspberrymatic-3.47.10.20190713-2019-08-03-0007.sbk
rm: remove 'raspberrymatic-3.47.10.20190713-2019-08-03-0007.sbk'? yes
rm: can't remove 'raspberrymatic-3.47.10.20190713-2019-08-03-0007.sbk': Read-only file system
root@raspberrymatic:/media/usb1/ccu_backups#

Benutzeravatar
jmaus
Beiträge: 7735
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 257 Mal
Danksagung erhalten: 917 Mal
Kontaktdaten:

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von jmaus » 05.05.2021, 21:20

Jayo73 hat geschrieben:
05.05.2021, 18:40
wie gesagt, "/bin/cronBackup.sh" führt zu:

Code: Alles auswählen

root@raspberrymatic:~# /bin/cronBackup.sh
mktemp: (null): Read-only file system
root@raspberrymatic:~# 
Dann ist das ein klares Zeichen dafür das das Dateisystem auf dem USB Stick soweit defekt ist das Linux der Meinung ist es ist sicherer das nur read-only anzubinden. Deshalb dann auch keine möglichkeit hier irgendwelche neuen Daten draufzuschreiben oder zu modifizieren.
Jayo73 hat geschrieben:
05.05.2021, 18:40
Kann ich den Stick auf der RaspberryMatic in der Konsole in ein gutes/passendes Format formatieren?
Klar kann man das, aber das würde hier zu weit führen bzw. zu lange dauern das hier darzulegen und wäre auch nicht ein einzelner Befehl. Der empfohlene Weg ist:

1. CCU/RaspberryMatic runterfahren
2. USB-Stick abziehen
3. USB-Stick am PC mit FAT32/NTFS frisch formatieren (oder unter Linux mit ext4 oder f2fs).
4. USB-Stick an CCU/RaspberryMatic stecken
5. Strom an CCU/RaspberryMatic stecken und hochfahren.

Danach sollte der Stick dann (wie du das sicher ursprünglich gemacht hast) korrekt erkannt werden und wieder funktionieren.
Jayo73 hat geschrieben:
05.05.2021, 18:40
Wie ist denn der Befehl um den Stick auszuwerfen und/oder geht das auch in der WebUi?
Auch das ist nicht ein einfacher Befehl den man da hat. Auch hier gilt es die CCU herunterzufahren und dann erst den USB Stick abzuziehen. Das ist die sicherste Variante.
Jayo73 hat geschrieben:
05.05.2021, 18:40
Ein Backup löschen z.B. geht auch nicht:

Code: Alles auswählen

root@raspberrymatic:/media/usb1/ccu_backups# rm raspberrymatic-3.47.10.20190713-2019-08-03-0007.sbk
rm: remove 'raspberrymatic-3.47.10.20190713-2019-08-03-0007.sbk'? yes
rm: can't remove 'raspberrymatic-3.47.10.20190713-2019-08-03-0007.sbk': Read-only file system
root@raspberrymatic:/media/usb1/ccu_backups #
Das wundert nicht. Das Dateisystem auf dem USB Stick ist wie gesagt als defekt markiert. Formatiere den Stick neu wie oben beschrieben und er sollte wieder gehen und zieh ihn niemals im Laufenden Zustand der CCU/RaspberryMatic ab.
RaspberryMatic 3.59.6.20211009 @ ESXi – ~195 Hm-RF/HmIP-RF/HmIPW Geräte + ioBroker – GitHub / Twitter / Facebook / Sponsors

Jayo73
Beiträge: 122
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von Jayo73 » 09.05.2021, 00:31

Hallo,

auf dem Stick ist noch ein Ordener namens "measurement" vorhandne mit solchen Dateien:
Bildschirmfoto 2021-05-09 um 00.30.25.png
Muss ich die den Ordner inkl. Inhalt sichern und nach formatieren des Sticks wieder auf diesen laden?

Jayo73
Beiträge: 122
Registriert: 20.03.2021, 17:03
System: CCU
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

Re: RaspberryMAtic macht plötzlich keine auto Backups mehr

Beitrag von Jayo73 » 11.05.2021, 04:50

?

Antworten

Zurück zu „RaspberryMatic“