RaspberryMatic 3.63.9.20220625 – Neue Version

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

wseifert
Beiträge: 14
Registriert: 08.07.2019, 17:54

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von wseifert » 14.07.2022, 10:09

jmaus hat geschrieben:
12.07.2022, 20:05
wseifert hat geschrieben:
12.07.2022, 19:02
Zeigt 86.2 °C an, dürfte also wirklich zu hoch sein. Ich werde am Woe mal auf die vorherige version zurückgehen und da nachschauen.
Und was genau soll das bringen? Ich versteh ehrlich gesagt inmer nicht diese Herangehensweise mit "zurückgehen auf vorherige Version"?!? Du hast doch in der Tat wohl ein Problem das dein Pi4 zu heiss wird. Ergo wäre das mittel der wahl dich via SSH einzuloggen und zu schauen ob es irgendein Prozess gibt der zuviel CPU Last macht um dann herauszubekommen warum das so ist. Oder zumindest auf der Hilfeseite die Load/Auslastungswerte anzuschauen um ein Gefühl dafür zu bekommen warum die Temperatur so hoch ist. Jetzt einfach nur auf die Vorversion zurückzugehen kann vielleicht das Problem beseitigen - vmtl liegt das dann aber mehr an dem durchgeführten Neustart als an irgendwelchen Dingen die mot der neuen Version eingeführt wurden.
Ich möchte nicht als "Klugscheisser" auftreten, aber bis zur vorherigen Version hatte ich das Problem nicht, erst seit dem Update. Ich habe aber sowieso einen grossen passiven Kühlkörper für den Raspi 4 bestellt, der steht im Wohnzimmer und da ist der WAF* halt nur gegeben wenn es kein Lüftergeräusch gibt ...

* Women Akzeptance Factor

lg
Werner

Sven_A
Beiträge: 3851
Registriert: 26.01.2016, 08:14
System: Alternative CCU (auf Basis OCCU)
Wohnort: Renningen
Hat sich bedankt: 259 Mal
Danksagung erhalten: 219 Mal

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von Sven_A » 14.07.2022, 10:44

wseifert hat geschrieben:
14.07.2022, 10:09
...bis zur vorherigen Version hatte ich das Problem nicht, erst seit dem Update...
Das mag ja sein.
Und es mag im schlimmsten Fall auch wirklich einzig und allein an der neuen Version liegen.

Nur: Trotzdem sollte man schauen WAS und WARUM die neue Version bei dir anders macht als die vorherige. Also schauen WOHER die Wärme kommt, welcher Prozess jetzt über gebühr CPU-Zeit verbrät. Und das geht eben nur mit der neuen, im schlimmsten Fall fehlerhaften Version.

Nur so könnte Jens überhaupt einen Fehler beheben, wenn es den denn tatsächlich gäbe.

Ein einfacher Neustart mag da schonmal ein Anfang sein, um zu schauen ob sich vielleicht nicht nur irgendwas verschluckt hat.
Gehst du auf die alte Version zurück sind die Chancen gut das du mit der übernächsten Version wieder das selbe Problem hast. Oder eben auch nicht, reboot sei dank.

Also einmal sauber einen Reboot, und schauen ob es das schon war.
Wenn nicht mal per SSH auf die Konsole und per "top" gucken wer denn da die CPU zum schwitzen bringt.

Gruß,
Sven

MichaelN
Beiträge: 5809
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 441 Mal
Danksagung erhalten: 852 Mal

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von MichaelN » 14.07.2022, 11:50

wseifert hat geschrieben:
14.07.2022, 10:09
aber bis zur vorherigen Version hatte ich das Problem nicht, erst seit dem Update.
Ja, aber was erhofft Du Dir vom downgrade? Auch Dein größerer Kühlkörper ist doch nur Symptombekämpfung. Hoffst Du, das auf magische Weise der Bug in der übernächsten Version weg ist? Ohne das Du irgendjemand eine Fehleranalyse durchgeführt hat?
LG, Michael.

Wenn du eine App zur Bedienung brauchst, dann hast du kein Smarthome.

Wettervorhersage über AccuWeather oder OpenWeatherMap+++ Rollladensteuerung 2.0 +++ JSON-API-Ausgaben auswerten +++ undokumentierte Skript-Befehle und Debugging-Tipps +++

wseifert
Beiträge: 14
Registriert: 08.07.2019, 17:54

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von wseifert » 14.07.2022, 17:36

MichaelN hat geschrieben:
14.07.2022, 11:50
wseifert hat geschrieben:
14.07.2022, 10:09
aber bis zur vorherigen Version hatte ich das Problem nicht, erst seit dem Update.
Ja, aber was erhofft Du Dir vom downgrade? Auch Dein größerer Kühlkörper ist doch nur Symptombekämpfung. Hoffst Du, das auf magische Weise der Bug in der übernächsten Version weg ist? Ohne das Du irgendjemand eine Fehleranalyse durchgeführt hat?
So, nun etwas mehr an Infos:

das ist die Ausgabe von top:
Homematic_rpi4_top.JPG
Was mir auffällt ist

Code: Alles auswählen

java -Dos.arch=aarch64 -Dgnu.io.rxtx.SerialPorts=/dev/mmd_hmip -Xmx384m -Dlog4j.configuration=file:///var/etc/log4j.xml -Dfile
hat 200 %VSZ, etwas viel für meinen Geschmack.
Der Inhalt von file:///var/etc/log4j.xml:

Code: Alles auswählen

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE log4j:configuration SYSTEM "log4j.dtd">
<log4j:configuration xmlns:log4j="http://jakarta.apache.org/log4j/" debug="false">
  <appender name="FILE" class="org.apache.log4j.RollingFileAppender">
    <param name="File" value="/var/log/hmserver.log"/>
    <param name="MaxFileSize" value="4096KB"/>
    <layout class="org.apache.log4j.PatternLayout">
      <param name="ConversionPattern" value="%d{MMM d HH:mm:ss} %c %-5p [%t] %m %n"/>
    </layout>
  </appender>

  <appender name="SYSLOG" class="org.apache.log4j.net.SyslogAppender">
    <param name="SyslogHost" value="127.0.0.1"/>
    <param name="Facility" value="USER"/>
    <param name="FacilityPrinting" value="false"/>
    <layout class="org.apache.log4j.PatternLayout">
      <param name="ConversionPattern" value="HMIPServer: %c %-5p [%t] %m %n"/>
    </layout>
  </appender>

  <category name="de.eq3">
    <priority value="ERROR"/>
  </category>
  <category name="org">
    <priority value="ERROR"/>
  </category>
  <category name="com">
    <priority value="ERROR"/>
  </category>

  <root>
    <priority value="ERROR"/>
    <appender-ref ref="FILE"/>
  </root>
</log4j:configuration>
Meiner Meinung nach dürfte da das Problem liegen ...

lg
Werner

Benutzeravatar
jmaus
Beiträge: 8639
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 335 Mal
Danksagung erhalten: 1273 Mal
Kontaktdaten:

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von jmaus » 14.07.2022, 17:46

wseifert hat geschrieben:
14.07.2022, 17:36
Was mir auffällt ist

Code: Alles auswählen

java -Dos.arch=aarch64 -Dgnu.io.rxtx.SerialPorts=/dev/mmd_hmip -Xmx384m -Dlog4j.configuration=file:///var/etc/log4j.xml -Dfile
hat 200 %VSZ, etwas viel für meinen Geschmack.
Der Inhalt von file:///var/etc/log4j.xml:
[...]
Meiner Meinung nach dürfte da das Problem liegen ...
die 200% VSZ sind normal und unkritisch. Und ich wüsste auch nicht warum etwas in der log4j.xml nicht korrekt sein soll? Dann zeig mal den Part wo du denkst der Fehler liegt.

In der Tat zeigt top jedoch das es da wohl wenig CPU auslastung gibt. Wenn du also trotz dieser geringen Auslastungswerte eine CPU/Systemtemperatur von >80 Grad hast, dann hast du definitiv ein thermisches Problem mit deinem Pi4. Dem solltest du nachgehen.
RaspberryMatic 3.65.6.20220723 @ Proxmox – ~195 Hm-RF/HmIP-RF/HmIPW Geräte + ioBroker – GitHub / Twitter / Facebook / Sponsors

opu
Beiträge: 23
Registriert: 28.03.2021, 09:36
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 3 Mal

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von opu » 14.07.2022, 22:06

Hallo liebe Gemeinde,
ihr hattet recht.
Ich habe das Raspberrymatic addon auf port 80 laufen. Wenn man es direkt aufruft kann man die Geräte ansprechen und updaten.
DANKE !!!!
Gruß opu

MichaelN
Beiträge: 5809
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 441 Mal
Danksagung erhalten: 852 Mal

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von MichaelN » 14.07.2022, 22:15

Ich habe mein Produktivsystem nun auch upgedatet.
Dabei ist bei einem Teil der DV das Umlaut Problem wieder aufgetreten. Es handelt sich dabei um DVs die ich vor Jahren noch unter original CCU Firmware angelegt hatte.
LG, Michael.

Wenn du eine App zur Bedienung brauchst, dann hast du kein Smarthome.

Wettervorhersage über AccuWeather oder OpenWeatherMap+++ Rollladensteuerung 2.0 +++ JSON-API-Ausgaben auswerten +++ undokumentierte Skript-Befehle und Debugging-Tipps +++

BoyStefan
Beiträge: 16
Registriert: 30.06.2022, 08:54
System: Alternative CCU (auf Basis OCCU)
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von BoyStefan » 16.07.2022, 21:06

Hallo, wollte wissen ob es schon eine Lösung für das Backup Problem gibt unter OSX.

Benutzeravatar
onkeltommy
Beiträge: 1309
Registriert: 07.05.2016, 08:03
Wohnort: Wien
Hat sich bedankt: 25 Mal
Danksagung erhalten: 22 Mal

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von onkeltommy » 17.07.2022, 10:13

BoyStefan hat geschrieben:
16.07.2022, 21:06
Hallo, wollte wissen ob es schon eine Lösung für das Backup Problem gibt unter OSX.
Hi

wollte ich auch grad fragen, bei mir waren es via Edge 9 Versuche bis es runtergeladen werden konnte. Im FF hats heute überhaupt nicht (mehr) geklappt.
Ein paar kB kommen an, dann bleibt stehen.
lG
Thomas
--------------------------
RaspberryMatic 3.63.9.20220430 @ TinkerS (Produktivsystem) & RB3+ (Netzwerküberw.) & VMWare (Historian) & 2x RB3+ @ Nachwuchs

Benutzeravatar
klana
Beiträge: 903
Registriert: 08.02.2015, 08:37
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 34 Mal
Danksagung erhalten: 14 Mal

Re: RaspberryMatic 3.63.9.20220625 – Neue Version

Beitrag von klana » 17.07.2022, 11:49

onkeltommy hat geschrieben:
17.07.2022, 10:13
BoyStefan hat geschrieben:
16.07.2022, 21:06
Hallo, wollte wissen ob es schon eine Lösung für das Backup Problem gibt unter OSX.
Hi

wollte ich auch grad fragen, bei mir waren es via Edge 9 Versuche bis es runtergeladen werden konnte. Im FF hats heute überhaupt nicht (mehr) geklappt.
Ein paar kB kommen an, dann bleibt stehen.
Da hänge ich mich mit dran...
Es ist nett, wichtig zu sein. Aber es ist wichtiger, nett zu sein.

Gesperrt

Zurück zu „RaspberryMatic“