RaspberryMatic 3.65.6.20220723 – Neue Version

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Josh
Beiträge: 144
Registriert: 28.04.2018, 20:55
Hat sich bedankt: 5 Mal
Danksagung erhalten: 4 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von Josh » 25.07.2022, 18:36

OVA-Update verlief problemlos.

Update auf einem HAP auch, ohne Probleme, wenn es auch recht lange gedauert hat (gefühlt 5 min.)

Nur der zweite HAP ist zickig => Update gestartet -> nach 5 min. geht die Meldung "Das Update des Gerätes wird durchgeführt" wieder in den üblichen Update-Button über. Aber dieser HAP ist dann weiterhin auf der V2.4.12. Habe ihn schon mal kurz stromlos gemacht und somit neu gestartet. Leider hat's nicht geholfen.

Jemand eine Idee? Oder lieber neuen Thread aufmachen, weil evtl. nichts mit der neuen RM-FW zu tun hat?
RaspberryMatic 3.65.6.20220723 in VM auf einem Intel NUC10i5 mit ProxmoxVE V7.1 - RPI-RF-MOD auf RB-RF-ETH - XML-API 1.21 / 44 HMIP-Geräte (HmIP-BWTH, HmIP-WTH-2, HmIP-BSM, HmIP-FAL230-C6, HmIP-BSL, HmIP-SWSD, HmIP-FSM, HmIP-BROLL, HmIP-SMI55, HmIP-PSM, 2x HmIP-HAP) / ioBroker-Master/ 2x ioBroker-Slave / Synology DS720+ Mosquitto-Server im Dockercontainer

HMSchrottix
Beiträge: 31
Registriert: 27.12.2018, 21:09
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von HMSchrottix » 25.07.2022, 22:31

jp112sdl hat geschrieben:
25.07.2022, 13:36

Um die ReGa in RaspberryMatic neu zu starten ist

Code: Alles auswählen

monit restart ReGaHss
zu verwenden.
Tja, das scheint ja auf meiner Kiste nicht zu funktionieren!
Laut monit läuft die CCU jetzt fast 4 Std. nach dem Clean-Install und Einspielen des Backup.
Beim Abmelden vor ca. 4 Std. keine Anzeichen von Problemen.
Jetzt keine Anmeldung mehr möglich...
...Bitte warten. Sie werden automatisch auf die Startseite weitergeleitet.....
kein Anmeldescreen, nur schönes blaues Logo...
SSH-Login:

Code: Alles auswählen

Mem: 454092K used, 524032K free, 2308K shrd, 14940K buff, 136268K cached
CPU:   6% usr  22% sys   0% nic  71% idle   0% io   0% irq   0% sirq
Load average: 1.00 1.00 1.00 4/219 23477
  PID  PPID USER     STAT   VSZ %VSZ %CPU COMMAND
22978     1 root     R    33500   3%  24% /bin/ReGaHss -f /etc/rega.conf -l 2
23477 23345 root     R     3708   0%   4% top -n 1
  930     1 root     S    3477m 363%   0% java -Dos.arch=aarch64 -Dgnu.io.rxtx.SerialPorts=/dev/mmd_hmip -Xmx128m -Dlog4
  395     1 root     S    78636   8%   0% /usr/sbin/irqbalance
  831   830 root     S    21344   2%   0% /bin/hs485d -l 5 -g -i 0 -f /var/etc/hs485d.conf
  889     1 root     S    19888   2%   0% /bin/rfd -f /var/etc/rfd.conf -l 5
  287     1 root     S    17796   2%   0% /sbin/udevd -d
23471   287 root     S    17796   2%   0% /sbin/udevd -d
 1261     1 root     S    16788   2%   0% /usr/bin/monit -Ic /etc/monitrc
  853     1 root     S<   12196   1%   0% /bin/multimacd -f /var/etc/multimacd.conf -l 5
  711   710 root     S     8464   1%   0% /usr/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf -D
23334   733 root     S     7284   1%   0% sshd: root@pts/0
  733     1 root     S     6892   1%   0% sshd: /usr/sbin/sshd [listener] 0 of 10-100 startups
  405     1 root     S     5724   1%   0% /usr/sbin/rngd -q -x jitter
  260     1 root     S     4660   0%   0% /bin/hss_led -l 6
  830     1 root     S     4404   0%   0% /bin/hs485dLoader -l 5 -dw /var/etc/hs485d.conf
  703     1 root     S     4336   0%   0% /bin/eq3configd
  720     1 root     S     4152   0%   0% /bin/ssdpd
    1     0 root     S     3708   0%   0% init
  457     1 root     S     3708   0%   0% /sbin/syslogd -n -m 0 -s 4096 -b 1 -D
 1158     1 root     S     3708   0%   0% /usr/sbin/crond -f -l 9
23345 23334 root     S     3708   0%   0% -sh
23455  1261 root     S     3708   0%   0% {S70ReGaHss} /bin/sh /etc/init.d/S70ReGaHss restart
ReGaHSS wird offensichtlich automatisch immer wieder gestartet.
Also konnte ich mal Dein Kommando ausprobieren:

Code: Alles auswählen

root@CCU-RASPI:~# monit restart ReGaHss
root@CCU-RASPI:~# 
Es passiert gar nichts!!! Keine Ausgabe! Keine Fehlermeldung! Nix!
Normalerweise kenne ich das so:

Code: Alles auswählen

root@CCU-RASPI:~# /bin/sh   /etc/init.d/S70ReGaHss stop
Stopping ReGaHss: .....................ERROR
Also mal die summary aufgerufen:

Code: Alles auswählen

root@CCU-RASPI:~# monit summary
Monit 5.30.0 uptime: 3h 54m
Service Name                    │ Status                     │ Type          │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ CCU-RASPI                       │ OK                         │ System        │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ hw-watchdog                     │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
││ chronyd                         │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ eq3configd                      │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ lighttpd                        │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ ssdpd                           │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ sshd                            │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ hs485d                          │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ multimacd                       │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ rfd                             │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ HMIPServer                      │ OK                         │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ ReGaHss                         │ Connection failed | Exe... │ Process       │
├─────────────────────────────────┼────────────────────────────┼───────────────┤
│ crond                           │ OK                         │ Process       │

Da steht: ReGaHss => Connection failed
Also wird monit nicht viel ausrichten können!

Fazit: Nach 4 Stunden hat sich die ReGaHSS wieder schön an den Baum gefahren.
Da ich schon vorsichtshalber fast alle Programm deaktiviert habe, kann ich jetzt nur noch die HmIP-Geräte rausschmeißen, solange die CCU nach dem Clean-Install und Einspielen eines Backup der letzten Tage noch läuft.

MichaelN
Beiträge: 5837
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 442 Mal
Danksagung erhalten: 853 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von MichaelN » 25.07.2022, 22:38

HMSchrottix hat geschrieben:
25.07.2022, 22:31
kann ich jetzt nur noch die HmIP-Geräte rausschmeißen
Was soll das bringen? Deine Symptome deuten eher auf Amok laufende skripte oder Middleware hin.
LG, Michael.

Wenn du eine App zur Bedienung brauchst, dann hast du kein Smarthome.

Wettervorhersage über AccuWeather oder OpenWeatherMap+++ Rollladensteuerung 2.0 +++ JSON-API-Ausgaben auswerten +++ undokumentierte Skript-Befehle und Debugging-Tipps +++

HMSchrottix
Beiträge: 31
Registriert: 27.12.2018, 21:09
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von HMSchrottix » 25.07.2022, 23:56

MichaelN hat geschrieben:
25.07.2022, 22:38

Was soll das bringen? Deine Symptome deuten eher auf Amok laufende skripte oder Middleware hin.
Also Programme mit Skripten habe ich natürlich als erstes alle deaktiviert. Middleware?
Alle Addons wie CUxD, Highchart, Redmatic sind raus. Nur noch Programme drucken und Mailversand sind noch drin.
Sonst läuft da nichts auf dem Raspi.
Ein frisches RaspberryMatic 3.65.6.20220723 plus Backup sicherheitshalber ein paar Tage zurück.
Nach dem 1. Hochfahren schnell fast alle Programme deaktiviert und angefangen, die HmIP-Geräte zu löschen. Bin aber nicht weit gekommen, dann war schon Schicht im GUI.
Nur noch SSH und Filezilla geht.

Im lighttpd-error.log finde ich jede Menge solcher Einträge:

Code: Alles auswählen

Connection refused
2022-07-25 22:50:12: (../src/gw_backend.c.993) all handlers for /login.htm? on  are down.
2022-07-25 22:50:15: (../src/gw_backend.c.360) gw-server re-enabled: tcp:127.0.0.1:8183 127.0.0.1 8183 
2022-07-25 22:50:18: (../src/gw_backend.c.283) establishing connection failed: socket: tcp:127.0.0.1:8183:
Da hängt sich wohl der Webserver auf, denke ich.

SSH: top

Code: Alles auswählen

em: 604856K used, 373268K free, 3712K shrd, 22916K buff, 265908K cached
CPU:   8% usr  17% sys   0% nic  73% idle   0% io   0% irq   0% sirq
Load average: 1.02 0.86 0.58 3/221 6832
  PID  PPID USER     STAT   VSZ %VSZ %CPU COMMAND
 6298     1 root     R    32732   3%  25% /bin/ReGaHss -f /etc/rega.conf -l 2
  962     1 root     S    3473m 363%   0% java -Dos.arch=aarch64 -Dgnu.io.rxtx.SerialPorts=/dev/mmd_hmi
 6127  6114 root     R     3708   0%   0% top
Nach meiner Ansicht hat die ReGaHSS hat keinen zugeteilten Speicher mehr. Es wäre noch einiges RAM frei, aber da scheint es ein Limit zu geben. Jemand frisst mir den Speicher weg.
Und ich hab' keine Idee mehr...
Ich sehe nur HmIP-Fehler beim Starten, keine HM- oder HMW-Fehler. Das alte Zeug lief immer wie geschmiert. Wenn jemand spinnt, dann war es bei mir immer HmIP.

Frage: Kann man die Geräte auch per SSH aus der CCU löschen?

Preisselbeere
Beiträge: 15
Registriert: 27.02.2017, 07:05

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von Preisselbeere » 26.07.2022, 15:21

Nach dem Update auf die neue Version, sind alle CUXD Geräte unbrauchbar.
Ist nicht das erste mal nach nem update.

Bastian79
Beiträge: 35
Registriert: 16.03.2017, 10:36
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 7 Mal
Danksagung erhalten: 1 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von Bastian79 » 26.07.2022, 15:53

Ich bin leider echt etwas ratlos, all meine Geräte sind nach dem Update nicht mehr erreichbar.
Ich habe auch bereits mit Backups am hantiert, bekomme die RaspberryMatic aber nicht mehr funktionstüchtig wie vorher.

Folgende Art von Fehler finde ich massenhaft im Log:

Code: Alles auswählen

Jul 26 11:16:49 de838cd8-raspberrymatic local0.warn ReGaHss: WARNING: XMLRPC 'getValue': rpcClient.isFault() failed (url: xmlrpc://127.0.0.1:32010, params: {"002BDD89B07897:12","STATE"}, result: [faultCode:-5,faultString:"Unknown Parameter value for value key: STATE"]) [CallXmlrpcMethod():iseXmlRpc.cpp:2608]
Jul 26 11:16:49 de838cd8-raspberrymatic local0.err ReGaHss: ERROR: XMLRPC 'getValue' call failed (interface: 1237, params: {"002BDD89B07897:12","STATE"}) [CallGetValue():iseXmlRpc.cpp:1435]
Jul 26 11:16:49 de838cd8-raspberrymatic local0.err ReGaHss: ERROR: CallGetValue failed; sVal = 0 [ReadValue():iseDOMdpHSS.cpp:124]
Hat jmd. eine Idee?
Alle Geräte neu anlernen würde ich gerne vermeiden.

Viele Grüße, Bastian

MichaelN
Beiträge: 5837
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 442 Mal
Danksagung erhalten: 853 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von MichaelN » 26.07.2022, 16:01

Diese Meldungen sind kurz nach dem Start normal. Bevor es in Aktionismus ausartet einfach nochmal in Rihe neu starten und dann mal abwarten. Morgen früh schaust Du nochmal drauf. Wahrscheinlich ist die Welt dann in Ordnung.
LG, Michael.

Wenn du eine App zur Bedienung brauchst, dann hast du kein Smarthome.

Wettervorhersage über AccuWeather oder OpenWeatherMap+++ Rollladensteuerung 2.0 +++ JSON-API-Ausgaben auswerten +++ undokumentierte Skript-Befehle und Debugging-Tipps +++

MichaelN
Beiträge: 5837
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 442 Mal
Danksagung erhalten: 853 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von MichaelN » 26.07.2022, 16:02

Preisselbeere hat geschrieben:
26.07.2022, 15:21
Nach dem Update auf die neue Version, sind alle CUXD Geräte unbrauchbar.
Ist nicht das erste mal nach nem update.
Definiere unbrauchbar. Und hast Du Cuxd auch vorher auf die aktuelle Version gebracht?
LG, Michael.

Wenn du eine App zur Bedienung brauchst, dann hast du kein Smarthome.

Wettervorhersage über AccuWeather oder OpenWeatherMap+++ Rollladensteuerung 2.0 +++ JSON-API-Ausgaben auswerten +++ undokumentierte Skript-Befehle und Debugging-Tipps +++

McPan
Beiträge: 134
Registriert: 29.11.2021, 07:04
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 22 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von McPan » 26.07.2022, 19:20

MichaelN hat geschrieben:
26.07.2022, 16:02
Preisselbeere hat geschrieben:
26.07.2022, 15:21
Nach dem Update auf die neue Version, sind alle CUXD Geräte unbrauchbar.
Ist nicht das erste mal nach nem update.
Definiere unbrauchbar. Und hast Du Cuxd auch vorher auf die aktuelle Version gebracht?
Kann ich so gerade auch nicht bestätigen. Hatte auch erst nach dem Update auf die aktuelle RaspberryMatic-Version gesehen, dass es für den CUxD das Update auf 2.9.3 gibt und hab's erst hinterher installiert. Funktioniert trotzdem alles. Ist bisher bei mir auch noch nie vorgekommen, dass die CUxD-Geräte nach einem Raspberrymatic-Update nicht mehr funktioniert haben.

Da muss es wohl noch ein paar ungeklärte Zusammenhänge mehr zwischen Update und CUxD-Dysfunktionalität geben. Wenn's schon häufiger vorgekommen ist, stellt sich die Frage: was hast du bisher getan, damit die Geräte im Anschluss an das Raspberrymatic-Update wieder funktionieren?
Elektrische Bauteile funktionieren mit Rauch. Der Beweis: tritt der Rauch aus, funktioniert das Bauteil nicht mehr!

Hackertomm
Beiträge: 630
Registriert: 18.04.2018, 12:32
System: Alternative CCU (auf Basis OCCU)
Wohnort: Neuhausen auf den Fildern
Hat sich bedankt: 15 Mal
Danksagung erhalten: 16 Mal

Re: RaspberryMatic 3.65.6.20220723 – Neue Version

Beitrag von Hackertomm » 27.07.2022, 09:51

So, nachdem mein PC umgerüstet ist und nun offiziell Windows 11 läuft, wurde nun die RM ebenfalls upgedatet.
Klappte klaglos!
Gruß
Hackertomm

Virtual Image auf einer Qnap TS-451D2, 2GHZ Celeron u. 8GB RAM, aktuell Raspberry OVA, Vers. 3.65.6.20220723

Antworten

Zurück zu „RaspberryMatic“