Der Schlüssel konnte nicht gesetzt werden.

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
funzel1607
Beiträge: 131
Registriert: 13.10.2015, 14:34
Hat sich bedankt: 2 Mal

Der Schlüssel konnte nicht gesetzt werden.

Beitrag von funzel1607 » 06.08.2022, 13:48

Hi zusammen,

nach drei Jahren hat plötzlich mein RapsberryMatic LanGateway seinen Dienst quittiert. Hatte auch keinen Zugriff via ssh mehr (connection refused).
Somit gerade die neuste Version (3.65.6.20220723Rpi2) auf eine neue frische Karte geflasht und den Guide durchgegangen. Alles klappt soweit und ich habe auch wieder Zugriff via ssh. Nur ich erhalte beim setzen des Sicherheitsschlüssels immer eine Fehlermeldung, welche mit folgendes anzeigt:

Der Schlüssel konnte nicht gesetzt werden. Informationen dazu finden Sie in den Servicemeldungen.
Bildschirmfoto 2022-08-06 um 13.33.32.png
Fehlermelung-Schlüssel
Bildschirmfoto 2022-08-06 um 13.33.32.png (14.29 KiB) 146 mal betrachtet
Leider waren in den Servicemeldungen keinerlei Einträge und auch im Systemprotokoll tauchte nichts auf.

Ich habe erst mal ohne weitergemacht und die HMLGW angelegt, wonach auch es auch nur als Gateway startete und mir eine gültige SN ausgegeben hat.

===========

Ich kürze hier ab, da ich parallel weiter an dem Teil gearbeitet habe und der Fehler dabei behoben wurde. Ich schreibe jedoch den Post zu Ende, um anderen und auch mir zukünftig vielleicht in der Zukunft damit helfen zu können.

Ich habe davon gelesen, dass es ein Update (ich meine des RF-Moduls) gegeben hat, welches erst nach einem weiteren Reboot als normale Zentrale sauber drauf ist. Erst danach ist es möglich den Sicherheitsschlüssel zu setzen. Dies klappt jedoch NICHT, wenn man bereits die HMLGW Datei angelegt hat und nach dem Neustart direkt als Gateway arbeitet. Ich habe die Datei wieder gelöscht und versucht den Schlüssel zu setzen, was auch nicht ging.

Erst ein erneuter Reboot aus dem "Zentralen-Modus" in den "Zentralen-Modus" brachte den Erfolg, dass ich danach den Sicherheitsschlüssel setzen konnte!
Habe nun via ssh mit "touch /usr/local/HMLGW" die Datei erzeugt und gerebootet hoffe nun, dass alles läuft.

Vielleicht bekommt Jens da noch was hin, was den Fehler behebt und das Update nach einem Reboot trotzt HMLGW hinbekommt oder zumindest tatsächlich ein Hinweis in den Servicemeldungen auftaucht :)

Viel Erfolg!

Antworten

Zurück zu „RaspberryMatic“