Probleme mit Raspberrymatic und HmIP-RFUSB

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

jay-jey
Beiträge: 23
Registriert: 27.11.2019, 10:26

Probleme mit Raspberrymatic und HmIP-RFUSB

Beitrag von jay-jey » 07.11.2022, 15:24

Hallo,

ich würde gerne von meinem Debianmatic System auf einem Raspberry auf ein Raspberrymatic System auf Proxmox umsteigen. Leider habe ich ein Problem damit. Installation von Raspberrymatic funktionierte auch ohne Probleme. Dann habe ich die Debianmatic abgeschaltet und ein Backup von der Debianmatic in die Raspberrymatic eingespielt und gewartet. Aber irgendwie tut sich da gar nichts. Ich habe den kompletten Sonntag gewartet und heute morgen dann doch wieder die Debianmatic eingespielt.
Zusatzinfo: bei der Debianmatic hatte ich das Aufsteck Funk-Modul RPI-RF-MOD und bei der "virtuellen" Raspberrymatic den HmIP-RFUSB Stick.

Hier mal das Logfile.
Dateianhänge
homematic-ccu2-2022-11-06(1).txt
(73.78 KiB) 13-mal heruntergeladen
Zuletzt geändert von jay-jey am 11.11.2022, 16:05, insgesamt 1-mal geändert.

frd030
Beiträge: 2393
Registriert: 14.07.2019, 20:49
System: CCU
Hat sich bedankt: 496 Mal
Danksagung erhalten: 339 Mal

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von frd030 » 07.11.2022, 19:37

Und die Proxmox Installation hat Internetzugang? Sicher?
Hinweis: Wenn Du ein anderes Funkmodul einsetzt, ist zumindest für HmIP ein Rekeying fällig und das geht nur mit Internetzugang!

jay-jey
Beiträge: 23
Registriert: 27.11.2019, 10:26

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von jay-jey » 07.11.2022, 20:17

Ja bin mir realtiv sicher, aber es sind ja auch nicht nur die IP Geräte funktionieren. Die normalen Geräte funktionieren auch nicht.

jay-jey
Beiträge: 23
Registriert: 27.11.2019, 10:26

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von jay-jey » 09.11.2022, 08:26

Moin,

komme grade nicht weiter, gibt es eine Möglichkeit den USB Stick zu testen, ob der ordentlich läuft? Hab ihn heute auch noch mal in einen "normalen" Raspi gesteckt und da will er auch nicht.

jay-jey
Beiträge: 23
Registriert: 27.11.2019, 10:26

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von jay-jey » 09.11.2022, 16:31

Hallo,

so habe mal ein wenig rumprobiert. Also ich habe auch mal ein Debianmatic System auf einem Raspi 3 aufgesetzt. Da habe ich folgendes im Log gefunden, im prinzip das gleiche wie bei Raspberrymatic.

Code: Alles auswählen

Nov  9 14:16:33 raspberrypi kernel: [   59.440935] raw-uart raw-uart: Registered new raw-uart device using underlying device GPIO@3f201000.serial.
Nov  9 14:16:33 raspberrypi kernel: [   59.481594] usb 1-1.4: Found eQ-3 HmIP-RFUSB with serial 3014F711A000041F2995E40C at usb-3f980000.usb-1.4
Nov  9 14:16:33 raspberrypi kernel: [   59.481861] raw-uart raw-uart1: Reset radio module
Nov  9 14:16:33 raspberrypi kernel: [   59.481881] raw-uart raw-uart1: Registered new raw-uart device using underlying device eQ-3 HmIP-RFUSB@usb-3f980000.usb-1.4.
Nov  9 14:16:33 raspberrypi kernel: [   59.504527] usbcore: registered new interface driver hb_rf_usb_2
Nov  9 14:16:33 raspberrypi mtp-probe: bus: 1, device: 3 was not an MTP device
Nov  9 14:34:13 raspberrypi kernel: [ 1119.455705] raw-uart raw-uart: Reset radio module
Nov  9 14:34:31 raspberrypi kernel: [ 1137.670226] raw-uart raw-uart1: Reset radio module
Dann habe ich mal geschaut was ich über das hmip-copro-update tool herraus finde. Es sollte ja nach der Anleitung des Sticks die Firmware ausgeben, aber ich erhalte da gar nichts

Code: Alles auswählen

pi@raspberrypi:/opt/HmIP $ java -jar hmip-copro-update.jar -p /dev/raw-uart1 -v
[INFO] Homematic IP coprocessor update tool V1.0.10
[ERROR] Error while trying to open serial port: Exception while trying to open serial port. Check configured port '/dev/raw-uart1'
[INFO] Exiting update tool.
pi@raspberrypi:/opt/HmIP $ java -jar hmip-copro-update.jar -p /dev/raw-uart -v
[INFO] Homematic IP coprocessor update tool V1.0.10
[ERROR] Error while trying to open serial port: Exception while trying to open serial port. Check configured port '/dev/raw-uart'
[INFO] Exiting update tool.
In der Anleitung steht das Gerät solle sich als /dev/ttyUSB melden aber so ein Gerät habe ich bei mir. Weiß´jemand vielleicht was hier schief läuft?

TimoB
Beiträge: 126
Registriert: 30.11.2016, 17:44
System: Alternative CCU (auf Basis OCCU)
Wohnort: Grand Swabian Ländle
Hat sich bedankt: 123 Mal
Danksagung erhalten: 8 Mal

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von TimoB » 10.11.2022, 06:43

Hast Du im Proxmox GUI den USB-Stick der Raspberrymatic zugewiesen?

USB.jpg

jay-jey
Beiträge: 23
Registriert: 27.11.2019, 10:26

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von jay-jey » 10.11.2022, 06:57

Ja das habe ich gemacht und auch schon mit USB 3 und ohne USB3 probiert.

jay-jey
Beiträge: 23
Registriert: 27.11.2019, 10:26

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von jay-jey » 11.11.2022, 14:57

Hallo,

also ich hätte da mal die Frage wie sich der HmIP-RFUSB Stick denn beim System melden muss?

/dev/ttyUSB0

oder
/dev/raw-usb1?

kann es sein, dass bei meinem System der CP210X Treiber nicht geladen wird, bzw. der Stick nicht richtig eingebunden wird? Weil sich mein Stick immer als raw-USB1 meldet.

Benutzeravatar
jmaus
Beiträge: 8843
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 353 Mal
Danksagung erhalten: 1357 Mal
Kontaktdaten:

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von jmaus » 11.11.2022, 15:00

jay-jey hat geschrieben:
11.11.2022, 14:57
kann es sein, dass bei meinem System der CP210X Treiber nicht geladen wird, bzw. der Stick nicht richtig eingebunden wird? Weil sich mein Stick immer als raw-USB1 meldet.
der CP210X Treiber darf NICHT geladen werden, da der sich mit dem generic_raw_uart Treiber beisst. Folglich darf der stick innerhalb von RaspberryMatic nur als /dev/raw-uart Device angebunden werden.
RaspberryMatic 3.65.11.20221005 @ Proxmox – ~195 Hm-RF/HmIP-RF/HmIPW Geräte + ioBroker – GitHub / Twitter / Facebook / Sponsors

jay-jey
Beiträge: 23
Registriert: 27.11.2019, 10:26

Re: Probleme mit Raspberrymatic auf Proxmox

Beitrag von jay-jey » 11.11.2022, 15:58

super (bzw. Mist) dann stimmt das zumindest bei mir schon einmal, ist halt etwas verwirrend weil überall von /tty/usb0 geredet wird.
Mist weil das Problem dann immer noch besteht, dass ich keine Geräte angelernt bekomme bzw. wenn ich ein Backup einspiele auch die Geräte nicht wollen und elv leider auch keine Hilfe ist:

Aufgrund des großen Funktionsumfangs und der Komplexität kann ELV zu diesem Produkt leider keinerlei Support übernehmen. Für alle Fragen zum HmIP-RFUSB steht Ihnen das Homematic-Forum zur Verfügung.

Antworten

Zurück zu „RaspberryMatic“