Reboot Schleife

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
nullchar
Beiträge: 4
Registriert: 29.10.2022, 14:35
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal

Reboot Schleife

Beitrag von nullchar » 09.11.2022, 12:20

Hallo,

ich verwende die Raspberrymatic in Kombination mit einer Synology DS920+ via VMM v2.6.1-12139 (alles up-to-date) und als Funkmodul den HmIP-RFUSB (das Fertigmodul der Telekom).

Vorher nutzte ich eine CCU3 und habe die Konfiguration in der Raspberrymatic übernommen.

Soweit, sogut, funktioniert auch alles tadellos.

Tatsächlich gibt es nur ein Problem beim Neustart der VM (oder der ganzen Synology): Raspberrymatic versucht zu Beginn im GRUB permanent als erstes in den Recovery-Modus zu starten.

Dies passiert nicht bei der frischen Installation - Erst, sobald das Backup eingespielt wurde. Wenn nun das Recoverysystem gebootet wird, erscheint in der Konsole für den Bruchteil einer Sekunde einen Text, den ich leider nicht einfrieren kann (Für Tipps bin ich ansonsten sehr dankbar), und der GRUB Loader ist wieder zu sehen und wieder wird nach 4 Sekunden der Recovery-Modus gebootet. Dies läuft dann bis in alle Unendlichkeit, bis ich im Bootvorgang von Hand auf den normalen Modus Wechsel. Beim nächsten Neustart wird dann wieder versucht zuerst im Recoverymodus zu starten. Dies ist auch unabhängig davon, wie ich die VM herunterfahre oder neustarte (Sowohl über Synology als auch über die WebUI, egal ob "herunterfahren und manuell neu starten" oder einfach nur neustarten).

Meine Kenntnisse in Linux/Unix würde ich als "stets bemüht" bezeichnen - man kämpft sich durch aber das war es dann auch schon.

Nun die Fragestellung:
Gibt es eine Möglichkeit, dass ich die Bootpriorität ändere? Sodass das normale System hochgefahren wird?
Liegt dies vllt. am eingespielten Backup? Gibt es eine Möglichkeit im System aktiv die Bootreihenfolge zu ändern?
Fehlt ihm irgendwas?

Leider kann ich diagnostisch nicht viel mehr beitragen, da ich eventuelle Fehlermeldungen nicht sehen kann, da die Terminalanzeige sofort wieder zum GRUB Loader wechselt.

Um eventuelle Konfigurationsfehler auszuschließen, habe ich die VMM jetzt bereits in allen erdenklichen Konfigurationen neu angelegt (Ähnliche Probleme wurden mit vga vs vgavm berichtet, USB 2 vs USB 3, mit USB Stick, ohne Stick) - In jeder erdenklichen Konfiguration derselbe Fehler. Daher wäre jetzt meine Vermutung, dass ggf. im eingespielten Backup irgendwie hinterlegt ist, dass das System im Recoverymodus starten soll o.ä.?

Ist jetzt natürlich kein Weltuntergang aber im Falle eines Neustartes wäre es natürlich schön, wenn das System von alleine normal bootet.

Falls hierzu jmd. ähnliche Probleme/Lösungsvorschläge hat, wäre dies sehr hilfreich.

Vielen Dank!

nullchar
Beiträge: 4
Registriert: 29.10.2022, 14:35
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal

Re: Reboot Schleife

Beitrag von nullchar » 09.11.2022, 18:58

Hallo,

ich denke, ich habe das Problem gefunden.

in /usr/local lag die Datei ".recoveryMode"

Nach etwas googlen konnte ich mir erschließen, dass diese Datei für den Start in den recoveryMode (u.A.) verantwortlich ist (vgl. https://github.com/jens-maus/RaspberryM ... c/grub.cfg).

Datei gelöscht, nun wird als erstes das Operativsystem hochgefahren.

Woher die Datei stammt, ist mir nicht wirklich klar (vermutlich über die Backup-Datei?).

Kann daher geschlossen werden - Vllt. eine Hilfe für andere.

Antworten

Zurück zu „RaspberryMatic“