[GELÖST] Raspberrymatic Anlernkatastrophe

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

frd030
Beiträge: 2606
Registriert: 14.07.2019, 20:49
System: CCU
Hat sich bedankt: 555 Mal
Danksagung erhalten: 383 Mal

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von frd030 » 26.11.2022, 14:09

Ich würde trotzdem den usb Stick mal min. 2 Meter vom rpi4 oder anderen potentiellen Störquellen wegrücken. Dann nochmal anlernversuch

Benutzeravatar
Baxxy
Beiträge: 7863
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 454 Mal
Danksagung erhalten: 1500 Mal

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von Baxxy » 26.11.2022, 18:22

Im Logfile ist absolut nichts von einem IP-Gerät im Anlernmodus zu sehen.
Das macht die Problemfindung schwierig.

Mögliche Ursachen:
- es befindet sich kein IP Gerät korrekt im Anlernmodus
- der Pi4B stört so stark das das IP-Gerät im Anlernmodus "nicht gehört" wird
- der HmIP-RFUSB-TK hat ne Macke

Empfehlen würde ich einen echten HmIP-RFUSB zu besorgen/nutzen. Dazu dann gleich eine 1,5 - 2,0m USB-Verlängerung wenn du beim Pi4B bleiben willst.
Oder den Pi4B durch einen Pi3B/Pi3B+ ersetzen, dann darf der Stick auch direkt angestöpselt sein.

Ratte
Beiträge: 5
Registriert: 25.11.2022, 19:51
System: sonstige

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von Ratte » 26.11.2022, 18:30

Hallo,
ja irgendwas stimmt hier grundsätzlich nicht.
werde deinen Rat annehmen und einen "echten" Stick besorgen und einen Pi3 (den pi4 hatte ich eh nur zum Test dran, denke der ist auch etwas überdimensioniert).
Vielen Dank für euren Einsatz. Sobald ich was Neues weiß melde ich mich.
LG Frank

diepe
Beiträge: 22
Registriert: 06.12.2022, 14:18
System: in Planung
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Raspberrymatic Anlernkatastrophe

Beitrag von diepe » 06.01.2023, 20:16

Baxxy hat geschrieben:
12.11.2022, 14:57
Volker-der-Erster hat geschrieben:
12.11.2022, 13:38
ähnliche Erfahrungen
Es gibt in letzter Zeit "gefühlt" alle paar Tage Berichte dieser Art.
Volker-der-Erster hat geschrieben:
12.11.2022, 13:38
eine Lösung für mein Problem?
Nicht "out-of-the-box" da es mehrere Ursachen geben kann.
Wenn du ordentlich mitarbeitest kann man das Problem eingrenzen und hoffentlich finden und beheben.

Wir nehmen deinen Pi3B (mit dem HmIP-RFUSB an der Verlängerung) der bitte mindestens 1m Abstand zum Pi4B und anderen elektronischen Geräten hat. (Router, TV usw.)

Durchführung:
  • A: Batterien aus allen Geräten raus
  • B: die RaspberryMatic auf dem Pi3B über "Systemsteuerung > Sicherheit" werksresetten (System-Reset)
  • C: nach dem Reboot die Ersteinrichtung abschließen und den HmIP-RFUSB aus dem Posteingang holen
    C-1: ist er nicht vorhanden dann Screenshot der Hilfeseite der RM posten, kann auch gepostet werden wenn vorhanden)
    C-2: den Stick unter "Status und Bedienung > Geräte" auswählen und DC und CS Werte kontrollieren/posten
  • D: in der "Systemsteuerung > Zentralenwartung" das Fehlerprotokoll für Homematic-IP auf Tracing stellen, dann rebooten
  • E: eins deiner Geräte rauspicken (ich würde das STHD nehmen) und einen korrekten! Werksreset (siehe Bedienungsanleitung) durchführen
  • F: ist das Gerät danach im Anlernmodus (ca. alle 10s kurzes orangenes blinken) dann den IP-Anlernmodus (mit Internet) auf der Zentrale starten, dabei die LED des STHD beobachten und beschreiben was du siehst
  • G: wurde das STHD dann korrekt angelernt und aus dem Posteingang geholt kannst du versuchen es aus der WebUI heraus zu bedienen (Sollwert ändern usw.) Geht das problemlos, gibt's auch kein Problem. :wink:
    Andernfalls das Logfile über "Systemsteuerung > Zentralenwartung > Fehlerprotokoll > Logdatei herunterladen" und hier zur Verfügung stellen.
Rückmeldungen zu den einzelnen Schritten am besten mit Angabe des "Schritt-Buchstabens" z.B. zu A: ....
A erledigt
B erledigt
C2 erledigt
Screenshot 2023-01-06 at 19-58-31 RaspberryMatic WebUI.png
D erledigt
E HmIP-RC8 Werksreset

1. Legen Sie die Batterie entsprechend der Polaritätsmarkierungen wieder ein und halten Sie gleichzeitig die Systemtaste für 4 sec gedrückt, bis die LED schnell orange zu blinken beginnt
2. Lassen Sie die Systemtaste wieder los.
3. Drücken Sie die Systemtaste erneut für 4 sec (während die LED orange schnell blinkt), bis dieLED grün aufleuchtet.
4. Lassen Sie die Systemtaste wieder los, um das Wiederherstellen der Werkseinstellungen abzuschließen.

F ca. alle 10s kurzes orangenes blinken dann den IP-Anlernmodus (mit Internet) auf der Zentrale LED blinkt weiter ca. alle 10s kurzes orange
erledigt

G Kein Posteingang > Logfile heruntergeladen und gepostet


homematic-raspi-2023-01-06(4).log
(324.91 KiB) 8-mal heruntergeladen
Die letzten Stellen des KEY sind -GCE5T1
Die letzten Stellen des SGTIN sind -BB5F

Benutzeravatar
Baxxy
Beiträge: 7863
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 454 Mal
Danksagung erhalten: 1500 Mal

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von Baxxy » 07.01.2023, 00:32

diepe hat geschrieben:
06.01.2023, 20:16
Logfile heruntergeladen und gepostet
Soweit so gut, aber letztlich doch schlecht.

Falls du schon selber in deinem Logfile nach der SN gesucht hast weißt du es schon...
Es gibt nicht das kleinste Anzeichen das das Gerät im Anlernmodus überhaupt registriert wird.

Die Ursache ist unklar, es gibt aber grob 3 Szenarien.
  • A: Stick defekt oder schlecht/falsch zusammengelötet
  • B: IP-Gerät welches angelernt werden soll defekt
  • C: irgendwas mit deinem Setup, obwohl die ova's eher selten Zicken machen wenn der Stick sauber durchgereicht wird
Ich tippe auf A.
Daher mal was über die Herkunft des Stick's berichten und wenn selbst gelötet idealerweise scharfe Bilder der Lötstellen posten.

Zu B: Eher unwahrscheinlich. Wenn möglich das Gerät mal an einer funktionierenden Zentrale anlernen (HAP oder bei Freunden etc.)

Zu C: kann man nicht ganz ausschließen, ich empfehle einen Pi2B/Pi3B mit RM zu booten und das dort mal zu testen.

Es gilt das Problem so weit wie möglich einzugrenzen.

diepe
Beiträge: 22
Registriert: 06.12.2022, 14:18
System: in Planung
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von diepe » 08.01.2023, 14:31

Danke für Deine Hilfe Baxxy,
der Stick scheint wohl DEF zu sein. Ich habe ihn bei ELV gekauft!
Baxxy hat geschrieben:
07.01.2023, 00:32

Die Ursache ist unklar, es gibt aber grob 3 Szenarien.
  • A: Stick defekt oder schlecht/falsch zusammengelötet
  • B: IP-Gerät welches angelernt werden soll defekt
  • C: irgendwas mit deinem Setup, obwohl die ova's eher selten Zicken machen wenn der Stick sauber durchgereicht wird
Ich tippe auf A.
Daher mal was über die Herkunft des Stick's berichten und wenn selbst gelötet idealerweise scharfe Bilder der Lötstellen posten.

Zu B: Eher unwahrscheinlich. Wenn möglich das Gerät mal an einer funktionierenden Zentrale anlernen (HAP oder bei Freunden etc.)

Zu C: kann man nicht ganz ausschließen, ich empfehle einen Pi2B/Pi3B mit RM zu booten und das dort mal zu testen.

Es gilt das Problem so weit wie möglich einzugrenzen.
Zu C: Auf Pi4 >das selbe problem
Zu B: Keine Möglichkeit
Zu A: Alles nochmal entlötet und neu gelötet. >das selbe problem
20230108_133946.jpg
20230108_133935.jpg
Und nu?
USB Stick zurücksenden und auf Kulanz hoffen?
Neuen Stick fertig gelötet kaufen?

scorpionking
Beiträge: 937
Registriert: 14.02.2016, 12:32
System: Alternative CCU (auf Basis OCCU)
Wohnort: Heidenheim
Hat sich bedankt: 49 Mal
Danksagung erhalten: 166 Mal

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von scorpionking » 08.01.2023, 16:20

Ui, ich würde mal sagen im Bild von der Rückseite sieht man eine schöne Lötbrücke wo keine sein sollte zwischen den mittleren rechten Lötpunkten.
diepe hat geschrieben:
08.01.2023, 14:31
Kulanz
Würde ich dir als Verkäufer nicht gewähren :mrgreen:, aber wer weiß...
diepe hat geschrieben:
08.01.2023, 14:31
Neuen Stick fertig gelötet kaufen?
Vermutlich wäre das die sichere Lösung. :wink:

diepe
Beiträge: 22
Registriert: 06.12.2022, 14:18
System: in Planung
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von diepe » 12.01.2023, 09:56

scorpionking hat geschrieben:
08.01.2023, 16:20
diepe hat geschrieben:
08.01.2023, 14:31
Neuen Stick fertig gelötet kaufen?
Vermutlich wäre das die sichere Lösung. :wink:
So ich habe mir einen neuen Stick gekauft. Der funktioniert einwandfrei!
Anlernen funktioniert nach wenigen Sekunden. Zum Glück auch ohne Reset der FROLL Aktoren, da die mittlerweile übertapeziert sind.
So jetzt kann ich mich erstmalig ans parametrieren geben.

Danke an euch, und ganz besonderen Dank an Baxxy!

Benutzeravatar
Baxxy
Beiträge: 7863
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 454 Mal
Danksagung erhalten: 1500 Mal

Re: [GELÖST] Raspberrymatic Anlernkatastrophe

Beitrag von Baxxy » 17.01.2023, 23:18

Da sich die Probleme mit dem HmIP-RFUSB "gefühlt" irgendwie häufen und ich mir den Thread-Titel so gut merken kann...

Hier mal ein Logauszug des hmserver.log während sich ein IP-Gerät im Anlernmodus befindet. (die Zentrale ist noch nicht im Anlernmodus)

Code: Alles auswählen

2023-01-17 22:42:08,283 de.eq3.cbcs.server.core.internal.HMIPTRXListener TRACE [RXTXPortMonitor(/dev/mmd_hmip)] HM /IP Frame received Frametype: HMIP_NM_DEVICE_INCLUSION_REQUEST 
2023-01-17 22:42:08,293 de.eq3.cbcs.server.core.vertx.IncomingHMIPFrameHandler TRACE [vert.x-eventloop-thread-6] AP 3014F711A0000xxxxxxxx558: HM /IP Frame received  Frametype: HMIP_NM_DEVICE_INCLUSION_REQUEST from 15068F (15068F) 
2023-01-17 22:42:08,308 de.eq3.cbcs.server.core.internal.InclusionHandling TRACE [vert.x-eventloop-thread-6] AP 3014F711A0000xxxxxxxx558: Inclusion Request device with SGTIN: 3014F711A0000xxxxxxxx644; accept Master Key: true; accept Local Key: true 
2023-01-17 22:42:08,309 de.eq3.cbcs.server.core.internal.InclusionHandling DEBUG [vert.x-eventloop-thread-6] AP 3014F711A0000xxxxxxxx558: Not in inclusion mode. Do nothing. Device 3014F711A0000xxxxxxxx644 IP-Address 15068F MAC-Address 15068F 
2023-01-17 22:42:08,315 de.eq3.cbcs.legacy.bidcos.rpc.internal.LegacyNotificationHandler TRACE [vert.x-worker-thread-3] DEVICE_INCLUSION_REQUESTED : {"caller.id":"event","request.id":-1,"notification.type":50,"accesspoint.id":"3014F711A0000xxxxxxxx558","device.id":"3014F711A0000xxxxxxxx644","device.type":{"label":"HmIP-FSM16","id":301,"manufacturer_code":1,"updatable":true,"parentType":"FSM"},"device.descr":{"id":"FSM_V5","type":"FSM","description":"Full flush switch actuator with Measuring","version":5}}
Ist also sichergestellt das sich das IP-Gerät korrekt im Anlernmodus befindet (ca. alle 10s oranges aufblinken) und man sieht davon nichts im Log (IP-Logging auf TRACE), dann kann man wohl von einem defekten HmIP-RFUSB ausgehen.

Live Log View per ssh mit:

Code: Alles auswählen

tail -f /var/log/hmserver.log 

Antworten

Zurück zu „RaspberryMatic“