RPi4 keine Funkverbindung zu Geräten

Virtualisierte CCU für Raspberry Pi und Clones

Moderator: Co-Administratoren

Antworten
Elreldur
Beiträge: 3
Registriert: 02.06.2021, 15:07
System: Alternative CCU (auf Basis OCCU)

RPi4 keine Funkverbindung zu Geräten

Beitrag von Elreldur » 02.06.2021, 15:14

Servus Liebe Homematic-Community,

ich wollte mein Haus, in welches ich in einem Monat einziehe, mit SmartHome Geräten von Homematic rüsten.
Aktuell habe ich schon die Rollo-/Markisenaktoren, Brandmelder, Heizthermostate und eine Wetterstation gekauft.

Als SmartHome-Zentrale dient ein RPi4 8GB mit RPI-RF-MOD.
Als Speicher habe ich eine SSD mit 120GB per USB3 verbunden.
Zur Stromversorgung nutze ich das original Rpi Netzteil über USB mit nachträglich aufgesezten Ferritring.
Als Betriebssystem läuft das aktuelle Raspbian lite mit neusten Updates.
Per USB-Verlängerung habe ich einen ConBee 2 Stick angeschlossen.
(Dieser hat ohne Verlängerungskabel kein einziges Gerät finden können.)

Folgende Dienste laufen auf dem Gerät:
Webmin, Pi-Hole, pvccu3, deConz, Unify-Controller, Homebridge, Wireguard, unbound

Nun zum eigentlichen Problem und meinen vergeblichen Versuchen an einer Problemlösung:
Ich bekomme Homematic-Geräte nur schwer bis gar nicht verbunden und der Datenaustausch findet dann auch so gut wie nie statt.
Das Problem hatte ich auch mit Zigbee Geräten.
Dort konnte das Problem über eine Absetzung des Conbee Sticks per USB-Verlängerung beseitigt werden.
Ich habe die RPI-RF-MOD Platine überprüft um eine kaputte Lötstelle auszuschließen.
Zusätzlich habe ich eine abgesetzte Antenne (Abstand 50cm zum pi) angeschlossen.
Eine Verbindung funktionierte so fast nie und mit viel Glück war eine kurze Verbindung zu den Geräten möglich.
Ich erhielt dabei ständig die Fehlermeldung "Kommunikation Gestört".
Der Anschluss einer einfachen Stabantenne brachte nur kurz eine Besserung bis es nach ca. 5 Minuten genau gleich schlecht/gar nicht ging.

Ich hoffe jemand kennt dieses Problem und kann mir sagen wie ich es in den Griff bekomme.
Habe schon einiges über Störungen durch den Pi selbst gelesen, aber dieses Ausmaß übertrifft die Schilderungen anderer User.
Anbei noch ein Paar Bilder zur besseren Vorstellung meines Aufbaus.

Liebe Grüße
Dateianhänge
6B32D727-52FB-42C6-AC0E-19ABD3C0C0EF.jpeg
ABB5B706-8D7B-46F0-8526-A46F98DC82F0.jpeg
55240AB1-4866-4864-B8B5-5FAB6FBB9ACD.jpeg
8D314629-8B8D-479F-AB11-8C8D22224667.jpeg

BOP
Beiträge: 46
Registriert: 09.12.2018, 11:39
Hat sich bedankt: 2 Mal
Danksagung erhalten: 3 Mal

Re: RPi4 keine Funkverbindung zu Geräten

Beitrag von BOP » 02.06.2021, 15:36

Hallo!
Ich hatte das Problem bei meinen Eltern. Die Verbindung zu den Geräten war immer nur kurz nach dem Start vorhanden und dann auch schnell wieder weg.

Im Endeffekt half ein anderes Netzteil. Sofort nach dem Tausch waren die Probleme verschwunden. Auch wenn es das Originalnetzteil bei dir ist, würde ich das als Erstes ausprobieren.
Bei meinen Eltern läuft übrigens seitdem ein altes Handyladegerät.

Benutzeravatar
shartelt
Beiträge: 4265
Registriert: 14.01.2015, 14:59
Hat sich bedankt: 121 Mal
Danksagung erhalten: 250 Mal

Re: RPi4 keine Funkverbindung zu Geräten

Beitrag von shartelt » 02.06.2021, 15:41

oder aber das bekannte Pi4 gegen ein Pi3 tauschen wie hier dauernd zu lesen.
Oder per USB oder Netzwerk das Funkmodul absetzen.

Baxxy
Beiträge: 3599
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 246 Mal
Danksagung erhalten: 608 Mal

Re: RPi4 keine Funkverbindung zu Geräten

Beitrag von Baxxy » 02.06.2021, 16:38

Mein Liebling der Pi4B... dazu noch mit Funkmodul auf dem Stacking-Header... :mrgreen:

Tipps zur Behebung der Funkproblematik im 1.Link in meiner Signatur.

Elreldur
Beiträge: 3
Registriert: 02.06.2021, 15:07
System: Alternative CCU (auf Basis OCCU)

Re: RPi4 keine Funkverbindung zu Geräten

Beitrag von Elreldur » 14.06.2021, 20:51

Vielen Dank für die schnelle Hilfe.
Ich habe nun endlich die HB-RF-USB-2 Platine bekommen und gleich mal angeschlossen.
Leider lässt sich der Raspberry mit eingesteckter HB-RF-USB-2 Platine nicht mehr booten.
Folgende Fehlermeldung tritt auf "usb msd timed out after 20 seconds".
Das booten ohne eingesteckter Platine funktioniert.
Wenn ich sie dann nachträglich einstecke friert mir das ganze System ein.

Ich hoffe jemand kennt dieses Problem


Elreldur
Beiträge: 3
Registriert: 02.06.2021, 15:07
System: Alternative CCU (auf Basis OCCU)

Re: RPi4 keine Funkverbindung zu Geräten

Beitrag von Elreldur » 14.06.2021, 22:18

Danke für den Tipp. Ja, war natürlich falsch herum. :roll:
Habe es jetzt nach ein Paar Anlaufschwierigkeiten hinbekommen.
Funkverbindung geht jetzt mit Hilfe der USB Platine perfekt.

Vielen Dank an alle!

Antworten

Zurück zu „piVCCU“