piVCCU3 mit Sonos API oder AddOn ohne Funktion

Virtualisierte CCU für Raspberry Pi und Clones

Moderator: Co-Administratoren

klassisch
Beiträge: 3346
Registriert: 24.03.2011, 04:32

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von klassisch » 06.01.2019, 17:18

Bei mir sieht der udp Aufruf über cocat so aus so aus

Code: Alles auswählen

dom.GetObject("CUxD.CUX2801001:1.CMD_EXEC").State("/bin/sh /usr/local/addons/DispON.sh")
In dem genannten DispON.sh steht dann der eigentliche Befehl

Code: Alles auswählen

echo 'Wolido:DisplayON' | /usr/local/addons/cuxd/extra/socat UDP:192.168.178.33:6666,cr -
Wie gesagt, uralter Code, aus Anleitungen abgeschrieben und heute sicher veraltet. Bin kein Linuxer und was läuft, das bleibt.
Das CUxD Gerät CUX2801001 wird benutzt um system.exec abzulösen.

pattex2002
Beiträge: 16
Registriert: 16.04.2015, 11:27

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von pattex2002 » 06.01.2019, 17:34

deimos hat geschrieben:
06.01.2019, 17:15
Hi,

es wäre sicherlich auch mal hilfreich, wenn du Details zum Aufruf postet (u.A. also auch mal das Skript).

Zu der Sache mit dem Escaping: Ersten Treffer, den ich gefunden habe: viewtopic.php?f=19&t=47213

Ist schon etwas älter und war auch ein Thema in der CCU2, allerdings nur, wenn man die Community Variante der Logikschicht aktiv hatte.

Viele Grüße
Alex

Hallo Alex,

so sieht der Aufruf aus:

! --- Sonos Gaestebad lauter
string url = "wget --no-check-certifikate --quit -0 /dev/null \"http://192.168.178.88:5005/gaestebad/volume/50\"";
dom.GetObject("CUxD.CUX2801001:1.CMD_EXEC").State (url);


Gruß
Patrick

deimos
Beiträge: 2416
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Kontaktdaten:

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von deimos » 06.01.2019, 17:52

Hi,

ist das bei dir hinter dem quit der große Buchstabe o oder die Zahl 0? Bei Zahl wäre es falsch und würde deine Probleme erklären.

Viele Grüße
Alex

pattex2002
Beiträge: 16
Registriert: 16.04.2015, 11:27

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von pattex2002 » 06.01.2019, 18:03

deimos hat geschrieben:
06.01.2019, 17:52
Hi,

ist das bei dir hinter dem quit der große Buchstabe o oder die Zahl 0? Bei Zahl wäre es falsch und würde deine Probleme erklären.

Viele Grüße
Alex
Hi,

es war die Null...aber nach ändern auf O leider immer noch kein Erfolg...
Könnte man evtl. im Log von CUxD was sehen?

Gruß
Patrick

deimos
Beiträge: 2416
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Kontaktdaten:

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von deimos » 06.01.2019, 18:12

Hi,

was es noch sein könnte: Du hast keinen Pfad bei wget angegeben.

Ansonsten: Probier mal aus, was passiert, wenn du dich per SSH auf der CCU (Container, nicht Host) anmeldest und folgenden Befehl ausführst:

Code: Alles auswählen

wget --no-check-certifikate --quit -O /dev/null "http://192.168.178.88:5005/gaestebad/volume/50"
Viele Grüße
Alex

pattex2002
Beiträge: 16
Registriert: 16.04.2015, 11:27

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von pattex2002 » 06.01.2019, 18:26

ähm...
Per SSH auf dem RasPi anmelden ok, aber wie mache ich das bei der CCU?

Und was meinst DU mit Pfad?

Danke und Gruß
Patrick

klassisch
Beiträge: 3346
Registriert: 24.03.2011, 04:32

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von klassisch » 06.01.2019, 20:43

pattex2002 hat geschrieben:
06.01.2019, 18:26
Per SSH auf dem RasPi anmelden ok, aber wie mache ich das bei der CCU?
SSH aktivieren -> Systemsteuerung -> Sicherheit
Schau mal weiter für die credentials. Dann kann man z.B. mit WinSCP oder putty drauf
viewtopic.php?p=331320#p331320
pattex2002 hat geschrieben:
06.01.2019, 18:26
Und was meinst DU mit Pfad?
Den Pfad zur Datei des wget-Kommandos. Ich habe bei meinem Beispiel angegeben wo das socat Kommando "versteckt" ist. Das ist jetzt aber nicht wirklich Linux- und schon gar nicht piVCCU spezifisch.

pattex2002
Beiträge: 16
Registriert: 16.04.2015, 11:27

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von pattex2002 » 07.01.2019, 18:37

hm....
...also, ich habe in der Systemsteuerung SSH aktiviert und ein Password vergeben.
Über den Putty, der IP der CCU3 kann ich mich verbinden, aber mit dem Benutzer Admin und dem vergebenen PW Zugriff verweigert. :(


pattex2002
Beiträge: 16
Registriert: 16.04.2015, 11:27

Re: piVCCU3 mit Sonos API oder AddOn ohne Funktion

Beitrag von pattex2002 » 12.01.2019, 16:24

So...
...habe mir jetzt mal das komplette Image (Pi3B-Pi3B+ - AIO-piVCCU3 + ioBroker + Homebridge + GUI + BerryLAN 10-12-2018) käuflich erworben.
Image aufgespielt, CUxD in der Version cuxd_2.2.0_ccu3.tar installiert. Taster angelegt und reboot des Pi.

Weiterhin kann ich durch URL Aufruf im Browser die Sonos steuern:

http://192.168.178.88:5005/gaestebad/play/

In der CCU habe ich folgendes Skript angelegt - auch gleich den Putty-Ausschnitt, wenn ich den wget-Befehl auf der CCU ausführe.
Dateianhänge
wget.PNG

Antworten

Zurück zu „piVCCU“