HB-OU-MP3-LED

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

pafra
Beiträge: 98
Registriert: 16.05.2018, 21:13

Re: HB-OU-MP3-LED

Beitrag von pafra » 15.04.2019, 15:45

jp112sdl hat geschrieben:
15.04.2019, 15:19
pafra hat geschrieben:
15.04.2019, 11:13
Was komisch ist, dass ich bei der seriellen Schnittstelle (wieder mal) 115k Baud einstellen muss, damit was lesbares kommt.
Wenn das schon nicht stimmt hast du wahrscheinlich ein 16 mhz Arduino. Dann klappt auch die Kommunikation mit dem DFPlayer nicht.
EDIT: mit dem HB-OU-MP3-LED Sketch geht alles mit 57600 Baud - nur bei dem Beispiel muss ich 115200 Baud einstellen.

Kann ich gerne nochmal nachsehen bzw. einen neuen aufbauen.
Allerdings funktioniert genau diese Hardware ja mit dem Sketch vom HB-UNI-Sen-CAP-MOIST.
Auch mit dem Funkmodul.

Beim letzten Mal bei der Wetterstation (wo ich ja definitiv zuerst einen falschen drin hatte) ging das Anlernen ja mit dem 16MHz Board auch nicht.
Bei diesem Boards klappt das aber mit dem Sketch vom HB-UNI-Sen-CAP-MOIST.

Wie gesagt,
ich probier mal ne andere Hardware aus.
Nicht, dass mir der nette chinesische Händler da wieder was falsches geschickt bzw. drunter geschmuggelt hat.

Vielen Dank nochmal für Deine Unterstützung.

Gruß
Franz

jp112sdl
Beiträge: 3021
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 6 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 15.04.2019, 18:13

Die anderen Sketche kommunizieren aber nicht seriell mit externer Peripherie.

VG,
Jérôme

thgorjup
Beiträge: 10
Registriert: 14.04.2019, 15:57

Re: HB-OU-MP3-LED

Beitrag von thgorjup » 16.04.2019, 11:33

So, heute ist mein PL2303 geliefert worden und ich bekomme eine ähnliche Ausgabe wie pafra. Auch nur bei 115200 Baud.
@pafra: Konntest du das Problem lösen?

Code: Alles auswählen

AskSin++ V3.1.7 (Apr 14 2019 23:45:13)
Address Space: 32 - 567
CC init1
Error at 3E expected: 03 read: 00
CC Version: 14
Error at 3E expected: C0 read: 00
 - ready
Enable PinPolling: 6 - 1
DFPlayer Init Error.

jp112sdl
Beiträge: 3021
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 6 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 16.04.2019, 11:40

So lange es bei 57600 keine Ausgabe gibt - ihr also keinen 8Mhz getakteten 328P einsetzt - wird das mit dem DFPlayer nix gescheites werden.

VG,
Jérôme

thgorjup
Beiträge: 10
Registriert: 14.04.2019, 15:57

Re: HB-OU-MP3-LED

Beitrag von thgorjup » 16.04.2019, 11:58

Bin mir aber auch sicher einen 3.3V/8MHz zu nutzen. Wie kann man das prüfen?

pafra
Beiträge: 98
Registriert: 16.05.2018, 21:13

Re: HB-OU-MP3-LED

Beitrag von pafra » 16.04.2019, 12:55

thgorjup hat geschrieben:
16.04.2019, 11:33
So, heute ist mein PL2303 geliefert worden und ich bekomme eine ähnliche Ausgabe wie pafra. Auch nur bei 115200 Baud.
@pafra: Konntest du das Problem lösen?

Code: Alles auswählen

AskSin++ V3.1.7 (Apr 14 2019 23:45:13)
Address Space: 32 - 567
CC init1
Error at 3E expected: 03 read: 00
CC Version: 14
Error at 3E expected: C0 read: 00
 - ready
Enable PinPolling: 6 - 1
DFPlayer Init Error.
Bei mir wird das Funkmodul korrekt initialisiert.
Und der Sketch bleibt dann aber auch bei "DFPlayer Init Error" stehen.
Allerdings sehe ich das bei 57600 Baud.

Ich kann da erst leider wieder in 2 Wochen weiter machen, da ich jetzt erst mal im Urlaub bin ;-)
thgorjup hat geschrieben:
16.04.2019, 11:58
Bin mir aber auch sicher einen 3.3V/8MHz zu nutzen. Wie kann man das prüfen?
Das hatte ich aber auch schon mal, dass ich einen 3,3V/8MHz bestellt, dann aber einen 5V/16MHz geschickt bekommen hatte.
Hast Du noch nen anderen Arduino z.B. von einer anderen Lieferung?

Gruß
Franz

thgorjup
Beiträge: 10
Registriert: 14.04.2019, 15:57

Re: HB-OU-MP3-LED

Beitrag von thgorjup » 16.04.2019, 13:31

Das hatte ich aber auch schon mal, dass ich einen 3,3V/8MHz bestellt, dann aber einen 5V/16MHz geschickt bekommen hatte.
Hast Du noch nen anderen Arduino z.B. von einer anderen Lieferung?
Auf meinem Oszilator steht tatsächlich "AR" drauf. Da scheint mich der Chinese wirklich auf Kreuz gelegt zu haben.
Check hier: http://electronicsideasforyou.blogspot. ... ltage.html

Da muss ich ich wirklich neue bestellen und auch ein paar Wochen warten.

Gruß
Thomas

jp112sdl
Beiträge: 3021
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 6 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 16.04.2019, 17:13

Das Problem ist neben den 16MHz auch der 5V LDO.
Wenn ihr das CC1101 an Vcc anschließt, bekommt es 5V statt 3.3V beim 8MHz.
Lt. Specs ist beim CC1101 max. 3.9V zulässig.
Hab es selbst auch schon mit weitaus mehr betrieben.

VG,
Jérôme

thgorjup
Beiträge: 10
Registriert: 14.04.2019, 15:57

Re: HB-OU-MP3-LED

Beitrag von thgorjup » 16.04.2019, 19:25

Ich habe alle meine Arduino Pro Mini's durchgeschuat und tasächlich noch einen mit 8MHz gefunden. Diesen gleich verbaut und geflashed.
Klappte dann wunderbar. Danke für eure Hilfe!

Code: Alles auswählen

AskSin++ V3.1.7 (Apr 16 2019 18:18:49)
Address Space: 32 - 567
CC init1
CC Version: 14
 - ready
Enable PinPolling: 6 - 1
DFPlayer Mini online.
LED Interrupt Running: 1
MP3 Interrupt Running: 1
ID: F34400  Serial: JPMP300000
<- 0E 01 86 10 F34400 000000 06 01 00 00 00  - 2170
<- 0E 02 86 10 F34400 000000 06 02 00 00 00  - 2269
Ich konnte sogar das Device in FHEM anlernen. Allerdings ist das Device "unknown".
Hoffentlich schlägt mich jetzt niemand, wenn ich frage, ob jemand weiß, was in in FHEM ergänzen muss, damit es dort nutzbar ist?

Danke und Gruß
Thomas

jp112sdl
Beiträge: 3021
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 6 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 16.04.2019, 21:48

thgorjup hat geschrieben:
16.04.2019, 19:25
Hoffentlich schlägt mich jetzt niemand, wenn ich frage, ob jemand weiß, was in in FHEM ergänzen muss, damit es dort nutzbar ist?
Hmm... da wirst du wohl im grünen Forum fragen müssen.;)

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“