Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

McShire
Beiträge: 11
Registriert: 21.10.2020, 22:32
System: keine Zentrale (nur Pairing, FHEM etc.)
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von McShire » 23.10.2020, 23:28

Danke, mit der entsprechenden Änderung funktioniert es.

Aber ich habe immer noch Probleme mit der Stromaufnahme.
LED und LDO auf dem Mini entfernt, LDO auf dem Sensor entfernt und Brücke eingelötet, die Stromaufnahme
sollte dann in Ruhe von 68 uA auf 4 uA gehen.
Scheinbar geht das Modul BH1750 nicht in den Ruhezustand (PowerOFF-Modus?). Die Stromaufnahme während
der Übertragungspausen ist für den kompletten Sensor145 uA, davon fließen 140 uA in das BH1750 Modul.

Am Mini liegt es nicht, Wenn ich einen Temperatursensor BME280 einsetze und den entsprecheden Sketch lade
ist der Ruhestrom 4,7 uA.
Muss ich da noch irgendwo den Code ändern?

mfg

McShire
Beiträge: 11
Registriert: 21.10.2020, 22:32
System: keine Zentrale (nur Pairing, FHEM etc.)
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von McShire » 24.10.2020, 12:15

Nachtrag:
Das Modul überträgt zwar alle 120 min Daten an FHEM, aber man kann im Monitor der Arduino IDE sehen,
dass alle 9 sec eine Messung durchgeführt wird.
mfg
Werner

McShire
Beiträge: 11
Registriert: 21.10.2020, 22:32
System: keine Zentrale (nur Pairing, FHEM etc.)
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von McShire » 24.10.2020, 12:16

120 sec natürlich

maxx3105
Beiträge: 161
Registriert: 19.10.2018, 16:07
Hat sich bedankt: 58 Mal
Danksagung erhalten: 15 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von maxx3105 » 24.10.2020, 12:28

Das erklärt warum bei mir die Batterien so schnell leer geworden sind. Ich habe ihn aus dem Grund mit Akku und Solarzelle versehen. Bietet sich bei einem Lichtsensor an.

jp112sdl
Beiträge: 6762
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 341 Mal
Danksagung erhalten: 696 Mal
Kontaktdaten:

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von jp112sdl » 24.10.2020, 14:34

McShire hat geschrieben:
24.10.2020, 12:15
dass alle 9 sec eine Messung durchgeführt wird.
Sollten eigentlich 8 Sekunden sein 8)
Das ist die Einstellung txMinDelay.
Kannst das in den WebUI Geräteeinstellungen hoch setzen

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

McShire
Beiträge: 11
Registriert: 21.10.2020, 22:32
System: keine Zentrale (nur Pairing, FHEM etc.)
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von McShire » 24.10.2020, 22:25

Danke für die Info.
habe txMinDelay im WebUI von FHEM für das device weder in der Commandlist set ... noch als attr gefunden.
habe dann in der Arduino IDE den Wert für txMindelay an 2 Stellen geändert.
Einmal in der Registerdefinition
DEFREGISTER(LiReg0, MASTERID_REGS, DREG_TRANSMITTRYMAX, DREG_CYCLICINFOMSGDIS, DREG_LOCALRESETDISABLE, DREG_INTKEY)
in der Zeile
txMindelay(8);
auf von 8 auf 60 hochgesetzt und in der Funktion
virtual void trigger (__attribute__ ((unused)) AlarmClock& clock) {
in der Zeile
uint8_t txMindelay = max(8,this->getList1().txMindelay());
ebenfalls.
Dann erfolgt die Messung alle 60 s.

Aber das Modul geht nicht in den Ruhezustand sondern zieht immer noch in den Pausen 141 uA.

Gibt es eine Möglichkeit den Ruhezustand einzuschalten?
mfg
Werner

jp112sdl
Beiträge: 6762
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 341 Mal
Danksagung erhalten: 696 Mal
Kontaktdaten:

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von jp112sdl » 24.10.2020, 22:36

Im Sketch brauchst du nichts ändern.
Der txMindelay ist ein Geräteparameter und der wird über Funk gesetzt.
Deine hart codierte Änderung hat nun zur Folge, dass du keinen Wert < 60 mehr per Funk einstellen kannst.
Aber gut, dann sei es so.
McShire hat geschrieben:
24.10.2020, 22:25
zieht immer noch in den Pausen 141 uA.
viewtopic.php?t=47999#p480701
TomMajor hat geschrieben:
22.10.2020, 00:02
da gab es wohl ein paar Änderungen im Sketch in der Zwischenzeit.
ich würde sagen Zeile 20 so ändern (ungetestet):

Code: Alles auswählen

#define SENSOR_CLASS Bh1750<0x23,::BH1750::Mode::CONTINUOUS_LOW_RES_MODE>
:arrow: ::BH1750::Mode::ONE_TIME_HIGH_RES_MODE

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

McShire
Beiträge: 11
Registriert: 21.10.2020, 22:32
System: keine Zentrale (nur Pairing, FHEM etc.)
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von McShire » 25.10.2020, 01:44

jp112sdl hat geschrieben:
24.10.2020, 22:36
Im Sketch brauchst du nichts ändern.
Der txMindelay ist ein Geräteparameter und der wird über Funk gesetzt.
Deine hart codierte Änderung hat nun zur Folge, dass du keinen Wert < 60 mehr per Funk einstellen kannst.
Aber gut, dann sei es so.
McShire hat geschrieben:
24.10.2020, 22:25
zieht immer noch in den Pausen 141 uA.
viewtopic.php?t=47999#p480701
TomMajor hat geschrieben:
22.10.2020, 00:02
da gab es wohl ein paar Änderungen im Sketch in der Zwischenzeit.
ich würde sagen Zeile 20 so ändern (ungetestet):

Code: Alles auswählen

#define SENSOR_CLASS Bh1750<0x23,::BH1750::Mode::CONTINUOUS_LOW_RES_MODE>
:arrow: ::BH1750::Mode::ONE_TIME_HIGH_RES_MODE
Vielen Dank,
0x23,::BH1750::Mode::ONE_TIME_HIGH_RES_MODE
ist die Lösung!
Stromaufnahme in den Pausen mit eingelötetem LDO im BH1750 beträgt 10,9 uA, da lohnt das Auslöten bald nicht mehr. :D :D :D :D
CONTINUOUS heißt wohl "gehe nicht in den Power Off Mode.

Wenn ich jetzt noch eine Anweisung bekomme, wie man txMindelay über Funk setzt, ich nehme an in FHEM,
ist es perfekt.
Viele Grüße
Werner

McShire
Beiträge: 11
Registriert: 21.10.2020, 22:32
System: keine Zentrale (nur Pairing, FHEM etc.)
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von McShire » 25.10.2020, 02:18

jp112sdl hat geschrieben:
24.10.2020, 14:34
McShire hat geschrieben:
24.10.2020, 12:15
dass alle 9 sec eine Messung durchgeführt wird.
Sollten eigentlich 8 Sekunden sein 8)
Das ist die Einstellung txMinDelay.
Kannst das in den WebUI Geräteeinstellungen hoch setzen
WebUI Geräteeinstellungen gibt es in der CCU2.
Ich habe als Zentrale FHEM auf einem Raspi3B mit einem Selbstbau nanoCUL 868MHz rfMote HomeMatic.
Welcher Parameter / Attribut stellt hier txMindelay ein? Ist das vielleicht actCycle?

mfg
Werner

McShire
Beiträge: 11
Registriert: 21.10.2020, 22:32
System: keine Zentrale (nur Pairing, FHEM etc.)
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Anleitung Nachbau HM-Sen-LI-O (mit BH1750)

Beitrag von McShire » 25.10.2020, 10:25

LDO wieder ausgelötet, Ruhestromaufnahme jetzt 4,7 uA.
mfg
Werner

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“