Nachbau HB-UNI-Sensor1

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

CHK_BLN
Beiträge: 3
Registriert: 24.06.2019, 21:23

Re: Nachbau HB-UNI-Sensor1

Beitrag von CHK_BLN » 16.12.2019, 20:34

Hallo zusammen,

meine Erfahrung:
Ich habe mir 5 Stck. 18B20 mit Edelsstahlhülse und 3 Meter Zuleitung bestellt. Ein Vergleich bei Zimmertemperatur (alle 5 Sensoren waren an einen RPI angeschlossen) hat ergeben, dass die Abweichnung teilweise bis 1,5 Grad waren und somit nicht mehr in der Toleranz von +-0,5 Grad.
Ich habe mir dann 5 Sensoren unkonfektioniert bestellt. Siehe da, die Diffferenz untereinder war fast 0 Grad Abweichnung.

Ich glaube das unterschiedliche Qualitäten verkauft werden.
Leider sieht man das nicht bei der Bestellung

Gruß

wolwin
Beiträge: 111
Registriert: 06.06.2018, 12:27
Danksagung erhalten: 11 Mal

Re: Nachbau HB-UNI-Sensor1

Beitrag von wolwin » 18.12.2019, 16:51

Hallo zusammen,
Danke für Eure Beiträge - hier mal der Stand meiner Recherchen zu DS18B20-TO92. Der Verkäufer hat dann nach drei Anschreiben doch geantwortet:

Es befinden sich mittlerweile mehrere Varianten des DS18B20 von maxim integrated am Markt, in den Edelstahlhülsen beispielsweise sind andere Modelle des ICs verbaut.

Super - das habe ich ja auch schon gemerkt. Ich habe den Verkäufer dann heute noch einmal darauf hingewiesen, dass er die 'originalen' Chips beworben und zum Kauf angeboten hat - incl. einem Handbuch, in dem genau die Spezifikationswerte aufgeführt sind! Eine Antwort gibt es bis jetzt nicht …

Ich habe dann alle meine DS18B20-TO92 geprüft - insgesamt aus drei Lieferungen - alle vom gleichen Verkäufer. Und was soll ich sagen: es gibt sie doch, die stromsparenden DS18B20 !!! Zwei Lieferungen enthielten die 'Fake-Chips' und eine Lieferung enthielt die 'Original-Chips'. Dabei unterschieden sich die Aufdrucke der Chips:

Fake: 18B20 1827C4
Original: 18B20 1804C4

18-12-2019 16-44-27.jpg

TomMajor
Beiträge: 1006
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 54 Mal
Danksagung erhalten: 168 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von TomMajor » 18.12.2019, 17:12

wolwin hat geschrieben:
18.12.2019, 16:51
Ich habe dann alle meine DS18B20-TO92 geprüft - insgesamt aus drei Lieferungen - alle vom gleichen Verkäufer. Und was soll ich sagen: es gibt sie doch, die stromsparenden DS18B20 !!! Zwei Lieferungen enthielten die 'Fake-Chips' und eine Lieferung enthielt die 'Original-Chips'. Dabei unterschieden sich die Aufdrucke der Chips:

Fake: 18B20 1827C4
Original: 18B20 1804C4


18-12-2019 16-44-27.jpg
ist imho nur der date code, z.B. Jahr/Woche
nur daran allein wird man es nicht festmachen können.
ich schau mir mal bei Gelegenheit meine an..
Viele Grüße,
Tom

TomMajor
Beiträge: 1006
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 54 Mal
Danksagung erhalten: 168 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von TomMajor » 18.12.2019, 17:16

Viele Grüße,
Tom

wolwin
Beiträge: 111
Registriert: 06.06.2018, 12:27
Danksagung erhalten: 11 Mal

Re: Nachbau HB-UNI-Sensor1

Beitrag von wolwin » 22.12.2019, 21:01

TomMajor hat geschrieben:
18.12.2019, 17:16
interessante Lektüre
Stimmt - nachdem ich das gelesen habe, wundert mich nichts mehr - da bleibt einem nur noch jeden Sensor nach dem Kauf zu checken ... :(

MDK2412
Beiträge: 5
Registriert: 26.12.2019, 21:36

Re: Nachbau HB-UNI-Sensor1

Beitrag von MDK2412 » 26.12.2019, 22:16

Ich habe Probleme, einen HB-Uni-Sensor1 an der CCU (pivccu3, Firmwareversion 3.49.17) anzulernen. Als Hardwarebasis habe ich einen (mit dem Sketch funktionierenden) HM-WDS40-TH-I-BME280 genommen. Laut seriellem Monitor funktioniert der HB Uni an sich, Messwerte werden ausgelesen, der Funk geht auch (an der Frequenz liegt es nicht, der CC1101 funkt auf der korrekten Frequenz). Nur das Anlernen klappt einfach nicht! Das Addon ist natürlich auf der CCU installiert (mehrfach neu installiert). Ich habe es auch mit einer anderen Sensorplatine (der allerdings noch der BME280 fehlt) mit "nur" Dummy-Werten versucht. Selbes Ergebnis, der Frequenztest-Sketch läuft sauber durch, als HB Uni lässt er sich nicht anlernen.

Wo kann ich noch nach der Ursache suchen? Mache ich was grundsätzlich falsch?
Zuletzt geändert von Roland M. am 27.12.2019, 00:47, insgesamt 1-mal geändert.
Grund: Doppelpost gelöscht
Viele Grüße,

Dirk

TomMajor
Beiträge: 1006
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 54 Mal
Danksagung erhalten: 168 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von TomMajor » 27.12.2019, 01:27

zeig mal bitte die seriellen Logs, sowohl vom Power-On des Gerätes als auch vom Anlernversuch.
ich muss außerdem erwähnen das ich die 3.49.17 noch nicht getestet habe.
Viele Grüße,
Tom

MDK2412
Beiträge: 5
Registriert: 26.12.2019, 21:36

Re: Nachbau HB-UNI-Sensor1

Beitrag von MDK2412 » 27.12.2019, 09:27

Log nach Power On:

Code: Alles auswählen

AskSin++ V4.1.1 (Dec 27 2019 09:21:41)
Sensor setup done
Serial: UNISENS001
Clock SYSCLOCK
Address Space: 32 - 79
CC init1
CC Version: 14
 - ready
tmBattery Voltage: 3077
Battery set low:  21
Battery set crit: 19
Config Freq: 0x216562
Config Changed: List0
ledMode: 1
lowBatLimit: 24
Battery set low:  24
transmitDevTryMax: 6
updCycle: 600
altitude: 0
<- 17 01 84 70 FCFDFE 000000 00 BC 2A 80 58 00 86 47 00 00 0C 05 00 00  - 167
Nach Anlernen ein in CCU und Taster an:

Code: Alles auswählen

 debounce
 pressed
 released
<- 1A 02 84 00 FCFDFE 000000 13 F0 F1 F2 F3 F4 F5 F6 F7 F8 F9 FA FB 70 01 01 01  - 227

ignore 14 98 A4 5F 4127E5 402949 85 11 BC 00 3C D6 02 E3 08 DB FF  - 5582
ignore 0A 98 80 02 402949 4127E5 00  - 5697
ignore 14 B2 84 5E 453112 000000 80 98 6A 00 00 00 00 00 08 ED 01  - 12830
ignore 14 99 A4 5F 4127E5 402949 85 11 C0 00 3D 26 02 E6 08 DB FF  - 13565
ignore 0A 99 80 02 402949 4127E5 00  - 13682
Was mir hier auffällt: sollte nicht "FCFDFE" die ID sein? Die steht laut cfg-Datei aber auf 0x10, 0x11, 0x12.
Zuletzt geändert von MDK2412 am 27.12.2019, 09:34, insgesamt 1-mal geändert.

jp112sdl
Beiträge: 5417
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 215 Mal
Danksagung erhalten: 444 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von jp112sdl » 27.12.2019, 09:33

MDK2412 hat geschrieben:
27.12.2019, 09:27
Nach Anlernen ein in CCU und Taster an:

Code: Alles auswählen

<- 1A 02 84 00 FCFDFE 000000 13 F0 F1 F2 F3 F4 F5 F6 F7 F8 F9 FA FB 70 01 01 01  - 227
Da ist was faul.
Entweder schon im Sketch bei der Definition von Model, Serial und Address oder am 328P selbst.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

MDK2412
Beiträge: 5
Registriert: 26.12.2019, 21:36

Re: Nachbau HB-UNI-Sensor1

Beitrag von MDK2412 » 27.12.2019, 09:48

Also der Frequenztest-Sketch (mit Ping, also mit ID und Serial) gibt folgendes Log:

Code: Alles auswählen

AskSin++ V4.1.1 (Dec 27 2019 09:45:49)
CC init1
CC Version: 14
 - ready
Start searching ...
Freq 0x21656A 868.300 MHz: 670A0C.  1 / -66dBm
Search for upper bound
Freq 0x21657A 868.306 MHz: 670A0C.  1 / -66dBm
Freq 0x21658A 868.313 MHz: 4127E5.  1 / -97dBm
Freq 0x21659A 868.319 MHz: 402949.  1 / -80dBm
Freq 0x2165AA 868.325 MHz: 670A0C.  1 / -66dBm
Freq 0x2165BA 868.332 MHz: 670A0C.  1 / -67dBm
Freq 0x2165CA 868.338 MHz: 670A0C.  1 / -69dBm
Freq 0x2165DA 868.344 MHz:   0
Search for lower bound
Freq 0x21655A 868.294 MHz: 670A0C.  1 / -67dBm
Freq 0x21654A 868.287 MHz: 4127E5.  1 / -99dBm
Freq 0x21653A 868.281 MHz: 402949.  1 / -81dBm
Freq 0x21652A 868.274 MHz: 670A0C.  1 / -66dBm
Freq 0x21651A 868.268 MHz: 670A0C.  1 / -66dBm
Freq 0x21650A 868.262 MHz: 670A0C.  1 / -66dBm
Freq 0x2164FA 868.255 MHz: 670A0C.  1 / -67dBm
Freq 0x2164EA 868.249 MHz:   0

Done: 0x2164FA - 0x2165CA
Calculated Freq: 0x216562 868.297 MHz
Store into config area: 6562
Daher schließe ich mal einen Hardware-Defekt aus. Es liegt also wohl irgendwie an der ID und der Serial im HB-Uni-Sketch bzw. kommen diese nicht korrekt in der Hardware an. Frage nur: warum und was dagegen tun? Da ist wohl ein Wurm in meiner Arduino-Installation.
Viele Grüße,

Dirk

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“