Nachbau HB-UNI-Sensor1

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

spaceduck
Beiträge: 401
Registriert: 02.06.2010, 08:07
Danksagung erhalten: 4 Mal

Re: Nachbau HB-UNI-Sensor1

Beitrag von spaceduck » 13.03.2020, 18:42

@Tom:
Ich habe mich jetzt mal etwas auf Fehlersuche begeben und rausgefunden das es mir irgendwann in der Vergangenheit den Update Intervall Wert zerschrieben hat. Im Code ist 600s als default, ich habe den Wert in den vergangenen Monaten mehrmals per WebUI im Bereich 60s-120s geändert und im Serial Log war zuletzt dann 575 dringestanden. Das gleiche für die Höhe. Kann durchaus sein das da auch mal ein sehr hoher utopischer Wert dringestanden hat und der Sensor deswegen nicht mehr gesendet hat. Ich hab jetzt mal den EEPROM blankgeputzt, den Code für meine Werte angepasst und auf den AVR geflasht, jetzt läuft der Sensor absolut zuverlässig und sendet wie gewünscht alle 120s.

TomMajor
Beiträge: 861
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 46 Mal
Danksagung erhalten: 139 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von TomMajor » 14.03.2020, 13:21

Freut mich das es jetzt geht.

Btw, ich hatte mal im letzen Frühjahr eine Nacht lang keine Telegramme vom Unisensor im Außenbereich. hatte es damals auf die Antenne geschoben und eine andere verbaut.
Jerome hatte hier irgendwo in einem thread das Problem Betauung/Kondenswasser der Platine ins Spiel gebracht und eine Lackierung bei Außeneinsatz empfohlen - glaub ich zumindest.
Viele Grüße,
Tom

jp112sdl
Beiträge: 4716
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 151 Mal
Danksagung erhalten: 327 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von jp112sdl » 14.03.2020, 13:26

Ja richtig. Bei Wetterstation und Bodenfeuchtesensor... seither keine Probleme mehr.
Hatte mit Marco vor kurzem erst das Thema.
Ich hatte noch SK10 Lötlack zu stehen, den hab ich zum "Versiegeln" dann auch genommen.

VG,
Jérôme

stan23
Beiträge: 900
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Hat sich bedankt: 131 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von stan23 » 14.03.2020, 13:30

Meine Wetterstationsplatine habe ich mit Plastik 70 eingesprüht, das klebt nicht und lässt sich trotzdem noch löten.

Steht aber noch im Keller weil ich noch keinen Glasdeckel habe.
Viele Grüße
Marco

RaspberryMatic
~70 Geräte (HM, HmIP, HMW, HBW, AskSin)

jp112sdl
Beiträge: 4716
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 151 Mal
Danksagung erhalten: 327 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von jp112sdl » 14.03.2020, 13:32

stan23 hat geschrieben:
14.03.2020, 13:30
Steht aber noch im Keller weil ich noch keinen Glasdeckel habe.
Bei EDEKA gibts Wasabi Pulver im Glas. Das könnte sich gut eignen (also das Glas... für die Wetterstation... und das Wasabi für Sushi :mrgreen: )

VG,
Jérôme

spaceduck
Beiträge: 401
Registriert: 02.06.2010, 08:07
Danksagung erhalten: 4 Mal

Re: Nachbau HB-UNI-Sensor1

Beitrag von spaceduck » 14.03.2020, 15:43

Glas ist aber nicht für den UV Sensor geeignet, Da gehen Kunststoffkappen viel besser...

jp112sdl
Beiträge: 4716
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 151 Mal
Danksagung erhalten: 327 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von jp112sdl » 14.03.2020, 15:52

Ich nutze ein solches Glas.
Habe ohne und mit Abdeckung gemessen - kein Unterschied. Daher würde ich sagen... geht.

Borosilikatglas geht im allgemeinen ohnehin.

VG,
Jérôme

stan23
Beiträge: 900
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Hat sich bedankt: 131 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von stan23 » 14.03.2020, 17:12

Edeka, das ist im Moment besser zu erreichen als Ikea. Das KORKEN war ja zumindest die ursprüngliche Empfehlung.
Viele Grüße
Marco

RaspberryMatic
~70 Geräte (HM, HmIP, HMW, HBW, AskSin)

spaceduck
Beiträge: 401
Registriert: 02.06.2010, 08:07
Danksagung erhalten: 4 Mal

Re: Nachbau HB-UNI-Sensor1

Beitrag von spaceduck » 14.03.2020, 17:43

Hallo Jerome,

Dann hattest du wohl Glück bei dem Glas. Ich habe mit UV LEDs getestet, volle Hutze auf den VELM, der meldete Index 9. dann Glas dazwischen und der Index ging auf 2 oder 3 zurück. Bei den Kunststoffkappen von Modulor ging der Index auf 8 zurück.

jp112sdl
Beiträge: 4716
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 151 Mal
Danksagung erhalten: 327 Mal
Kontaktdaten:

Re: Nachbau HB-UNI-Sensor1

Beitrag von jp112sdl » 14.03.2020, 17:45

Mit Kunststoff hatte ich wiederum kein Glück. :|

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“