Seite 4 von 9

Re: Nachbau HB-UNI-Sensor1

Verfasst: 06.08.2018, 19:31
von jp112sdl
Kleiner Hinweis noch: Der TSL2561 ist ein mieser Sensor. Der verträgt kein direktes Sonnenlicht. Aber wirst ja sehen, wie es bei dir funzt.
Besser ist der BH1750.
Noch besser ist der Max44009, aber den hab ich da (noch) nicht implementiert.

Re: Nachbau HB-UNI-Sensor1

Verfasst: 06.08.2018, 19:41
von Frankey
Dann bestell ich mir mal davon welche.

Danke nochmal!

Re: Nachbau HB-UNI-Sensor1

Verfasst: 11.08.2018, 13:19
von WRadebeul
Hi jp112sdl,

ich bin dabei mit Deinen AskSinPP Skripten einige Sensoren zusammenzu bauen.
2x BME280 und 1x MOIST funktionieren schon. Klasse Projekt und Tolle Leistung von Dir !!!

Wollte gerade den Sketch für 3. BME280 hochladen, dieses funktioniert aber nicht.
Device ID + Device Serial habe ich geändert.

Beim anschließen des FTDI232 3,3V blinkt allerdings die rote LED am MiniPro (8MHz, 3,3V)
(die nahe dem Reset Button) Sie blinkt auch weiter wenn ich versuche den Sketch hochzuladen.

Ich habe gelesen, dass dann der Bootloader auf dem MinIPro fehlt. Ist diese einfach selber zu installieren ?
wenn Ja, welcher Bootloader und wie geht es / wo wäre eine entsprechende Anleitung ?

Hier nochmals die Fehlermeldung beim Hochladen des Sketches:


Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x84

avrdude done. Thank you.

Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.

Re: Nachbau HB-UNI-Sensor1

Verfasst: 11.08.2018, 13:32
von jp112sdl
WRadebeul hat geschrieben:
11.08.2018, 13:19
Beim anschließen des FTDI232 3,3V blinkt allerdings die rote LED am MiniPro (8MHz, 3,3V)
(die nahe dem Reset Button) Sie blinkt auch weiter wenn ich versuche den Sketch hochzuladen.

Ich habe gelesen, dass dann der Bootloader auf dem MinIPro fehlt. Ist diese einfach selber zu installieren ?
wenn Ja, welcher Bootloader und wie geht es / wo wäre eine entsprechende Anleitung ?
Dann ist da auch ein Bootloader drauf, wenn die LED blinkt.
WRadebeul hat geschrieben:
11.08.2018, 13:19
Hier nochmals die Fehlermeldung beim Hochladen des Sketches:


Using Port : COM3
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x84
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x84

avrdude done. Thank you.

Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.
Hast du auch nur auf "Hochladen" geklickt? Du darfst nicht "Hochladen mit Programmer" wählen, wenn du mittels FTDI hochlädst.

Re: Nachbau HB-UNI-Sensor1

Verfasst: 11.08.2018, 13:38
von WRadebeul
Ja,
erst überprüfen und Kompilieren,
dann Hochladen

Re: Nachbau HB-UNI-Sensor1

Verfasst: 11.08.2018, 13:54
von jp112sdl
Und COM3 ist auch richtig? Vielleicht hat sich der COM-Port geändert? Hab mal gehört, dass Windows gern solche Späße macht.

Re: Nachbau HB-UNI-Sensor1

Verfasst: 11.08.2018, 14:06
von WRadebeul
Ja, COM3 ist der richtige.

Re: Nachbau HB-UNI-Sensor1

Verfasst: 11.08.2018, 14:07
von jp112sdl
Hmm... Dann bin ich an der Stelle auch ratlos.

Re: Nachbau HB-UNI-Sensor1

Verfasst: 11.08.2018, 14:14
von WRadebeul
habe gerade den 4. gebaut und den Sketch hochgeladen,
funktioniert einwandfrei.

Re: Nachbau HB-UNI-Sensor1

Verfasst: 29.10.2018, 18:18
von Muxer
Hallo,
ich habe z.Zt. 2 HB-UNI-Sensor1 im Betrieb.
Da die Temperatur-Messwerte beider BGR ca. 3 Grad unterschiedlich sind, läßt sich irgendwo ein Korrekturwert eintragen?

Das Sendeintervall habe ich auf 1800 (30 Min).
Gibt es ein Kommando damit der Sensor die akt. Daten ausserhalb seines Sendeintervalles 1 mal sendet?