Wetterstation HB-UNI-SEN-WEA

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Nowiwan
Beiträge: 32
Registriert: 18.09.2017, 20:24
Hat sich bedankt: 1 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von Nowiwan » 19.11.2020, 16:07

dj.tifosi hat geschrieben:
28.10.2020, 01:03
Nowiwan hat geschrieben:
25.10.2020, 11:49

Die Kalibrierung des Regenmengenmessers in der Software ist ausführlich hier https://github.com/jp112sdl/HB-UNI-Sen- ... IN_COUNTER beschrieben.
Hallo nochmal in die Runde,
ich habe den Regenmengenmesser nach dj.tifosi mit grossem Erfolg nachgebaut.
Die Wippe ist nun , wie es sein soll, sehr leichtgängig.
Auch habe ich dieXML Datei in der Raspberrymatic entsprechend angepasst.(lt. Link oben )
Nun die grosse Frage :
Ich habe die Wetterstation noch nicht wie beschrieben abgelent und neu angelernt,sonern ersteinmal ohne dieses Prozedere die Funktion der Wippe getestet.
Ich habe auch ohne an und ablernen nach jedem Wippenschlag nun den geänderten Wert von 0,7 mm ( vorher 1 mm ) Niederschlag.
Muss ich denn nun zwingend die Station neu ab-und anmelden ?
Ich habe ein wenig Angst, dass es mir so geht wie einigen Mitstreitern, dass die Variablen und Programme durcheinander geraten.
Für Antworten wärw ich sehr dankbar.
VG
Georg

jp112sdl
Beiträge: 8677
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 504 Mal
Danksagung erhalten: 1165 Mal
Kontaktdaten:

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von jp112sdl » 19.11.2020, 16:10

Nowiwan hat geschrieben:
19.11.2020, 16:07
Ich habe auch ohne an und ablernen nach jedem Wippenschlag nun den geänderten Wert von 0,7 mm ( vorher 1 mm ) Niederschlag.
Wenns auch so passt - dann lass es so

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

dj.tifosi
Beiträge: 29
Registriert: 25.12.2014, 22:44
Danksagung erhalten: 7 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von dj.tifosi » 19.11.2020, 19:53

Nowiwan hat geschrieben:
19.11.2020, 16:07

Muss ich denn nun zwingend die Station neu ab-und anmelden ?
Wenn es auch so geklappt hat mit der Anpassung des Multiplikators, dann kannst du es natürlich so lassen.

Aber bedenke, dass die 0,7 mm kein definierter Wert ist, der auch bei deinem Nachbau so stimmen muss. Das war nur der Erfahrungswert, den ich anhand meines Regenmengenmessers an meiner Station gesammelt habe, muss bei deinem nicht eins zu eins passen.

Am einfachsten findest du es heraus, wenn du mal einen leeren Eimer ins Freie stellst und einen Niederschlag abwartest.

Dann wiegst du den Inhalt des Eimers, misst den Durchmesser des Eimers und rechnest daraus die Querschnittsfläche des Eimers aus und berechnest schließlich per Dreisatz den Niederschlag pro m².

Und diesen Wert kannst du nun mit dem vom Niederschlagsmesser gemessenen Wert vergleichen. Bzw. wenn du diesen Wert durch die Anzahl der Wippenschläge teilst, weißt du, welche Niederschlagsmenge einem Wippenschlag entspricht und hast so den richtigen Faktor ermittelt.

Jasimo
Beiträge: 23
Registriert: 20.10.2019, 12:06
Hat sich bedankt: 6 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von Jasimo » 07.01.2021, 19:50

Moin,
hab seit ein paar Tagen Probleme mit meinem HB-UNI-SEN-WEA, er lieferte plötzlich keine Daten mehr.
Nachdem ich ihn Stromlos gemacht und nach 2 Minuten wieder aktiviert habe, liefert er genau 1 mal Daten und dann ist wieder Funkstille.

Hat da jemand eine Idee oder Tipp?

Gruß
Jan

Martin62
Beiträge: 518
Registriert: 09.12.2019, 21:24
Hat sich bedankt: 110 Mal
Danksagung erhalten: 40 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von Martin62 » 07.01.2021, 21:28

Spannung am Sensor (Batterie schwach) in Ordnung?
Gruß Martin

Jasimo
Beiträge: 23
Registriert: 20.10.2019, 12:06
Hat sich bedankt: 6 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von Jasimo » 08.01.2021, 11:52

Martin62 hat geschrieben:
07.01.2021, 21:28
Spannung am Sensor (Batterie schwach) in Ordnung?
Hab heute morgen ein anderes Netzteil dran gehängt, keine Änderung.
Dann mal alle Sensoren ab und den Programmer dran, im seriellen Monitor kommen Meldungen.
Alle Sensoren wieder dran, tot!
Hab jetzt nur den BME und Regenmenge dran, alles andere (Blitz, Max, VEML) sind ab, bisher läuft er so.

Werde dann mal nach und nach die anderen Sensoren dazu stecken, mal gucken wer der Übeltäter ist!

dj.tifosi
Beiträge: 29
Registriert: 25.12.2014, 22:44
Danksagung erhalten: 7 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von dj.tifosi » 08.01.2021, 13:26

Jasimo hat geschrieben:
08.01.2021, 11:52
Martin62 hat geschrieben:
07.01.2021, 21:28
Spannung am Sensor (Batterie schwach) in Ordnung?
Hab heute morgen ein anderes Netzteil dran gehängt, keine Änderung.
Dann mal alle Sensoren ab und den Programmer dran, im seriellen Monitor kommen Meldungen.
Alle Sensoren wieder dran, tot!
Hab jetzt nur den BME und Regenmenge dran, alles andere (Blitz, Max, VEML) sind ab, bisher läuft er so.

Werde dann mal nach und nach die anderen Sensoren dazu stecken, mal gucken wer der Übeltäter ist!
Waren die Sensoren denn trocken oder hat sich eventuell Tau / Kondenswasser daran niedergeschlagen?

Jasimo
Beiträge: 23
Registriert: 20.10.2019, 12:06
Hat sich bedankt: 6 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von Jasimo » 08.01.2021, 13:31

Gerade geschaut sieht alles trocken aus, es ist scheinbar der Max, habe ich den dran geht nix.
Hab den gerade mal sauber gemacht (Isopropanol) und ne Brücke von A0 gegen GND gemacht, bringt aber nix, scheint defekt zu sein,

spaceduck
Beiträge: 446
Registriert: 02.06.2010, 08:07
Hat sich bedankt: 1 Mal
Danksagung erhalten: 9 Mal

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von spaceduck » 23.01.2021, 14:47

Da ich aktuell mit Ausfällen des UNI-SEN-WEA bei niedrigen Temperaturen kämpfe hab ich mich gerade mal mit der seriellen draufgeklemmt. Folgendes sehe ich beim Start:

14:38:34.919 -> LD IRQ SRC NOT EXPECTED

Was bedeuted das? Wer weiß da was?

Danke...

TomMajor
Beiträge: 1443
Registriert: 30.08.2017, 23:25
Hat sich bedankt: 124 Mal
Danksagung erhalten: 287 Mal
Kontaktdaten:

Re: Wetterstation HB-UNI-SEN-WEA

Beitrag von TomMajor » 23.01.2021, 15:26

spaceduck hat geschrieben:
23.01.2021, 14:47
Da ich aktuell mit Ausfällen des UNI-SEN-WEA bei niedrigen Temperaturen kämpfe hab ich mich gerade mal mit der seriellen draufgeklemmt. Folgendes sehe ich beim Start:

14:38:34.919 -> LD IRQ SRC NOT EXPECTED

Was bedeuted das? Wer weiß da was?

Danke...
Das ist nur ein Update Interrupt vom Blitzsensor bzgl. Entfernung und hat imho nichts mit den Ausfällen zu tun.

ich hatte innerhalb der letzten 6 Wochen auch 2 Ausfälle beim HB-UNI-Sensor1, V2.01, Außengerät, ich glaube bei Temp. < 0C, er hat einfach nicht mehr gesendet.
Spannung war ok, ein Reset und alles lief wieder. Wüsste gern warum.
Viele Grüße,
Tom

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“