Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

der-pw
Beiträge: 25
Registriert: 26.01.2019, 13:39
Wohnort: Wolfenbüttel
Kontaktdaten:

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von der-pw » 07.03.2019, 18:42

Ich habe jetzt mal eine Steckdose in die hinterletzte Ecke verfrachtet und werde das testen.
Schöne Grüße,
Patrick

FHEM-Enthusiast, der nun doch das ganze Geraffel auf CCU3 und IOBroker wuppen will.

lame
Beiträge: 57
Registriert: 15.02.2019, 10:01

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von lame » 07.03.2019, 18:55

der-pw hat geschrieben:
07.03.2019, 18:42
Ich habe jetzt mal eine Steckdose in die hinterletzte Ecke verfrachtet und werde das testen.
Bei ca. 2m zur Antenne bekomme ich aktuell -86 dBm ↓/-54 dBm ↑ angezeigt.
Die -54 dBm aber nur wenn ich den Taster an der Steckdose betätige.
Hab aber noch keine Aussetzter gehabt.
Viele Grüße
Lars

der-pw
Beiträge: 25
Registriert: 26.01.2019, 13:39
Wohnort: Wolfenbüttel
Kontaktdaten:

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von der-pw » 08.03.2019, 09:37

Es macht offensichtlich einen Unterschied, ob du am Taster auslöst oder "remote".
Zumindest habe ich das so, bei allen Selbstbau-Aktoren.
Erklären kann ich das aber nicht, dafür stecke ich zu wenig im Detail.

Letztlich halte ich es wie Jérôme, und ergänze um: "Wenn du es durch Freqtest nun stabil laufen hast, mach dir um die RSSI-Werte keine Gedanken." ;-)
Schöne Grüße,
Patrick

FHEM-Enthusiast, der nun doch das ganze Geraffel auf CCU3 und IOBroker wuppen will.

lame
Beiträge: 57
Registriert: 15.02.2019, 10:01

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von lame » 08.03.2019, 11:47

der-pw hat geschrieben:
08.03.2019, 09:37
...mach dir um die RSSI-Werte keine Gedanken." ;-)
Werd ich tun...
Viele Grüße
Lars

kpwg
Beiträge: 5
Registriert: 29.09.2018, 15:09

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von kpwg » 24.03.2019, 08:58

Guten Morgen,

Hat jemand in den letzten Tagen(Wochen) mit dem aktuellen AskSinPP-master den Sketch in Betrieb genommen?

Ich habe folgendes Problem: Die Dose lässt sich nicht mit dem Taster am Gerät schalten. Es passiert nichts. Anlernen mit dem selben Taster ist kein Problem, ebenso zuverlässiges Schalten über die Oberfläche, RSSI ist im grünen Bereich.

Ich habe bereits vor Monaten zwei Dosen nach dem Schema umgebaut, welche sofort komplett funktionierten, die drei aktuellen Dosen haben alle das selbe Problem. Wo sollte ich suchen?

Viele Grüße, Ricardo

jp112sdl
Beiträge: 2715
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von jp112sdl » 24.03.2019, 09:39

kpwg hat geschrieben:
24.03.2019, 08:58
Ich habe folgendes Problem: Die Dose lässt sich nicht mit dem Taster am Gerät schalten. Es passiert nichts.
Hab mir den Sketch gerade mit der aktuellsten AskSin++ auf meinen Test-ProMini geflasht.
Kurzer Tastendruck am Anlerntaster (Pin 8 ) toggelt den Schaltzustand und das wird auch in der WebUI angezeigt.
Zuletzt geändert von jp112sdl am 24.03.2019, 09:59, insgesamt 1-mal geändert.

VG,
Jérôme

stan23
Beiträge: 525
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Kontaktdaten:

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von stan23 » 24.03.2019, 09:55

Hi Ricardo,

hast du einen FTDI-Adapter und kannst auslesen was die serielle Schnittstelle ausgibt? Natürlich ohne 230V!
Viele Grüße
Marco

RaspberryMatic
~60 Geräte (HM, HmIP, HMW, HBW, AskSin)

kpwg
Beiträge: 5
Registriert: 29.09.2018, 15:09

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von kpwg » 24.03.2019, 11:39

Danke Jérôme fürs gegen-testen.

Habe gleich mal ein altes Siemens-Datenkabel recycelt und mit CuteCom angeschlossen.

Beim Einschalten:

Code: Alles auswählen

[11:32:51:804] AskSin++ V3.1.7 (Mar 16 2019 18:51:53)␊
[11:32:51:811] Address Space: 32 - 256␊
[11:32:51:822] CC init1␊
[11:32:51:822] CC Version: 14␊
[11:32:51:838]  - ready␊
[11:32:53:983] <- 0E 01 A2 10 110919 F11034 06 01 00 00 00  - 2181␊
[11:32:54:118] -> 0A 01 80 02 F11034 110919 00  - 2316␊
[11:32:54:128] waitAck: 01␊
Beim Taster an der Dose drücken:

Code: Alles auswählen

[11:33:02:863]  debounce␊
[11:33:02:905]  pressed␊
[11:33:03:011]  released␊
[11:33:03:013] -> 0B 02 02 40 110919 110919 01 02  - 2842␊
[11:33:03:054] ␊
über Funk einschalten:

Code: Alles auswählen

[11:55:15:238] -> 0E 02 A0 11 F11034 110919 02 01 C8 00 00  - 3547␊
[11:55:15:366] <- 0E 02 80 02 110919 F11034 01 01 C8 00 5E  - 3676␊
über Funk ausschalten:

Code: Alles auswählen

[11:55:30:569] -> 0E 03 A0 11 F11034 110919 02 01 00 00 00  - 4225␊
[11:55:30:694] <- 0E 03 80 02 110919 F11034 01 01 00 00 58  - 4352␊

jp112sdl
Beiträge: 2715
Registriert: 20.11.2016, 20:01
Kontaktdaten:

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von jp112sdl » 24.03.2019, 12:10

Hast du das interne Peering gelöscht?
Wenn man das entfernt, passiert genau das, was du beschreibst...

Am besten mal das Gerät komplett resetten (Anlerntaster drücken bis RESET im seriellen Monitor erscheint), danach neu anlernen.
Dateianhänge
Bildschirmfoto 2019-03-24 um 12.09.53.png

VG,
Jérôme

kpwg
Beiträge: 5
Registriert: 29.09.2018, 15:09

Re: Umbau OBI-Wifi-Stecker zu HM-LC-Sw1-Pl-DN-R1_OBI

Beitrag von kpwg » 24.03.2019, 12:32

Krass, genau das wars :shock:

Das interne Peering hat es offenbar nie gegeben, denn alle drei neuen Dosen hatten das Problem und funktionieren erst nach RESET.

Wieder was gelernt: nach dem Aufbau mit RESET initialisieren, falls es nicht gleich klappen will.

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“