HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

magnum1795
Beiträge: 170
Registriert: 13.05.2020, 17:56
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 28 Mal
Danksagung erhalten: 13 Mal

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von magnum1795 » 18.03.2021, 14:35

jp112sdl hat geschrieben:
26.09.2020, 17:37
Hi,

...

Der Vl53l0 arbeitet ja von 2.6...3.5V, dann könntest du theoretisch auf die das ganze RAW-Zeugs verzichten (R2, R3, 5V Versorgung) und die Schaltung direkt mit 3(.3)V versorgen, musst dann aber im Sketch die Batteriemessung ändern auf IrqInternalBatt statt BatterySensorUni<BATT_SENS_PIN, BATT_EN_PIN, 0>
...
@ jp112sdl

möchte nochmal kurz dieses Thema raufholen. Habe mir nun mehrere VL53L0X Time of Flight Sensor gekauft, aber noch nicht verbaut. Um sicher zu sein und die Teile nicht gleich zu schrotten, hätte ich noch paar Fragen dazu.

Ich habe den Sketch angepasst auf 3,3 Volt Betrieb. Heißt also ich habe den ganzen Eintrag BatterySensorUni<BATT_SENS_PIN, BATT_EN_PIN, 0> gelöscht und stattdessen nun nur noch IrqInternalBatt dort eingefügt. Sollte ja soweit Richtig sein wenn ich dich verstanden habe. Hardwaremäßig habe ich die Widerstände R2, R3 nicht verbaut.

Nun aber eine Frage zum Anschluss des VL53L0X. Dieser hat ja 6 Anschlüsse. VCC, GND, SDA, SDL, GPIO1 und XSHUT.
Hier schließe ich ja dann VCC an VCC, GND an GND soweit ist es klar. An welche Pins des Arduiono aber schließe ich den dann SDA und SDL an? Ich gehe davon aus das die Pins SDA an A4 und SDL an A5 kommen, Richtig? Und die beiden anderen bleiben frei.

Muss ich da noch etwas anderes anpassen außer das mit der Batterie in dem Sketch (https://github.com/jp112sdl/HB-UNI-Sen- ... EV-TOF.ino) oder sollte dann soweit alles passen, auch mit den Pin´s A4 und A5? Ich frage nur, weil ich im Sketch keine Pindefinierung A4, A5 oder Pin 18 und Pin 19 (was ja SDA bzw SDL entsprechen sollte) finde. Und Endschuldige meine Fragen, sehe da aber noch nicht richtig durch wie der VL53LOX dann angesprochen wird.

Sage schonmal Danke
Zuletzt geändert von magnum1795 am 18.03.2021, 16:25, insgesamt 1-mal geändert.

jp112sdl
Beiträge: 9720
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 613 Mal
Danksagung erhalten: 1451 Mal
Kontaktdaten:

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von jp112sdl » 18.03.2021, 15:21

Hi,

sollte so klappen.
magnum1795 hat geschrieben:
18.03.2021, 14:35
weil ich im Sketch keine Pindefinierung A4, A5 oder Pin 18 und Pin 19 (was ja SDA bzw SDL entsprechen sollte) finde
A4 und A5 sind die hardwareseitigen I2C Pins des 328P.
Bild

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

magnum1795
Beiträge: 170
Registriert: 13.05.2020, 17:56
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 28 Mal
Danksagung erhalten: 13 Mal

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von magnum1795 » 20.03.2021, 17:56

@jp112sdl

habe es nun zusammengabaut und angeschlossen. Funktioniert soweit gut in der Regentonne. Habe aber einen kleinen "Schwimmkörper" in Form einer dünnen Styropor Deckenplatte zugeschnitten und mit reingelegt. Klappt mit der Anzeige und Messung nun.

Was mir aber nun aufgefallen ist, beim HB-UNI-Sen-LEV-US Sensor hast du ja eine Füllhöhe und zusätzlich die Temperaturanzeige mit eingebaut. Dort funktioniert es wirklich gut.

Meine Frage wäre diesbezüglich, könntest du bitte die Füllhöhe und eben die Temperaturanzeige zusätzlich in den Sketch für den HB-UNI-Sen-LEV-ToF mit einbauen? Diese VL53L0X Sensoren haben einen sehr kleinen "Öffnungswinkel" und messen bis ca. 2 Meter ziemlich genau, was sie für eben die Regentonnen gerade zu prädistiniert. Meine Regentonnen haben zum Beispiel nur eine Fläche von ca. 350mm x 500mm und sind etwa 178cm hoch. Da gab/gibt es mit den normalen SR04 massive Probleme und es wird meist schon nach ca. 50 cm die Wand gemessen/reflektiert, was nun mit den VL53LOX nicht mehr ist. ich hoffe das du mir da weiter helfen kannst mit den Zusätzlichen Anzeigen. Sage schonmal vielen Dank.

PS: Aufgebaut sind sie auf der Platine von Alexander Reinhart HB-UNI-SENS-BATT. Aber da dort beim Einbauort sowieso schon Strom anliegen tut, habe ich ein kleines mini Netzteil 220V auf 3,3 Volt mit eingebaut und brauche daher keine Batterien
Dateianhänge
PXL_20210320_170233088.jpg
PXL_20210320_170217920.jpg
8.jpg
7.jpg
6.jpg

jp112sdl
Beiträge: 9720
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 613 Mal
Danksagung erhalten: 1451 Mal
Kontaktdaten:

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von jp112sdl » 21.03.2021, 16:02

Vielleicht... irgendwann... in nächster Zeit jedoch nicht.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

truk0649
Beiträge: 75
Registriert: 26.11.2019, 20:04
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von truk0649 » 24.05.2021, 18:43

Hi
ich habe bisher die Raspi Version 3.53.30.20201024 genutzt in Zusamennehang mit Rpi3+ und dem Ultraschallsensor SRT 04. Alles war auch ok mit der Anzeige.
Jetzt habe ich einen update auf 3.57.5.20210424 durchgeführt und habe jetzt das Problem dass mit die aktuelle Füllhöhe nicht mehr angezeigt wird.
Stattdessen "Filling Height 0" obwohl die Sprachwahl auf Deutsch war.
Gibt es dafür eine Erklärung ?
Danke in Voraus
truk
Screenshot (28).png

jp112sdl
Beiträge: 9720
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 613 Mal
Danksagung erhalten: 1451 Mal
Kontaktdaten:

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von jp112sdl » 24.05.2021, 19:25

Welche Addon Version hast du installiert?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

truk0649
Beiträge: 75
Registriert: 26.11.2019, 20:04
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von truk0649 » 24.05.2021, 19:49

Oh Ich habe noch die 3.3 im Einsatz...

jp112sdl
Beiträge: 9720
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 613 Mal
Danksagung erhalten: 1451 Mal
Kontaktdaten:

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von jp112sdl » 24.05.2021, 20:17

truk0649 hat geschrieben:
24.05.2021, 19:49
Oh Ich habe noch die 3.3 im Einsatz...
Um es sauber zu haben - installier Addon V 5.2 und danach schieb noch mal unbedingt die RaspberryMatic 3.57.5.20210424 drüber :!:

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

truk0649
Beiträge: 75
Registriert: 26.11.2019, 20:04
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von truk0649 » 24.05.2021, 22:06

Danke Jerome das war die Lösung :roll: :roll: :roll:

Beetle2003
Beiträge: 1
Registriert: 24.08.2021, 20:02
System: keine Zentrale (nur Pairing, FHEM etc.)

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von Beetle2003 » 24.08.2021, 20:08

myoo hat geschrieben:
17.07.2020, 00:33
:idea:
Es scheint irgendwie mit dem SENSOR_EN_PIN zu tun zu haben. Wenn ich den direkt an VCC hänge funktioniert es einwandfrei und ich bekomme die gleichen Meßergebnisse wie beim Test-Sketch - bis runter auf 4cm. :)

:arrow: Die Aufwachzeit habe ich bis auf 5000ms getestet - hat leider nichts am Meßergebnis geändert.

:arrow: nointerrupts() und interrupts(); habe ich um diesen Block herum gesetzt - hat leider auch nicht geholfen.
https://github.com/jp112sdl/HB-UNI-Sen- ... #L156-L175

:arrow: Ich habe die noch freien PINS 2,3,5,6,7,9 für SENSOR_ECHO_PIN und SENSOR_EN_PIN durchprobiert. Aber auch dies ohne Erfolg.

Ich habe das auch noch mit 2 anderen US-100 ausprobiert. Aber auch dort scheint nur der direkte Anschluss des Sensors an VCC zu einem brauchbaren Ergebnis bei kurzen Distanzen zu führen. Das ist sicherlich nicht so optimal für den Gesamtstromverbrauch, aber schon mal besser als vorher. :D

Hallo,

ich muss das Thema noch einmal ausgraben.

Hast Du eine Lösung gefunden?
Ich habe den 3. Füllstandssensor neu gebaut. Hierfür natürlich einen neuen JSN-SR04T V20 gekauft.

Nun geht es mir so wie Dir. Habe zufällig die gleichen Versuche gemacht. Ergebnis: Den VCC des Sensors direkt an VCC des Adruino - er misst.
Nachteil: Jeden Tag wird die Batterie 0,1V leerer obwohl ich das Messinterval auf 2600sec gestellt habe.

Ich betreibe den Sensor im Mode 1. Ist das ggf der Fehler?

Danke

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“