HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

magnum1795
Beiträge: 112
Registriert: 13.05.2020, 17:56
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 16 Mal
Danksagung erhalten: 7 Mal

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von magnum1795 » 02.08.2020, 15:37

Muss das ganze Thema noch mal hochholen. Ich habe mir ja 2 Stück Füllstandsensoren nach dieser Anleitung (https://github.com/jp112sdl/HB-UNI-Sen-LEV-US)selbst gebaut und funktionieren auch (Teilweise). Problem ist aber, das sie Regelmäßig falsche Werte liefern. Habe es mal paar Wochen beobachtet und man kann eine sehr gute "Regelmäßigkeit" feststellen.

Dazu muss ich sagen, der Sensor ist fest verbaut in einen Brunnen. Dazu wurde ein 110mm Loch gebohrt und in dieses dann ein ca. 120 Meter langes KG Rohr eingebracht. In diesen sitzt Mittig der Sensor. Der Brunnen ist etwa 4 Meter tief, wobei der Sensor etwa 2.60 Meter über den Wasserspiegel hängt.Der max. Wasserspiegel im Brunnen liegt bei etwa 1,20 Metern, was aber schon sehr lange nicht mehr der fall war. Zur Zeit pendelt der Wasserstand so zwischen 65 bis 75 cm, jenachdem ob die Tiefbrunnenpumpe gerade fördert oder eben nicht. Der Sensor wird weder bewegt im Rohr noch sonstwas was das Messergebnis so fälschen könnte. Einzig ist, das meine Sensoren (MaxSonarMB1040) nicht mit Batterie, sondern mit einen MiniNetzteil 220 Volt zu 5 Volt betrieben werden und somit direkt mit dem 220 Volt Netz verbunden sind. Die Schaltung und der Aufbau ist aber genau so wie oben im Link gebaut worden. Es wurden keine Veränderungen gemacht, weder am Sketch noch an der Hardware. Also alles so Original wie dort vorgestellt, inkl. den Widerständen etc.

Ich kann es mir einfach nicht erklären warum der Sensor Regelmäßig "aussteigt und falsche Werte" anzeigt. Kann mir vielleicht einer der "Spezialisten" hier mal einen Tipp geben an was denn nun liegen könnte oder was ich verändern müsste um das es eben in Zukunft Richtig gemessen/angezeigt wird?

Im Diagramm (von einer Woche) sieht man ganz deutlich, wenn der Wasserstand 1,20 Meter angezeigt wird (obere Linie), was definitiv falsch ist. (er steigt nie und nimmer 50 cm in so kurzer Zeit, noch dazu bei absoluter Trockenheit wie wir sie jetzt haben) Die unteren Striche geben den tatsächlichen Wasserstand "Richtig" an. Bin nun Ratlos an was denn nun liegen kann.Die Funkwerte sind zwar nicht die besten, sollten dennoch aber Ausreichend sein, Oder? Bitte um Hilfe. Danke
Dateianhänge
4.jpg
3.jpg
IMG_20200802_152807.jpg
1.jpg

lips1
Beiträge: 88
Registriert: 13.10.2012, 20:29

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von lips1 » 08.08.2020, 07:29

Hallo,
ich spiele gerade mit dem Füllstandssensor. Als Sensoren habe ich den SR04, den US-100 und den GY-US42V2 (Maxsonar) getestet.
Ich will das ganze für meinen geschweißten Heizöltank verwenden.

- Kann der Messintervall für Test / Einrichtungszwecke verkürzt werden? Dauerbetrieb? Wenn ja, wie muss der Code angepasst werden?
- Die Rohwerte (RS232) werden bei mir bei allen drei Sensoren falsch angezeigt. Wenn ich 50cm Entfernung habe, werden 100cm und bei 60cm 120cm Angezeigt. Also immer das Doppelte.

Grüsse lips
Rasp 3 mit piVCCU3, HM-Wired/Funk, 103 Geräte

jp112sdl
Beiträge: 6457
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 308 Mal
Danksagung erhalten: 623 Mal
Kontaktdaten:

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von jp112sdl » 08.08.2020, 08:17

lips1 hat geschrieben:
08.08.2020, 07:29
Die Rohwerte (RS232) werden bei mir bei allen drei Sensoren falsch angezeigt.
Hast du 57600 Baud oder was anders im seriellen Monitor eingestellt?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

lips1
Beiträge: 88
Registriert: 13.10.2012, 20:29

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von lips1 » 08.08.2020, 11:05

115200 Baud, bei 57600 Baud kommen nur wirre Zeichen.
Rasp 3 mit piVCCU3, HM-Wired/Funk, 103 Geräte

jp112sdl
Beiträge: 6457
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 308 Mal
Danksagung erhalten: 623 Mal
Kontaktdaten:

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von jp112sdl » 08.08.2020, 11:26

lips1 hat geschrieben:
08.08.2020, 11:05
115200 Baud, bei 57600 Baud kommen nur wirre Zeichen.
Dachte ich mir fast... :wink:
Also entspricht deine Hardware nicht der aus der Projektbeschreibung.
Du hast einen 16MHz getakteten Arduino Pro Mini statt 8 MHz

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

lips1
Beiträge: 88
Registriert: 13.10.2012, 20:29

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von lips1 » 08.08.2020, 11:44

Ok muss ich mal mit dem Scope nachmessen. Gekauft hatte ich eigentlich einen Pro Mini 3,3V mit 8Mhz.
Das Funkmodul läuft aber sauber. Ist in der CCU angemeldet. Zum Abgleich des Funkmoduls hatte ich den Test Sketch laufen.
Rasp 3 mit piVCCU3, HM-Wired/Funk, 103 Geräte

lips1
Beiträge: 88
Registriert: 13.10.2012, 20:29

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von lips1 » 08.08.2020, 12:36

Also es sind tatsächlich 16MHz :oops:

Wie sieht es mit dem verkürzen des Messintervals aus? Aktuell sind es ja 10s. Zum einrichten im Tank währe schneller besser.

Lips
Rasp 3 mit piVCCU3, HM-Wired/Funk, 103 Geräte

jp112sdl
Beiträge: 6457
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 308 Mal
Danksagung erhalten: 623 Mal
Kontaktdaten:

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von jp112sdl » 08.08.2020, 12:43

lips1 hat geschrieben:
08.08.2020, 12:36
Also es sind tatsächlich 16MHz
Dann ist da auch bestimmt ein 5V LDO verbaut, d.h. dein CC1101 wird grad etwas überstrapaziert.
lips1 hat geschrieben:
08.08.2020, 12:36
Wie sieht es mit dem verkürzen des Messintervals aus? Aktuell sind es ja 10s. Zum einrichten im Tank währe schneller besser.
https://github.com/jp112sdl/HB-UNI-Sen- ... S.ino#L305
Schreibst da statt _txMindelay die Sekunden rein

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

lips1
Beiträge: 88
Registriert: 13.10.2012, 20:29

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von lips1 » 08.08.2020, 13:47

Danke. Werde ich testen.

Lips
Rasp 3 mit piVCCU3, HM-Wired/Funk, 103 Geräte

magnum1795
Beiträge: 112
Registriert: 13.05.2020, 17:56
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 16 Mal
Danksagung erhalten: 7 Mal

Re: HB-UNI-Sen-LEV-US - Ultraschall Füllstandsensor

Beitrag von magnum1795 » 17.08.2020, 17:17

Habe mal eine Frage wegen der Berechnung der Füllmenge in L. Wenn ich mich noch recht erinnere (Schulzeit ist schon sehr lange her :lol: ) wird doch das Volumen mit der Formel pi*r²*h berechnet. Mein Brunnen hat z.B. innen 1 Meter Durchmesser. Die gemessene (und auch fast genaue 67 cm) Füllhöhe beträgt 68 cm. Wenn ich dies nun zur Berechnung heranziehe, kommt z.B. eine Literzahl von rund 534 Liter heraus. In der Anzeige steht aber "nur" 471 L.
Nicht das mich das unbedingt stören würde, möchte aber dennoch gern wissen warum das so ist.
Dateianhänge
zy.gif
zy.gif (943 Bytes) 144 mal betrachtet
11.jpg
10.jpg

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“