HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 21.09.2018, 20:08

Puuuh, Fuses geändert... hab ich noch nie gemacht.
Weiss nicht, ob ich das hinbekomme.

Kann es sein, das die Arduinos von chinaland unterschiedlich eingestellt sind?

jp112sdl
Beiträge: 3351
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 37 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 21.09.2018, 20:18

Garagenloeter hat geschrieben:
21.09.2018, 20:08
Kann es sein, das die Arduinos von chinaland unterschiedlich eingestellt sind?
Eigentlich nicht.
Die stehen per Default auf 2.7V.

VG,
Jérôme

Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 21.09.2018, 20:49

Dann sind die ja so für den batteriebetrieb ja eher ungeeignet.

jp112sdl
Beiträge: 3351
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 37 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 21.09.2018, 21:00

So wie sie ausgeliefert werden - ja.

Fuses setzen dauert keine 10 Sekunden. Man benötigt jedoch einen ISP dafür.

VG,
Jérôme

Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 21.09.2018, 21:02

naja, wenn man weiss wie, ist man ganz weit vorne...
Ich weiss es nicht.

deimos
Beiträge: 3044
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 10 Mal
Danksagung erhalten: 54 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von deimos » 21.09.2018, 21:09

Hi,

Suchfunktion mit den Worten "Fuses setzen" führt einen ganz schnell hierhin: viewtopic.php?f=76&t=41932&p=428275&hil ... en#p428177

Viele Grüße
Alex

jp112sdl
Beiträge: 3351
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 37 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 21.09.2018, 21:16

Ja - so wie @deimos schreibt.
Hier noch mal die Kurzfassung:
1.) ISP kaufen - für das Fuses Zeugs reicht ein billiger.
Ich habe diesen hier: https://www.ebay.de/itm/272275171388
Andere mögen vielleicht einen Diamex empfehlen. Diesen habe ich auch daheim. Aber den brauchte ich bisher erst 1x um einen gebrickten 328P wiederzubeleben.
Man könnte sogar einen Arduino UNO als ISP verwenden (https://www.arduino.cc/en/Tutorial/ArduinoISP)

2.) ISP an Pro Mini anschließen: https://qph.fs.quoracdn.net/main-qimg-f ... 2147a632-c

3.) Fuses setzen mit

Code: Alles auswählen

avrdude –c usbasp –p m328p -U lfuse:w:0xff:m -U hfuse:w:0xd2:m -U efuse:w:0xff:m
Fertig.

EDIT: Das CC1101 kann dabei auch schon angelötet sein!

VG,
Jérôme

Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 21.09.2018, 21:33

super, danke.
so nen ISP hab ich hier irgendwo noch rumliegen. Ich werde das mal antesten.

Garagenloeter
Beiträge: 200
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 22.09.2018, 14:25

ich diesen hier:
https://www.ebay.de/itm/AVR-51-grammer- ... 0005.m1851

Nach langem hin und her, hab ich den Treiber installiert bekommen. W7 32bit.
Aus einem Passendem Flachbandkabel und ner Pfostenleiste hab ich noch nen Adaper gelötet.


Muss der nicht in der IDE auf einem COM Port erscheinen? tut er bei mir nicht.

jp112sdl
Beiträge: 3351
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 37 Mal
Danksagung erhalten: 70 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 22.09.2018, 15:10

Bei Windoof bin ich raus

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“