HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

dondaik
Beiträge: 10055
Registriert: 16.01.2009, 18:48
Wohnort: Steingaden
Hat sich bedankt: 10 Mal
Danksagung erhalten: 13 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von dondaik » 22.09.2018, 16:07

unter windows als: com / lpt ... usb-serial ....
in der IDE sollte dann zu sehen sein welcher vom port ...
-------
wer schreibfehler findet darf sie behalten.

Garagenloeter
Beiträge: 180
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 22.09.2018, 16:30

im Geräte Manager taucht der auch auf, aber nicht in der IDE... :?

jp112sdl
Beiträge: 3027
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 7 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 22.09.2018, 16:42

So, hab mir deinen Link mal angeschaut...
Das ist ja der, den ich auch hab.
Der emuliert keinen "COM-Port" / serielle Schnittstelle und wird auch nicht als Port in der Arduino IDE aufgelistet.

Brauchst du zum Setzen der Fuses eh nicht, weils nicht aus der Arduino IDE heraus geht.

Möchtest du jedoch den Sketch mithilfe deines ISP flashen, musst du bei Werkzeuge->Programme "USBasp" auswählen.
Und dann Sketch -> "Hochladen mit Programmer"

VG,
Jérôme

jp112sdl
Beiträge: 3027
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 7 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 22.09.2018, 16:43

Wenn du dir den Befehl zum Setzen der Fuses mittels USBasp ISP von gestern anschaust, ist dort auch kein serieller Port angegeben...

Code: Alles auswählen

avrdude –c usbasp –p m328p -U lfuse:w:0xff:m -U hfuse:w:0xd2:m -U efuse:w:0xff:m

VG,
Jérôme

Garagenloeter
Beiträge: 180
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 22.09.2018, 18:14

was ich nicht verstehe, warum muss beim Arduino ein COM Port ausgewählt werden, und beim USBasp nicht.
Die IDE weiss dochsonst gar nicht, an welchen COM Port die Daten rausschicken muss
Und Sketch hochladen über den Programmer geht auch nicht:

Code: Alles auswählen

Arduino: 1.8.6 (Windows 7), Board: "Arduino Pro or Pro Mini, ATmega328P (3.3V, 8 MHz)"

In file included from C:\Users\Juergen\Documents\Arduino\Homematic Ordner\HM-WDS40-TH-I-BME280\HM-WDS40-TH-I-BME280.ino:10:0:

C:\Users\Juergen\Documents\Arduino\libraries\EnableInterrupt/EnableInterrupt.h:22:125: note: #pragma message: NOTICE: *** EnableInterrupt library version pre-0.9.6. This is not a problem. Keep calm, and carry on. ***

#pragma message("NOTICE: *** EnableInterrupt library version pre-0.9.6. This is not a problem. Keep calm, and carry on. ***")

^

Der Sketch verwendet 23530 Bytes (76%) des Programmspeicherplatzes. Das Maximum sind 30720 Bytes.
Globale Variablen verwenden 1082 Bytes (52%) des dynamischen Speichers, 966 Bytes für lokale Variablen verbleiben. Das Maximum sind 2048 Bytes.
avrdude: Warning: cannot query manufacturer for device: No such file or directory
Beim Hochladen des Sketches ist ein Fehler aufgetreten
avrdude: Warning: cannot query product for device: No such file or directory
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'
Ich glaub inzwischen, das der Treiber nicht passt.

jp112sdl
Beiträge: 3027
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 7 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 22.09.2018, 18:38

Garagenloeter hat geschrieben:
22.09.2018, 18:14
Die IDE weiss dochsonst gar nicht, an welchen COM Port die Daten rausschicken muss
Weil beim "Hochladen mit Programmer" der Programmer angesprochen wird.
Je nach Programmer wird ein serieller Anschluss emuliert.
Beim USBasp jedoch nicht.
Dort wird an den USB-Ports nach einem Gerät mit den Eigenschaften "USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'" gesucht.
Ob überhaupt Treiber notwendig sind, mag ich bald gar nicht festmachen.
Beim Mac brauchte ich jedenfalls keine. Weil das Gerät direkt angesprochen wird.

VG,
Jérôme

Garagenloeter
Beiträge: 180
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 22.09.2018, 20:40

Ich gebs fürs erste auf.
Ich bekomm das Ding nicht ans laufen. :(

Danke für Eure Geduld.

deimos
Beiträge: 2884
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 3 Mal
Danksagung erhalten: 14 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von deimos » 22.09.2018, 20:49

Hi,

ich kann da nur den Diamex empfehlen, der rennt einfach.
Der usbasp ist kein echter USB Chips, sondern der MC da drauf hat eine USB Software Emulation und die macht immer mal wieder Probleme.

Viele Grüße
Alex

Garagenloeter
Beiträge: 180
Registriert: 04.07.2018, 21:52
Hat sich bedankt: 1 Mal

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von Garagenloeter » 22.09.2018, 21:17

also mit anderen Worten: Müll

jp112sdl
Beiträge: 3027
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 7 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: HB-UNI-SENS-BAT mit HM-WDS40-TH-I-BME280 frißt Batterien

Beitrag von jp112sdl » 22.09.2018, 21:28

Bei mir läuft er 1a.
Hatte erst vermutet, dass er mir die 328 schrottet.
Lag aber an mir bzw an meiner „Fehlbedienung“.
Ist schön kompakt und steckt direkt im USB Port.

Mag jeder seinen Lieblings-ISP haben :)

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“