Erstes Projekt: HB-UNI-Sen-LEV-US

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

DocMarten
Beiträge: 136
Registriert: 12.11.2006, 23:33

Re: Erstes Projekt: HB-UNI-Sen-LEV-US

Beitrag von DocMarten » 02.12.2018, 23:10

Hat es schon mal jemand damit probiert? Scheints für 1m, 2m... zu geben: https://www.aliexpress.com/item/ATA100- ... 81591.html
Standort 1: FS20 + Homematic mit CUL und FHEM (immer aktuelle Ver.) auf Raspberry Pi
Standort 2: Homematic (Wired + einige Funkmodule) über CCU2 und PocketHome HD, VCCU auf Raspberry
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods)

DocMarten
Beiträge: 136
Registriert: 12.11.2006, 23:33

Re: Erstes Projekt: HB-UNI-Sen-LEV-US

Beitrag von DocMarten » 29.12.2018, 11:58

Moin,
endlich bin ich meiner Zisterne und somit dem Ernstfall-Einsatzort nah... einbinden in CCU2 hat reibungslos geklappt, die über fhem gesetzten Register sind erwartungsgemäß erhalten.
Habe die aktuelle ino geflashed, seitdem meldet der Sensor "Batterieladezustand gering" an die CCU, auch mit nagelneuen Batterien.
Einstellungen sind default: Low-Bat.-Schwelle 2.2, melden tut der Sensor eine Spannung von 0,0 V.
Habe jetzt die vorherige Version wieder eingespielt.
Grüße
Martin
Standort 1: FS20 + Homematic mit CUL und FHEM (immer aktuelle Ver.) auf Raspberry Pi
Standort 2: Homematic (Wired + einige Funkmodule) über CCU2 und PocketHome HD, VCCU auf Raspberry
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods)

jp112sdl
Beiträge: 3163
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 20 Mal
Danksagung erhalten: 43 Mal
Kontaktdaten:

Re: Erstes Projekt: HB-UNI-Sen-LEV-US

Beitrag von jp112sdl » 29.12.2018, 12:12

Hast du den Spannungsteiler auch richtig angeschlossen?

Das Problem bei der alten Ino ist, dass dort niemals LowBat kommt und immer irgendwas mindestens um 3.3...3.6V gemessen wird

VG,
Jérôme

DocMarten
Beiträge: 136
Registriert: 12.11.2006, 23:33

Re: Erstes Projekt: HB-UNI-Sen-LEV-US

Beitrag von DocMarten » 29.12.2018, 18:16

Habe an der verlöteten Hardware nicht geändert, d.h. wenn es mit der neuen ino keine veränderten Spezifikationen bez. Widerständen gab, ist alles beim Alten.
Bei mir wurden BTW auch mit der alten ino Spannungen von 5,x Volt angezeigt.
Was bei mir nach wie vor - auch nach dem zweiten Zusammenlöten from the scratch - nie leuchtet ist die LED.
Grüße
Martin
Standort 1: FS20 + Homematic mit CUL und FHEM (immer aktuelle Ver.) auf Raspberry Pi
Standort 2: Homematic (Wired + einige Funkmodule) über CCU2 und PocketHome HD, VCCU auf Raspberry
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods)

DocMarten
Beiträge: 136
Registriert: 12.11.2006, 23:33

Re: Erstes Projekt: HB-UNI-Sen-LEV-US

Beitrag von DocMarten » 21.01.2019, 15:46

Moin,
je leerer der Tank wird (= je größer der Abstand Sensor <> Wasseroberfläche), um so problematischer scheint es mit den Reflexionen zu werden (s. Grafik im Anhang, bis zum 16.1. stabil, dann eine größere Wasserentnahme. Am 17., 18. und 20.1. stieg der Wasserstand durch Niederschläge wieder etwas, aber die Messung hat wilde Ausschläge, obwohl die Wände eigentlich weit genug entfernt sind. Vielleicht wird ja auch von der Wasseroberfläche an die Betondecke des Beckens reflektiert und von da unkontrolliert gestreut. Allerdings gab es zwischendurch ja auch Tage, an denen die Messung stabil blieb.
Aber... soeben ist der Drucksensor angekommen, nun werde ich mal versuchen, den anstelle des US-Sensors zu integrieren. Ich fange aber dafür mal einen separaten Thread an, damit der Titel nicht in die Irre leitet.
Grüße
Martin
Dateianhänge
IMG_1238.JPG
IMG_1237.JPG
homebrew_US.jpg
Standort 1: FS20 + Homematic mit CUL und FHEM (immer aktuelle Ver.) auf Raspberry Pi
Standort 2: Homematic (Wired + einige Funkmodule) über CCU2 und PocketHome HD, VCCU auf Raspberry
3 x Raspi3 mit piCorePlayer/Kodi für Multiroom Audio (+ Tablets/iPeng/iPods)

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“