HB-UNI-Sen-CAP-MOIST

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

jp112sdl
Beiträge: 3388
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 41 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von jp112sdl » 09.06.2019, 18:45

Hast du Technikkram mal angeschrieben?
Dass man den Sensor noch kalibrieren muss, haben sie auch bis heute nicht erwähnt.

VG,
Jérôme

JoeBerlin
Beiträge: 6
Registriert: 14.03.2019, 15:32

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von JoeBerlin » 09.06.2019, 19:20

Ich habe ja bei die Analogwerte gepostet. Diese unterscheiden sich im Nass- und Trockenzustand augenscheinlich nicht. Das Kalibrieren wäre ja der nächste Schritt nach aussagekräftigen Analogwerten. Aber ich gebe dir Recht und frage nochmal bei Technikkram nach einem passenden .ino -File.

JoeBerlin
Beiträge: 6
Registriert: 14.03.2019, 15:32

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von JoeBerlin » 09.06.2019, 22:46

Habe soeben erfahren, dass an dem Projekt kräftig gearbeitet wird und einen Probesketch erhalten, der bei schnellem Rüberschauen gute Analogwerte liefert.
Danke für Eure Hilfe und Arbeit.

Christian295
Beiträge: 16
Registriert: 10.11.2018, 08:03

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von Christian295 » 10.06.2019, 09:02

In der Bauanleitung sind die Sensorkabel vertauscht. Deshalb bekommst Du keine Messwerte. Braun und Blau tauschen. Dann geht es.

Christian295
Beiträge: 16
Registriert: 10.11.2018, 08:03

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von Christian295 » 10.06.2019, 18:08

Ich habe auch noch ein Problem mit Versorgungsspannungsanzeige. Ich habe PIN A3 (17) und 6 definiert.
Ausgelesen wird aber immer 3.3 Volt bzw. 3.5 Vol,t wenn der Apadter angeschlosssen ist. Vermutlich wird mir immer VCC angezeigt und nicht die
Spannung am Eingang.
Wo liegt mein Fehler?

jp112sdl
Beiträge: 3388
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 41 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von jp112sdl » 10.06.2019, 18:10

Steht in deinem Sketch was von "BatterySensor" oder "BatterySensorUni"?

VG,
Jérôme

Christian295
Beiträge: 16
Registriert: 10.11.2018, 08:03

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von Christian295 » 10.06.2019, 18:11

typedef AskSin<LedType, BatterySensorUni<BATT_SENS_PIN, BATT_EN_PIN, 0>, RadioType> BaseHal;

Die 0 durch Zahlenwerte zu ersetzen hat keine Änderung gebracht.

jp112sdl
Beiträge: 3388
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 41 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von jp112sdl » 10.06.2019, 18:15

Ohne Adapter, mit Versorgung am RAW Pin - was wird dann gemessen?

Und wie gesagt - am master wurde was an der Batteriemessung geändert.
Habt seitdem kein AskSin Gerät mehr kompiliert.
Kann nicht ausschließen, dass die Änderung was mit deinem Problem zu tun hat.

VG,
Jérôme

Christian295
Beiträge: 16
Registriert: 10.11.2018, 08:03

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von Christian295 » 10.06.2019, 18:20

Am RAW Pin liegen 5 Volt an (kommen von einem LIPO AKku Schutz der immer 5V erzeugt. Die Akkuspannung wird über einen 470K/100K an PIN 6 und A3 zusätzlich angelegt. Intern wird RAW auf 3.3V reduziert. Diese 3.3V werden mir angezeigt.

jp112sdl
Beiträge: 3388
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 41 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:

Re: HB-UNI-Sen-CAP-MOIST

Beitrag von jp112sdl » 10.06.2019, 18:22

Hmm... mach mal die Gegenprobe, tausch mal in der AskSinPP Lib die BatterySensor.h aus und nimm dafür diese hier aus dem V4 Branch:
https://raw.githubusercontent.com/pa-pa ... rySensor.h

VG,
Jérôme

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“