Flashen mit Arduino IDE geht seltsamerweise nicht

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Antworten
Airwave
Beiträge: 24
Registriert: 19.04.2017, 09:49

Flashen mit Arduino IDE geht seltsamerweise nicht

Beitrag von Airwave » 28.12.2018, 12:39

Hallo zusammen,

ich bin gerade dabei mein erstes Projekt zu basteln aber irgendwie scheitert es an dem Flashen.
Halte mich komplett an diese Anleitung: https://jp112sdl.github.io/AskSinPPColl ... rduino-ide

Treiber für den FTDI Adapter musste ich nachinstallieren: CDM21228_Setup.exe .

Das Flashen endet mit dem Fehler, dass der Programmer nicht reagiert.

Das sind die LEDs die leuchten. Die obere Rechts am Arduino blinkt langsam.
IMAG1771.jpg
Hier die Einstellungen. Ich fand nirgend eine Angabe zu dem Programmer. Ist dieser korrekt eingestellt?
2018-12-28 12_35_29-HM-SEC-MDIR _ Arduino 1.8.8.png
2018-12-28 12_35_29-HM-SEC-MDIR _ Arduino 1.8.8.png (22.59 KiB) 286 mal betrachtet
Danke im Voraus

LG

Airwave
Beiträge: 24
Registriert: 19.04.2017, 09:49

Re: Flashen mit Arduino IDE geht seltsamerweise nicht

Beitrag von Airwave » 28.12.2018, 13:20

Hallo zusammen,

hab es selbst gefunden. Programmer muss stehen auf AVR ISP!

Aber kann die Ausgabe im seriellen Montor mit diesen ganzen Errors korrekt sein?

Code: Alles auswählen

AskSin++ V3.0.2 (Dec 28 2018 13:17:32)
Address Space: 32 - 76
CC init1
Error at 00 expected: 2E read: 00
Error at 02 expected: 06 read: 00
Error at 03 expected: 0D read: 00
Error at 04 expected: E9 read: 00
Error at 05 expected: CA read: 00
Error at 07 expected: 0C read: 00
Error at 0B expected: 06 read: 00
Error at 0D expected: 21 read: 00
Error at 0E expected: 65 read: 00
Error at 0F expected: 6A read: 00
Error at 10 expected: C8 read: 00
Error at 11 expected: 93 read: 00
Error at 12 expected: 03 read: 00
Error at 15 expected: 34 read: 00
Error at 17 expected: 03 read: 00
Error at 18 expected: 18 read: 00
Error at 19 expected: 16 read: 00
Error at 1B expected: 43 read: 00
Error at 21 expected: 56 read: 00
Error at 23 expected: E9 read: 00
Error at 24 expected: 2A read: 00
Error at 25 expected: 1F read: 00
Error at 26 expected: 11 read: 00
Error at 29 expected: 59 read: 00
Error at 2C expected: 81 read: 00
Error at 2D expected: 35 read: 00
Error at 2E expected: 09 read: 00
Error at 3E expected: 03 read: 00
CC Version: 00
Error at 3E expected: C0 read: 00
 - ready
Bat: 31
Danke im Voraus.

LG

deimos
Beiträge: 2671
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Kontaktdaten:

Re: Flashen mit Arduino IDE geht seltsamerweise nicht

Beitrag von deimos » 28.12.2018, 13:23

Hi,

da du offensichtlich keinen CC1101 angeschlossen hast, sind die Fehlermeldungen normal.

Viele Grüße
Alex

rbeudel
Beiträge: 126
Registriert: 29.06.2018, 17:37
Wohnort: Essen

Re: Flashen mit Arduino IDE geht seltsamerweise nicht

Beitrag von rbeudel » 28.12.2018, 13:26

Hallo,
bin zwar auch nur Anfänger. Kann das sein das noch kein Funkmodul angeschlossen ist? Dann kann auch noch nichts sinnvolles kommen.
Viele Grüße,
Ralf
Viele Grüße,
Ralf


Debmatic in Proxmox VM 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64 auf
Intel NUC mit influxdb und Grafana zur Visualisierung der Homematic Daten über Openhab 2.4.0, Volkszähler und SBFSpot zur Visualisierung meiner Stromzählerdaten und der Solaranlage

Airwave
Beiträge: 24
Registriert: 19.04.2017, 09:49

Re: Flashen mit Arduino IDE geht seltsamerweise nicht

Beitrag von Airwave » 28.12.2018, 21:30

Hi,

ich habe das mal provisorisch angeschlossen und ja, das war es wohl :D .

Aber nochmal eine andere Frage:

Bei Batteriebetrieb wird ja empfohlen die BuiltIn LED, die Power LED sowie den LDO zu entfernen.
Wie macht man das immer am besten? Rauslöten oder vielleicht per feinem Seitenschneider rausknipsen?
Müssen die Kontakte dann gebrückt werden?

Danke im Voraus.

LG

Benutzeravatar
DiJe
Beiträge: 474
Registriert: 04.03.2015, 05:51

Re: Flashen mit Arduino IDE geht seltsamerweise nicht

Beitrag von DiJe » 28.12.2018, 22:20

Hallo Airwave,
ich verwende immer ein spitzes Messer zum rausbrechen.
Es braucht nichts gebrückt zu werden.
Gruß Dieter

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“