HB-OU-MP3-LED

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

jp112sdl
Beiträge: 10660
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 704 Mal
Danksagung erhalten: 1689 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 09.09.2021, 21:53

luzudemca hat geschrieben:
09.09.2021, 20:59
Hat jemand vieleicht eine Idee was das sein könnte?
Hast du was am Sketch verändert? Irgendwas an Serial/Model ID?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

luzudemca
Beiträge: 2
Registriert: 09.09.2021, 20:52
System: CCU

Re: HB-OU-MP3-LED

Beitrag von luzudemca » 12.09.2021, 12:49

Ich habe jeweils bei der Serial ID und Device ID die letzte Ziffer, die 0, gegen eine 1 ersetzt. Jedoch hatte ich das selbe problem auch ohne veränderte Serial/Device ID.

Edit: Ich habe jetzt den Code neu heruntergeladen und es funktioniert jetzt, auch mit veränderter ID.

andyboeh
Beiträge: 20
Registriert: 16.06.2021, 11:07
System: sonstige
Danksagung erhalten: 3 Mal

Re: HB-OU-MP3-LED

Beitrag von andyboeh » 05.12.2021, 16:20

Hey,

ich habe mir auch eine Klingel auf Basis der Platine von ssbingo gebaut - soweit klappt alles! Interessanterweise funktioniert aber die Audio-Wiedergabe nach einigen Tagen im Betrieb nicht mehr. Die LEDs leuchten weiterhin, aber der Klingelton wird nicht mehr abgespielt. Hat das sonst auch jemand beobachtet?

Ich verwende eine Direktverknüpfung mit einem Taster (auch asksinpp, ist ein RWE Wandtaster), habe aber vergessen, zu testen, ob ich über die Zentrale dann noch Audio aktivieren kann.

LG

EDIT: Habe gerade über die DFPlayer-Module nachgelesen, offenbar gibt es unterschiedliche ICs und mein Modul ist ein "Fake": Rote Status-LED (original ist angeblich blau) und keine Lötbrücken auf der Unterseite.

t0mk
Beiträge: 208
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 19 Mal

Re: HB-OU-MP3-LED

Beitrag von t0mk » 30.01.2022, 16:00

Moin,

ich versuche den HB-OU-MP3-LED nach Asselheads Art nachzubauen:
Asselhead hat geschrieben:
24.05.2021, 12:37
ich habe mal ein alternatives Gehäuse für den HB-OU-MP3-LED gemacht, welches etwas flacher ist.
Vielleicht kann das ja noch jemand brauchen:
https://www.thingiverse.com/thing:4867745
Dementsprechend nutze ich diese Platine und diesen LED-Ring, ansonsten halt die Standardkomponenten wie Pro Mini Klon mit 8MHz, CC1101 Stamp, DFPro-MP3-Player. Auf den Lautsprecher gehe ich hier erstmal nicht ein, ich würde gerne erstmal die optische Ausgabe hinkriegen.

AskSinPP Grundschaltung funktioniert, Frequenztest ist durchgeführt, HB-OU-MP3-LED ist an der CCU angelernt, die Kanäle können auch ein und ausgeschaltet werden. Der LED-Ring funktioniert grundsätzlich, den habe ich mit WLED-Firmware getestet, läuft dort als 24 Bit WS21812B RGB einwandfrei. An HB-OU-MP3-LED bleibt er jedoch dunkel, egal was ich bis jetzt probiert habe. 5V kommen an dem Ring an, mehr kann ich mit meinem Equipment nicht testen. Netzteil ist ein 5V 2A, den ich auch mit Raspberrys nutze, ohne Unterspannungs-Probleme.

Hat noch jemant eine Idee?

Muss ich irgendwas in der SW einstellen (Bis jetzt habe ich nur von GRB auf RGB umgestellt, und später in der CCU die Anzahl der LEDS angepasst)?
20210130_CCU.png

t0mk
Beiträge: 208
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 19 Mal

Re: HB-OU-MP3-LED

Beitrag von t0mk » 03.02.2022, 22:07

Guten Abend,

ich habe mal probehalber einen Beispiel-Sketch der FastLED-Library auf den Arduino gespielt (ColorPalette), vorher natürlich den Daten-Pin und die Anzahl der LEDs angepasst. Es passiert was komisches, der LED-Ring bleibt dunkel, bis ich das Netzteil abziehe (der FTDI-Adapter bleibt dran), während der nächsten paar Sekunden leuchtet der Ring und zwar nicht irgendwie chaotisch, sondern wie er es an einem weiteren zu Testzwecken aufgesetzten Arduino mit demselben Sketch tut. Bis offenbar die Kondensatoren leer sind. An dem besagten anderen, identischen Arduino, nur halt ohne ganze Peripherie, leuchtet der Ring stundenlang (naja, zumindest minutenlang, bis ich ihn ausschalte).

Habe ich irgendwas beim Bestücken der Platine übersehen? Immerhin scheint sie ja bei einigen ohne Probleme im Einsatz zu sein :?:

t0mk
Beiträge: 208
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 19 Mal

Re: HB-OU-MP3-LED

Beitrag von t0mk » 09.02.2022, 22:08

Guten Abend,

ich unternehme noch einen letzten Versuch, fachliche Unterstützung von Euch zu bekommen ;)

Ich habe weiter mit dem Gerät rumgespielt und mittlerweile die Soundausgabe ans Laufen bekommen. Auch bezüglich der LEDs habe ich neue Erkenntnisse:
- Schließe ich die Stromversorgung an der Micro-USB-Buchse an und aktiviere die LEDs bleibt der Ring dunkel. Spiele ich parallel eine mp3-Datei ab, kommen ein paar leuchtende LED zum Vorschein. Die bewegen sich, entsprechend den eingestellten Werten und versuchen auch die Farbe zu treffen, bleiben dann abrupt stehen, wenn die Soundausgabe zu Ende ist. S. 1. Video.
- Schließe ich die Stromversorgung an dem Pin-Header an, an dem auch der LED-Ring angeschlossen wird, so leuchtet der Ring, wie man es erwarten würde. Man könnte ja sagen, Fall gelöst, dann muss die Stromversorgung eben darüber erfolgen... ABER: Spiele ich parallel eine mp3-Datei ab, wird die Beleuchtung unterbrochen / zum Stocken gebracht, s. 2. Video.

Ich habe die Stromaufnahme des Rings gemessen, die variiert zw. 25 und 200 mA, also kann es kaum an dem Netzteil oder der Platinen-Leiterbahnen liegen, oder? Aber warum spielt es eine Rolle, wo ich den Strom einspeise und warum unterbricht die Audio-Ausgabe die Beleuchtung oder macht sie erst möglich?

jp112sdl
Beiträge: 10660
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 704 Mal
Danksagung erhalten: 1689 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 09.02.2022, 22:29

t0mk hat geschrieben:
09.02.2022, 22:08
kann es kaum an dem Netzteil ... liegen
Hast du es denn mit einem anderen probiert?
Ich hatte mal ein total ungesiebtes 5V 2A Netzteil, da haben die WS2812B nur wild geblitzt.
Ggf. hilft ein dicker Elko.

Die Videos kann ich nicht anschauen. Deine Links führen zu einer mit Werbung überladenen Seite, wo irgendein Warte-Timer runterläuft.

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

t0mk
Beiträge: 208
Registriert: 08.08.2018, 20:13
Hat sich bedankt: 5 Mal
Danksagung erhalten: 19 Mal

Re: HB-OU-MP3-LED

Beitrag von t0mk » 10.02.2022, 08:00

Hi,
jp112sdl hat geschrieben:
09.02.2022, 22:29
t0mk hat geschrieben:
09.02.2022, 22:08
kann es kaum an dem Netzteil ... liegen
Hast du es denn mit einem anderen probiert?
Ich hatte mal ein total ungesiebtes 5V 2A Netzteil, da haben die WS2812B nur wild geblitzt.
Ggf. hilft ein dicker Elko.
Direkt am USB-Anschluss habe ich nur dieses eine verwendet, wie gesagt läuft es ansonsten mit nem Raspi 3B+ ohne "Undervoltage detected", damit dachte ich wäre es über jeden Zweifel erhaben. Aber ich suche noch ein anderes raus, mehr als 1A sollte ja nicht nötig sein.

Wenn Elko: über welche Dimensionen sprechen wir da und wo genau? Da wo jetzt schon 10uF-Kondensator sitzt (direkt oberhalb des Pin-Headers)? Wären 100uF dick genug?

jp112sdl hat geschrieben:
09.02.2022, 22:29
Die Videos kann ich nicht anschauen. Deine Links führen zu einer mit Werbung überladenen Seite, wo irgendein Warte-Timer runterläuft.
sorry, die Werbung nehme ich mit dem Werbe-Blocker nicht wahr, aber besonders komfortabel ist's auch so nicht. Wenn's irgendeine andere Möglichkeit ohne Anmeldezwang gibt, würde ich die Videos noch mal hochladen.

Benutzeravatar
Hoppla
Beiträge: 310
Registriert: 29.12.2018, 19:39
System: Alternative CCU (auf Basis OCCU)
Wohnort: Leipzsch
Hat sich bedankt: 27 Mal
Danksagung erhalten: 10 Mal

Re: HB-OU-MP3-LED

Beitrag von Hoppla » 14.02.2022, 22:17

Ich hab letztens nach sehr langer Zeit die Rasperrymatic auf die aktuelle Version gehoben.
Soweit alles Gut
Leider lassen sich die Auswahlmenüs für Kanalaktion nicht mehr öffnen!
Beim Bausatz "ELV Homematic Bausatz Funk-Gong-Modul MP3 mit microSD-Karten-Slot HM-OU-cm-PCB" von ELV hingegen funktioniert das noch.

Getestet in Chrome und fFox.

jp112sdl
Beiträge: 10660
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 704 Mal
Danksagung erhalten: 1689 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 15.02.2022, 06:52

Hoppla hat geschrieben:
14.02.2022, 22:17
Ich hab letztens nach sehr langer Zeit die Rasperrymatic auf die aktuelle Version gehoben.
Die neueste JP-HB-Devices-Addon ( 5.8 ) ist auch installiert?
Hoppla hat geschrieben:
14.02.2022, 22:17
Leider lassen sich die Auswahlmenüs für Kanalaktion nicht mehr öffnen!
Bei mir geht das weiterhin
Bild

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“