HB-OU-MP3-LED

Entwicklung und Bau von Hardware aller Art, die im HM-Umfeld eingesetzt werden kann

Moderator: Co-Administratoren

Stefan137
Beiträge: 19
Registriert: 02.12.2019, 22:21

Re: HB-OU-MP3-LED

Beitrag von Stefan137 » 30.06.2020, 23:59

Ah, okay. Danke für die Antworten :-D

der-pw
Beiträge: 222
Registriert: 26.01.2019, 13:39
Wohnort: Wolfenbüttel
Hat sich bedankt: 56 Mal
Danksagung erhalten: 44 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von der-pw » 02.07.2020, 10:35

Mit der Modifizierung, die ich unter viewtopic.php?f=76&t=49189&start=140#p561121 gefunden/beschrieben habe, ist das Reedrelais eigentlich nicht mehr nötig. Nur mal als Anregung. ;-)

Das einzige was mir inzwischen aufgefallen ist, dass in seltenen Fällen, beim Initialisieren, die serielle Verbindung nicht zustande kommt.
Das habe ich aber im Code abgefangen. Sitz nur gerade nicht an dem Rechner, auf dem der Sketch liegt.
Grüße,
Patrick

Horbi
Beiträge: 60
Registriert: 29.05.2019, 12:51
Danksagung erhalten: 3 Mal

Re: HB-OU-MP3-LED

Beitrag von Horbi » 03.07.2020, 12:50

Kann ich bestätigen, der Mod ist Klasse!
Kein Rauschen oder sonstiges Knacken...

Stefan137
Beiträge: 19
Registriert: 02.12.2019, 22:21

Re: HB-OU-MP3-LED

Beitrag von Stefan137 » 03.07.2020, 14:02

Jap, bei mir funktioniert das gerät, lässt sich an der ccu anlernen, aber taucht weder in den geräten auf, noch kann man die einstellungen aufrufen, oder das gerät löschen.
Ich benutze debmatic (3.51.6-45) und über debmatic dein Addon (2.11-7).
Ich kann es auch nicht in einem Programm benutzen....
Gibts da einen schnellen tipp?

Edit:
Wenn ich versuche das zu löschen, dann meldet die zentrale Fehler. Wenn ich auf "Gerät aus der Zentrale löschen" gehe, dann passiert einfach garnichts mehr.

Edit2:
Ich hab vergessen zu sagen, dass das symbol richtig angezeigt wird. und ein Funktionstest erfolgreich ist.

Edit3:
Mod gemacht und begeistert...

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 03.07.2020, 15:24

Stefan137 hat geschrieben:
03.07.2020, 14:02
Mod gemacht und begeistert...
Heißt, dass es jetzt geht?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Stefan137
Beiträge: 19
Registriert: 02.12.2019, 22:21

Re: HB-OU-MP3-LED

Beitrag von Stefan137 » 03.07.2020, 15:40

jp112sdl hat geschrieben:
03.07.2020, 15:24
Stefan137 hat geschrieben:
03.07.2020, 14:02
Mod gemacht und begeistert...
Heißt, dass es jetzt geht?
Der audio Teil funktioniert jetzt perfekt, aber die ccu weigert sich noch immer... leider.

Ich hatte zum testen der einzelnen Teile zuerst eine kleine eigene firmware geschrieben, die sich nicht mit der CCU versteht. Da konnte ich aber testen ob leds, mp3 modul und funkmodul antworten.

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 03.07.2020, 15:49

Stefan137 hat geschrieben:
03.07.2020, 15:40
aber die ccu weigert sich noch immer... leider.
Inwieweit das mit debmatic zu tun haben mag, kann ich nicht beurteilen.
Um einen klassischen Fehler auszuschließen, der ein ähnliches Verhalten produziert:
Die Seriennummer ist auch 10stellig (falls du sie von meinem Sketch abgeändert haben solltest)?

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Stefan137
Beiträge: 19
Registriert: 02.12.2019, 22:21

Re: HB-OU-MP3-LED

Beitrag von Stefan137 » 03.07.2020, 17:38

jp112sdl hat geschrieben:
03.07.2020, 15:49
Die Seriennummer ist auch 10stellig (falls du sie von meinem Sketch abgeändert haben solltest)?
Hab sie nicht geändert, ich wollte erstmal ausprobieren ob es überhaupt funktioniert.
Ich benutze Platformio unter Ubuntu zum flashen. Ich kann mir das zwar nicht wirklich vorstellen, aber könnte es theoretisch sein, dass ich von der Nullterminirung gefressen werde und die Seriennummer jetzt in Wirklichkeit 11stellig ist? :?: :?:

Und wie würdest du jetzt versuchen den chip neu zu flashen?

Edit:
Vllt hat ja irgendwer hier deine Projekte in Verbindung mit debmatic laufen...

jp112sdl
Beiträge: 5786
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 249 Mal
Danksagung erhalten: 500 Mal
Kontaktdaten:

Re: HB-OU-MP3-LED

Beitrag von jp112sdl » 03.07.2020, 17:59

Stefan137 hat geschrieben:
03.07.2020, 17:38
dass ich von der Nullterminirung gefressen werde und die Seriennummer jetzt in Wirklichkeit 11stellig ist?
Nein nein, da passiert nix :)
Stefan137 hat geschrieben:
03.07.2020, 14:02
über debmatic dein Addon (2.11-7).
Ich bin bei der CCU-Version mittlerweile bei 2.26
Kann mich zwar nicht mehr erinnern, dass ich in den letzten Versionen was für den HB-OU-MP3-LED anpassen musste, aber wer weiß

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

Stefan137
Beiträge: 19
Registriert: 02.12.2019, 22:21

Re: HB-OU-MP3-LED

Beitrag von Stefan137 » 03.07.2020, 18:06

Soll ich auf meinem Laptop mal eine virtuelle ccu aufsetzen und testen, ob es mit der neueren version geht?

Weißt du, wie ich das ding bei bedarf neu flashen kann, ohne den ota mechanismus zu benutzen?

Antworten

Zurück zu „Hardwareentwicklung und Selbstbau von Aktoren und Sensoren“