Seite 7 von 12

Re: HB-OU-MP3-LED

Verfasst: 09.05.2019, 13:10
von pafra
Hallo Jerome,

vielen Dank!

Ich habe mir jetzt mal zwei neue MP3-Player bestellt.
Nicht, dass die beiden, die ich momentan habe, ein Problem haben.

Ich hätte jetzt trotzdem noch eine Frage:
Von welcher Quelle hast Du die DFRobotDFPlayerMini.h und die SoftwareSerial.h?
Ich möchte auch ausschließen, dass ich da eventuell ein Problem habe...

Gruß
Franz

Re: HB-OU-MP3-LED

Verfasst: 09.05.2019, 13:16
von jp112sdl
SoftwareSerial: https://github.com/PaulStoffregen/SoftwareSerial
DFRobot....h: https://github.com/DFRobot/DFRobotDFPlayerMini

Du arbeitest auch wirklich mit einem 8MHz getakteten Pro Mini?

Re: HB-OU-MP3-LED

Verfasst: 09.05.2019, 13:21
von pafra
Hallo Jerome,

vielen Dank.
Ich werde das heute Abend mal damit testen.

Ja, denke schon, dass das 8MHz Arduinos sein sollten.
Hab extra noch einen aus einer anderen Lieferung ausprobiert.
Andere Sketche laufen darauf einwandfrei (inclusive dem Funkmodul) und die Serielle läuft auch mit 57600 Baud.

Gruß
Franz

Re: HB-OU-MP3-LED

Verfasst: 09.05.2019, 13:23
von jp112sdl
pafra hat geschrieben:
09.05.2019, 13:21
und die Serielle läuft auch mit 57600 Baud.
Das ist schon mal wichtig und richtig.
Ansonsten noch mal checken, ob evtl. RX/TX vertauscht wurden oder falsche Widerstände verwendet wurden.
Ich weiß auch nicht, wie sich der DFPlayer verhält, wenn keine oder eine falsch formatierte SD Card eingelegt ist

Re: HB-OU-MP3-LED

Verfasst: 09.05.2019, 13:28
von pafra
jp112sdl hat geschrieben:
09.05.2019, 13:23
Ich weiß auch nicht, wie sich der DFPlayer verhält, wenn keine oder eine falsch formatierte SD Card eingelegt ist
Guter Tipp - Danke!
Denn bisher hatte ich da noch keine SD-Karte drin bzw. irgendeine mal testweise rein gesteckt.
Werde ich auch prüfen.

Gruß
Franz

Re: HB-OU-MP3-LED

Verfasst: 09.05.2019, 22:41
von Kaheti
Ohne die SD- Karte erhielt ich auch immer die " DFPlayer Init Error" Meldung.
Nach allen Kontrollen auf fehlerhafte Verdrahtung bzw. Lötstellen brachte das
Einlegen der SD-Karte den gewünschten Erfolg.
Ein Problem mit dem DC habe ich auch nicht.

Gruß
K.H.

Re: HB-OU-MP3-LED

Verfasst: 11.05.2019, 17:07
von lame
...die Init Fehlermeldung ohne (formatierte) SD-Karte kann ich bestätigen.
Ein tickern und knacken aus dem Lautsprecher hab ich wegbekommen indem ich dem DF-Player 5V gegeben habe :idea:.
Zwischen Pro-Mini und DF-Player sitzt jetzt zur Sicherheit ein Pegelwandler.
Ein Grundrauschen hab ich nicht, nur ein kurzes knacken beim einschalten.

Mit diesem Projekt hab ich Super viel Spaß, Danke dafür :D

Re: HB-OU-MP3-LED

Verfasst: 16.05.2019, 14:26
von Jack01
Moin,
auch von mir vielen Dank für dieses tolle Projekt.
Ich habe die Hardware so wie empfohlen auf einem Breadboard aufgebaut. Die LEDs lassen sich auch über die Homematic-Zentrale ansteuern. Allerdings bekomme ich keine Soundausgabe. Das MP3 Modul habe ich mit der SD-Karte im "I/O" Mode (wie im DFRobot Wiki gezeigt) erfolgreich getestet.
Ich mußte allerdings auf 5V Versorgungsspannung gehen.
Damit ich jetzt keine Probleme mit dem 3,3V Arduino bekomme, habe ich in die 3 Datenleitungen (TX, RX, Busy) sowie in die LED-Datenleitung einen Pegelwandler zwischengesetzt.

#lame,
auf welcher Seite der Pegelwandler hast Du die beiden 1k Widerstände eingesetzt?

Gruß

Hans-Jürgen

Re: HB-OU-MP3-LED

Verfasst: 16.05.2019, 15:57
von lame
Jack01 hat geschrieben:
16.05.2019, 14:26
#lame,
auf welcher Seite der Pegelwandler hast Du die beiden 1k Widerstände eingesetzt?
Ich schau noch mal, bin mir aber ziemlich sicher das ich keine Widerstände mehr eingebaut habe.

RX/TX mal gedreht?

//Edit
Hab nachgeschaut, keine Widerstände eingebaut.

//Edit 2
Lt. DF-Robot gehören aber 1k an den DF-Player RX Pin und evtl. auch an TX.

Re: HB-OU-MP3-LED

Verfasst: 16.05.2019, 20:35
von Garagenloeter
Hab das Teil nun auch mal nachgebaut.
Ich bekomms leider nicht am laufen.
Das Ding will nicht in den Anlern Modus gehn.

Serieller Monitor zeigt das:

Code: Alles auswählen

AskSin++ V4.1.0 (May 16 2019 20:27:33)
Address Space: 32 - 567
CC init1
CC Version: 14
 - ready
Enable PinPolling: 6 - 1
DFPlayer Init Error.
Ich hab gerade keine Neopixel und den MP3 Player nicht angeschlossen.
kann es daran liegen?

Und... muss beim Player ne LED Leuchten?